Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VapourSynth

Reply
 
Thread Tools Search this Thread Display Modes
Old 18th June 2020, 05:11   #81  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 96
MinSharp and TimeCube archives are corrupted:

shph is offline   Reply With Quote
Old 18th June 2020, 06:11   #82  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 96
Quote:
Originally Posted by l33tmeatwad View Post
Noticed the FFMS2 included in the installer was the old copy that links to Libz even though I had removed it in favor of using the static lib. While it still works without it is possible it may have some issues with random stuff so I updated the R49 & R50 installers with a new copy and also updated LSMASHSource to the latest release. There is also a new copy of LSMASHSource in the plugin downloads location with the static libs as well and that copy uses FFmpeg 4.3.
So if i install your new version of VapourSynth-R50 there is no need to install additional separate LSMASHSource FFMS2 plugins?

By the way is it ok that ffmsindex file installed by VapourSynth-R50 (/Library/Frameworks/VapourSynth.framework/bin/ffmsindex) and ffmsindex bundled in FFMS2-2.23.1 have different size?

How do you think, may static libs versions affect apps like Hybrid?
shph is offline   Reply With Quote
Old 18th June 2020, 15:24   #83  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Wow, thanks for catching that, not sure what happened but they are fixed now!

Okay, now for the static vs shared libs discussion...to over-simplify things, when using a static library that it's like that lib is copied into the plugin instead of just adding a location of where the external lib is. I have transitioned everything over to using static libs so that they are more portable since most of the libs they link to are not very large. That said, in the installer I choose for D2V Source, FFMS2, and LSMASHSource to link to FFmpeg libs to avoid having the installer size extra bloated. The static versions are available for download for users that installed via brew or compiled the source and want an easy way to snag those plugins. Most of the time I compile them at the same time so they are essentially the same plugin just one links and the other has the copy internally for FFmpeg libs.

Now, as for the updated installer, when I was previously linking to all the library files FFMS2 also linked to libz, which I had removed from the installer since all the other plugins that linked to it were built with the static version. I did however forget to swap out the ffms2 plugin, which means that it would not be able to run any functions built in that needed it, however that just means it would either error or run differently based on how it was actually programed. I ran a few tests on my test machine and it appeared to work normally, however it may be best to either re-install OR just snag the static version for now just to avoid any issues.

Hopefully this explanation clarifies a few things.
l33tmeatwad is offline   Reply With Quote
Old 22nd June 2020, 18:07   #84  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 96
Ok, so if same D2V Source, FFMS2, and LSMASHSource included in installer, i will not touch same separate plug-ins.
So with new static plug-ins there is no need to install additional .dylib Dependencies to /Library/Frameworks/VapourSynth.framework/lib/ ?
I guess you removed those Dependencies from Mediafire

Last edited by shph; 22nd June 2020 at 19:36.
shph is offline   Reply With Quote
Old 22nd June 2020, 19:58   #85  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Quote:
Originally Posted by shph View Post
Ok, so if same D2V Source, FFMS2, and LSMASHSource included in installer, i will not touch same separate plug-ins.
So with new static plug-ins there is no need to install additional .dylib Dependencies to /Library/Frameworks/VapourSynth.framework/lib/ ?
I guess you removed those Dependencies from Mediafire
Yes I did, and I removed the copies of the plugins that needed them as well.
l33tmeatwad is offline   Reply With Quote
Old 22nd June 2020, 20:01   #86  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
In light of the recent news from Apple, I will do what I can to continue this thread to make life easier for macOS users, however I doubt I will have the cash flow to acquire a new Mac when they come out. Anyone willing to help out by building things on the new hardware once it's out feel free to reach out to me.
l33tmeatwad is offline   Reply With Quote
Old 12th July 2020, 16:54   #87  |  Link
DEW8H
Registered User
 
Join Date: Jul 2020
Posts: 4
I've been having problems on Catalina where using any QTGMC option above medium leads to an instant crash.

This is the script that has been working fine until recently:

Quote:
clip = core.ffms2.Source('myfile.mkv', fpsnum=30000, fpsden=1001)
clip = haf.QTGMC(clip, Preset='Very Slow', SourceMatch=3, Sharpness=1.0, TFF=True)
clip = core.resize.Spline36(clip, 640, 480, format=vs.YUV420P10)
clip.set_output()
I don't think havsfunc itself is the problem because QTGMC options up to "medium" work, but anything above like "slower" doesn't. There is no error message, VS editor simply crashes.

FFmpeg reports:
Quote:
pipe:: Invalid data found when processing input
This applies to both the AMVPack version and the standalone installer with plugins added.
DEW8H is offline   Reply With Quote
Old 12th July 2020, 16:59   #88  |  Link
HolyWu
Registered User
 
HolyWu's Avatar
 
Join Date: Aug 2006
Location: Taiwan
Posts: 755
Quote:
Originally Posted by DEW8H View Post
There is no error message, VS editor simply crashes.
Have you tried "vspipe -p script.vpy ." ?
HolyWu is offline   Reply With Quote
Old 12th July 2020, 18:13   #89  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Quote:
Originally Posted by DEW8H View Post
I've been having problems on Catalina where using any QTGMC option above medium leads to an instant crash.

This is the script that has been working fine until recently:



I don't think havsfunc itself is the problem because QTGMC options up to "medium" work, but anything above like "slower" doesn't. There is no error message, VS editor simply crashes.

FFmpeg reports:


This applies to both the AMVPack version and the standalone installer with plugins added.
Unfortunately I'm unable to replicate this issue, is there a crash log you could post so I can narrow down exactly what plugin is crashing for you and why?
l33tmeatwad is offline   Reply With Quote
Old 13th July 2020, 10:42   #90  |  Link
DEW8H
Registered User
 
Join Date: Jul 2020
Posts: 4
I have tried it on another Mac now and got the same result. VS editor doesn't report any error, I only get the notice "app quit unexpectedly".

Quote:
Originally Posted by HolyWu View Post
Have you tried "vspipe -p script.vpy ." ?
Yes, pipe reports the error "pipe:: Invalid data found when processing input".

@l33tmeatwad, full crash log is too long to copy here, sent you a DM, but it suggests libmvtools might be the issue.
DEW8H is offline   Reply With Quote
Old 13th July 2020, 14:57   #91  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
That does appear to be the issue, found some old copies you can try, they will need the dependency placed in the Library Directory.

MVTools v19
MVtools v20

Dependency: FFTW

Last edited by l33tmeatwad; 13th July 2020 at 15:05.
l33tmeatwad is offline   Reply With Quote
Old 13th July 2020, 17:28   #92  |  Link
DEW8H
Registered User
 
Join Date: Jul 2020
Posts: 4
Tested and can confirm it does work with the older version.

It seems someone over at the Hybrid forum also reported the same problem.

Quote:
aside from qtgmc crashing on slow, very slow, placebo, or custom, everything seems to work great.
DEW8H is offline   Reply With Quote
Old 13th July 2020, 18:09   #93  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Quote:
Originally Posted by DEW8H View Post
Tested and can confirm it does work with the older version.

It seems someone over at the Hybrid forum also reported the same problem.
I'll compile a few of the older versions, if you don't mind testing to see what the last working version is that would be helpful for narrowing down the issue.
l33tmeatwad is offline   Reply With Quote
Old 14th July 2020, 09:45   #94  |  Link
DEW8H
Registered User
 
Join Date: Jul 2020
Posts: 4
The two older copies you posted work without problems. I believe the last one that worked without issues for me was the one included in January/May(?) release of AMVPack and the last 2-3 updates of Vapour already had the crashing issue.
DEW8H is offline   Reply With Quote
Old 14th July 2020, 20:06   #95  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Quote:
Originally Posted by DEW8H View Post
The two older copies you posted work without problems. I believe the last one that worked without issues for me was the one included in January/May(?) release of AMVPack and the last 2-3 updates of Vapour already had the crashing issue.
There were releases since then, if you could test those after I compile them it would be helpful for sending information along to the developer. I also want to recompile those with the dependency built in to make sure that's not somehow causing the issue.
l33tmeatwad is offline   Reply With Quote
Old 19th July 2020, 21:36   #96  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Added MVtools versions 20 to 22 to the downloads, if anyone who had issues with v23 please test and post the results here.
l33tmeatwad is offline   Reply With Quote
Old 20th July 2020, 11:04   #97  |  Link
shph
Registered User
 
Join Date: Mar 2020
Posts: 96
I see the size is different. Old v20 was about 1 MB, new v20 and v21 are about 2MB. New v22 and v23 are about 4.5 MB Are they all self contained versions now?
By the way, from real life point of view what is the benefit to use newer version? Is it some improvement quality or speed? Or just some new special options? I guess dramatic changes in v22 and v23 size means some fundamental changes in plug-in. Maybe just stay with stable v20?

Last edited by shph; 20th July 2020 at 12:35.
shph is offline   Reply With Quote
Old 20th July 2020, 13:15   #98  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Quote:
Originally Posted by shph View Post
I see the size is different. Old v20 was about 1 MB, new v20 and v21 are about 2MB. New v22 and v23 are about 4.5 MB Are they all self contained versions now?
By the way, from real life point of view what is the benefit to use newer version? Is it some improvement quality or speed? Or just some new special options? I guess dramatic changes in v22 and v23 size means some fundamental changes in plug-in. Maybe just stay with stable v20?
The old version had an external dependency (fftw) and these have it built in for simplicity as needing to download and place extra dependencies confused some users. As with any software, new versions add features and the goal is to improve speed, efficiency, quality, and stability, however sometimes random glitches pop up and only affect certain systems so developers don't realize there is an issue. In this situation finding out what version was the first to be broken will hopefully norrow down what the problem is so it can be fixed in future versions.
l33tmeatwad is offline   Reply With Quote
Old 24th July 2020, 03:28   #99  |  Link
AdamCarter
Registered User
 
Join Date: Jul 2020
Posts: 31
HI all i think i noted the qtgmc slow, slower, slowest And placebo crash, but the mvtools fix seems to fix that. Ii also have crashes using denoisers. Only one that seems to work is fftd3d. Would l0ve to try mosquitoNR but its not available on the mac as far as i can tell.

Last edited by AdamCarter; 24th July 2020 at 22:12.
AdamCarter is offline   Reply With Quote
Old 24th July 2020, 15:26   #100  |  Link
l33tmeatwad
Registered User
 
l33tmeatwad's Avatar
 
Join Date: Jun 2007
Posts: 294
Quote:
Originally Posted by AdamCarter View Post
I all i think i noted the qtgmc slow, slower, slowest And placebo crash, but the mvtools fix seems to fix that. Ii also have crashes using denoisers. Only one that seems to work is fftd3d. Would l0ve to try mosquitoNR but its not available on the mac as far as i can tell.
What other filters are crashing for you? Also if there is a filter you'd like to see complied feel free to look to the source code here and I'll see what I can do.
l33tmeatwad is offline   Reply With Quote
Reply

Tags
meatwadismagical, meatwadthegreat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:17.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.