Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 29th September 2018, 22:10   #741  |  Link
Kurogane
Registered User
 
Join Date: Jul 2011
Posts: 16
Quote:
Originally Posted by real.finder View Post
no solution for now (unless pinterf or anyone find fix for it)

what you mean outside of MT? you must not use Prefetch at all (remove it from the script) to make it work
Code:
SetFilterMTMode("DEFAULT_MT_MODE", 2)
.....
Prefetch(6)
sanimebob()
srestore()
Kurogane is offline   Reply With Quote
Old 11th December 2018, 19:05   #742  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,513
Does anyone have something to try to restore this video? It's from Dream Theater Live at Budokan Blu-ray.

https://drive.google.com/open?id=11f...9noVkd85CbslmV

To me it looks like hard telecined content encoded in a very wrong way but I cannot figure out how to make it look good (enough).
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 11th December 2018, 20:02   #743  |  Link
Sharc
Registered User
 
Join Date: May 2006
Posts: 3,427
Quote:
Originally Posted by Boulder View Post
Does anyone have something to try to restore this video? It's from Dream Theater Live at Budokan Blu-ray.

https://drive.google.com/open?id=11f...9noVkd85CbslmV

To me it looks like hard telecined content encoded in a very wrong way but I cannot figure out how to make it look good (enough).
This looks like a messed up framerate (multiple) conversion. Blended progressive frames, and both fields of the interlaced/telecined sections also blended….
I doubt there is a fix for that…….
Perhaps try to catch the clean frames and interpolate the gaps?
Sharc is offline   Reply With Quote
Old 11th December 2018, 21:14   #744  |  Link
hello_hello
Registered User
 
Join Date: Mar 2011
Posts: 3,868
Quote:
Originally Posted by Boulder View Post
Does anyone have something to try to restore this video? It's from Dream Theater Live at Budokan Blu-ray.

https://drive.google.com/open?id=11f...9noVkd85CbslmV

To me it looks like hard telecined content encoded in a very wrong way but I cannot figure out how to make it look good (enough).
The frame rate is a little odd, and there's still a couple of blended frames on scene changes. Maybe the blending pattern changes. I'm not sure. You might be able to tune SRestore's double blend removal a bit. Or maybe drop TDeint or the frame rate conversion to see if they're the cause. This seems to clean it up reasonably well though. If there's still aliasing in places, you might want to try QTGMC(FPSDivisor=2) instead of TDeint. Not perfect yet, but it's a start.

LWLibavVideoSource("D:\dreamtheater.mkv.lwi", fpsnum=30000, fpsden=1001)
TDeint()
Srestore(mode=-4,omode="pp0")
TDecimate()
Gradfun3()

dreamtheater.mkv

PS. Where it says dmode in the SRestore wiki (if it still does), it should say mode.

Last edited by hello_hello; 11th December 2018 at 21:16.
hello_hello is offline   Reply With Quote
Old 12th December 2018, 03:45   #745  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,513
Thanks, I'll give that one a go The scene changes are not a big problem since it's usually quite hard to make things work around them, especially with this kind of material with lots of flashes etc.
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 17th December 2018, 13:31   #746  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 6,486
Boulder,
I ran your sample through ExBlend (latest beta Edition), and it seemed to be detecting about 96% of blends.
See this thread first for Didee's Blur inspiration:- https://forum.doom9.org/showthread.p...hlight=exblend

And then here:- https://forum.doom9.org/showthread.p...40#post1558840

NOTE, The ExbFile arg dont work properley on Win7 (think M$ must have broken it, also recently seen similar problems posted about Avs+ paths),
so you need give full path (defaults to "ExBlend", need set eg "D:\ExBlend" to fix on Win7+, & maybe Vista).

ExBlend is definitely not intended for this sort of clip, it does however seem to detect it.
Good luck.

EDIT: It even seems to detect without the blur, but give it a whirl with/without.
I did not try with blur.

EDIT: Path problem, where ExbFile="ExBlend" on XP, works fine writing data file to current dir, on W7, says it wrote ok, but file nowhere to be found, dont know where it gets written (if indeed it does at all, search did not find it).

EDIT:
Code:
AVISource("D:\ExB\dreamtheater.264.AVI")
#ExBlend(mode=1,PAL=0,ExBFile="D:\EXB\ExBlend",Debug=true)
ExBlend(mode=2,PAL=0,ExBFile="D:\EXB\ExBlend",Debug=true,Show=5)
Return Last
Dont use directshow.

EDIT: Seems that ChiDragon already reported problems in paths, although I had no idea as to the cause back then.
Quote:
Originally Posted by ChiDragon View Post
On my system, the default location for writing "Exbfile" is the Plugin's dir rather than the script dir. This is a problem because it gets written to the VirtualStore and then isn't read back when set to mode=2. (My plugin is located in %PROGRAMFILES(x86)%\AviSynth 2.5\plugins\)
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 17th December 2018 at 14:16.
StainlessS is offline   Reply With Quote
Old 17th December 2018, 13:58   #747  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,513
Thanks, I'll have to try that one too. There seems to be something seriously wrong with that release, I noticed a section where there were dupes all over the place after the deblending of SRestore. I was already resigned to leaving everything as they are
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 17th December 2018, 14:26   #748  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 6,486
Quote:
dupes all over the place after the deblending of SRestore
I think you could do worst than give DropDeadGorgeous a try on the dupes [EDIT: After SRestore or ExBlend].
If you do, then please give some kind of feedback, good or bad, thanx.

Incidentally, I think I totally misinterpreted (mis-remembered) JohnMeyer description of the DropDeadGorgeous problem, should have been
dupes followed by eventual drops, but I implemented drops followed by eventual dupes
(John must have decided not to let on, and leave me in suspense, likes a good giggle does john).
Anyways, does a bloody good job even though I fixed the wrong problem, maybe I try fix the right prob when I get time.
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 17th December 2018 at 14:28.
StainlessS is offline   Reply With Quote
Old 18th December 2018, 16:17   #749  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 6,486
Use something like

Code:
AVISource("D:\ExB\dreamtheater.264.AVI")
ORG=Last
DC=ORG.Blur(0,1)
#ORG.ExBlend(DClip=DC,mode=1,PAL=0,ExBFile="D:\EXB\ExBlend",Debug=true)
ORG.ExBlend(DClip=DC,mode=2,PAL=0,ExBFile="D:\EXB\ExBlend",Debug=true,Show=5)
Return Last
EDIT: Shows detection of blends @ 95.44% on last frame from of your sample.
92 blend pairs detected out of maximum possible 96.

EDIT:
Hope this works ok, long time since I use ExBlend.
Code:
AVISource("D:\ExB\dreamtheater.264.AVI")
DC=Last.Blur(0,1)

#return Last.ExBlend(mode=1,PAL=0,ExBFile="D:\EXB\ExBlend",Debug=true,DClip=DC) # Pass 1

SHOW        =0  # 0(off) or 5
DISP_EXBLEND = 1
COMP_UB      = 1   # DeBlended frame from DC, Adjacent from Source)
# Combed Clip, Deblended, Decimated
EXB=Last.ExBlend(mode=2,PAL=0,disp=DISP_EXBLEND,CompUB=COMP_UB,ExBFile="D:\EXB\ExBlend",Debug=true,Show=SHOW,dclip=DC)
MC=EXB.MCDegrain(1) # Denoise all frames
ClipClop(EXB,MC,CMD="ExBlend_Decimated.Txt") # ExBlend clip with denoised De-blended frames only
Return Last
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 18th December 2018 at 17:20.
StainlessS is offline   Reply With Quote
Old 18th December 2018, 17:05   #750  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,513
Is there an x64 version of ExBlend available or will I need to install a 32-bit Avisynth+ environment?
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 18th December 2018, 17:18   #751  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 6,486
Quote:
Is there an x64 version
I'll do one now (with fixed "ExbFile" path arg).
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???
StainlessS is offline   Reply With Quote
Old 18th December 2018, 22:12   #752  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 6,486
Ok, wanna try this
Code:
AVISource("D:\ExB\dreamtheater.264.AVI")
#ConvertToYUY2   # CANNOT USE MCDegrain on YUY2
ConvertToYV12
#ConvertToYV16
#ConvertToYV24
#ConvertToY8

#return Last.ExBlend(ver=true) # Version only

DC=Last.Blur(0,1)
Return Last.ExBlend(mode=1,PAL=0,Debug=true,DClip=DC,Show=5) # Pass 1

SHOW         = 5        # 0(off) or 5
CLIPCLOPSHOW = False     # ONLY used if SHOW=0
DISP_EXBLEND = 1
COMP_UB      = 1         # DeBlended frame from DC, Adjacent from Source)
MC           = True      # Denoise with McDegrain
SHARP        = 0.333     # Use McDegrainSharp if > 0.0
#############
MC=IsYUY2 ? False : MC
SHARP=IsYUY2 ? 0.0 : SHARP
CLIPCLOPSHOW=(SHOW==0) ? CLIPCLOPSHOW : False
# Orig Clip, blurred DC, result Deblended, Decimated
EXB=Last.ExBlend(mode=2,PAL=0,disp=DISP_EXBLEND,CompUB=COMP_UB,Debug=true,Show=SHOW,dclip=DC)
#return EXB
# Denoise all frames (BUT NOT IF YUY2, unsupported in MCDeGrain)
DENOISED = (!IsYUY2) ? ((SHARP>0.0) ? EXB.MCDegrainSharp(1,csharp=SHARP) : EXB.MCDegrain(1)) : Last
# ExBlend clip with denoised De-blended frames only (Skipped if YUY2)
(!IsYUY2&&MC) ? ClipClop(EXB,DENOISED,CMD="ExBlend_Decimated.Txt",show=CLIPCLOPSHOW) : EXB
Return Last
Holla if you have probs.

ExBlend v1.04:- https://forum.doom9.org/showthread.php?t=175948
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 19th December 2018 at 04:05.
StainlessS is offline   Reply With Quote
Old 19th December 2018, 03:53   #753  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,513
Thanks, I'll start working with that and see what comes out
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 26th February 2019, 15:28   #754  |  Link
a1s2d3f4
Registered User
 
Join Date: Nov 2010
Posts: 72
Just upgraded from the old AviSynth2.5 (x86) to Avisynth+ from here http://avs-plus.net/.

The claim on the page that it is fully compatible with the old AviSynth.

However, as soon as I tried to test one of my .avs scripts, I got this error.
---------------------------
VirtualDub Error
---------------------------
Avisynth open failure:
lutxy : invalid yExpr
(C:/Program Files (x86)/AviSynth 2.5/plugins/Srestore.avsi, line 93)
(F:\PRODUCTS\test\VIDEO_TS\VTS_01_1-Cziffra-GGC-srestore1.avs, line 66)
---------------------------
OK
---------------------------


Does anyone know whether or not srestore can be made to work with AviSynth+ or should I downgrade?

Thanks,
a1
a1s2d3f4 is offline   Reply With Quote
Old 26th February 2019, 17:43   #755  |  Link
poisondeathray
Registered User
 
Join Date: Sep 2007
Posts: 3,756
Quote:
Originally Posted by a1s2d3f4 View Post

Does anyone know whether or not srestore can be made to work with AviSynth+ or should I downgrade?
Yes it works, but you need updated , matching versions of srestore and dependencies.

(Basically you need newer versions if using avs+, older matching versions if using avs classic)
poisondeathray is offline   Reply With Quote
Old 26th February 2019, 18:01   #756  |  Link
Groucho2004
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Posts: 4,111
Quote:
Originally Posted by a1s2d3f4 View Post
Just upgraded from the old AviSynth2.5 (x86) to Avisynth+ from here http://avs-plus.net/.
You should use the latest AVS+ from here.
__________________
Groucho's Avisynth Stuff
Groucho2004 is offline   Reply With Quote
Old 26th February 2019, 19:56   #757  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Location: Berlin, Germany
Posts: 2,451
Yeah, version hell again, this time not caused by Microsoft, but by the "AVS Plugins Modernization Effort" which started after the introduction of AVS+.

Basically users cannot mix older and newer versions of the AVSI scripts, the plugins these scripts depend on and the AVS versions. Everything needs to fit, a newer AVSI needs newer plugins plus a newer AVS+ version. No backward compatibility, going back from AVS+ to classic AVS requires to install older script and plugin versions.

I do use AVS+ now, but I do not care for the new High Bitdepth and HiColor features. All I want is MT. And I absolutely need backwards compatibility for my scripts and plugins.

For Srestore I use the last MoMonster version 2.7e together with an older MT_Masktools version. Works nicely under classic AVS 2.6 as well as under the latest AVS+ version. Here is an All-In-One version:
https://files.videohelp.com/u/172211...e_2.7e_AIO.zip


Cheers
manolito
manolito is offline   Reply With Quote
Old 26th February 2019, 20:09   #758  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,112
Quote:
Originally Posted by a1s2d3f4 View Post
Just upgraded from the old AviSynth2.5 (x86) to Avisynth+ from here http://avs-plus.net/.

The claim on the page that it is fully compatible with the old AviSynth.

However, as soon as I tried to test one of my .avs scripts, I got this error.
---------------------------
VirtualDub Error
---------------------------
Avisynth open failure:
lutxy : invalid yExpr
(C:/Program Files (x86)/AviSynth 2.5/plugins/Srestore.avsi, line 93)
(F:\PRODUCTS\test\VIDEO_TS\VTS_01_1-Cziffra-GGC-srestore1.avs, line 66)
---------------------------
OK
---------------------------


Does anyone know whether or not srestore can be made to work with AviSynth+ or should I downgrade?

Thanks,
a1
I think this is masktools bug, it should not use Expr if the avs+ don't have it (like old avs+ in that link)
__________________
My Avisynth Stuff

Last edited by real.finder; 26th February 2019 at 20:15.
real.finder is offline   Reply With Quote
Old 26th February 2019, 20:15   #759  |  Link
real.finder
Registered User
 
Join Date: Jan 2012
Location: Mesopotamia
Posts: 1,112
Quote:
Originally Posted by manolito View Post
Yeah, version hell again, this time not caused by Microsoft, but by the "AVS Plugins Modernization Effort" which started after the introduction of AVS+.

Basically users cannot mix older and newer versions of the AVSI scripts, the plugins these scripts depend on and the AVS versions. Everything needs to fit, a newer AVSI needs newer plugins plus a newer AVS+ version. No backward compatibility, going back from AVS+ to classic AVS requires to install older script and plugin versions.

I do use AVS+ now, but I do not care for the new High Bitdepth and HiColor features. All I want is MT. And I absolutely need backwards compatibility for my scripts and plugins.

For Srestore I use the last MoMonster version 2.7e together with an older MT_Masktools version. Works nicely under classic AVS 2.6 as well as under the latest AVS+ version. Here is an All-In-One version:
https://files.videohelp.com/u/172211...e_2.7e_AIO.zip


Cheers
manolito
most if not all edits I did for avsi's don't need newer avs+ (especially the last updates), even avs2.5 still supported in most of avsi's I edits, but most of times they (avsi's) need newer plugins if you using avs 2.6 or avs+
__________________
My Avisynth Stuff

Last edited by real.finder; 26th February 2019 at 20:18.
real.finder is offline   Reply With Quote
Old 26th February 2019, 22:15   #760  |  Link
Groucho2004
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Posts: 4,111
Quote:
Originally Posted by real.finder View Post
most of times they (avsi's) need newer plugins if you using avs 2.6 or avs+
And this is really not so difficult:

Avisynth+

Average
MaskTools
RGTools (includes RemoveGrain)
GRunT
TIVTC

AIO MS runtimes

Some of the plugins in manolito's package are 15 years old. There have been many improvements, especially in Masktools. It makes no sense (to me) to run these ancient versions.
__________________
Groucho's Avisynth Stuff
Groucho2004 is offline   Reply With Quote
Reply

Tags
mrestore, srestore

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:16.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.