Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > (HD) DVD, Blu-ray & (S)VCD > DVD & BD Rebuilder

Reply
 
Thread Tools Search this Thread Display Modes
Old 26th January 2018, 14:52   #81  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
TSM2UHD v1.11

I've updated the first post of this thread with a new release of TSM2UHD.

Changes:

Code:
- Added MEDIAINFO to the release (zip file) for collection of UHD and HDR information
  Note:  The version of MediaInfo.exe included with TSM2UHD must
  be present in the same folder as TSM2UHD.EXE in order for it to execute.
- Now adds necessary extensions to MPLS and index.bdmv files.  This assures greater compliance.
- Several minor changes and updates.
- With this version you may often be able to keep original files intact (when they fit on a BD-50).
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 26th January 2018 at 18:02.
jdobbs is offline   Reply With Quote
Old 26th January 2018, 16:43   #82  |  Link
spexman
Registered User
 
Join Date: Apr 2008
Posts: 26
All your excellent work and expertise is much appreciated....thanks!
spexman is offline   Reply With Quote
Old 26th January 2018, 20:16   #83  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
Quote:
Originally Posted by MB2 View Post
I've had success but most of the time, before I can even get it into a folder format, TSMuxer gives me this error:

Reading buffer overflow. Possible container streams are not syncronized. Please, verify stream fps. File name: H:\Batman v Superman Dawn Of Justice (2016) (UHD) (BD100)\BDMV\STREAM\00000.m2ts

Any ideas, suggestions or settings? All I am doing is dropping in the m2ts and creating Blu-ray folder.



The film "Hidden Figures" loses it's HDR for some reason too after running through TSm2UHD
Just an additional note on this. Most of the time if you demux the video first, and then demux the audio/subtitles you can get past this error (that's what BD Rebuilder does when it runs into it). Then just remux by combining all the components in TSMUXER. If you have access to the MPLS in a source BD structure, you can also open that with TSMUXER -- and cut and paste the chapter times from the Blu-Ray tab into the same place in the new mux.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net

Last edited by jdobbs; 26th January 2018 at 20:19.
jdobbs is offline   Reply With Quote
Old 27th January 2018, 08:16   #84  |  Link
wolflop
Registered User
 
Join Date: Sep 2009
Posts: 31
Still the same problem as I already described. Movie burned on a BDXL 100 Rewriteable, played with UB900. No picture, sound is working properly

mediainfo after TM2Uhd 1.1

Allgemein
ID : 1 (0x1)
Vollständiger Name : E:\Datensicherung\UHDRips\AlienCov\BDMV\STREAM\00000.m2ts
Format : BDAV
Format/Info : Blu-ray Video
Dateigröße : 32,0 GiB
Dauer : 2 h 2 min
Modus der Gesamtbitrate : variabel
Gesamte Bitrate : 37,5 Mb/s
maximale Gesamtbitrate : 35,5 Mb/s

Video
ID : 4113 (0x1011)
Menü-ID : 1 (0x1)
Format : HEVC
Format/Info : High Efficiency Video Coding
Format-Profil : Main 10@L5.1@High
Codec-ID : 36
Dauer : 2 h 2 min
Bitrate : 35,3 Mb/s
Breite : 3 840 Pixel
Höhe : 2 160 Pixel
Bildseitenverhältnis : 16:9
Bildwiederholungsrate : 23,976 (24000/1001) FPS
ColorSpace : YUV
ChromaSubsampling/String : 4:2:0 (Type 2)
BitDepth/String : 10 bits
Bits/(Pixel*Frame) : 0.177
Stream-Größe : 30,1 GiB (94%)
verwendete Encoder-Bibliothek : ATEME Titan File 3.8.3 (4.8.3.0)
colour_range : Limited
colour_primaries : BT.2020
transfer_characteristics : PQ
matrix_coefficients : BT.2020 non-constant
MasteringDisplay_ColorPrimaries : R: x=0.680000 y=0.320000, G: x=0.265000 y=0.690000, B: x=0.150000 y=0.060000, White point: x=0.312700 y=0.329000
MasteringDisplay_Luminance : min: 0.0050 cd/m2, max: 1000.0000 cd/m2

Audio
ID : 4352 (0x1100)
Menü-ID : 1 (0x1)
Format : DTS
Format/Info : Digital Theater Systems
Format_Settings_Mode : 16
Format-Einstellungen für Endianess : Big
Codec-ID : 130
Dauer : 2 h 2 min
Bitraten-Modus : konstant
Bitrate : 768 kb/s
Kanäle : 6 Kanäle
Kanal-Positionen : Front: L C R, Side: L R, LFE
Samplingrate : 48,0 kHz
Bildwiederholungsrate : 93,750 FPS (512 SPF)
BitDepth/String : 24 bits
Stream-Größe : 670 MiB (2%)

Text #1
ID : 4608 (0x1200)
Menü-ID : 1 (0x1)
Format : PGS
Codec-ID : 144

Text #2
ID : 4609 (0x1201)
Menü-ID : 1 (0x1)
Format : PGS
Codec-ID : 144
Dauer : 2 h 1 min
Video Verzögerung : 3s 86 ms

Last edited by wolflop; 27th January 2018 at 08:18.
wolflop is offline   Reply With Quote
Old 27th January 2018, 08:49   #85  |  Link
A.Fenderson
Registered User
 
Join Date: Mar 2009
Posts: 230
Quote:
Originally Posted by wolflop View Post
Still the same problem as I already described. Movie burned on a BDXL 100 Rewriteable, played with UB900. No picture, sound is working properly
Unfortunately, as with the early-ish days of Blu-ray, it seems as though playback of consumer writable and rewritable media at the native format capacity (100 GB here) is not a requirement for players to meet the UHD-BD standard. From what I've seen, it's starting to look as though most players will likely support BD-R/RE 25 GB and 50 GB discs, but very few will support BDXL R/RE 100 GB discs. If the remuxed stream will fit on a BD-R/RE 50 GB disc, have you tried that?
A.Fenderson is offline   Reply With Quote
Old 27th January 2018, 10:24   #86  |  Link
geheim
Registered User
 
Join Date: Feb 2014
Posts: 60
Thanks for the new version, jdobbs.
Unfortunately it still doesn't work like expected on my x800. HDR is not recognized, seems there are still some flags missing. Audio is not sync with video, there is a difference of quite a few minutes at the end of the movie. And the video itself plays better than before, but there are still some occasional stutterings.

Hopefully you can figure out what is still missing. If I can help with some additional testing feel free to ask. Thanks for working on this!
geheim is offline   Reply With Quote
Old 27th January 2018, 11:29   #87  |  Link
no-one
Registered User
 
Join Date: Dec 2011
Posts: 39
Quote:
Originally Posted by geheim View Post
Thanks for the new version, jdobbs.
Unfortunately it still doesn't work like expected on my x800. HDR is not recognized, seems there are still some flags missing. Audio is not sync with video, there is a difference of quite a few minutes at the end of the movie. And the video itself plays better than before, but there are still some occasional stutterings.

Hopefully you can figure out what is still missing. If I can help with some additional testing feel free to ask. Thanks for working on this!
Same problem.

And After process tsmuxer, every movie duration is set = 01:53:45:443 in mpls file

Last edited by no-one; 27th January 2018 at 11:31.
no-one is offline   Reply With Quote
Old 27th January 2018, 11:44   #88  |  Link
wolflop
Registered User
 
Join Date: Sep 2009
Posts: 31
The Ub900 supports 100 GB of Xl BDR discs. If I burn complete untouched discs, they will work fine.
wolflop is offline   Reply With Quote
Old 27th January 2018, 15:34   #89  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
Standard BD-XL discs are not formatted in the same way as a UHD BD-100. It just isn't reasonable to expect them to work. For them to do so would be the exception rather than the rule.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 27th January 2018, 18:05   #90  |  Link
rtosco
Registered User
 
Join Date: Oct 2017
Posts: 3
Quote:
Originally Posted by jdobbs View Post
Standard BD-XL discs are not formatted in the same way as a UHD BD-100. It just isn't reasonable to expect them to work. For them to do so would be the exception rather than the rule.
Hi jdobbs, I don't think the video problem on the UB900 is related to BD-100, I'm using BD-RE 50 and still have no picture even with 1.11 program version. The player does not trigger HDR on the TV and only sound is (correctly) played. Maybe something is still missing and/or the Panasonic player is more adherent to UHD specs than other players.
Thanks for keeping improving your piece of SW!
rtosco is offline   Reply With Quote
Old 27th January 2018, 18:28   #91  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
Quote:
Originally Posted by geheim View Post
Thanks for the new version, jdobbs.
Unfortunately it still doesn't work like expected on my x800. HDR is not recognized, seems there are still some flags missing. Audio is not sync with video, there is a difference of quite a few minutes at the end of the movie. And the video itself plays better than before, but there are still some occasional stutterings.

Hopefully you can figure out what is still missing. If I can help with some additional testing feel free to ask. Thanks for working on this!
Well... I have the same player and I am getting no sync issues, no stuttering, etc. What process are you using to create it?
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 27th January 2018, 19:00   #92  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
Quote:
Originally Posted by rtosco View Post
Hi jdobbs, I don't think the video problem on the UB900 is related to BD-100, I'm using BD-RE 50 and still have no picture even with 1.11 program version. The player does not trigger HDR on the TV and only sound is (correctly) played. Maybe something is still missing and/or the Panasonic player is more adherent to UHD specs than other players.
Thanks for keeping improving your piece of SW!
Can you send me a zip containing everything on the disc except the M2TS file?
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 27th January 2018, 19:16   #93  |  Link
geheim
Registered User
 
Join Date: Feb 2014
Posts: 60
Quote:
Originally Posted by jdobbs View Post
Well... I have the same player and I am getting no sync issues, no stuttering, etc. What process are you using to create it?
This time I tested with an MKV file from Inferno with german audio - processed with TSMuxer, using BluRay folder output mode. Then I used TSM2UHD 1.11 on that folder.
The resulting disc folder didn't play at all on Windows using DVDFab Media Player, but I burnt to a Sony BD-RE 50GB to test on my x800 and got the issues described above...
geheim is offline   Reply With Quote
Old 27th January 2018, 19:49   #94  |  Link
A.Fenderson
Registered User
 
Join Date: Mar 2009
Posts: 230
movie: Argo UHD (66 GB dual layer disc).
ripped via MakeMKV 1.10.10.
demuxed via tsMuxeR 2.6.11.
reumuxed main (only) video (HEVC 4K), DTS core English audio, & 2 English PGS streams via tsMuxer 2.6.11.
burned & verified with ImgBurn 2.5.8.0 to Verbatim BD-R (not -RE) 50 GB disc via Asus BW-16D1HTv3.00
attempted playback in LG UP870: recognized as Blu-ray disc, but playback immediately fails to main system menu.
attempted playback in Xbox One S: playback semi-successful with audio but no video. Xbox bitrate scanner showed as high as ~130 Mbps, which is max allowable bitrate on HTR zone of 66 & 100 GB UHD-BD discs. However, it also reported the stream as 1080p.

ran TSM2UHD v1.11 on above-referenced remux: success with no errors reported.
burned & verified with ImgBurn 2.5.8.0 to Verbatim BD-R (not -RE) 50 GB disc via Asus BW-16D1HTv3.00
attempted playback in LG UP870: playback attempted, audio fine, video displays decode errors every two seconds or more often, largely as bright monochrome blocks throughout the picture.
I noticed there was a pending firmware upgrade for the player, so applied that, but no change in playback results.
attempted playback in Xbox One S: playback is largely OK, with no audio issues and only occasional slight stuttering of the video, but result is actually arguably watchable, just not perfect.

I'm guessing from this test that the Xbox One S may have the ability to spin BD50s at speeds high enough to ensure smooth(ish) playback of videos encoded somewhere above the max bitrate the spec calls for regarding BD50s, but that the LG UP870 isn't quite as successful.

For what it's worth, I'm now burning to BD-RE XL 100 GB, but I don't anticipate that working at all, as neither of my players previously worked with this disc type.

---
edit: neither player will recognize the BD-RE XL 100 GB burn (verified via ImgBurn) of Argo.

Last edited by A.Fenderson; 27th January 2018 at 22:10.
A.Fenderson is offline   Reply With Quote
Old 27th January 2018, 20:19   #95  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
Quote:
Quote:
Originally Posted by geheim View Post
Thanks for the new version, jdobbs.
Unfortunately it still doesn't work like expected on my x800. HDR is not recognized, seems there are still some flags missing. Audio is not sync with video, there is a difference of quite a few minutes at the end of the movie. And the video itself plays better than before, but there are still some occasional stutterings.

Hopefully you can figure out what is still missing. If I can help with some additional testing feel free to ask. Thanks for working on this!
Well... I have the same player and I am getting no sync issues, no stuttering, etc. What process are you using to create it?
I stand corrected. I just ran a disc and got the same results you posted. I'd done this disc before... I'm now looking to see what has changed.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 27th January 2018, 20:20   #96  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
Quote:
Originally Posted by geheim View Post
This time I tested with an MKV file from Inferno with german audio - processed with TSMuxer, using BluRay folder output mode. Then I used TSM2UHD 1.11 on that folder.
The resulting disc folder didn't play at all on Windows using DVDFab Media Player, but I burnt to a Sony BD-RE 50GB to test on my x800 and got the issues described above...
I'm not sure about all the details around your post... but it is rare that the video in an MKV is compliant.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 27th January 2018, 21:05   #97  |  Link
geheim
Registered User
 
Join Date: Feb 2014
Posts: 60
Quote:
Originally Posted by jdobbs View Post
I'm not sure about all the details around your post... but it is rare that the video in an MKV is compliant.
It was a remux from an original UHD - so the video inside the MKV was compliant as it was an original hevc stream.
geheim is offline   Reply With Quote
Old 27th January 2018, 23:57   #98  |  Link
rtosco
Registered User
 
Join Date: Oct 2017
Posts: 3
Quote:
Originally Posted by jdobbs View Post
Can you send me a zip containing everything on the disc except the M2TS file?
I would gladly do, but I can't find your e-mail address I should send the files to. And I'm not able to send private messages either...

Could you please send me a pm?
Thanks,
Roberto
rtosco is offline   Reply With Quote
Old 28th January 2018, 03:22   #99  |  Link
jdobbs
Moderator
 
Join Date: Oct 2001
Posts: 20,453
Quote:
Originally Posted by rtosco View Post
I would gladly do, but I can't find your e-mail address I should send the files to. And I'm not able to send private messages either...

Could you please send me a pm?
Thanks,
Roberto
I sent you a pm. You can also find the address under HELP in BD Rebuilder.
__________________
Help with development of new apps: Donations.
Website: www.jdobbs.net
jdobbs is offline   Reply With Quote
Old 28th January 2018, 13:03   #100  |  Link
ocean
Registered User
 
Join Date: Mar 2016
Posts: 87
Thanks for the great work, the mpls file now contains data extensions HDR, something is missing in the clpi file for HDR activation, replacing the original clpi file in the structure created with TSM2UHD, works HDR.

File clpi original:

"ProgramInfo": {
"reserved_for_word_align": 0,
"program_sequence": [
{
"SPN_program_sequence_start": 0,
"program_map_PID": 256,
"reserved01": 0,
"stream_in_ps": [
{
"stream_PID": 4113,
"stream_coding_type": "H.265",
"video_format": "2160p",
"frame_rate": "23.976",
"aspect_ratio": "16:9",
"reserved01": 0,
"cc_flag": 0,
"reserved02": 4608,
"ISRC": {
"country_code": "",
"copyright_holder": "",
"recording_year": "",
"recording_number": ""
},
"reserved03": 0


File clpi after use TSMuxer and TSM2UHD:

"ProgramInfo": {
"reserved_for_word_align": 0,
"program_sequence": [
{
"SPN_program_sequence_start": 0,
"program_map_PID": 256,
"reserved01": 0,
"stream_in_ps": [
{
"stream_PID": 4113,
"stream_coding_type": "H.265",
"video_format": "2160p",
"frame_rate": "23.976",
"aspect_ratio": "16:9",
"reserved01": 0,
"cc_flag": 0,
"reserved02": 0,
"ISRC": {
"country_code": "00",
"copyright_holder": "000",
"recording_year": "00",
"recording_number": "00000"
},
"reserved03": 0
ocean is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.