Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 1st August 2016, 16:19   #1541  |  Link
Blight
Software Developer
 
Blight's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 998
Which thread priority does mediainfo use and is it somehow controllable? (I want to use it in idle thread priority so it has the least affect on UI performance)
__________________
Yaron Gur
Zoom Player . Lead Developer
Blight is offline   Reply With Quote
Old 8th August 2016, 02:38   #1542  |  Link
filler56789
SuperVirus
 
filler56789's Avatar
 
Join Date: Jun 2012
Location: Antarctic Japan
Posts: 937
Hi Zenitram,

¿don't you think the "descriptive string" «Convenient unified display etc Etc ETC» is too long and annoying?

¿Why not say simply 'MediaInfo'?

filler56789 is offline   Reply With Quote
Old 8th August 2016, 09:29   #1543  |  Link
SeeMoreDigital
Life looks better in UHD
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 11,452
Quote:
Originally Posted by filler56789 View Post
Hi Zenitram,

¿don't you think the "descriptive string" «Convenient unified display etc Etc ETC» is too long and annoying?

¿Why not say simply 'MediaInfo'?

Or even 'MediaInfo: Media file meta-data analyzer'
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline   Reply With Quote
Old 2nd September 2016, 08:26   #1544  |  Link
filler56789
SuperVirus
 
filler56789's Avatar
 
Join Date: Jun 2012
Location: Antarctic Japan
Posts: 937
^ Never mind, just use Resource Hacker for the win

filler56789 is offline   Reply With Quote
Old 2nd September 2016, 09:01   #1545  |  Link
Groucho2004
►◄
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Location: A wretched hive of scum and villainy
Posts: 4,459
Quote:
Originally Posted by filler56789 View Post
Hi Zenitram,

¿don't you think the "descriptive string" «Convenient unified display etc Etc ETC» is too long and annoying?

¿Why not say simply 'MediaInfo'?

Similar issue here. Few devs know that Windows pulls the text from "FileDescription" instead of "ProductName".
__________________
Groucho's Avisynth Stuff
Groucho2004 is offline   Reply With Quote
Old 13th September 2016, 19:46   #1546  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,047
New MediaInfo builds (version 0.7.88), CLI and GUI, are now available:
https://github.com/lordmulder/mediai...ases/tag/v2.21
__________________
There was of course no way of knowing whether you were being watched at any given moment.
How often, or on what system, the Thought Police plugged in on any individual wire was guesswork.


LoRd_MuldeR is offline   Reply With Quote
Old 14th September 2016, 13:32   #1547  |  Link
Brazil2
Registered User
 
Join Date: Jul 2008
Posts: 479
Quote:
Originally Posted by LoRd_MuldeR View Post
New MediaInfo builds (version 0.7.88), CLI and GUI, are now available:
https://github.com/lordmulder/mediai...ases/tag/v2.21
Thanks
Brazil2 is offline   Reply With Quote
Old 15th September 2016, 23:00   #1548  |  Link
ggtop
Registered User
 
Join Date: Mar 2003
Posts: 285
shell integration

Hi LoRd_MuldeR,

something I observed using 2.21 on Win7 x64:
Everytime MediaInfo is started I have a new entry MediaInfoXP in Windows Explorer context menu though it is disabled in preferences. I have to enable and disable it for removal. MediaInfoXP is started from a portable drive.

Thanks for looking into the behavior in advance

ggtop
ggtop is offline   Reply With Quote
Old 16th September 2016, 18:42   #1549  |  Link
Brazil2
Registered User
 
Join Date: Jul 2008
Posts: 479
Quote:
Originally Posted by ggtop View Post
using 2.21 on Win7 x64:
Everytime MediaInfo is started I have a new entry MediaInfoXP in Windows Explorer context menu though it is disabled in preferences. I have to enable and disable it for removal.
Yes same for me and it behaves the same on Windows XP so it's not OS related.
Brazil2 is offline   Reply With Quote
Old 27th September 2016, 18:22   #1550  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,191
I have basically always found it necessary to toggle Explorer preferences on/off/on in any version of MediaInfo (XP32SP3).
(with gui close between toggles, that though is to switch something on, not off)
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???
StainlessS is offline   Reply With Quote
Old 27th September 2016, 19:29   #1551  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,191
MediaInfo v7.88, Access Violation on mp3 (XP32SP3):- EDIT: LINK REMOVED

With Settings, Explorer Tooltip enabled, hover over pretty much any mp3 file and get Access Violation.
I ended up have to delete original faulting mp3 via command line as just kept crashing explorer when approaching with mouse.
Going to any old mp3 folder, hovering over the 2nd of many mp3's, same again, so example mp3 is probably not really necessary.

EDIT: Disable Tooltip and no Access Violations.
@Zenitram, please say when taken sample file, so I can delete.

EDIT:
Code:
General
Complete name                            : C:\TEMP\Test.mp3
Format                                   : MPEG Audio
File size                                : 1.72 MiB
Duration                                 : 2 min 30 s
Overall bit rate mode                    : Constant
Overall bit rate                         : 96.0 kb/s
Album                                    : Something Something Something
Track name                               : Something
Track name/Position                      : 48
Performer                                : Somebody
Genre                                    : Pop
Recorded date                            : 2002
Cover                                    : Yes
Cover MIME                               : image/jpg
MusicMatch_Situation                     : Background
MusicMatch_Mood                          : Morose

Audio
Format                                   : MPEG Audio
Format version                           : Version 2
Format profile                           : Layer 3
Mode                                     : Joint stereo
Mode extension                           : Intensity Stereo + MS Stereo
Duration                                 : 2 min 30 s
Bit rate mode                            : Constant
Bit rate                                 : 96.0 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 22.05 kHz
Compression mode                         : Lossy
Replay gain                              : -0.06 dB
Replay gain peak                         : 0.480973
Stream size                              : 1.72 MiB (100%)
MP3Gain, Min/Max                         : 135,180
EDIT: I know, its difficult, hard, impossible, to use MusicMatch after(And I think including) IE7. (I tag with W2K OS and MusicMatch, nothing I like better for that)
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 4th December 2016 at 13:28.
StainlessS is offline   Reply With Quote
Old 28th September 2016, 10:37   #1552  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Location: Berlin, Germany
Posts: 2,630
For me this only happens when the meta data of the MP3 contain cover information. See this post:
http://forum.doom9.org/showthread.ph...73#post1759773

The last MediaInfo version without this issue is 0.7.81.


Cheers
manolito
manolito is offline   Reply With Quote
Old 28th September 2016, 19:19   #1553  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,191
Cheers Mani, love that smile [You should be in movies]
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???
StainlessS is offline   Reply With Quote
Old 28th September 2016, 21:58   #1554  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Location: Berlin, Germany
Posts: 2,630
He still has a very nice smile, doesn't he?
http://www.henrydarrow.com/
manolito is offline   Reply With Quote
Old 29th September 2016, 14:59   #1555  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,191
Quote:
Originally Posted by manolito View Post
He still has a very nice smile, doesn't he?
http://www.henrydarrow.com/
Yep.
Also from your link
Quote:
He was also the lead guest star on a still-beloved program called "Bonanza", produced by the man who would later give us "The High Chaparral"
Seems that Gavino is right, even when he thinks he is wrong:- http://forum.doom9.org/showthread.ph...31#post1574331

EDIT: Deleting given mp3 link in about 24 hours.
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 29th September 2016 at 16:27.
StainlessS is offline   Reply With Quote
Old 4th November 2016, 22:18   #1556  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,047
In latest "All inclusive" package there still is a weird problem with the zlibstat project:

No matter what I do, the individual source code files in that project simply don't apply the settings (e.g. /MT vs. /MD switch) that I have set up in the "main" project properties - even if I explicitly apply "inherit from project defaults"

Had to remove the zlibstat project from the MediaInfo solution and add the normal zlib project instead, which seemed to fix this weirdness. Not sure why they exist both, anyway...
__________________
There was of course no way of knowing whether you were being watched at any given moment.
How often, or on what system, the Thought Police plugged in on any individual wire was guesswork.



Last edited by LoRd_MuldeR; 4th November 2016 at 22:29.
LoRd_MuldeR is offline   Reply With Quote
Old 3rd December 2016, 23:16   #1557  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Location: Berlin, Germany
Posts: 2,630
The latest MediaInfo v 0.7.91 fixes the issue from this post:
http://forum.doom9.org/showthread.ph...41#post1781741

Thanks Zenitram...

Cheers
manolito
manolito is offline   Reply With Quote
Old 29th January 2017, 20:16   #1558  |  Link
stax76
Registered User
 
stax76's Avatar
 
Join Date: Jun 2002
Location: Chamber 36
Posts: 5,852
here is a new MediaInfo cmdlet for PowerShell:

https://forum.doom9.org/showthread.php?t=174267
stax76 is offline   Reply With Quote
Old 24th March 2017, 22:01   #1559  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,047
MediaInfoXP v2.24 (MediaInfo v0.7.93)
* https://github.com/lordmulder/mediai...ases/tag/v2.24
* https://sourceforge.net/projects/mul...8CLI%2BGUI%29/
* https://www.mediafire.com/folder/wps...k8qv/MediaInfo
__________________
There was of course no way of knowing whether you were being watched at any given moment.
How often, or on what system, the Thought Police plugged in on any individual wire was guesswork.



Last edited by LoRd_MuldeR; 24th March 2017 at 22:04.
LoRd_MuldeR is offline   Reply With Quote
Old 1st April 2017, 17:46   #1560  |  Link
manolito
Registered User
 
manolito's Avatar
 
Join Date: Sep 2003
Location: Berlin, Germany
Posts: 2,630
Thanks for the new version 0.7.94...

For the 32-bit CLI executable I found a small cosmetic bug (running under WinXP). For every file I throw at it I get this STDERR output:
Quote:
E: File read error
E: is the drive where Windows is installed, MediaInfo.exe is called from a different drive. So this new version seems to try reading a file on the OS drive which probably does not exist...

The STDOUT output seems to be be correct, and since the error message does not cause a crash, I consider it cosmetic. The previous version had no problem. Also the 32-bit DLL 0.7.94 works fine.

Cheers
manolito

Last edited by manolito; 1st April 2017 at 18:12.
manolito is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.