Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > New and alternative video codecs

Reply
 
Thread Tools Search this Thread Display Modes
Old 20th August 2005, 04:23   #21  |  Link
MeteorRain
紺野木綿季
 
Join Date: Dec 2003
Location: NJ; OR; Shanghai
Posts: 472
Any introduction about 'snow'? what's the features?
interesting about this codec

regards!
MeteorRain is offline   Reply With Quote
Old 20th August 2005, 09:44   #22  |  Link
hellfred
FFmpeg fan
 
Join Date: Dec 2003
Location: Germany
Posts: 427
Quote:
Originally Posted by MeteorRain
Any introduction about 'snow'? what's the features?
interesting about this codec

regards!
Snow is a wavelet-based video codec created by Michael Niedermayer, the main programmer of ffmpeg. Wavelet-based video codecs, snow and dirac are open source codecs of this kind - are supposed to have no blocking issues. The manpage of mplayer/mencoder (available at www.mplayerhq.hu under documentation as html or text file) has a description of all parameters, that can be used to encode with snow. Another short introduction to the snow codec can be found in mplayer sources (main/DOCS/tech/snow.txt). You can browse the cvs here

Hellfred
hellfred is offline   Reply With Quote
Old 20th August 2005, 10:33   #23  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
@sugala: you have the GUI, why don't you see for yourself?
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 20th August 2005, 11:13   #24  |  Link
MeteorRain
紺野木綿季
 
Join Date: Dec 2003
Location: NJ; OR; Shanghai
Posts: 472
Next job job15-1 is a video job. encoder commandline:
"H:\mp4\mplayer2005.06.09.Athlon-64\mencoder.exe" "H:\subgroup\final approach\ncop\VTS_01_1.avs" -ovc lavc -lavcopts vcodec=snow:vqscale=5:cmp=1:subcmp=1:mbcmp=1:qpel:vstrict=-2 -o "H:\subgroup\final approach\ncop\VTS_01_1.avi" -of avi -ffourcc SNOW
successfully set up video encoder and callbacks for job job15-1
----------------------------------------------------------------------------------------------------------

Log for job job15-1

============ Sorry, this file format is not recognized/supported =============
=== If this file is an AVI, ASF or MPEG stream, please contact the author! ===
Cannot open demuxer.
Output file should exist but was not found. Something went wrong while encoding
----------------------------------------------------------------------------------------------------------


i'm encoding an avs file (from dvdrip), but seems it don't support avs input? confused


EDIT==========
NO P/B frame supported???
i decode it using ffdshow, but i only see that all the frams are I frame... what's wrong?

Last edited by MeteorRain; 20th August 2005 at 11:36.
MeteorRain is offline   Reply With Quote
Old 20th August 2005, 12:11   #25  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
uh, first you report a complete failure (most likely completely unrelated to the GUI but a mencoder issue and those belong someplace else), then you have an encoded file?
And then job15-1.. that signifies a subsequent job, yet your commandline looks like a CQ job, so that doesn't make sense.
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 20th August 2005, 12:31   #26  |  Link
MeteorRain
紺野木綿季
 
Join Date: Dec 2003
Location: NJ; OR; Shanghai
Posts: 472
job15-2 is a mkv-muxing job....
i feed a good avs file to the encoder, and it don't work.
but i feed a wmv9 avi file, it works.
so it doesn't support avs? =. =

i test it in command console:
AVS input:
Code:
D:\Documents and Settings\MeteorRain>"H:\mp4\mplayer2005.06.09.Athlon-64\mencode
r.exe" "H:\subgroup\final approach\ncop\VTS_01_1.avs" -ovc lavc -lavcopts vcodec
=snow:vqscale=1.00:qpel:v4mv:vstrict=-2 -o "H:\subgroup\final approach\ncop\VTS_
01.avi" -of avi -ffourcc SNOW -nosound
MEncoder dev-CVS-050609-00:54-3.4.4 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices  (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: Type: 8 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

85 audio & 199 video codecs
File not found: 'frameno.avi'
Failed to open frameno.avi
success: format: 0  data: 0x0 - 0x112
============ Sorry, this file format is not recognized/supported =============
=== If this file is an AVI, ASF or MPEG stream, please contact the author! ===
Cannot open demuxer.

Exiting...

And for avi input:
Code:
D:\Documents and Settings\MeteorRain>"H:\mp4\mplayer2005.06.09.Athlon-64\mencode
r.exe" "H:\subgroup\final approach\ncop\ncop.avi" -ovc lavc -lavcopts vcodec=sno
w:vqscale=1.00:qpel:v4mv:vstrict=-2 -o "H:\subgroup\final approach\ncop\VTS_01_.
avi" -of avi -ffourcc SNOW -nosound
MEncoder dev-CVS-050609-00:54-3.4.4 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices  (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: Type: 8 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

85 audio & 199 video codecs
File not found: 'frameno.avi'
Failed to open frameno.avi
success: format: 0  data: 0x0 - 0x4921000
AVI file format detected.
AVI_NI: No audio stream found -> no sound.
VIDEO:  [WMV3]  640x480  24bpp  23.976 fps  7125.1 kbps (869.8 kbyte/s)
[V] filefmt:3  fourcc:0x33564D57  size:640x480  fps:23.98  ftime:=0.0417
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1  (-1=autodetect) osd: 1
==========================================================================
Opening video decoder: [dmo] DMO video codecs
IMediaObject ERROR: 00AF9A40  could not open DMO DLL (0x0 : 0)
Failed to create DMO filter
ERROR: Could not open required DirectShow codec wmv9dmod.dll.
You need to upgrade/install the binary codecs package.
Go to http://mplayerhq.hu/homepage/dload.html
VDecoder init failed :(
Opening video decoder: [dmo] DMO video codecs
DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested
GetOutput r=0x0   size:921600  align:1
StreamCount r=0x0  1  1
Decoder supports the following formats: YV12 YUY2 UYVY YVYU RGB8 RGB555 RGB565 R
GB24 RGB32
Decoder is capable of YUV output (flags 0x1b)
VDec: vo config request - 640 x 480 (preferred csp: Packed YUY2)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
videocodec: libavcodec (640x480 fourcc=574f4e53 [SNOW])
Using constant qscale = 1.000000 (VBR)
Selected video codec: [wmvdmo] vfm:dmo (Windows Media Video DMO)
==========================================================================
Forcing output fourcc to 574f4e53 [SNOW]
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp h
eader.
ODML: Aspect information not (yet?) available or unspecified, not writing vprp h
eader.
regards!
MeteorRain is offline   Reply With Quote
Old 20th August 2005, 12:36   #27  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
Quote:
job15-2 is a mkv-muxing job....
Uh, there is no matroska support in MeGUI snow edition All the tests I did (see previous posts and links) were done with avisynth files.. clearly something is wrong with yours, but since you didn't post it or tested it in any other applications, the ball is fully in your court...

I'm using the http://www.aziendeassociate.it/cd//m...3.Athlon-64.7z mencoder build by the way.
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 20th August 2005, 12:44   #28  |  Link
MeteorRain
紺野木綿季
 
Join Date: Dec 2003
Location: NJ; OR; Shanghai
Posts: 472
nvm, i'm using the full version LOL
and it was a misclick, so i just deleted the mkv muxing job before the encode

and then, what should i post?

and now, i'm downloading the version you give, and 'll try.
MeteorRain is offline   Reply With Quote
Old 20th August 2005, 12:55   #29  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
Quote:
and then, what should i post?
AviSynth script, and test the script in VirtualDub. Does the same script work for x264.exe? These are really basic error reporting things, they should be mandatory for a first post.
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 20th August 2005, 13:01   #30  |  Link
chilledoutuk
Registered User
 
chilledoutuk's Avatar
 
Join Date: Jun 2003
Posts: 334
Hi doom do you plan to implement the 2 pass workaround or are you just going to wait for snow to be fixed?
__________________
HQ XviD Music Video Forum

When I'm good I'm very, very good but when I'm bad I'm better.
chilledoutuk is offline   Reply With Quote
Old 20th August 2005, 13:12   #31  |  Link
MeteorRain
紺野木綿季
 
Join Date: Dec 2003
Location: NJ; OR; Shanghai
Posts: 472
Quote:
Originally Posted by Doom9
AviSynth script, and test the script in VirtualDub. Does the same script work for x264.exe? These are really basic error reporting things, they should be mandatory for a first post.
Code:
LoadPlugin("g:\dgmpgdec140b2\DGDecode.dll")
LoadPlugin("g:\avs\it.dll")
loadplugin("g:\avs\Convolution3D.dll")
MPEG2Source("VTS_01_1.d2v")
IT(fps=24,ref="TOP",blend=false,diMode=1)
bicubicresize(640,480,0.3333,0.3333)
Convolution3D(preset="AnimeHQ")
it works very well under any other condition, either in VDMod, or for x264.

and i used the new version of mencoder, and still don't work
MeteorRain is offline   Reply With Quote
Old 20th August 2005, 13:20   #32  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
@chilledoutuk: I think you missed the new version.. the workaround is already implemented, and it worked well in my tests

Code:
mpeg2source("D:\DVDs\DVDVolume\VIDEO_TS\re-trailer.d2v")
crop(18,82,684,412)
LanczosResize(640,352)
Works just fine for me.. so you should a) try to reduce your script to find the offending line, then open a new thread with a title like "mencoder doesn't like avisynth input with xyz" (where xyz is the culprit you found), and make sure you put all pertinents facts in that thread (script, culprit, avisynth version, the fact that x264 works, and that you've tested it in VirtualDub (iirc it should be VirtualDub not VDubMod, there's a bit of a difference that seems to matter (check the main megui thread, berrinam once pointed it out)).
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 20th August 2005, 14:16   #33  |  Link
MeteorRain
紺野木綿季
 
Join Date: Dec 2003
Location: NJ; OR; Shanghai
Posts: 472
Code:
avisource("tsq_re.avi", false).trim(0,100)
even this DOESN'T work!!!
orz...........
MeteorRain is offline   Reply With Quote
Old 21st August 2005, 20:40   #34  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
a new build is out. It contains improvements and fixes in the bitrate calculator.
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 22nd August 2005, 03:18   #35  |  Link
Koti
Always trying
 
Koti's Avatar
 
Join Date: Jan 2005
Location: The O.C. ;)
Posts: 221
Quote:
Originally Posted by chilledoutuk
Hi doom do you plan to implement the 2 pass workaround or are you just going to wait for snow to be fixed?
Possibly a 2 pass error in MeGui Snow Edition

1st pass generated by MeGuiSnow "C:\Program Files\Snow Encoder\mencoder.exe" "N:\DVD 1\History .avs" -ovc lavc -o NUL: -passlogfile "2pass.log" -lavcopts vcodec=snow:vqscale=5:vstrict=-2

Missing from 1st pass CLI sent to mencoder is the switch "vpass=1" . This caused the logfile never to be output explaining the 2nd pass failing.
Attached Images
 

Last edited by Koti; 22nd August 2005 at 07:37.
Koti is offline   Reply With Quote
Old 22nd August 2005, 08:03   #36  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
indeed, you are correct. I guess I must've had a valid logfile in my megui directory all along when I tested.

P.S. a few suggestions for your settings: SSD in all cases except for SAD, and don't use m4v.. it kills your speed and doesn't yield useful results at this point. And keep the number of predictors from previous frames at 0.. I think that about covers it (the author suggests those things for optimal results).
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 25th August 2005, 16:40   #37  |  Link
Koti
Always trying
 
Koti's Avatar
 
Join Date: Jan 2005
Location: The O.C. ;)
Posts: 221
Pass 1 is set at a fixed value of vqscale=5 , would it be possible to allow adjustment of this as to get closer to the actual target quant on the 1st pass ?

Quote:
Don't use it for 1st pass as CBR isn't implemented yet,use vqscale instead, and set it to a quantizer near the target average quant of the final encode.
thx
Koti is offline   Reply With Quote
Old 25th August 2005, 17:07   #38  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
Quote:
Pass 1 is set at a fixed value of vqscale=5 , would it be possible to allow adjustment of this as to get closer to the actual target quant on the 1st pass ?
It is only a temporary workaround until libavcodec gets fixed. It's a two line thing.. changing the GUI isn't a two liner, plus then there's the problem with automated 2/3 pass (where there's only a bitrate). And since you don't really know which quantizer you'll get until you have encoded the second pass, I'll stick to what I have and revert back to the proper code when libavcodec gets fixed.
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 28th August 2005, 21:57   #39  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
a new build is up, incorporating the hopefully final fix to get the 2/3 pass workaround working. A full changelog can be found here: http://forum.doom9.org/showthread.ph...495#post674495
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 29th August 2005, 20:42   #40  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,572
the 0.2.2.3a build contains nothing new, but it's compiled using csc so it's smaller. I'll leave the VS.NET build up for a few days to see if there are no problems with this new build.
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.