Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th January 2005, 00:36   #1  |  Link
stax76
staxrip & mpv.net
 
Join Date: Jun 2002
Posts: 5,239
new AVSEdit test build (1.1.1.1 alpha)

Code:
1.1.1.1 alpha (2005-01-16)

parameter help in parameter grid enabled again. I don't know why this was disabled.

fixed bug in KernelDeint filter description

fixed a bug where a param info popup won't close before another one pops up

added support for relative paths. This required to create temporary files in the directory of the script, they will be deleted however when the application exits

settings are now handled in user locations

30% faster startup

400% faster Preview and Crop Dialog
http://www.planetdvb.net/AVSEdit_1.1.1.1.exe

with yv12 the video loads slow, process Explorer shows it loads xvid dll's, is there something faster?
__________________
StaxRip - use pastebin for log files and imgbox for screenshots
mpv.net player
stax76 is offline   Reply With Quote
Old 17th January 2005, 12:31   #2  |  Link
mkanel
Registered User
 
Join Date: Mar 2002
Posts: 109
Stax,

With version 1.1.1.1 alpha I'm not able to preview even a simple avs script with nothing more than the avisource line. I get a message that says in part: "An unhandled exception has occured in your application...Exception has been thrown by the target of invocation." I am able to preview "version".

Also the user defined functions, AVSIs, from the Avisynth plugin directory are no longer showing up in the filter list.

Everything works fine when I reinstall 1.1.0.0

Here are the details of the preview error:
Code:
See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: Native handle is 0
Parameter name: handle
   at System.Drawing.Image.SetNativeImage(IntPtr handle)
   at System.Drawing.Bitmap.FromGDIplus(IntPtr handle)
   --- End of inner exception stack trace ---
   at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault, Assembly caller, Boolean verifyAccess)
   at System.Reflection.RuntimeMethodInfo.InternalInvoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean verifyAccess)
   at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at VFW.AVIFile.GetBMPFromDib2(IntPtr pDIB)
   at VFW.AVIFile.Draw(Graphics g)
   at VFW.AVIFile.Draw()
   at AVSEdit.fPreview.pVideo_Paint(Object sender, PaintEventArgs e)
   at System.Windows.Forms.Control.OnPaint(PaintEventArgs e)
   at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
   at System.Windows.Forms.Control.WmPaint(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 1.0.5000.0
    Win32 Version: 1.1.4322.573
    CodeBase: file:///c:/windows/microsoft.net/framework/v1.1.4322/mscorlib.dll
----------------------------------------
AVSEdit
    Assembly Version: 1.1.1.1
    Win32 Version: 1.1.1.1
    CodeBase: file:///C:/Program%20Files/AVSEdit/AVSEdit.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 1.0.5000.0
    Win32 Version: 1.1.4322.573
    CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll
----------------------------------------
System
    Assembly Version: 1.0.5000.0
    Win32 Version: 1.1.4322.573
    CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 7.0.5000.0
    Win32 Version: 7.10.3052.4
    CodeBase: file:///c:/windows/assembly/gac/microsoft.visualbasic/7.0.5000.0__b03f5f7f11d50a3a/microsoft.visualbasic.dll
----------------------------------------
System.Drawing
    Assembly Version: 1.0.5000.0
    Win32 Version: 1.1.4322.573
    CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll
----------------------------------------
ICSharpCode.TextEditor
    Assembly Version: 2.0.1738.17375
    Win32 Version: 2.0.1738.17375
    CodeBase: file:///C:/Program%20Files/AVSEdit/ICSharpCode.TextEditor.DLL
----------------------------------------
DockingSuite
    Assembly Version: 0.9.2.0
    Win32 Version: 0.9.2.0
    CodeBase: file:///C:/Program%20Files/AVSEdit/DockingSuite.DLL
----------------------------------------
System.Xml
    Assembly Version: 1.0.5000.0
    Win32 Version: 1.1.4322.573
    CodeBase: file:///c:/windows/assembly/gac/system.xml/1.0.5000.0__b77a5c561934e089/system.xml.dll
----------------------------------------
AVIFile
    Assembly Version: 1.0.1843.271
    Win32 Version: 1.0.1843.271
    CodeBase: file:///C:/Program%20Files/AVSEdit/AVIFile.DLL
----------------------------------------

************** JIT Debugging **************
To enable just in time (JIT) debugging, the config file for this
application or machine (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the machine
rather than being handled by this dialog.
Thanks for the continuing development of AVSEdit. If you need any more details let me know. Mike
mkanel is offline   Reply With Quote
Old 17th January 2005, 13:04   #3  |  Link
stax76
staxrip & mpv.net
 
Join Date: Jun 2002
Posts: 5,239
I don't know what could couse the problem with the user defined functions. I didn't make any changes in that area but I'll try to figure it out.

The crash is because of the new very fast drawing code. It uses kind of a hack (reflection) to access private parts of the .NET framework and it uses GDI+. Microsoft recommends to use GDI+ (until Avalon hits the scene ). If you don't have Windows XP or Windows 2003 than you might need to install GDI+ (gdiplus.dll) if no other application did that before. Normally if a file is missing a FileNotFound exception is raised. Maybe the new code requires full user rights, in that case I have to make a fallback function and use the old slow drawing code.

http://www.microsoft.com/downloads/d...displaylang=en
__________________
StaxRip - use pastebin for log files and imgbox for screenshots
mpv.net player
stax76 is offline   Reply With Quote
Old 18th January 2005, 13:57   #4  |  Link
mkanel
Registered User
 
Join Date: Mar 2002
Posts: 109
Stax,

The problem I found is with my system, I tried AVSEdit 1.1.1.1 in a different computer and both the preview and the user defined functions work as in AVSEdit 1.1.0.0. They're both Windows XP, I don't know why the earlier version works but not the latter version, on my primary computer. The gdiplus.dll is there on the problem system.

Anyway, thanks again for the continued development and for your quick reply.

Mike.
mkanel is offline   Reply With Quote
Old 18th January 2005, 14:43   #5  |  Link
stax76
staxrip & mpv.net
 
Join Date: Jun 2002
Posts: 5,239
the old drawing code doesn't work on all systems either, that's how I started working on it, a DVX user made a bug report. There were a few systems where it didn't work. For that user the new code works so if I make a fallback function it works for a few users more. Of course I would like to have this working on all systems and fast. It's a little bit problematic since it don't happen on my systems, bugs every programmer loves. The problem could relate to many things like resolution, color depth, color space of the source, graphic cards and driver, maybe a different system library version, maybe other reasons. If a couple of people post a description of their system maybe the reason can be encircled.
__________________
StaxRip - use pastebin for log files and imgbox for screenshots
mpv.net player
stax76 is offline   Reply With Quote
Old 18th January 2005, 15:36   #6  |  Link
mkanel
Registered User
 
Join Date: Mar 2002
Posts: 109
Quote:
If a couple of people post a description of their system maybe the reason can be encircled.
Here's mine to start:

PIII 933Mhz
Radeon 7200 AGP 32mb, Driver: ATI Technologies Inc, version: 6.14.10.6462
Resolution 1024x768 16 bit.
Color space of soure is YUY2

Windows XP Pro SP2, Net framework SP1.

I don't know what a system library version is. If more details are useful let me know.
mkanel is offline   Reply With Quote
Old 18th January 2005, 16:28   #7  |  Link
mkanel
Registered User
 
Join Date: Mar 2002
Posts: 109
AVSEdit 1.1.1.1 preview works for me if I add "ConvertToRGB" to the avs script, it doesn't work with YUY2. 1.1.0.0 works with YUY2. Neither works with YV12 even though VDMod does work with YV12. Hmmm.

The user defined functions are showing up now. I upgraded to .net framework SP1, I don't know if that fixed it or if a reboot fixed some weird random error.
mkanel is offline   Reply With Quote
Old 19th January 2005, 01:17   #8  |  Link
stax76
staxrip & mpv.net
 
Join Date: Jun 2002
Posts: 5,239
I hope it works now .

http://www.planetdvb.net/AVSEdit_1.1.1.2.exe

AVSEdit don't has build in YV12 support, for YV12 XviD should be installed, it loads fast , if it don't please ensure you have this reg key:

Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
"VIDC.YV12"="xvidvfw.dll"
__________________
StaxRip - use pastebin for log files and imgbox for screenshots
mpv.net player

Last edited by stax76; 19th January 2005 at 01:30.
stax76 is offline   Reply With Quote
Old 19th January 2005, 05:28   #9  |  Link
mkanel
Registered User
 
Join Date: Mar 2002
Posts: 109
Quote:
I hope it works now .
I'll test it on my problem machine as soon as I can. Unfortunately I won't be home until the weekend. I'll let you know then if it works for me. Thanks Stax. Mike.
mkanel is offline   Reply With Quote
Old 21st January 2005, 16:05   #10  |  Link
Socio
Registered User
 
Join Date: May 2004
Posts: 291
This little program is great!

Is there a way to capture preview frames for comparison purposes?
Socio is offline   Reply With Quote
Old 21st January 2005, 17:52   #11  |  Link
Leak
ffdshow/AviSynth wrangler
 
Leak's Avatar
 
Join Date: Feb 2003
Location: Austria
Posts: 2,441
Is there a way to directly jump to a frame in the preview window, either by frame number or a time position? That's the feature I miss most compared to VirtualDubMod...

np: Autechre - Second Bad Vilbel (Anvil Vapre)
Leak is offline   Reply With Quote
Old 24th January 2005, 16:05   #12  |  Link
mkanel
Registered User
 
Join Date: Mar 2002
Posts: 109
Quote:
I hope it works now .
You fixed it! All the colorspaces that I use are now viewable in AVSEdit's preview window.

Thanks Stax.
mkanel is offline   Reply With Quote
Old 24th January 2005, 17:02   #13  |  Link
stax76
staxrip & mpv.net
 
Join Date: Jun 2002
Posts: 5,239
Socio & Leak:

I'll add those shortly, seems important and likely won't require much effort , thanks

mkanel:

great and thanks for your support
__________________
StaxRip - use pastebin for log files and imgbox for screenshots
mpv.net player
stax76 is offline   Reply With Quote
Old 26th January 2005, 16:37   #14  |  Link
azsd
6502 fan
 
azsd's Avatar
 
Join Date: Sep 2004
Location: forest
Posts: 131
Hi,I am azsd that reported the bug at sf.net

new 1.1.1.1 version still hang when run

when trace into it stoped with this hint

System.Xml.Schema.XmlSchemaComplexType..cctor
Attached Images
 
azsd is offline   Reply With Quote
Old 29th January 2005, 02:26   #15  |  Link
stax76
staxrip & mpv.net
 
Join Date: Jun 2002
Posts: 5,239
@azsd

I have no idea, can you please tell me about your system?



1.1.1.3 alpha (2005-01-29)

added key (S) in preview to save the current frame to a file.

added key (C) in preview to copy the current frame to the clipboard.

added key (G) in preview to open a new "Go To Frame" dialog which accepts frame number or time.

fixed negative values when cropping with mouse

crop dialog, trim and filter preview work now if functions are called before the selection but defined after the selection

gdiplus library included (another MB)

http://www.planetdvb.net/AVSEdit_1.1.1.3.exe
__________________
StaxRip - use pastebin for log files and imgbox for screenshots
mpv.net player
stax76 is offline   Reply With Quote
Old 29th January 2005, 02:30   #16  |  Link
Socio
Registered User
 
Join Date: May 2004
Posts: 291
Awesome Stax!

Thanks!
Socio is offline   Reply With Quote
Old 29th January 2005, 20:10   #17  |  Link
azsd
6502 fan
 
azsd's Avatar
 
Join Date: Sep 2004
Location: forest
Posts: 131
Hi,stax

the attached picture can't displayed (may the fourm limited it?)

that dialog look like this:
========================================================

Just-In-Time Debugging

An exception 'System.ExecutionEngineException' has occurred in AVSEdit.exe.

&Possible Debuggers:

New Instance of Visual Studio .NET 2003

Do you want to debug using the selected debugger?

&Yes &No

=========================================================

My system:
Windows Server 2003 std(all hotfix applied)
P4 2.4,512DDR

avisynth 2.5.5 + avsedit 1.0,works fine
avisynth 2.5.5 + avsedit 1.1.0.0/1.1.1.1 hang
avisyhth 2.5.6 + avsedit 1.1.1.3 the same results
azsd is offline   Reply With Quote
Old 30th January 2005, 16:38   #18  |  Link
stax76
staxrip & mpv.net
 
Join Date: Jun 2002
Posts: 5,239
Which .NET version does AVSEdit exucute? If you got more than one versions you can find out with "Process Explorer".
__________________
StaxRip - use pastebin for log files and imgbox for screenshots
mpv.net player
stax76 is offline   Reply With Quote
Old 2nd February 2005, 20:34   #19  |  Link
Socio
Registered User
 
Join Date: May 2004
Posts: 291
The new version is has become an indispensable tool for me;
Using the frame capture makes it real easy to tweak scripts; no more trial & error guess work!


Great job Stax!
Socio is offline   Reply With Quote
Old 8th February 2005, 16:30   #20  |  Link
Ebobtron
Errant Knight
 
Ebobtron's Avatar
 
Join Date: Oct 2004
Location: St Louis, M0 US
Posts: 364
Using 1.1.1.3 and I use it a lot.

Seems better

Save button on tool bar never greys out.

I would love an external preview button on the tool bar.

Thanks great tool.
Ebobtron is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:41.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.