Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-2 Encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th December 2004, 22:08   #1  |  Link
auroauro
Registered User
 
Join Date: Jul 2004
Location: Bucaramanga
Posts: 13
Jerky motion - Script help ??

Hello;

I am converting my home movies to DVD, I capture and process them with Adobe Premiere Pro, I export the movie as AVI, encode it with CCE and author with DVD-Lab.

The DVD plays fine in my PC but it is jerky and interlaced lines shows on my DVD. I encoded the movie with the encoder included in Premiere Pro (sloooow), and it worked fine, so I assume the problem is I am doing something wrong since I have been using CCE (2.67 trial) with rebuilder for a long time withouth a glitch. I am using all the CCE settings showed in the DVto DVD-R guide.

I did not use the recommended Avisynth scripts showed in the DV to DVD-R guide since I am doing all the processing in Adobe and do not want to do Convolution3D or any processing, and I want to keep the video interlaced since it is going to be used on my DVD, not on my PC. I used Avisynth because CCE shows a decode error if I feed the AVI directly (I am using a panasonic codec).

The code I use is:

AviSource("C:\Trabajo\test.avi")

Any ideas ??

Regards;

Rafael
auroauro is offline   Reply With Quote
Old 18th December 2004, 14:44   #2  |  Link
auroauro
Registered User
 
Join Date: Jul 2004
Location: Bucaramanga
Posts: 13
Hi,

After reading and re-reading (it has been difficult for me to understand) I found the problem to be the script I was using, I tried this:

code:

AviSource("C:\Trabajo\Test.avi")
SeparateFields()
odd=SelectOdd
evn=SelectEven
Interleave(evn,odd)
Weave()
DoubleWeave.SelectOdd()

And it worked fine. Sorry for asking this dumb questions but I was having a lot of trouble undertanding what the script means, I thought I was to deinterlace the video.

Now for another question, it is recommended to convert the avi to YUY2 and/or just use the ReInterpolate411() command as showed in the DV to DVD-R guide ?

Sorry if this questions are too lame, please have some patience with me, regards;

Rafael
auroauro is offline   Reply With Quote
Old 18th December 2004, 15:10   #3  |  Link
scharfis_brain
brainless
 
scharfis_brain's Avatar
 
Join Date: Mar 2003
Location: Germany
Posts: 3,605
SeparateFields()
odd=SelectOdd
evn=SelectEven
Interleave(evn,odd)
Weave()

is only wasting CPU-Czcles. It is a NOP!

meaning, this Code is fully sufficient, to inverse the fieldorder:

AviSource("C:\Trabajo\Test.avi")
DoubleWeave.SelectOdd()

but, one doesn't need to change the fieldorder using AVISynth.
You just need to change it in your encoding settings...

DV-AVIs are always BFF (Bottom Field First), while analogue captures using TV-Cards are commonly TFF (Top Field First)
__________________
Don't forget the 'c'!

Don't PM me for technical support, please.
scharfis_brain is offline   Reply With Quote
Old 18th December 2004, 23:24   #4  |  Link
auroauro
Registered User
 
Join Date: Jul 2004
Location: Bucaramanga
Posts: 13
Thanks a lot Scharfis_brain (great logo btw),

I finally could undestood that after a long study of the "How to process interlaced and the final result to be interlaced" thread, there is a lot to learn in that thread, should be made a Sticky in Avisynth and DV forums.

Btw how do I correct the BFF problem in the encoding ? I am using CCE 2.67 trial and does not have a "Upper field first" checkbox in the Video tab ?

Thanks and regards;

Rafael
auroauro is offline   Reply With Quote
Old 19th December 2004, 10:07   #5  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,298
Use the script Scharfi gave you:

Code:
AviSource("C:\Trabajo\Test.avi")
DoubleWeave.SelectOdd()
It will change the field order from BFF to TFF.
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 21st December 2004, 04:22   #6  |  Link
auroauro
Registered User
 
Join Date: Jul 2004
Location: Bucaramanga
Posts: 13
Thanks a lot to all for your help, I have learned a lot.

Regards;

Rafael
auroauro is offline   Reply With Quote
Old 19th January 2005, 15:56   #7  |  Link
kolak
Registered User
 
Join Date: Nov 2004
Location: UK
Posts: 2,169
Quote:
Originally posted by auroauro
Btw how do I correct the BFF problem in the encoding ? I am using CCE 2.67 trial and does not have a "Upper field first" checkbox in the Video tab ?
Thanks and regards;
Rafael
This what you's looking for is "Offset line" (in Video setings). 0 means upper field and 1 bottom field. You can set more e.g. 50. Try you'll see result

Last edited by kolak; 19th January 2005 at 23:56.
kolak is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:58.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.