Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 3rd February 2005, 01:07   #101  |  Link
Liisachan
李姗倩 Lǐ Shān Qin
 
Liisachan's Avatar
 
Join Date: Nov 2002
Posts: 1,140
Halli's filter worked fine with MPC 2005-01-31, and I started to really like it, but it doesnt work anymore after I updated MPC to 2005-02-02 (They are on my mirror). Haali's tasktray icon doesn't show up anymore.... I'm trying to play an MKV with 2 audio / 2 subs, on my Windows 2000 SP4.

Anyone can confirm this, or is it just for me?
Liisachan is offline   Reply With Quote
Old 3rd February 2005, 09:02   #102  |  Link
drjimmy526
Registered User
 
Join Date: Apr 2004
Posts: 5
Haali's splitter is working fine for me except for some frustrating problems with certain files with multiple audio tracks.

After a bunch of testing, it seems to be tied in to AAC tracks somehow. If I have a mkv file, for example, with 2 AAC and 1 MP3 track, when I switch tracks and (I'm using Zoom Player) try to bring up the right click menu I get a non-fatal "Access violation at address ### in module 'zplayer.exe'. Read of address ###" (the actual addresses vary). I get a similar error in MPC as well when I try to check out the Filters in the right-click menu. This is when using FFDSHOW audio to decode AAC, but if I disable FFDSHOW and use the latest CoreAAC, I have the same problem - the error message usually just cites the access violation at 'CoreAAC.ax' instead.

With FFDSHOW audio decoding and filtering disabled I don't have any problems with a different 4 AAC track-only file, but using FFDSHOW, I get the usual error.

I've tested and have no problems with multiple track MP3-only and Vorbis-only files, even using FFDSHOW audio for decoding.

I've tried muxing the problematic files with mkvtoolnix 1.0.1 and 1.2.0, to no avail.
drjimmy526 is offline   Reply With Quote
Old 3rd February 2005, 18:58   #103  |  Link
niamh
Dismembered
 
niamh's Avatar
 
Join Date: Nov 2003
Location: Craggy Island
Posts: 873
@Liisachan, it's working fine here, but I'm on XP.(but it should behave the same). It wouldn't be anything really stupid like the internal matroska splitter switched itself on?

@drjimmy526: You wouldn't have the 3ivx audio decoder installed, by any chance? It was crashing me last week(notably it wouldn't switch AAC tracks properly), even though I hadn't it set to decode anything; all problems were resolved after I uninstalled it (as I've no more use for it anyway). (The audio decoder expires as well as interferes, and I'd forgotten to unregister the dlls).This is just a shot in the dark, as my players were just hanging, not actually totally crashing.And vorbis was working I remember.
__________________
Allen's Axiom: When all else fails, read the instructions.
niamh is offline   Reply With Quote
Old 3rd February 2005, 22:18   #104  |  Link
drjimmy526
Registered User
 
Join Date: Apr 2004
Posts: 5
Nope, I never even installed 3ivx on my system.
drjimmy526 is offline   Reply With Quote
Old 4th February 2005, 00:13   #105  |  Link
Liisachan
李姗倩 Lǐ Shān Qin
 
Liisachan's Avatar
 
Join Date: Nov 2002
Posts: 1,140
Quote:
Originally posted by niamh
It wouldn't be anything really stupid like the internal matroska splitter switched itself on?
/me is baka, but Im not that stupid to do that. ahem! you know I am the one who found the hack to disable mpc's internal splitter from outside by hacking the registry.

The problem is, even you uncheck that checkbox in MPCs Options and disable the internal splitter, MPC will recheck that checkbox automatically by itself. Really strange, possibly something to do with the hack in Haali's installer that will forcefully disable MPC's internal splitter...????

Plus, 2005-01-31 MPC works ok, while 2005-02-02 and 2005-02-03 doesn't mix with Haali's well. But yes, perhaps I'm doing something really stupid somewhere else.

There might be another reason, as my system is not too stable having too many betas, like ffdshow 2005-02-01 and ac3filter 1.02a_test3...thats why i asked "is it only for me?"

EDIT
Something is wrong: Ive just tried to "Store settings in .ini file" in MPC then MPC crashed; most probably this is MPC's problem, and not Haali's filter's. <bug status = closed>

Last edited by Liisachan; 4th February 2005 at 00:26.
Liisachan is offline   Reply With Quote
Old 4th February 2005, 08:22   #106  |  Link
niamh
Dismembered
 
niamh's Avatar
 
Join Date: Nov 2003
Location: Craggy Island
Posts: 873
I've just tried to store settings to ini files, and it worked perfectly

Quote:
The problem is, even you uncheck that checkbox in MPCs Options and disable the internal splitter, MPC will recheck that checkbox automatically by itself.
Well, not here,not even the avi splitter, not if nothing is stored in an ini file either, so Haali's splitter loads fine.Someone on 2k needs to try for you I think.(And I have a fresh system, though I've already installed ffdshow 2005-02-01, so that could be ruled out)
__________________
Allen's Axiom: When all else fails, read the instructions.
niamh is offline   Reply With Quote
Old 4th February 2005, 09:54   #107  |  Link
Liisachan
李姗倩 Lǐ Shān Qin
 
Liisachan's Avatar
 
Join Date: Nov 2002
Posts: 1,140
Yeah, probably something was just messed up.
I got kinda short-tempered and deleted everything under
HKEY_CURRENT_USER\Software\Gabest\Media Player Classic
HKEY_LOCAL_MACHINE\SOFTWARE\Gabest
and the problem is gone. Thanks for the advices & sorry for confusing the thread ^^;

-Edit-
Wait. There IS some problem.
After I cleared the registry settings, Haali's tray icon appeared once, but only once. Next time I started MPC, it didnt appear anymore.

Haali's tray icon does appear if I open the same mkv file using GraphEdit. So I assume something delicate is going on between Haali's filter and MPC.

Last edited by Liisachan; 4th February 2005 at 10:31.
Liisachan is offline   Reply With Quote
Old 4th February 2005, 16:16   #108  |  Link
niamh
Dismembered
 
niamh's Avatar
 
Join Date: Nov 2003
Location: Craggy Island
Posts: 873
Maybe something got screwed Haali's side, rather than MPC's side? I supposed you cleaned that up too....I've the 29/01/2005 splitter(the afternoon one, i.e. the second one), maybe you have a newer one? I'm not sure if it has been updated again..just throwing ideas to the wind, as you've much more knowledge than me on all this anyway
__________________
Allen's Axiom: When all else fails, read the instructions.
niamh is offline   Reply With Quote
Old 5th February 2005, 01:42   #109  |  Link
Liisachan
李姗倩 Lǐ Shān Qin
 
Liisachan's Avatar
 
Join Date: Nov 2002
Posts: 1,140
wild guess

Can't you reproduce this problem on MPC 2005-02-02 or later?
I know this problem doesn't happen for MPC 2005-01-31 or before.


My hunch is this is a problem of MPC.

My wild guess is MPC was enbugged on 2005-02-01, when Gabest changed
Code:
SRC_LAST=SRC_MPA<<1
to
Code:
SRC_DSM=SRC_MPA<<1, SRC_LAST=SRC_DSM<<1
in mplayerc.h,
http://cvs.sourceforge.net/viewcvs.p...1=1.32&r2=1.33
http://cvs.sourceforge.net/viewcvs.p...=date&view=log
That might have caused unexpected buggy side-effects somewhere else.

Haali's hack is, tweaking SrcFilters, default=ffffffff, tweaked=ffffffbf,
or more accurately
Code:
(DWORD) ( dwSrcFilters_CurrentValue & (~SRC_MATROSKA) )
this should disable SRC_MATROSKA;

When you uncheck the checkbox for internal MatroskaSplitter,
MPC 2005-02-03 will actually write fffffbbff as SrcFilters (not ffffffbf for some reason),
when you close the program. The registry is correctly updated.

However, looks like MPC 2005-02-03 does not understad the value fffffbbff,
even tho it wrote that value by itself,
and it's like "I don't understand what these flags should mean, ok then I'll use the
default, ffffffff."

So, even if you uncheck that checkbox, MPC will recheck it by itself next time it is started.

This problem does not occur with MPC 2005-01-31, so I have a reason to believe
MPC is the one that has been enbugged, and Haali's filter is innocent.
For instance, what is called SRC_LAST in Jan. 2005 is equal to what is called SRC_DSM in Feb. 2005,
and not equal to what is called SRC_LAST in Feb. 2005.
This might be totally unrelated, but even a newbie like me could know that this may be confusing.

Why? How? is just a wild guess, but I'm honestly assuming that this is MPC's problem,
not Haali's.
Liisachan is offline   Reply With Quote
Old 5th February 2005, 06:16   #110  |  Link
Liisachan
李姗倩 Lǐ Shān Qin
 
Liisachan's Avatar
 
Join Date: Nov 2002
Posts: 1,140
Confirmed: MPC's pb. Haali's filter is innocent.
http://forum.doom9.org/showthread.ph...087#post606087
Liisachan is offline   Reply With Quote
Old 7th February 2005, 14:19   #111  |  Link
sillKotscha
what's this for?
 
sillKotscha's Avatar
 
Join Date: Apr 2002
Location: Berlin, Germany
Posts: 993
I have a vorbis_5.1.mka testfile, which won`t play at all (MPC just say goodby) with Haalis latest splitter...

anyone else can confirm this??

you can download the file here...

EDIT:

link updated...

http://s31.yousendit.com/d.aspx?id=1...13HZHQM4VP8S65
__________________
latest mix sets: http://soundcloud.com/sill

Last edited by sillKotscha; 7th February 2005 at 14:21.
sillKotscha is offline   Reply With Quote
Old 7th February 2005, 16:05   #112  |  Link
niamh
Dismembered
 
niamh's Avatar
 
Join Date: Nov 2003
Location: Craggy Island
Posts: 873
I got it to work by muxing it to mkv as a mka it won't play, no.
__________________
Allen's Axiom: When all else fails, read the instructions.
niamh is offline   Reply With Quote
Old 7th February 2005, 16:12   #113  |  Link
Mosu
MKVToolNix author
 
Mosu's Avatar
 
Join Date: Sep 2002
Location: Braunschweig, Germany
Posts: 3,517
Haali has already fixed this problem after I've shown him this post. Expect the next release to contain that fix.
__________________
Latest MKVToolNix is v14.0.0

If I ever ask you to upload something, please use my FTP server.
Mosu is offline   Reply With Quote
Old 7th February 2005, 16:15   #114  |  Link
sillKotscha
what's this for?
 
sillKotscha's Avatar
 
Join Date: Apr 2002
Location: Berlin, Germany
Posts: 993
Quote:
Originally posted by Mosu
Haali has already fixed this problem after I've shown him this post. Expect the next release to contain that fix.
Danke Mosu

thanks for pointing him to this thread...
__________________
latest mix sets: http://soundcloud.com/sill
sillKotscha is offline   Reply With Quote
Old 11th February 2005, 18:18   #115  |  Link
Liisachan
李姗倩 Lǐ Shān Qin
 
Liisachan's Avatar
 
Join Date: Nov 2002
Posts: 1,140
I said that recent MPC from CVS doesn't mix will with Haali's filter (and that is MPC's problem), but I think that is true only when you are using Win2K. MPC+Haali's filter worked fine when I tested it on my XP, while I'm still experiencing the same problem on my Windows 2000.
It is now obvious that this is MPC's problem, not Haali filter's. But just fyi.
Liisachan is offline   Reply With Quote
Old 19th February 2005, 20:40   #116  |  Link
filewalker
Registered User
 
filewalker's Avatar
 
Join Date: Mar 2002
Location: Austria
Posts: 329
there's an update on Haali's HP:
Quote:
19/02/2005 Fix a crash when the cues table was present but empty, tray icon can be turned off, additional support for shared intro/outro, fix a subtle bug in buffering that could cause annoying jitter in avi playback, fix a bug in buffering that could cause jitter and excessive seeking in high bitrate matroska files.
http://haali.cs.msu.ru/mkv/

Cu
__________________
I 'm ripping waves!...nothing else! \m/
filewalker is offline   Reply With Quote
Old 21st February 2005, 05:53   #117  |  Link
DonGato
Registered User
 
Join Date: Sep 2004
Posts: 17
Two problems so far with some MKV files...

- if the languages added have no language setting (I know the encoder is quite lame to do that :P), just track names (like "English") then the loading preferences don't work. They work quite well with MPC or ZoomPlayer bundled features.

- these same files don't play with this splitter. You can move to any part of the file but pressing the play button doesn't work at all.

EIT: BTW, this splitter makes Zoom Player starts slow while opening an MKV file. Don't know what is doing during that delay. :/

Last edited by DonGato; 21st February 2005 at 06:03.
DonGato is offline   Reply With Quote
Old 25th February 2005, 18:57   #118  |  Link
karl_lillevold
Moderator
 
karl_lillevold's Avatar
 
Join Date: Oct 2002
Location: Seattle
Posts: 1,584
subtitles / Reclock crash / ActiveMovie window = VSFilter autoload needed

I have been using Gabest's splitter for my RV10 Matroska files, but wanted to try Haali's. However, I had some problems getting started:

1) with Reclock as preferred audio renderer: crash in OLE32.DLL. Happens for all players, incl. Graphedit.

2) removed Reclock. Now most videos now opened a separate ActiveMovie window to display the video. This is both ZoomPlayer and MPC. Videos without subtitles work fine, the problem occurs for all videos with subtitles. For a problem video, if I try to change the subtitle along, a 2nd ActiveMovie window opens (to a total of 3 windows).

Then in graphedit I then noticed that somehow the NVIDIA decoder was connecting to the subtitle output of Haali's splitter. So I set VSFilter autoload to "Yes" in Haali's settings (FAQ #1), and now things seem to work

Oh, and now Reclock also works!
__________________
This information is provided "AS IS" with no warranties, grants no rights, and reflects my personal opinion.
karl_lillevold is offline   Reply With Quote
Old 25th February 2005, 19:06   #119  |  Link
LeMoi
Registered User
 
Join Date: Sep 2004
Location: France
Posts: 322
If i have srt subs with the same name as the mkv file, these subs are not displayed (for example file.mkv and file.srt, i can't choose subs from file.srt) :/
LeMoi is offline   Reply With Quote
Old 3rd March 2005, 03:12   #120  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,182
A new version is available on Haali website.

Quote:
# 03/03/2005 Register shell file type if there was no .mkv yet, seamless subs switching with latest VSfilter and MPC, fix a typo in setting.
Kurtnoise is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:36.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.