Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 29th December 2003, 22:41   #1  |  Link
PBear
Registered User
 
PBear's Avatar
 
Join Date: Sep 2003
Posts: 15
AACMachine ignoring gain setting

Just started using AACMachine 0.52 with Psytel's aacenc.exe 2.15. Two problems:

1. Using "Gain" has no effect on the output file, regardless if I check "Auto Find Maximum Gain" or leave it unchecked and set my own number. If I use AutoFind, Azid runs and the DOS window shows it working; if I set the gain manually, Azid is skipped (as, I assume, it should be).

Either way, there is absolutely no difference in the volume of the output file (it's nearly inaudible).

The input file, in this case, is only 10 MB. Here is the log file using manual gain setting (likewise, when using the automatic setting, the highlighted line still reads "0.000db"):

--------------------------------------------------------

BeSplit v0.82 by DSPguru.
--------------------------
Logging start : 12/29/03 , 11:34:41.

C:\Program Files\Media\BeSplit\BeSplit.exe -core( -input C:\Dump\Knick Knack\Source\Knick Knack.ac3 -prefix C:\Dump\ -logfile C:\Program Files\Media\AACEncode\AACMachine.log -type ac3 -r -ending ) -split( 0 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 256 ) -profile( AacMachine v0.52 )

[00:00:00:000] +------- BeSplit -----
[00:00:00:000] | Input : C:\Dump\Knick Knack\Source\Knick Knack.ac3
[00:00:00:000] | Output Prefix : C:\Dump\
[00:00:00:000] +---------------------
[00:00:00:000] | Found starting address !
[00:03:35:648] | Writing C:\Dump\01.ac3
[00:03:35:648] +---------------------
[00:03:35:648] Operation Completed !
[00:00:00:000] <-- Process Duration
Logging ends : 12/29/03 , 11:34:41.

BeSweet v1.5b19 by DSPguru.
--------------------------
Using azid.dll v1.8 (b825) by Midas (midas@egon.gyaloglo.hu).

Logging start : 12/29/03 , 11:34:41.

C:\Program Files\Media\DVD2SVCD\BeSweet\BeSweet.exe -core( -input C:\Dump\01.ac3 -output C:\Dump\aacmachine.wav -logfilea C:\Program Files\Media\AACEncode\AACMachine.log -2ch ) -profile( The AacMachine v0.52 ) -ota( -sc 1024 -g 25db )

[00:00:00:000] +------- BeSweet -----
[00:00:00:000] | Input : C:\Dump\01.ac3
[00:00:00:000] | Output: C:\Dump\aacmachine.wav
[00:00:00:000] | Floating-Point Process: No
[00:00:00:000] +-------- AZID -------
[00:00:00:000] | Input Channels Mode: 3/2, Bitrate: 384kbps
[00:00:00:000] | Output Stereo mode: Dolby surround compatible
[00:00:00:000] | Total Gain: 0.000dB, Compression: None
[00:00:00:000] | LFE levels: To LR -INF, To LFE 0.0dB
[00:00:00:000] | Center mix level: BSI
[00:00:00:000] | Surround mix level: BSI
[00:00:00:000] | Dialog normalization: No
[00:00:00:000] | Rear channels filtering: No
[00:00:00:000] | Source Sample-Rate: 48.0KHz
[00:00:00:000] +---------------------
[00:03:35:648] Conversion Completed !
[00:03:35:648] Actual Avg. Bitrate : 1536kbps
[00:00:08:000] <-- Transcoding Duration

Logging ends : 12/29/03 , 11:34:49.


BeSplit v0.82 by DSPguru.
--------------------------
Logging start : 12/29/03 , 11:35:53.

C:\Program Files\Media\BeSplit\BeSplit.exe -core( -input C:\Dump\BeSplit.lst -join -type aac -prefix C:\Dump\Knick Knack\Source\Knick Knack.aac -logfilea C:\Program Files\Media\AACEncode\AACMachine.log ) -profile( AacMachine v0.52 )

[00:00:00:000] +------- BeSplit -----
[00:00:00:000] | Input : C:\Dump\BeSplit.lst
[00:00:00:000] | Output Prefix : C:\Dump\Knick Knack\Source\Knick Knack.aac
[00:00:00:000] +---------------------
[ 0] Proessing C:\Dump\01.aac..
[ 3958125] <-- Output file length
[00:00:00:000] +---------------------
[00:00:00:000] Operation Completed !
[00:00:00:000] <-- Process Duration
Logging ends : 12/29/03 , 11:35:53.

-------------------------------------------------------

2. The other problem is that when I click the "Add Wave Header" option, the output file does not get created. The log file stops with the BeSweet portion and BeSplit is not run the second time to create the output file.

[I don't know what adding a Wave header does; I just wanted to see if it would make the file playable with Windows Media Player, since the AAC files that AACMachine creates otherwise cause WMP to crash (unless they're muxed into an MP4 container with a video stream first).]

Thanks.
PBear is offline   Reply With Quote
Old 30th December 2003, 09:21   #2  |  Link
Tuning
I'm back! :D
 
Tuning's Avatar
 
Join Date: Aug 2003
Location: The Matrix
Posts: 1,029
Just a suggestion....

As there is new tool called Oagmachine for creating AAC, I would recommend to use it. Btw, only pre-gain is currently applicable with AAC bcoz no DS filter is currently available to handle Hybrid or post gain.[Oagmachine Guide]

Hope that helps..

Tuning is offline   Reply With Quote
Old 30th December 2003, 09:28   #3  |  Link
DSPguru
BeSweet Author
 
DSPguru's Avatar
 
Join Date: Oct 2001
Location: On top of a supercompact cardinal
Posts: 3,506
1. use BeSweet v1.5b25
2. use BeSplit b0.9b6
DSPguru is offline   Reply With Quote
Old 30th December 2003, 11:02   #4  |  Link
PBear
Registered User
 
PBear's Avatar
 
Join Date: Sep 2003
Posts: 15
Quote:
Originally posted by DSPguru
1. use BeSweet v1.5b25
2. use BeSplit b0.9b6
That did it, thanks ... although it only seems to work when setting the gain manually. When I tried using "Auto Find Maximum Gain" (even though I could watch Azid.dll running in the DOS window and it showed max gain numbers spinning by that reached close to 25db), the log file still showed 0.00db gain in the Azid section and there was no difference in the volume of the output file.

I was using the version of BeSweet that comes with DVD2SVCD, which I'd just updated the same day, so it didn't occur to me that it didn't have the latest version of BeSweet in it (forgot about the betas). Same thing when I downloaded BeSplit: just grabbed the last stable version.

Thanks again for your help.

-------------------------------------

Also to Tuning:

Thanks for the suggestion. I'll check out OagMachine sometime but, for now, I've got it working.

--

PBear
PBear is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:07.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.