Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-2 Encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 12th February 2003, 10:33   #1  |  Link
Fmazzanti
Registered User
 
Join Date: Oct 2001
Posts: 330
Maestro and bitrate underflow

Hi folks,
I put this question here, altough I've seen it has been discussed before but somehow doen't find an exact answer,so I try again
The fact is that sometimes, when authoring DVD's with maestro, it complains at the compiling stage about underflows and total bitrate being too high. I don't know what the underflow stuff means exactly, but too high a bitrate means to me that video+audios exceed the maximum allowed bitrate of a DVD, which I'd like to know what it is (9000? 9500? why an upper limit, by the way?). My solution to this problem is to reencode the video, telling CCE (actually it is DVD2SVCD) to lower the max bitrate: I usually set it to 9000 or 8500, but last night I had to put it as low as 7500 to get something that I'll check if it works tonight... Of course this a tedious procedure, because that means that I have to encode back the movie until I hit a value Maestro likes. Quite disgusting...
So does anybody know of a smarter procedure different from trial and error? Or any way to do the maths before starting the project?
Thanks...
Fmazzanti is offline   Reply With Quote
Old 12th February 2003, 11:17   #2  |  Link
hakko504
Remember Rule One
 
hakko504's Avatar
 
Join Date: Oct 2001
Location: SWEDEN
Posts: 1,612
Maximum bitrate for DVD is 10000kbps. This includes everything, sudio, subtitles,... Thus if you wish to keep a lot of audio, that means that the maximum botrate of the video must be lowered.

Why maximize bitrate: because DVD players weren't faster than that when the DVD standard was set. Still many players limit reading speed to 2x when reading video DVD's.
__________________
/hakko

http://www.boardgamegeek.com
hakko504 is offline   Reply With Quote
Old 12th February 2003, 15:56   #3  |  Link
slk001
Registered User
 
Join Date: Apr 2002
Posts: 399
I believe that this is an error in CCE. I get this warning during Maestro encoding:

AT LEAST ONE INSTANCE OF BUFFER UNDERFLOW OCCURRED DURING THE COMPILE PROCESS. THIS USUALLY MEANS THAT THE MAXIMUM BITRATE HAS BEEN EXCEEDED.

I ran my video through Bitrate Viewer and the maximum BR is less than 7.8Mbps. My audio is a single .AC3 track at 192kbps.

After some research, I discovered that the buffer they are refering to is the VBV (VIDEO BUFFER VERIFIER) that is set during the encode. If this was a DVD max bitrate thing (>10.08Mbps) then the compile should abort (fail - this is a true error).

I traced my problem to one length of a scene where the video was terribly over exposed. This caused CCE to go absolutely ape-shit, and try to encode at the maximum rate. I had to set a local maximum bitrate in CCE over this area, and it still had problems with setting the VBV properly. Since it was just a warning, I simply ignored it (but not until I had burned a test disk and checked that everything worked okay).

My suggestion? Just ignore the warning. If it really bothers you, then place some electrician's tape over the screen where it will appear!
slk001 is offline   Reply With Quote
Old 12th February 2003, 16:36   #4  |  Link
Fmazzanti
Registered User
 
Join Date: Oct 2001
Posts: 330
Quote:
Originally posted by slk001

My suggestion? Just ignore the warning. If it really bothers you, then place some electrician's tape over the screen where it will appear!
Nice point you made
Seriously speaking, I'm pretty sure you may be right. If max bitrate in a DVD is 10000, then I'm sure I haven't reached it with a max video bitrate of 8000 and two audio tracks... no way to get 2000 extra bitrate with 2 audios! So probably is just a CCE problem. What really worries me is the fact of ignoring that warning, as I thought that I would then get a troublesome DVD...
Fmazzanti is offline   Reply With Quote
Old 16th February 2003, 10:43   #5  |  Link
hendrix
Technicolor Japan
 
Join Date: Aug 2002
Location: Japan
Posts: 526
in CCE in the video settings...dont have DVD Compliant selected...
Actually all this option does is set the maximum bitrate in the MPEG-2 file to 9.8mbit which could lead to problems when compiling the project in DVDMaestro and/or Scenarist later on - the option has no influence on the actual bitrate.

hope this helps
hendrix is offline   Reply With Quote
Old 17th February 2003, 16:32   #6  |  Link
slk001
Registered User
 
Join Date: Apr 2002
Posts: 399
Quote:
Originally posted by hendrix
...Actually all this option does is set the maximum bitrate in the MPEG-2 file to 9.8mbit which could lead to problems when compiling the project in DVDMaestro and/or Scenarist later on - the option has no influence on the actual bitrate.
But this error isn't related to the max bitrate. That is a true ERROR. This is just a WARNING. In my research, I read that the VBV is a buffer that is important for CBR streams, and is less so for VBR streams. I tried to find some software that could change the VBV buffer size in my encoded file, but I had no success. I have heard that the original TMPEG encoder had an option in the MPEG TOOLS section. I haven't been able to find this version.
slk001 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.