Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > VirtualDub, VDubMod & AviDemux

Reply
 
Thread Tools Search this Thread Display Modes
Old 11th December 2003, 23:48   #1  |  Link
falcon_b
Registered User
 
Join Date: Oct 2001
Posts: 20
Slow directstream copy

After version 1.5.10. both Virtualdub and VitrualdubMod are very slow if I use them to join avi's in directstream mode. The old releases has 1000-2000 fps, the new one has 50-500.
Could somebody explain me why? I didn't found any help in this forum.


Thanks in advance
falcon_b is offline   Reply With Quote
Old 12th December 2003, 11:04   #2  |  Link
Tuning
I'm back! :D
 
Tuning's Avatar
 
Join Date: Aug 2003
Location: The Matrix
Posts: 1,029
Avery Lee might have changed the code of muxing part. or there will be a probability of bug in that part, which avery lee can only correct.
Tuning is offline   Reply With Quote
Old 12th December 2003, 11:15   #3  |  Link
Suiryc
Registered User
 
Join Date: Oct 2001
Location: France
Posts: 517
Avery Lee changed some pieces of code in the part reading AVI files.
His reading code (which caches a bit ahead of the actual data requests) now consumes less memory ... but is slower (sometimes really slower yeah).

I noticed that along the 1.5.x versions the speed indeed decreased (generally it takes me at least twice the time it needed in the last 1.4.x versions). On the other hand his code consumes less memory and he also does a bit more checkings (to notice and try to fix problems in files).

He also changed the whole muxing system but I don't think this part had a real impact (or nat least not as much as the reading part).
Suiryc is offline   Reply With Quote
Old 12th December 2003, 11:28   #4  |  Link
falcon_b
Registered User
 
Join Date: Oct 2001
Posts: 20
Thanks
falcon_b is offline   Reply With Quote
Old 19th December 2003, 02:59   #5  |  Link
kwyjibo99
Registered User
 
kwyjibo99's Avatar
 
Join Date: May 2003
Posts: 18
Well, I noticed to the new behaivour, but, in my case, demuxing audio streams. Demuxing audio is now very very slow, 7 min for a 20 Mb stream. Maybe I'm soing something wrong... Any idea?

(Maybe this is a feature request, so it must be in the tracker...)
kwyjibo99 is offline   Reply With Quote
Old 23rd December 2003, 02:48   #6  |  Link
AmigaFuture
Registered User
 
Join Date: Apr 2003
Location: Within the main Source.
Posts: 664
Hi,

I've noticed the slow down as well. I'd prefer more memory be used rather than slowing it down this much. Anyway, an idea in case some of you haven't thought about it...

If you have 2 HDDs, save the output file to the other HDD. That should give you a little more speed, it does for me.
__________________
Life is not a journey to the grave; but rather to skid out broadside, thoroughly used, torn and warn and loudly proclaim; WOW; What a ride!!! Soon, I'm going to do it AGAiN in different skin!!
AmigaFuture is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:31.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.