Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th December 2003, 22:38   #1381  |  Link
jimarick
Registered User
 
Join Date: Sep 2002
Posts: 16
Audio/Video Sync

I'm pretty sure it is a constant delay. I dont have any way of sending it to you as im on a 56k modem Sorry.
jimarick is offline   Reply With Quote
Old 15th December 2003, 22:53   #1382  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
Hm, and what should I do when the graph couldn't be rendered? When to display the media type reporting window then? If I go on and try to reopen the file through qt the media types will be lost. And what if one of the streams can be rendered, but not the other and there is no quicktime installed? If I go on in this case, the user will end up with nothing.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 15th December 2003, 23:25   #1383  |  Link
mklp
Registered User
 
Join Date: Dec 2003
Posts: 2
Audio Cd will not play with Mpc

I have installed powerdvd 5.0 and was trying to use the included audiocd playing filter (CLAudioCD.ax) for playing cd's with mpc on win98se. I know that the included audio filter only works with winxp which is why I was trying to get this to work. The "open cd-rom" option is greyed out so I go to open file and select a track to play but it doesn't work. I always get a "cannot render the file" message. I've tried setting it in the override section and selecting prefer filter but it still doesn't work. I even tried using it in graphedit and it worked no problem there so i have no idea what's up. Is there anyway to play cd's with mpc on windows98?
mklp is offline   Reply With Quote
Old 15th December 2003, 23:36   #1384  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
jimarick: a "sparse avi" can be really small, try to make one and see how big it gets after compressing it too.

mklp: Source filters have to be associated in the registry with either a file extension or some byte pattern. In graphedit, do you add this filter and load a .cda file manually, or can it construct the graph by itself if you drop it onto the window (or open from menu)?

edit: To setup the registry, add the HKEY_CLASSES_ROOT\Media Type\Extensions\.cda key, and create a Source Filter = {...} value with the CLSID of the cyberlink filter between the brackets.
__________________
gabest.org

Last edited by gabest; 15th December 2003 at 23:39.
gabest is offline   Reply With Quote
Old 19th December 2003, 12:42   #1385  |  Link
happy_harry
Registered User
 
Join Date: Jun 2003
Location: Budapest
Posts: 18
Hm. My posts were not so clear, i guess...
I used the forum's powerful search button, and i found that dzy has the same problem as me, and he has a really clear explanation:
"Hi gabest

thanks for the ogm splitter, is it possible to integrate vorbis decoder as well?

And there might be a bug in the audio switcher. If I enable audio switcher and use directsound for output, ac3filter's spdif passthrough won't work. The audio render audio stream info are the same, could it be the audio switcher somehow corrupted the data? the external decoder did change to ac3 mode when it's playing. It plays fine when using waveout.

I used to disable audio switcher to work around this, but the ogm splitter requires it enabled else all audio streams will be played at same time.

regards,
dzy"

I hope you can solve this issue, too.
Thx,
happy_harry
happy_harry is offline   Reply With Quote
Old 19th December 2003, 12:49   #1386  |  Link
billou2k
Registered User
 
Join Date: Feb 2002
Location: Under the grey sky
Posts: 146
wrong aspect ratio (update)

Gabest, about the problem I reported a few days ago,
I've changed the playback renderer from overlay mixer to vmr9 and it looks like the problem of wm9 16/9 videos occasionaly not being displayed in the correct aspect ratio is now solved...
Thanks!
__________________
Minds are like parachutes - they only function when open.
billou2k is offline   Reply With Quote
Old 19th December 2003, 17:28   #1387  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
happy_harry: Isn't the 44.1KHz resampler or the channel remapper enabled? Try to uncheck them if the were. I think this may be the problem here.
__________________
gabest.org
gabest is offline   Reply With Quote
Old 19th December 2003, 19:02   #1388  |  Link
happy_harry
Registered User
 
Join Date: Jun 2003
Location: Budapest
Posts: 18
No, they are not enabled.
happy_harry is offline   Reply With Quote
Old 21st December 2003, 21:50   #1389  |  Link
darkthrone
Registered User
 
Join Date: Nov 2003
Posts: 4
MPC won't autoload japanese audio stream/english sub stream

First of all I really appreciate your work Gabest, especially your autoload feature of different non-standard streams when playing anime .ogm files which unfortunately doesnt work for me

Objective

I want my .ogm files to automatically play with the
-japanese audio stream
-english sub stream.

Problem

"Prefered language for DVD Navigator and the external OGM Splitter" does not work.

I tried to play various .ogm files from various encoding groups but that feature (Options->Playback->DVD/OGM) always failed on me:

-mpc still autoloads the standard-audio stream (english) and not the japanese audio stream (stream 2)
-mpc still doesnt autoload the english sub stream

I've deinstalled & unregistered all codecs and filters and started from scratch by installing these codecs/filters step by step many times, without success:

-Media Player Classic 6.4.7.2 (but the previous version didn't work for me either)
-DivX 5.1 (DivX511Bundle.exe) by www.divx.com
-OggDS 0.9.9.5 (OggDS0995.exe original version by Tobias @ http://www.vorbis.com/files/1.0/tobias/OggDS0995.exe)
-VSfilter 2.32 (vsfilter_20031208.zip by guliverkli @ http://prdownloads.sourceforge.net/g...8.zip?download)

-CoreVorbis 1.0b6 (CoreVorbis_1.0b6_20031215.exe @ http://corecodec.org/project/showfil...release_id=113)

my MPC settings:
Player->General
Player->Formats
Playback->General
Playback->DVD/OGM->Menu
Playback->DVD/OGM->Audio
Playback->DVD/OGM->Subtitles
Playback->Output
Filters->General
Filters->Audioswitcher
Filters->Mpeg Decoder
Filters->Overrides
Subtitles->General

Vobsub Autoloading Version Settings:
Main
General
Misc

As you see I disabled the mpc-internal OGM Splitter, no success.
Everytime I open an OGM File with embedded Subs both the Vobsub and Ogg Splitter symbols appear in the system tray but that's absolutely normal I guess.

other things I've tried
-MPC:enabling/disabling "auto-load audio files" and/or "auto-load subtitles"
-MPC:disabling mpc audioswitcher
-Morgan Stream Switcher 0.99
-MPC: DirectShow Video: System Default, VRM7 Renderless, VRM9 Renderless
-MPC:all DirectShow Audio Options (System Default etc..)
-MPC:Overrides: Manually selecting the external OGM Splitter
-Ogg Splitter Options: "always enable all streams"
-OggDS 0.9.9.6 by mgerald (http://nic.dnsalias.com/OggDS0996_inst.zip)
-Nvidia Detonator 41.09_win2kxp.exe
-Vobsub 2.23 (tried it with _both_ Vobsub and Vsfilters installed even if there's no sense)
-Using the previous MPC Version

Misc. System Info

-Windows XP, AMD 1900+, 512 DDR Ram, Sound Blaster Live
-Nvidia Geforce Ti4200 Graphics Card
-Nvidia Detonator 53.03_winxp2k_english_whql.exe
-DirectX 9b

-Software that could interfere? (really doubt it though)
-RealOne Player
-PowerDVD
-Bsplayer

thanks in advance, i'm gonna donate some bucks too, even if im a poor student

Last edited by darkthrone; 21st December 2003 at 22:05.
darkthrone is offline   Reply With Quote
Old 22nd December 2003, 00:29   #1390  |  Link
dzy
Registered User
 
Join Date: Jul 2002
Posts: 18
6.4.7.3
audio switcher + dsound + spdif is working perfectly now

thank you gabest
dzy is offline   Reply With Quote
Old 22nd December 2003, 07:00   #1391  |  Link
darkthrone
Registered User
 
Join Date: Nov 2003
Posts: 4
I tried it with 6.4.7.3 too - still the same problem:

-japanese stream does not auto-load
-english sub stream does not auto-load

I think the fact that mpc doesn't even auto-load the japanese substream hints to an easy solution to my problem, but i just can't find it.
darkthrone is offline   Reply With Quote
Old 22nd December 2003, 15:15   #1392  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
darkthrone: Sorry, I read your post after I had released 6473. If this doesn't work with the original splitter then it is either some bug in mpc or the LCID was not set correctly in the ogm. Just to be sure, could you upload a little of this file somewhere?
__________________
gabest.org
gabest is offline   Reply With Quote
Old 22nd December 2003, 18:23   #1393  |  Link
darkthrone
Registered User
 
Join Date: Nov 2003
Posts: 4
@Gabest: ok sent you a pm and icq message.
darkthrone is offline   Reply With Quote
Old 23rd December 2003, 03:51   #1394  |  Link
opsis81
Registered User
 
Join Date: Nov 2003
Posts: 131
I installed the free versions of QuickTime and RealOne Player
(which is legal).
I copied the files I needed from them in my MPC folder
(which is legal).
Then I uninstalled QuickTime and RealOne Player
(which is also legal).
Now QuickTime decoding is working.RealVideo decoding isn't working
unless I create a reg file like this and add to the registry.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Software\RealNetworks]

[HKEY_CLASSES_ROOT\Software\RealNetworks\Preferences]

[HKEY_CLASSES_ROOT\Software\RealNetworks\Preferences\DT_Codecs]
@="C:\\Program Files\\Media Player Classic\\"

[HKEY_CLASSES_ROOT\Software\RealNetworks\Preferences\DT_Common]
@="C:\\Program Files\\Media Player Classic\\"

[HKEY_CLASSES_ROOT\Software\RealNetworks\Preferences\DT_Plugins]
@="C:\\Program Files\\Media Player Classic\\"

It seems that Media Player Classic tries to find the locations of RealVideo dll files from registry.If it fails it switches to DirectShow and RealMediaSplitter.
It would be really helpful for me if Media Player Classic searched at first without checking the registry(normally if the dll files are placed in system directory or in mplayerc.exe folder, Media Player Classic will find them),then checking the registry and if it fails again switch to DirectShow and RealMediaSplitter.

@Gabest: any answer will be appreciated and many thanks for your excellent work!
opsis81 is offline   Reply With Quote
Old 23rd December 2003, 08:48   #1395  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
opsis81: I only check for the codec dlls in the common dll paths when using realmediasplitter, in native rm mode I lookup the location of pnen3260.dll at DT_Common and this is the only file I use to communicate with codecs and other things.

darkthrone: I tried a few ogms of yours yesterday, but they seemed to open with jap audio + english subs after I set them in the options. I'm going to test more today, but could you check if really the original ogm splitter was loaded for you? In the menu at play/filters. You should see the selected tracks and a few other things in its submenu.
__________________
gabest.org

Last edited by gabest; 23rd December 2003 at 08:55.
gabest is offline   Reply With Quote
Old 23rd December 2003, 11:44   #1396  |  Link
oddball
Registered User
 
Join Date: Jan 2002
Posts: 1,263
MPC never saves the pan & scan setting. I ALWAYS have to set it to 16:9 manually. Can we have a save pan & scan setting on exit?

The other problem I have is with Quicktime which I think is Alt-Quicktime itself being the problem and was wondering if MPC could work around the bug somehow (Even if the player is not the thing that is causing it). When playing Quicktime movies TV overlay fails to work. I have to right click on the playback window to bring up a menu and THEN the TV overlay kicks in. Very odd.

OK just tried in Quicktime player proper and it still does it so is a Quicktime bug with my Nvidia GeForce4 440 MX? Hmm.
oddball is offline   Reply With Quote
Old 23rd December 2003, 12:41   #1397  |  Link
gabest
Registered User
 
gabest's Avatar
 
Join Date: Oct 2001
Posts: 1,459
oddball:

Are you using the "system default" qt renderer? That uses overlay whenever its window is not covered. I think when you bring up that popup menu it switches back to gdi and lets the tuner app take the overlay. Though it sounds strange, I've never seen any tv viewer being this smart, they just usually exit if overlay is not available.

> Can we have a save pan & scan setting on exit?

Maybe we can have
__________________
gabest.org
gabest is offline   Reply With Quote
Old 23rd December 2003, 16:18   #1398  |  Link
darkthrone
Registered User
 
Join Date: Nov 2003
Posts: 4
Re: MPC won't autoload japanese audio stream/english sub stream

@Gabest, yes, I posted my MPC settings in my original post:
As you can see I disabled the internal Ogg Splitter in MPC and chose the correct language settings for audio and subtitles:
OggDS 0995 is installed too

I talked to some other people and they have the same problem, it seems to only work for some..

Quote:
Originally posted by darkthrone

my MPC settings:
Player->General
Player->Formats
Playback->General
Playback->DVD/OGM->Menu
Playback->DVD/OGM->Audio
Playback->DVD/OGM->Subtitles
Playback->Output
Filters->General
Filters->Audioswitcher
Filters->Mpeg Decoder
Filters->Overrides
Subtitles->General

Vobsub Autoloading Version Settings:
Main
General
Misc

As you see I disabled the mpc-internal OGM Splitter, no success.

other things I've tried
-MPC:enabling/disabling "auto-load audio files" and/or "auto-load subtitles"
-MPC:disabling mpc audioswitcher
-Morgan Stream Switcher 0.99
-MPC: DirectShow Video: System Default, VRM7 Renderless, VRM9 Renderless
-MPC:all DirectShow Audio Options (System Default etc..)
-MPC:Overrides: Manually selecting the external OGM Splitter
-Ogg Splitter Options: "always enable all streams"
-OggDS 0.9.9.6 by mgerald (http://nic.dnsalias.com/OggDS0996_inst.zip)
-Nvidia Detonator 41.09_win2kxp.exe
-Vobsub 2.23 (tried it with _both_ Vobsub and Vsfilters installed even if there's no sense)
-Using the previous MPC Version

Misc. System Info

-Windows XP, AMD 1900+, 512 DDR Ram, Sound Blaster Live
-Nvidia Geforce Ti4200 Graphics Card
-Nvidia Detonator 53.03_winxp2k_english_whql.exe
-DirectX 9b

-Software that could interfere? (really doubt it though)
-RealOne Player
-PowerDVD
-Bsplayer

thanks in advance, i'm gonna donate some bucks too, even if im a poor student [/B]
darkthrone is offline   Reply With Quote
Old 23rd December 2003, 17:43   #1399  |  Link
oddball
Registered User
 
Join Date: Jan 2002
Posts: 1,263
Well Gabest about TV overlay. Yes it does that with default settings. I can get it to open up with TV overlay working if I change the settings to DX9 I think (Not sure of exact settings at the moment) but that gives another problem. If I then change the pan & scan so it outputs the correct ratio I wish to view the TV overlay goes black/blank. So I suffer the non-saved pan & scan settings and manually do it with default settings which will give me TV overlay and correct ratio. It's why I want the pan & scan settings saved on exit so that if I change to DX9 etc I don't have to touch the right click for Quictime files. Well I think that's how it would work anyhow.
oddball is offline   Reply With Quote
Old 25th December 2003, 05:26   #1400  |  Link
Xenoproctologist
Registered User
 
Join Date: Apr 2002
Posts: 66
Feature Request

Would it be possible to add an option to blank all other monitors when MPC is in fullscreen mode on a multimonitor system?
Xenoproctologist is offline   Reply With Quote
Reply

Tags
media player classic

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.