Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 13th February 2016, 13:06   #1  |  Link
codexredestemp
Registered User
 
Join Date: Jul 2015
Posts: 3
Mp4box changes resolution when using chroma 444

Hello.
Seems like there is a problem when muxing .264 files to .mp4 if the original .264 video uses chroma 4:4:4 (8 or 10 bit).

I have a video of 1000x800 resolution uncompressed .avi bgr24 and I did some tests:

.avi to .264 commands after pass 1:

Code:
x26410.exe ^
--pass 2 ^
--profile high444 ^
--preset slow ^
--output-csp i444 ^
--range pc ^
--fps 30 ^
--sar 1:1 ^
--stats "C:\testshit.stats" ^
--bitrate 6000 ^
--output testshit44410bit.264 "C:\testshit.avi"
Using x264 (8 or 10 bit) and using profile (high or high10) and using --output-csp i420:
- .264 video -> no problem
-muxing it with Mp4box -> no problem

Using x264 (8 or 10 bit) and using profile high444 and using --output-csp i444:
- .264 video -> no problem
-muxing it with Mp4box -> problem (changes width to 992 and, for example, MPC-HC reports resolution as "1000x800 (RdA 31:25)" 992x800.)

I have tested with mp4box version that comes with MP4BOXGUI 0606, mp4box rev563 and rev1180 using this commands:

Code:
 -add "C:\testshit44410bit.264:fps=30.000:delay=0:name=testshit44410bit.264" -itags tool="My MP4Box GUI 0.6.0.6 <http://my-mp4box-gui.zymichost.com>" -brand mp42 -new "C:\testshit44410bit.mp4"
Latest Mediainfo and x264 18jan2016 version.

Hope someone can help.

Last edited by codexredestemp; 13th February 2016 at 13:12.
codexredestemp is offline   Reply With Quote
Old 13th February 2016, 13:21   #2  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 4,669
Yes, the cropping calculation seems to be wrong when sub-sampling is not 4:2:0 and dimensions are not mod16.

If you want to make sure the developers see it create a ticket on their bug tracker:
https://github.com/gpac/gpac/issues
sneaker_ger is offline   Reply With Quote
Old 15th February 2016, 11:54   #3  |  Link
codexredestemp
Registered User
 
Join Date: Jul 2015
Posts: 3
Problem solved with Mp4box rev1192
codexredestemp is offline   Reply With Quote
Reply

Tags
10bit, 444, 8bit, chroma, mp4box

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 03:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.