Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 29th October 2013, 07:49   #1  |  Link
marcal
Registered User
 
Join Date: Feb 2012
Posts: 2
LoadPlugin Fail - SmoothAdjust.dll

I have 3 systems I use for rendering. 2 are XP-sp3 and 1 is W2k.
All are using Avisynth 2.58, Vdub 1.9.11 and AvsPmod 2.21.
All paths, folders and folder contents are kept identical.
On XP system #1 I can load smoothadjust.dll from autoload plugins folder or manually load from specific folder just fine. No errors.

On XP system #2 it fails to load with a gibberish error code in Vdub or AvsPmod. Since all folders are identical between systems I conclude that I must be missing something in the System32 folder.

Can anyone suggest what I may be missing on XP system #2 ??

As stated in the smoothadjust readme, XP or higher is required. But this is the first plugin I've encounter that doesn't run on W2k. Can anyone suggest if something could be added to W2k to make it work?

rgds.
marcal is offline   Reply With Quote
Old 29th October 2013, 10:15   #2  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 5,812
Quote:
Originally Posted by marcal View Post
fails to load with a gibberish error code
Error codes are not always gibberish to everyone.
If error code contained error 0x007e, then is probably a missing
CPP runtime.
Without the gibberish its hard to tell. (EDIT: I think earlier versions of SmoothAdjust may have required a
CPP runtime update, think current version may have removed this requirement.)

LaTo probably uses an OS function call that does not exist before XP, so there is nothing short of
an XP+ install that would enable usage on the W2K system.
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 29th October 2013 at 10:29.
StainlessS is online now   Reply With Quote
Old 29th October 2013, 10:25   #3  |  Link
Groucho2004
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Posts: 3,854
Quote:
Originally Posted by marcal View Post
Can anyone suggest if something could be added to W2k to make it work?
This older version might work on W2K.
Groucho2004 is offline   Reply With Quote
Old 29th October 2013, 15:08   #4  |  Link
LaTo
LaTo INV.
 
LaTo's Avatar
 
Join Date: Jun 2007
Location: France
Posts: 701
v2.8x uses VS2013 compiler which only support Windows XP SP3 and newer (so W2K is not supported).

However it should work on your XP system (working on my test machine).

What is the exact error message? (and make sure your OS is up-to-date)
LaTo is offline   Reply With Quote
Old 30th October 2013, 18:57   #5  |  Link
marcal
Registered User
 
Join Date: Feb 2012
Posts: 2
The Smoothadjust.dll ver. I'm using is 2.85.
When loading a simple script in Vdub the error message is
"E] Error: Avisynth open failure:
LoadPlugin: プラグイン読込エラー
(C:\video temp\test_load.avs, line 1)"

I found an old thread where StainlessS was helping someone else with a similar problem and it was suggested that maybe msfXX.dll or msvcpXX.dll or msvcrXX.dll were missing.

The failing XP system was missing several of these and after copying them over it now works. (hooray!) I should have copied them over one at a time but was too lazy.

Thanks for taking the time to respond.

**Lato
Groucho2004 suggested an older version of the dll may work in W2K. Is this a possibility?
marcal is offline   Reply With Quote
Old 30th October 2013, 19:28   #6  |  Link
LaTo
LaTo INV.
 
LaTo's Avatar
 
Join Date: Jun 2007
Location: France
Posts: 701
Quote:
Originally Posted by marcal View Post
The Smoothadjust.dll ver. I'm using is 2.85.
When loading a simple script in Vdub the error message is
"E] Error: Avisynth open failure:
LoadPlugin: プラグイン読込エラー
(C:\video temp\test_load.avs, line 1)"

I found an old thread where StainlessS was helping someone else with a similar problem and it was suggested that maybe msfXX.dll or msvcpXX.dll or msvcrXX.dll were missing.

The failing XP system was missing several of these and after copying them over it now works. (hooray!) I should have copied them over one at a time but was too lazy.

Thanks for taking the time to respond.

**Lato
Groucho2004 suggested an older version of the dll may work in W2K. Is this a possibility?
You can try, but W2K support was officially dropped with VS2010 (used in v2.62).
LaTo is offline   Reply With Quote
Old 3rd November 2013, 17:55   #7  |  Link
Gavino
Avisynth language lover
 
Join Date: Dec 2007
Location: Spain
Posts: 3,377
Quote:
Originally Posted by marcal View Post
Can anyone suggest if something could be added to W2k to make it work?
You might want to take a look at KDW, which provides an XP 'wrapper' for W2k.

Disclaimer: I haven't tried it myself, so I have no idea if it will work for your case. The documentation is not exactly easy to understand either.
__________________
GScript and GRunT - complex Avisynth scripting made easier
Gavino is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.