Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 21st February 2013, 15:02   #1  |  Link
rec
Registered User
 
Join Date: Oct 2007
Posts: 66
MeGui & x264 Crashes on Resizing - HELP!

I'm running a simple Avisynth script that resizes 720 60P to 1080 60P. MeGui crashes every time during the video encode. I'm using x264 *scratchpad* as the encoder. If I use Xvid *scratchpad*, the video encodes fine.

What on earth is going on? I really want to use x264.

There's something about the resizing that's causing the crash. If I run a script that doesn't resize, x264 works OK.

Thanks.
rec is offline   Reply With Quote
Old 21st February 2013, 15:54   #2  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
too hard for you to post a logfile ?
Kurtnoise is offline   Reply With Quote
Old 21st February 2013, 21:43   #3  |  Link
rec
Registered User
 
Join Date: Oct 2007
Posts: 66
Here you go, mate.

Preliminary log file only. During closing of MeGUI the well formed log file will be written.

-[Information] Versions
--[Information] [2/21/2013 12:44:32 PM] MeGUI: 2296
--[Information] [2/21/2013 12:44:32 PM] Operating System: Windows XP Professional x86 SP3 (5.1.196608.2600)
--[Information] [2/21/2013 12:44:32 PM] .Net Framework: 4.0 (4.0.30319)
--[Information] [2/21/2013 12:44:32 PM] AviSynth: 9/19/2009 1:36:58 PM
--[Information] [2/21/2013 12:44:32 PM] AvisynthWrapper: 1/3/2009 5:34:04 AM
--[Warning] [2/21/2013 12:44:32 PM] Haali Matroska Splitter not installed properly.
--[Warning] [2/21/2013 12:44:32 PM] Therefore DSS2() and certain functions of FFVideoSource() and the HD Streams Extractor may also not work.
--[Warning] [2/21/2013 12:44:32 PM] Please download and install it from http://haali.su/mkv/
--[Warning] [2/21/2013 12:44:32 PM] Haali DSS2: not installed
--[Information] [2/21/2013 12:44:32 PM] ICSharpCode.SharpZipLib: 0.85.5.452 (8/8/2008 5:31:12 AM)
--[Information] [2/21/2013 12:44:32 PM] LinqBridge: 1.0.0.0 (5/28/2009 10:24:34 AM)
--[Information] [2/21/2013 12:44:32 PM] MediaInfo: 0.7.61.0 (10/22/2012 1:29:04 AM)
--[Information] [2/21/2013 12:44:32 PM] MediaInfoWrapper: 0.7.61.0 (1/6/2013 11:47:14 PM)
--[Information] [2/21/2013 12:44:32 PM] MessageBoxExLib: 1.0.2218.28317 (12/20/2008 5:53:04 AM)
--[Information] [2/21/2013 12:44:32 PM] SevenZipSharp: 0.64.3890.29348 (1/2/2011 7:59:32 PM)
--[Information] [2/21/2013 12:44:32 PM] 7z: 9.20 (11/19/2010 1:27:34 AM)
-[Information] Update detection
--[Information] [2/21/2013 12:44:32 PM] Connecting to server: http://megui.org/auto/stable/
--[Error] [2/21/2013 12:44:32 PM] Could not connect to server http://megui.org/auto/stable/
--[Information] [2/21/2013 12:44:32 PM] Connecting to server: http://megui.xvidvideo.ru/auto/stable/
--[Error] [2/21/2013 12:44:32 PM] Could not connect to server http://megui.xvidvideo.ru/auto/stable/
-[Information] AutoEncode job generation log
--[Information] [2/21/2013 12:45:43 PM] Split Size : null
-[Information] [2/21/2013 12:45:43 PM] Video output file: F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.264
-[Information] [2/21/2013 12:45:43 PM] Muxed output file: F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter-muxed.mp4
-[Information] [2/21/2013 12:45:43 PM] Encodable audio stream 0: F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.ac3
--[Information] Eliminating duplicate filenames
-[Information] Log for job196 (audio, Resize 720 to 1080 - Spline36resize + Unfilter.avs -> Resize 720 to 1080 - Spline36resize + Unfilter.ac3)
--[Information] [2/21/2013 12:45:45 PM] Started handling job
--[Information] [2/21/2013 12:45:45 PM] Preprocessing
--[Information] [2/21/2013 12:45:45 PM] Encoding started
--[Information] [2/21/2013 12:45:45 PM] MediaInfo
---[Information] File: F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.avs
---[Information] AVS input file detected. Getting media information from AviSynth.
-[Information] Format: AVS
-[Information] FormatString: AviSynth Script
-[Information] FileSize: 77
-[Information] PlayTime: 00:00:11.5110000
---[Information] General
-[Information] ID: 0
-[Information] StreamOrder:
-[Information] Width: 1920
-[Information] Height: 1080
-[Information] FrameCount: 690
-[Information] FrameRate: 59.9401797006587
-[Information] FrameRateOriginal:
-[Information] FrameRateMode:
-[Information] ScanType: Progressive
-[Information] Codec: AVS Video
-[Information] CodecString: AVS
-[Information] Format: AVS
-[Information] AspectRatio: 16:9 (1.778)
-[Information] AspectRatioString:
-[Information] Delay: 0
-[Information] Title:
-[Information] Language:
-[Information] LanguageString:
-[Information] Default:
-[Information] DefaultString:
-[Information] Forced:
-[Information] ForcedString:
---[Information] Video
-[Information] ID: 0
-[Information] StreamOrder:
-[Information] Format: AVS
-[Information] FormatProfile:
-[Information] FormatSettingsSBR:
-[Information] FormatSettingsPS:
-[Information] SamplingRate: 48000
-[Information] SamplingRateString: 48000
-[Information] Channels: 2
-[Information] ChannelsString: 2 channels
-[Information] ChannelPositionsString2:
-[Information] BitRateMode: CBR
-[Information] Delay: 0
-[Information] Title:
-[Information] Language:
-[Information] LanguageString:
-[Information] Default:
-[Information] DefaultString:
-[Information] Forced:
-[Information] ForcedString:
---[Information] Audio
--[Information] [2/21/2013 12:45:46 PM] Trying to open the file with Import()
--[Information] [2/21/2013 12:45:46 PM] Successfully opened the file with Import()
-[NoImage] Import("F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.avs")
-[NoImage] 6<=Audiochannels(last)?GetChannel(last,1,3,2,5,6,4):last
-[NoImage] 32==Audiobits(last)?ConvertAudioTo16bit(last):last
-[NoImage] return last
--[Information] [2/21/2013 12:45:46 PM] Avisynth script
--[Information] [2/21/2013 12:45:46 PM] Commandline used: -i - -y -acodec ac3 -ab 512k "{0}"
--[Information] [2/21/2013 12:45:46 PM] Avisynth script environment opened
--[Information] [2/21/2013 12:45:47 PM] Script loaded
--[Information] Output Decoder
---[Information] [2/21/2013 12:45:47 PM] Channels: 2
---[Information] [2/21/2013 12:45:47 PM] Bits per sample: 16
---[Information] [2/21/2013 12:45:47 PM] Sample rate: 48000
--[Information] [2/21/2013 12:45:47 PM] Commandline: C:\Program Files\MeGUI 2296 x86\tools\ffmpeg\ffmpeg.exe -i - -y -acodec ac3 -ab 512k "F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.ac3"
--[Information] [2/21/2013 12:45:47 PM] Encoder process started
-[NoImage] ffmpeg version N-44601-gcb3591e Copyright (c) 2000-2012 the FFmpeg developers
-[NoImage] built on Sep 19 2012 16:28:01 with gcc 4.7.1 (GCC)
-[NoImage] configuration: --enable-gpl --enable-version3 --disable-pthreads --enable-runtime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libass --enable-libcelt --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
-[NoImage] libavutil 51. 73.101 / 51. 73.101
-[NoImage] libavcodec 54. 56.100 / 54. 56.100
-[NoImage] libavformat 54. 27.101 / 54. 27.101
-[NoImage] libavdevice 54. 2.100 / 54. 2.100
-[NoImage] libavfilter 3. 16.104 / 3. 16.104
-[NoImage] libswscale 2. 1.101 / 2. 1.101
-[NoImage] libswresample 0. 15.100 / 0. 15.100
-[NoImage] libpostproc 52. 0.100 / 52. 0.100
-[NoImage] [wav @ 0239d420] max_analyze_duration 5000000 reached at 5013333
-[NoImage] Guessed Channel Layout for Input Stream #0.0 : stereo
-[NoImage] Input #0, wav, from 'pipe:':
-[NoImage] Duration: 00:00:11.49, bitrate: N/A
-[NoImage] Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 48000 Hz, stereo, s16, 1536 kb/s
-[NoImage] Output #0, ac3, to 'F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.ac3':
-[NoImage] Metadata:
-[NoImage] encoder : Lavf54.27.101
-[NoImage] Stream #0:0: Audio: ac3, 48000 Hz, stereo, flt, 512 kb/s
-[NoImage] Stream mapping:
-[NoImage] Stream #0:0 -> #0:0 (pcm_s16le -> ac3)
-[NoImage] video:0kB audio:720kB subtitle:0 global headers:0kB muxing overhead 0.000000%
--[Information] [2/21/2013 12:45:47 PM] Output from encoder via stderr
--[Information] [2/21/2013 12:45:47 PM] MediaInfo
---[Information] File: F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.ac3
-[Information] Format: AC-3
-[Information] FormatString: AC-3
-[Information] FileSize: 737280
-[Information] PlayTime: 00:00:11.520
---[Information] General
-[Information] ID:
-[Information] StreamOrder:
-[Information] Format: AC-3
-[Information] FormatProfile:
-[Information] FormatSettingsSBR:
-[Information] FormatSettingsPS:
-[Information] SamplingRate: 48000
-[Information] SamplingRateString: 48.0 KHz
-[Information] Channels: 2
-[Information] ChannelsString: 2 channels
-[Information] ChannelPositionsString2: 2/0/0
-[Information] BitRateMode: CBR
-[Information] Delay:
-[Information] Title:
-[Information] Language:
-[Information] LanguageString:
-[Information] Default:
-[Information] DefaultString:
-[Information] Forced:
-[Information] ForcedString:
---[Information] Audio
--[Information] [2/21/2013 12:45:47 PM] Postprocessing
---[Information] Deleting intermediate files
--[Information] [2/21/2013 12:45:47 PM] Job completed
-[Information] Log for job197 (video, Resize 720 to 1080 - Spline36resize + Unfilter.avs -> Resize 720 to 1080 - Spline36resize + Unfilter.264)
--[Information] [2/21/2013 12:45:47 PM] Started handling job
--[Information] [2/21/2013 12:45:47 PM] Preprocessing
-[NoImage] directshowsource("00039.MTS")
-[NoImage] Spline36Resize(1920,1080)
-[NoImage] unfilter(50,50)
--[Information] [2/21/2013 12:45:47 PM] Avisynth input script
--[Information] [2/21/2013 12:45:48 PM] Job commandline: "C:\Program Files\MeGUI 2296 x86\tools\x264\x264.exe" --bitrate 44000 --keyint 599 --min-keyint 28 --sar 1:1 --output "F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.264" "F:\Video Files\Around L.A. 2011\Art Show 1-11\Resize 720 to 1080 - Spline36resize + Unfilter.avs"
--[Information] [2/21/2013 12:45:48 PM] Encoding started
--[Error] [2/21/2013 12:46:13 PM] Process exits with error: 3
--[Information] [2/21/2013 12:46:13 PM] Standard output stream
-[NoImage] avs [info]: 1920x1080p 1:1 @ 10000000/166833 fps (cfr)
-[NoImage] x264 [info]: using SAR=1/1
-[NoImage] x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE4.2
-[NoImage] x264 [info]: profile High, level 5.0
--[Information] [2/21/2013 12:46:13 PM] Standard error stream
--[Information] [2/21/2013 12:46:13 PM] Job completed
rec is offline   Reply With Quote
Old 22nd February 2013, 16:11   #4  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
Obviously, you didn't use x264 scratchpad settings...anyway, this is not your issue here.

How did you create your avs file ?

Code:
directshowsource("00039.MTS")
Spline36Resize(1920,1080)
unfilter(50,50)
The full path of your input seems to be missing...
Kurtnoise is offline   Reply With Quote
Old 22nd February 2013, 19:17   #5  |  Link
rec
Registered User
 
Join Date: Oct 2007
Posts: 66
Thanks for the reply. What's obvious to you is not obvious to me. What do you mean I didn't use x264 scratchpad settings? I set it as the encoder in the drop down menu. As for the avs file, I created it by typing it and putting it in the same folder as the clip ("00039.MTS"). Is this an issue? Like I said, MeGUI encoded this AVS fine when I used XVID scratchpad as the encoder.

I should add, the encoding actually starts with x264. It goes about 10 seconds and then crashes. I've tried using different clips - same problem.

The error message is:
Microsoft Visual C++ Runtime Library
x264.exe Abnormal Program Termination

Last edited by rec; 22nd February 2013 at 19:30.
rec is offline   Reply With Quote
Old 23rd February 2013, 12:49   #6  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
Well, maybe you have to update your c++ runtime libraries.

http://www.microsoft.com/en-us/download/details.aspx?id=30679
or
http://www.microsoft.com/en-us/download/details.aspx?id=8328

This is not caused by MeGUI. Probably Avisynth...
Kurtnoise is offline   Reply With Quote
Old 25th February 2013, 06:57   #7  |  Link
rec
Registered User
 
Join Date: Oct 2007
Posts: 66
I'm afraid MeGUI is hopeless. All I want to do is render h264 files in an MP4 wrapper directly from Avisynth scripts. Is there any other workflow that you can suggest?
rec is offline   Reply With Quote
Old 25th February 2013, 07:23   #8  |  Link
kypec
User of free A/V tools
 
kypec's Avatar
 
Join Date: Jul 2006
Location: SK
Posts: 821
Quote:
Originally Posted by rec View Post
I'm afraid MeGUI is hopeless. All I want to do is render h264 files in an MP4 wrapper directly from Avisynth scripts. Is there any other workflow that you can suggest?
Yes, try this x264 GUI tool if MeGUI is too bloated for your purposes.
kypec is offline   Reply With Quote
Old 27th February 2013, 20:41   #9  |  Link
rec
Registered User
 
Join Date: Oct 2007
Posts: 66
SOLVED! MeGUI was not the problem. For some reason, the version of x264.exe included with MeGUI was causing the crash. I replaced with a Jeeb build of x264 and all works fine now.
rec is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.