Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 7th December 2011, 17:26   #7601  |  Link
CoRoNe
Registered User
 
CoRoNe's Avatar
 
Join Date: Nov 2005
Posts: 642
No problem here;

Code:
NSV-file --> LAV Splitter --> FFDShow Video Decoder (VP31)
                          \-> FFDShow Audio Decoder (MP3)
[edit]Never mind. Video streams...I have to read better.[/edit]
__________________
My hobby website

Last edited by CoRoNe; 7th December 2011 at 17:29.
CoRoNe is offline   Reply With Quote
Old 7th December 2011, 17:40   #7602  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,745
Its not supposed to support streaming.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 7th December 2011, 18:25   #7603  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,745
Ok test build time:

http://files.1f0.de/lavf/LAVFilters-...0-gabb9707.zip

@mkanet
Please test CUVID mode with your Soft-Telecined material. Enable CUVID, set to Adaptive deinterlacing, and (hopefully) enjoy.

@Inspector.Gadget / Nevilne:
Please test if your key-frame seeking seems to be working better again

@XadoX
Try if anything changed?
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 7th December 2011, 18:54   #7604  |  Link
fastplayer
Registered User
 
Join Date: Nov 2006
Posts: 799
Argh! I didn't know that MPC's "Fast seek on keyframe" affects LAV's MKV demuxer too. So I had it disabled...
Now when enabled, seeking doesn't kill my slow 2.4GHz X2 anymore!
fastplayer is offline   Reply With Quote
Old 7th December 2011, 19:27   #7605  |  Link
Nevilne
Registered User
 
Join Date: Aug 2010
Posts: 134
Keyframe seek works better now, yes. Good way to test it was to hold seek key, in 0.42 it would stop on one frame sometimes.
(my keyboard repeat rate is set high though)
Nevilne is offline   Reply With Quote
Old 7th December 2011, 21:40   #7606  |  Link
mkanet
Registered User
 
Join Date: May 2002
Posts: 196
Hi nevcairiel, I can provide as many test streams as you need. I want to thank you so much for considering to look into this. I know that if anyone in this world can solve this problem, it would be you. The hard part was getting you interested

It would surely make a lot of people happy who record TV using Windows Media Center, Cablecards, R5000 based cableTV boxes. Most people dont even know why this stuttering is happening.

I would be very grateful for any help you can offer. I wont get my hopes too high, but can't help but hope you might have a "LAV" based solution


Quote:
Originally Posted by nevcairiel View Post
I think i found a rather crude yet theoretically working solution for playback of those mixed soft-telecined / hard-telecined files with CUVID deinterlacing.

A soft-telecine stream typically looks like this:

rtStart: 0, diff: 0, key: 1, repeat: 0, interlaced: 1, tff: 1
rtStart: 333667, diff: 333667, key: 0, repeat: 1, interlaced: 0, tff: 1
rtStart: 834222, diff: 500555, key: 0, repeat: 0, interlaced: 1, tff: 0
rtStart: 1167889, diff: 333667, key: 0, repeat: 1, interlaced: 0, tff: 0
rtStart: 1668333, diff: 500444, key: 0, repeat: 0, interlaced: 1, tff: 1
rtStart: 2002000, diff: 333667, key: 0, repeat: 1, interlaced: 0, tff: 1
rtStart: 2502556, diff: 500556, key: 0, repeat: 0, interlaced: 1, tff: 0
rtStart: 2836222, diff: 333666, key: 0, repeat: 1, interlaced: 0, tff: 0
rtStart: 3336667, diff: 500445, key: 0, repeat: 0, interlaced: 1, tff: 1
rtStart: 3670333, diff: 333666, key: 0, repeat: 1, interlaced: 0, tff: 1

The problem:
- Switching the deinterlacer on/off seems to cause performance issues
- The timestamps of soft-telecined material match a 60 fps stream, instead of 24p (not really a "bad" issue as long as the renderer will match to vsync anyway)
- Double-rate deinterlacing of soft-telecined material causes quite odd results (only the "interlaced: 1" frames above get doubled)

My idea:
- Detect soft-telecined (constant repeat 0/1 switching pattern)
- If detected:
--- Force deinterlacing of all frames, BUT, limit it to 25p/30p mode (no frame doubling) - this eliminates all combing, and doesnt require switching between interlaced/progressive
--- Delay frames with the repeat flag by one field, giving proper 24p timestamps (as an alternative, show frames without the repeat flag one field earlier)

The combination of those options would ensure that there is no combing because the full adaptive deinterlacer is being used, in addition, the timestamps should be smoothed out to ensure smooth playback, even with "stupid" renderers.

The only challenge is properly detecting the soft-telecine. Assuming the pattern is always constant, i could just activate it as soon as i find a repeat flag and turn it off again when there are 2-3 frames without a flag, but that will need investigation on different streams.

Thoughts?
Implementation would probably be somewhat simple.
Note: This mostly only applys to CUVID decoding and deinterlacing. Software decoding is another matter entirely, because i cannot control deinterlacing there.
mkanet is offline   Reply With Quote
Old 7th December 2011, 22:46   #7607  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,745
Quote:
Originally Posted by mkanet View Post
I wont get my hopes too high, but can't help but hope you might have a "LAV" based solution
Just try the test version posted above, and see how it works for you.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 7th December 2011, 22:57   #7608  |  Link
Leader
Registered User
 
Join Date: Jul 2011
Posts: 16
Found some problems:
1. When you open the Start menu - All Programs - LAV Audio Decoder, the properties of the decoder was called to trim the video (look at screenshot)
2. Is it possible to LAV Audio Decoder automatically included for all audio output selected only the most necessary, as I have, for example, does not support the "32 bit floating point", because of what the decoder does not work. Have long puzzled as to why he could not boot. Thanks in advance.
Attached Files
File Type: 7z window.7z (51.3 KB, 6 views)
Leader is offline   Reply With Quote
Old 8th December 2011, 00:10   #7609  |  Link
dead_screem
Registered User
 
Join Date: Jan 2005
Posts: 105
Quote:
Originally Posted by nevcairiel View Post
Ok test build time:

http://files.1f0.de/lavf/LAVFilters-...0-gabb9707.zip

@mkanet
Please test CUVID mode with your Soft-Telecined material. Enable CUVID, set to Adaptive deinterlacing, and (hopefully) enjoy.

@Inspector.Gadget / Nevilne:
Please test if your key-frame seeking seems to be working better again

@XadoX
Try if anything changed?
works great on my 9800GTX with everything I threw at it.
is something like this possible with YADIF?

Also, Should there be an option to disable this?
dead_screem is offline   Reply With Quote
Old 8th December 2011, 01:45   #7610  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Quote:
Originally Posted by nevcairiel View Post
Ok test build time:

http://files.1f0.de/lavf/LAVFilters-...0-gabb9707.zip

@Inspector.Gadget / Nevilne:
Please test if your key-frame seeking seems to be working better again
Yes, this build exhibits the preferred behavior. Thank you for your tireless work on these filters.
Inspector.Gadget is offline   Reply With Quote
Old 8th December 2011, 02:03   #7611  |  Link
mkanet
Registered User
 
Join Date: May 2002
Posts: 196
Full Report: Soft-Telecined switching issue

Okay I tested the new decoder with CUVID enabled and adaptive deinterlacing enabled.

1. There are NO MORE INTERLACING ARTIFACTS!!!
2. Video is perfectly smooth except for certain scenes have video stutter. Video stutter seems a little more milder.

Rather than send you long/big videos showing smooth video with random stutter... I decided to narrow down EXACTLY part of the video that stutters on my setup in the previous one minute Dexter clip.

Here's the 14 second video with stutter every time:
http://www.megaupload.com/?d=P827WH5F

Thanks a million,
MKANET

Quote:
Originally Posted by nevcairiel View Post
Ok test build time:

http://files.1f0.de/lavf/LAVFilters-...0-gabb9707.zip

@mkanet
Please test CUVID mode with your Soft-Telecined material. Enable CUVID, set to Adaptive deinterlacing, and (hopefully) enjoy.

@Inspector.Gadget / Nevilne:
Please test if your key-frame seeking seems to be working better again

@XadoX
Try if anything changed?
mkanet is offline   Reply With Quote
Old 8th December 2011, 03:32   #7612  |  Link
mkanet
Registered User
 
Join Date: May 2002
Posts: 196
The 9800GTX might be in the family of display adapters that can already handle the soft/hard-telecine switching issue (if that's what the probably actually is). Below are the Nvidia cards that are reported not to have have this issue. I have no idea what's unique about them to be more tolerant to these type of encodings.

NVIDIA
GeForce 8500GT 8600 GTS
GeForce 9300
GeForce 9400 (including ION platforms)
GeForce GT 430
GeForce GT 440 (same core as 430)

Quote:
Originally Posted by dead_screem View Post
works great on my 9800GTX with everything I threw at it.
is something like this possible with YADIF?

Also, Should there be an option to disable this?
mkanet is offline   Reply With Quote
Old 8th December 2011, 07:05   #7613  |  Link
XadoX
Registered User
 
XadoX's Avatar
 
Join Date: Feb 2002
Posts: 187
Quote:
Originally Posted by nevcairiel View Post
...@XadoX
Try if anything changed?
Thx for the fast feedback. At first tests the stuttering seems to be gone. I have to do some more testing to be realy sure.
XadoX is offline   Reply With Quote
Old 8th December 2011, 13:12   #7614  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,745
Quote:
Originally Posted by dead_screem View Post
is something like this possible with YADIF?
Not completely. If you set YADIF to 25p/30p mode, it would be possible to do something similar, however switching YADIF between the two modes on the fly is not as easy as it is for CUVID.

I can run some tests, i guess, but also isn't known to work 100% on telecined material, so artifacts may happen.

Quote:
Originally Posted by dead_screem View Post
Also, Should there be an option to disable this?
Not sure, the code is rather safe, all it really does is force some deinterlacing settings, so the worst thing that can happen is that you won't get 60p output when the stream is improperly flagged as soft telecine.

It relys on constant repeat flags, which means every second frame has to have a repeat flag, or it'll switch out of soft-TC mode again, so there really isn't much that can go terribly wrong.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 8th December 2011, 15:57   #7615  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,633
Can you consider implementing an "load VSFilter" option in the splitter or video decoder?

The problem is that WMP12 often refuses to load VSFilter by itself. The auto-load VSFilter option in Haali splitter works great, but only works for embedded subtitles. External subs won't load when using ffdshow or LAV video as preferred decoder. Oddly enough, they do work when using the crappy MS decoder.

I know WMP sucks, but many people do use it.

Since this problem only affects WMP/MC afaik, the workaround only needs to be applied for those players. Other players are smart enough to do things properly themselves.
clsid is offline   Reply With Quote
Old 8th December 2011, 18:32   #7616  |  Link
mkanet
Registered User
 
Join Date: May 2002
Posts: 196
The last link I posted would probably be the best possible example. Whatever nevcairiel did in the last test build of the video filter completely eliminated combing artifacts (which isn't by accident); however, there's still some remaining video judder. I'm presuming the soft-telecine flag is being detected; and "something" is being done, but not quite right.

Quote:
Originally Posted by madshi View Post
Ouch, that's nasty! You don't happen to have a sample available like that?
Quote:
Originally Posted by e-t172 View Post
sometimes even switching between the two several times per second
mkanet is offline   Reply With Quote
Old 8th December 2011, 18:44   #7617  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 8,745
Quote:
Originally Posted by mkanet View Post
Here's the 14 second video with stutter every time:
http://www.megaupload.com/?d=P827WH5F
I'm not sure this can be further improved without a full blown IVTC, which i'm not willing to invest in right now.
One thing you can try, change the CUVID deinterlacer to 25p/30p, and see if that helps at all?
__________________
LAV Filters - open source ffmpeg based media splitter and decoders

Last edited by nevcairiel; 8th December 2011 at 18:48.
nevcairiel is offline   Reply With Quote
Old 8th December 2011, 19:37   #7618  |  Link
mkanet
Registered User
 
Join Date: May 2002
Posts: 196
When I enable 25p/30p to occur all the time, the parts that have video judder look exactly the same. It appears the the video is being switched to 25p/30p already when soft-telecine is detected; however, this doesnt seem to completely eliminate the video judder.

Whatever you did helped a lot (which I'm sure isn't coincidence). I will definitely use your test build until the next official release.

Do you know what exactly is the cause for the remaining video judder? Can you see the same thing I am in that short video clip? Could you or someone please be kind enough to tell me how to supplement the correct directshow component to handle the remaining video judder please? Someone mentioned Dscaler IVTC; however, I dont know to supplement that with LAV Video AND still have CUVID for AVC/VC-1. The only other IVTC I know is the partially working experimental build of ffdshow with IVTC.

Anyway, if all else fails, at least I would have gained a new and improved LAV Video filter. I really appreciate all you help nevcairiel, now at least the video is pretty much watchable.

Quote:
Originally Posted by nevcairiel View Post
I'm not sure this can be further improved without a full blown IVTC, which i'm not willing to invest in right now.
One thing you can try, change the CUVID deinterlacer to 25p/30p, and see if that helps at all?
mkanet is offline   Reply With Quote
Old 8th December 2011, 20:34   #7619  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,757
Quote:
Originally Posted by mkanet View Post
Someone mentioned Dscaler IVTC; however, I dont know to supplement that with LAV Video AND still have CUVID for AVC/VC-1.
The DScaler IVTC Mod only decodes MPEG2, so giving it a try wouldn't affect AVC/VC-1 decoding at all. Just set DScaler to "preferred" in MPC-HC (if you're using MPC-HC). Which renderer are you using, btw, and which display refresh rate?
madshi is offline   Reply With Quote
Old 8th December 2011, 20:51   #7620  |  Link
sexus
Registered User
 
sexus's Avatar
 
Join Date: Apr 2011
Posts: 187
hows that dvd support comin along? nevcairiel

p.s: merry christmas and a happy new year to yall in advance xD
sexus is offline   Reply With Quote
Reply

Tags
decoders, directshow, filters, splitter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 01:53.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.