Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Decrypting

Reply
 
Thread Tools Search this Thread Display Modes
Old 18th March 2009, 09:02   #121  |  Link
Mike Chen
Registered User
 
Join Date: Jun 2008
Posts: 67
Quote:
Originally Posted by evdberg View Post
Hi Mike,

I am a bit confused. MakeMKV complains that it can't read the VID from the disc (just like cddump), but there is no way to provide the VID to MakeMKV to read from the original disc?
It should be able to read VID automatically. Does it give any specific error messages? Please enable "show debug messages" in preferences,restart the program, and try to open disc.
Mike Chen is offline   Reply With Quote
Old 18th March 2009, 13:25   #122  |  Link
evdberg
Registered User
 
Join Date: Dec 2006
Posts: 202
@Mike,

Did as you asked, and this is the result:
Code:
FAILURE: Code 2 at rIS~%I$w}N4L5D]`*:121262095
FAILURE: Code 0 at 2cCq8J8*@Y!@}90<U[:213129823
FAILURE: Code 2 at rIS~%I$w}N4L5D]`*:121262095
FAILURE: Code 1 at 2cCq8J8*@Y!@}90<U[:213129823
FAILURE: Code 2 at rIS~%I$w}N4L5D]`*:121262095
FAILURE: Code 2 at 2cCq8J8*@Y!@}90<U[:213129823
FAILURE: Code 2 at rIS~%I$w}N4L5D]`*:121262095
FAILURE: Code 3 at 2cCq8J8*@Y!@}90<U[:213129823
FAILURE: Code 2 at rIS~%I$w}N4L5D]`*:121262095
FAILURE: Code 4 at 2cCq8J8*@Y!@}90<U[:213129823
Can't read AACS VID from disc - most likely current AACS host certificate is revoked by your drive
The volume key is unknown for this disc - video can't be decrypted
FAILURE: Code 0 at 4NOxj\Jn:o# i2qL:121262141
FAILURE: Code 0 at 4NOxj\Jn:o# i2qL:121262440
Failed to open disc
evdberg is offline   Reply With Quote
Old 18th March 2009, 13:47   #123  |  Link
loo3aem3ON
Registered User
 
Join Date: Sep 2008
Posts: 189
His drive is patched so it will send the volume id even if authentication failed (e.g. due to revocation). Simply ask for the volume id regardless if the authentication was successful or not. Don't invalidate the AGID before that.
loo3aem3ON is offline   Reply With Quote
Old 18th March 2009, 18:35   #124  |  Link
Mtz
Registered User
 
Mtz's Avatar
 
Join Date: Sep 2003
Location: On The Beach
Posts: 712
The latest version 797 of MakeMKV is freezing my PC when I want to set the source. With older versions, no problem.
WindowsXP.

enjoy,
Mtz
Mtz is offline   Reply With Quote
Old 18th March 2009, 20:32   #125  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,274
@Mtz

Is this what you're talking about?

With Build 797, the initial analysis period APPEARS to be stalled, but look at the timers of both bars. After from 45 seconds to 1 minute, the blocks on the two bars start accumulating - and then the rest of the analysis goes more quickly than earlier version.

On previous versions, the blocks started accumulating almost immediately...
setarip_old is offline   Reply With Quote
Old 18th March 2009, 22:29   #126  |  Link
Mtz
Registered User
 
Mtz's Avatar
 
Join Date: Sep 2003
Location: On The Beach
Posts: 712
Even only closing the program and no other thing done will freeze my PC.

enjoy,
Mtz
Mtz is offline   Reply With Quote
Old 18th March 2009, 22:40   #127  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,274
@Mtz

I can only tell you that I've encountered no such problem running this version (1.03B797) on a system running XP SP3...

Have you tried it with several different discs, or only one?
setarip_old is offline   Reply With Quote
Old 19th March 2009, 01:20   #128  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,274
@Mike Chen

Hi!

I'm pleased to let you know that v.1.03 Build 797 now appears to properly process BluRay discs containing VC-1 video ;>}
setarip_old is offline   Reply With Quote
Old 30th March 2009, 16:22   #129  |  Link
Mtz
Registered User
 
Mtz's Avatar
 
Join Date: Sep 2003
Location: On The Beach
Posts: 712
Also the problem is with the 778 version. The latest working is 722.
This is the ONLY program installed on my PC with this problem. And I have many installed. Also I have XP SP3.

enjoy,
Mtz
Mtz is offline   Reply With Quote
Old 30th March 2009, 22:24   #130  |  Link
loo3aem3ON
Registered User
 
Join Date: Sep 2008
Posts: 189
Quote:
Originally Posted by Mtz View Post
Also the problem is with the 778 version. The latest working is 722.
This is the ONLY program installed on my PC with this problem. And I have many installed. Also I have XP SP3.
Doesn't Windows have some kind of logfile which could tell you what happend (e.g. kernel panic)?
loo3aem3ON is offline   Reply With Quote
Old 30th March 2009, 23:23   #131  |  Link
Mtz
Registered User
 
Mtz's Avatar
 
Join Date: Sep 2003
Location: On The Beach
Posts: 712
I can only power off the PC from the button.

enjoy,
Mtz
Mtz is offline   Reply With Quote
Old 31st March 2009, 08:45   #132  |  Link
Mike Chen
Registered User
 
Join Date: Jun 2008
Posts: 67
Quote:
Originally Posted by Mtz View Post
Also the problem is with the 778 version. The latest working is 722.
This is the ONLY program installed on my PC with this problem. And I have many installed. Also I have XP SP3.

enjoy,
Mtz
I wonder if this is a drive problem. Can you try the following - to disable your dvd drive in device manager, start makemkv and see if it will freeze the pc or not. What is your drive model?
Mike Chen is offline   Reply With Quote
Old 31st March 2009, 09:42   #133  |  Link
lchiu7
Registered User
 
Join Date: Apr 2002
Posts: 279
Well I encountered a disc with VC1 video and makemkv created a file that is not playable. It seemed to decode the title okay and create a mkv file but when I try to play it on a Popcorn Hour, it's jerky.

The file seems to be broken. Tried to re-encode the file to something smaller using megui (which calls x264) and x264 just hangs. mkvtoolnix can't demux the VC1 video either.
lchiu7 is offline   Reply With Quote
Old 31st March 2009, 09:45   #134  |  Link
Mtz
Registered User
 
Mtz's Avatar
 
Join Date: Sep 2003
Location: On The Beach
Posts: 712
Drive Information
Manufacturer: HL-DT-ST
Product: DVDRAM GSA-H10N
Revision: JL11
Firmware date: 2006-05-19 12:34:56

Daemon Tools (with 4 virtual drives)
Virtual Clone Drive

MakeMKV Version 797

First I disabled the dvd drive. The freezing come after about 1 minute. Then I was trying to reduce the numbers of daemon virtual drives. That seems to work for another few minutes.
Installing 772, enabling again the LG DVD Drive. Things work correct.
Installing again 797, disabling LG, and now MakeMKV even can't start and this is the error:
Code:
<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="makemkvcon.exe" FILTER="GRABMI_FILTER_PRIVACY">
    <MATCHING_FILE NAME="cddump.exe" SIZE="155648" CHECKSUM="0xE892A789" MODULE_TYPE="WIN32" PE_CHECKSUM="0x273BA" LINKER_VERSION="0x0" LINK_DATE="03/17/2009 02:15:29" UPTO_LINK_DATE="03/17/2009 02:15:29" />
    <MATCHING_FILE NAME="driveio.dll" SIZE="18432" CHECKSUM="0xF1D9A5CC" MODULE_TYPE="WIN32" PE_CHECKSUM="0x10D61" LINKER_VERSION="0x0" LINK_DATE="02/13/2009 08:58:43" UPTO_LINK_DATE="02/13/2009 08:58:43" />
    <MATCHING_FILE NAME="libdriveio.dll" SIZE="18432" CHECKSUM="0x825DE218" MODULE_TYPE="WIN32" PE_CHECKSUM="0x108E9" LINKER_VERSION="0x0" LINK_DATE="03/17/2009 02:10:40" UPTO_LINK_DATE="03/17/2009 02:10:40" />
    <MATCHING_FILE NAME="libmakemkv.dll" SIZE="183296" CHECKSUM="0x127AA2BB" MODULE_TYPE="WIN32" PE_CHECKSUM="0x2D435" LINKER_VERSION="0x0" LINK_DATE="03/17/2009 02:10:46" UPTO_LINK_DATE="03/17/2009 02:10:46" />
    <MATCHING_FILE NAME="makemkv.exe" SIZE="3549184" CHECKSUM="0x876954AC" MODULE_TYPE="WIN32" PE_CHECKSUM="0x36F14F" LINKER_VERSION="0x0" LINK_DATE="03/17/2009 02:18:51" UPTO_LINK_DATE="03/17/2009 02:18:51" />
    <MATCHING_FILE NAME="makemkvcon.exe" SIZE="2880000" CHECKSUM="0xC91462D4" MODULE_TYPE="WIN32" PE_CHECKSUM="0x2CECDB" LINKER_VERSION="0x0" LINK_DATE="03/17/2009 02:16:38" UPTO_LINK_DATE="03/17/2009 02:16:38" />
    <MATCHING_FILE NAME="mkvdll.dll" SIZE="183808" CHECKSUM="0x410FE53D" MODULE_TYPE="WIN32" PE_CHECKSUM="0x2E9DE" LINKER_VERSION="0x0" LINK_DATE="02/13/2009 08:58:49" UPTO_LINK_DATE="02/13/2009 08:58:49" />
    <MATCHING_FILE NAME="uninst.exe" SIZE="65302" CHECKSUM="0xAB0678E0" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="05/03/2008 14:08:42" UPTO_LINK_DATE="05/03/2008 14:08:42" />
</EXE>
<EXE NAME="libdriveio.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="libdriveio.dll" SIZE="18432" CHECKSUM="0x825DE218" MODULE_TYPE="WIN32" PE_CHECKSUM="0x108E9" LINKER_VERSION="0x0" LINK_DATE="03/17/2009 02:10:40" UPTO_LINK_DATE="03/17/2009 02:10:40" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="kernel32.dll" SIZE="989696" CHECKSUM="0x7D737C09" BIN_FILE_VERSION="5.1.2600.5512" BIN_PRODUCT_VERSION="5.1.2600.5512" PRODUCT_VERSION="5.1.2600.5512" FILE_DESCRIPTION="Windows NT BASE API Client DLL" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Microsoft® Windows® Operating System" FILE_VERSION="5.1.2600.5512 (xpsp.080413-2111)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. All rights reserved." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xF44A2" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.5512" UPTO_BIN_PRODUCT_VERSION="5.1.2600.5512" LINK_DATE="04/14/2008 00:11:24" UPTO_LINK_DATE="04/14/2008 00:11:24" VER_LANGUAGE="English (United States) [0x409]" />
</EXE>
</DATABASE>
The last setup was Virtual Clone Drive and 2 devices from Daemon.

enjoy,
Mtz
Mtz is offline   Reply With Quote
Old 31st March 2009, 12:50   #135  |  Link
loo3aem3ON
Registered User
 
Join Date: Sep 2008
Posts: 189
Quote:
Originally Posted by Mtz View Post
Drive Information
Manufacturer: HL-DT-ST
Product: DVDRAM GSA-H10N
Revision: JL11
Firmware date: 2006-05-19 12:34:56
Is this drive executing the original firmware? Your manufacturer string looks like a LG drive in safe mode.
loo3aem3ON is offline   Reply With Quote
Old 31st March 2009, 14:19   #136  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Quote:
Originally Posted by lchiu7 View Post
Well I encountered a disc with VC1 video and makemkv created a file that is not playable. It seemed to decode the title okay and create a mkv file but when I try to play it on a Popcorn Hour, it's jerky.

The file seems to be broken. Tried to re-encode the file to something smaller using megui (which calls x264) and x264 just hangs. mkvtoolnix can't demux the VC1 video either.
Are you using ffdshow to decode VC1? Don't. Use the WMVideo Decoder DMO.
Inspector.Gadget is offline   Reply With Quote
Old 31st March 2009, 14:56   #137  |  Link
Mtz
Registered User
 
Mtz's Avatar
 
Join Date: Sep 2003
Location: On The Beach
Posts: 712
Quote:
Originally Posted by loo3aem3ON View Post
Is this drive executing the original firmware? Your manufacturer string looks like a LG drive in safe mode.
If a DVD is working with all programs except 2 versions of one program, I think is not the DVD fault.

enjoy,
Mtz
Mtz is offline   Reply With Quote
Old 31st March 2009, 21:08   #138  |  Link
lchiu7
Registered User
 
Join Date: Apr 2002
Posts: 279
Quote:
Originally Posted by Inspector.Gadget View Post
Are you using ffdshow to decode VC1? Don't. Use the WMVideo Decoder DMO.
No - I am trying to play on a Popcorn Hour.

I tried all kinds of strategies to fix the file. In the end passed the file from makemkv through Handbrake and re-encoded the video at a lower bit rate and now it plays fine.

But I know it's not a bit rate issue since I have put full BD titles on a HD with no compression and the Popcorn plays them fine from a USB drive. I think it's a problem with Makemkv and VC1 video
lchiu7 is offline   Reply With Quote
Old 1st April 2009, 00:03   #139  |  Link
setarip_old
Registered User
 
setarip_old's Avatar
 
Join Date: Aug 2005
Posts: 16,274
@lchiu7
Quote:
Well I encountered a disc with VC1 video and makemkv created a file that is not playable.
What's the title of this disc? (Is it BluRay or HD-DVD?)
setarip_old is offline   Reply With Quote
Old 1st April 2009, 01:16   #140  |  Link
lchiu7
Registered User
 
Join Date: Apr 2002
Posts: 279
Quote:
Originally Posted by setarip_old View Post
@lchiu7What's the title of this disc? (Is it BluRay or HD-DVD?)

BR - Body of Lies (region B)

But once I ran the file through handbrake and configured it to be 720P and a lower bitrate, it played fine.

I don't use makemkv much (don't like the fact that it produces an output format that is not that flexible) so I can't comment much on whether this is a one off or normal behaviour for VC1 video
lchiu7 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:20.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.