Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 5th October 2007, 16:45   #1  |  Link
mjr4077au
Registered User
 
Join Date: Jul 2007
Posts: 97
DTS-ES track loses sync when appending with mkvmerge GUI

I have The Lord of the Rings extended boxset which I have ripped and the last one is still ripping.

I
ripped the first one by doing both split DVDs separatly and I joined them with AVI-Mux GUI and then remuxed it with mkvmerge. Worked perfectly.

Doing that with the 2nd movie, it gave a bunch of errors but proceeded and during the transition, it loses according to mkvmerge, 504ms.

I then found out how simple it was to append with mkvmerge so I did that and it says Track 2 (DTS-ES track) may not be appended properly but it proceeds and sure enough, it's out of sync.


Any suggestions?

Last edited by Guest; 5th October 2007 at 16:55. Reason: rule 4
mjr4077au is offline   Reply With Quote
Old 6th October 2007, 00:34   #2  |  Link
mjr4077au
Registered User
 
Join Date: Jul 2007
Posts: 97
Quote:
Originally Posted by mjr4077au View Post
I have The Lord of the Rings extended boxset which I have ripped and the last one is still ripping.

I
ripped the first one by doing both split DVDs separatly and I joined them with AVI-Mux GUI and then remuxed it with mkvmerge. Worked perfectly.

Doing that with the 2nd movie, it gave a bunch of errors but proceeded and during the transition, it loses according to mkvmerge, 504ms.

I then found out how simple it was to append with mkvmerge so I did that and it says Track 2 (DTS-ES track) may not be appended properly but it proceeds and sure enough, it's out of sync.


Any suggestions?

My bad about the swearing. It was 2am when I posted that. I'll ensure it doesn't happen again.
mjr4077au is offline   Reply With Quote
Old 6th October 2007, 04:05   #3  |  Link
mjr4077au
Registered User
 
Join Date: Jul 2007
Posts: 97
OK Here's an elaboration of whats going on and what messages I get.

First I add all tracks and subs into each movie with mkvmerge. Then I mux them with AVI-Mux GUI. The file I get plays fine.

Then I try to re-mux the file with mkvmerge as I think AVI-Mux GUI is dodgy (And evidently, it is). This is what I get

Quote:
Warning: 'C:\Documents and Settings\Mitchell\Desktop\lets hope this works 2.mkv' track 3: The current packet's timecode is smaller than that of the previous packet. This usually means that the source file is a Matroska file that has not been created 100% correctly. The timecodes of all packets will be adjusted by 504ms in order not to lose any data. This may throw A/V sync off, but that can be corrected with mkvmerge's "--sync" option. If you already use "--sync" and you still get this warning then do NOT worry -- this is normal. If this error happens more than once and you get this message more than once for a particular track then either is the source file badly mastered, or mkvmerge contains a bug. In this case you should contact the author Moritz Bunkus <moritz@bunkus.org>.
Warning: 'C:\Documents and Settings\Mitchell\Desktop\lets hope this works 2.mkv' track 4: The current packet's timecode is smaller than that of the previous packet. This usually means that the source file is a Matroska file that has not been created 100% correctly. The timecodes of all packets will be adjusted by 504ms in order not to lose any data. This may throw A/V sync off, but that can be corrected with mkvmerge's "--sync" option. If you already use "--sync" and you still get this warning then do NOT worry -- this is normal. If this error happens more than once and you get this message more than once for a particular track then either is the source file badly mastered, or mkvmerge contains a bug. In this case you should contact the author Moritz Bunkus <moritz@bunkus.org>.
Warning: 'C:\Documents and Settings\Mitchell\Desktop\lets hope this works 2.mkv' track 5: The current packet's timecode is smaller than that of the previous packet. This usually means that the source file is a Matroska file that has not been created 100% correctly. The timecodes of all packets will be adjusted by 504ms in order not to lose any data. This may throw A/V sync off, but that can be corrected with mkvmerge's "--sync" option. If you already use "--sync" and you still get this warning then do NOT worry -- this is normal. If this error happens more than once and you get this message more than once for a particular track then either is the source file badly mastered, or mkvmerge contains a bug. In this case you should contact the author Moritz Bunkus <moritz@bunkus.org>.
Warning: 'C:\Documents and Settings\Mitchell\Desktop\lets hope this works 2.mkv' track 6: The current packet's timecode is smaller than that of the previous packet. This usually means that the source file is a Matroska file that has not been created 100% correctly. The timecodes of all packets will be adjusted by 504ms in order not to lose any data. This may throw A/V sync off, but that can be corrected with mkvmerge's "--sync" option. If you already use "--sync" and you still get this warning then do NOT worry -- this is normal. If this error happens more than once and you get this message more than once for a particular track then either is the source file badly mastered, or mkvmerge contains a bug. In this case you should contact the author Moritz Bunkus <moritz@bunkus.org>.
Warning: 'C:\Documents and Settings\Mitchell\Desktop\lets hope this works 2.mkv' track 2: The current packet's timecode is smaller than that of the previous packet. This usually means that the source file is a Matroska file that has not been created 100% correctly. The timecodes of all packets will be adjusted by 421ms in order not to lose any data. This may throw A/V sync off, but that can be corrected with mkvmerge's "--sync" option. If you already use "--sync" and you still get this warning then do NOT worry -- this is normal. If this error happens more than once and you get this message more than once for a particular track then either is the source file badly mastered, or mkvmerge contains a bug. In this case you should contact the author Moritz Bunkus <moritz@bunkus.org>.

If I append both files with mkvmerge, I get this:

Quote:
Warning: The track number 2 from the file 'C:\Documents and Settings\Mitchell\Desktop\tlotr_ttt__2.mkv' can probably not be appended correctly to the track number 2 from the file 'C:\Documents and Settings\Mitchell\Desktop\tlotr_ttt__1.mkv': Please make sure that the resulting file plays correctly the whole time. The author of this program will probably not give support for playback issues with the resulting file.

The Return of the King is still ripping so I haven't tried that but by using the first method with AVI-Mux GUI and then remuxing it with mkvmerge, I had a perfect file. What should I do?
mjr4077au is offline   Reply With Quote
Old 6th October 2007, 04:11   #4  |  Link
mjr4077au
Registered User
 
Join Date: Jul 2007
Posts: 97
Those errors from the AVI-Mux GUI happen at about 1/2 way where the file joins. If I make with 2nd movie with a delay of -504ms, do you think that will offset it?
mjr4077au is offline   Reply With Quote
Old 6th October 2007, 04:33   #5  |  Link
mjr4077au
Registered User
 
Join Date: Jul 2007
Posts: 97
Quote:
Originally Posted by mjr4077au View Post
Those errors from the AVI-Mux GUI happen at about 1/2 way where the file joins. If I make with 2nd movie with a delay of -504ms, do you think that will offset it?
By doing what I quoted, I got "Warning: 'C:\Documents and Settings\Mitchell\Desktop\lets hope this works 2.mkv' track 2: The current packet's timecode is smaller than that of the previous packet. This usually means that the source file is a Matroska file that has not been created 100% correctly. The timecodes of all packets will be adjusted by 43ms in order not to lose any data. This may throw A/V sync off, but that can be corrected with mkvmerge's "--sync" option. If you already use "--sync" and you still get this warning then do NOT worry -- this is normal. If this error happens more than once and you get this message more than once for a particular track then either is the source file badly mastered, or mkvmerge contains a bug. In this case you should contact the author Moritz Bunkus <moritz@bunkus.org>."

3,700 times!!!
mjr4077au is offline   Reply With Quote
Old 6th October 2007, 11:02   #6  |  Link
mjr4077au
Registered User
 
Join Date: Jul 2007
Posts: 97
GOT IT... And it only took 30hrs

I had to append each individual track with mkvmerge and rename the audio files of the 2nd movie to "DELAY -504ms" so it would sync properly.

I NEVER WANT TO HEAR "THE TWO TOWERS" AGAIN!
mjr4077au is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 19:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.