Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 6th January 2002, 23:35   #1  |  Link
k-motion
Registered User
 
Join Date: Jan 2002
Posts: 6
problem with bilingual video creation

Hi there,

i have the following problem...i have a video file (already divx) and two audiostreams but i am unable to mux them correctly...i have used nandub with two wav files as sound source and everything was fine...sync...switchable...perfect..
then i set it to full compression...mp3...but nandub only encodes the first audiostream and leaves the second at wave...however the file works...then i used fileinput and streamed a pre-encoded mp3 into the movie...but this ends in either unplayable file or a file in which the second audiostream misses the last couple seconds..

i also tried avimux...but this progy is unable to encode mp3 on my system...it gives an errormessage....if i use wma..it works...the sound is complete but a bit out of sync...i already tried interleaving from 4ms to 500ms...it is always out of sync...

please help...

thanx in advance
k-motion
k-motion is offline   Reply With Quote
Old 7th January 2002, 09:01   #2  |  Link
chi
Registered User
 
Join Date: Oct 2001
Posts: 87

hi, try to compress before you mux...
(you may use lame or besweet)
__________________
simple.frontend
mpeg2avi gui with besweet support
http://www.world-free.com/chi
chi is offline   Reply With Quote
Old 8th January 2002, 02:38   #3  |  Link
k-motion
Registered User
 
Join Date: Jan 2002
Posts: 6

thanx, i already tried that...with limited success...either the file was unplayable....or the second track ends 2 to 4 seconds before the movie
k-motion is offline   Reply With Quote
Old 8th January 2002, 11:37   #4  |  Link
chi
Registered User
 
Join Date: Oct 2001
Posts: 87

when the audio ends 4 seconds to early, is it in synch before?
__________________
simple.frontend
mpeg2avi gui with besweet support
http://www.world-free.com/chi
chi is offline   Reply With Quote
Old 8th January 2002, 12:03   #5  |  Link
k-motion
Registered User
 
Join Date: Jan 2002
Posts: 6

yes, it is in perfect sync...both streams...it is just that the second stream ends abbruptly a couple o' seconds before it shoul end...however this only seems to occure with mp3...with wav the files are complete and in perfect sync...only that they r to big
k-motion is offline   Reply With Quote
Old 8th January 2002, 13:13   #6  |  Link
fratersinister
Registered User
 
Join Date: Jan 2002
Posts: 18

Hi K-motion,

What's the player you use to read your BivX ? because i still have pb when i switch from the first to the second audio stream and as you seem able to read it i would like to know.

Sinister
fratersinister is offline   Reply With Quote
Old 8th January 2002, 14:10   #7  |  Link
chi
Registered User
 
Join Date: Oct 2001
Posts: 87

@fratersinister
i use wmp with morgan stream switcher to play bivx...

@k-motion
do mp3 and avi have the same lenghth?
__________________
simple.frontend
mpeg2avi gui with besweet support
http://www.world-free.com/chi
chi is offline   Reply With Quote
Old 8th January 2002, 17:46   #8  |  Link
k-motion
Registered User
 
Join Date: Jan 2002
Posts: 6

i also use mp3 with morgan stream switcher...winamp with nicemcmedia should also work well...since it uses wmp to play the file...it only lacks the support of switching audio...one would have to build a graph for this..

all 3 files are of the perfect same length...
since it works well with 2 wave files...all of the same length...i thought the problem may be nandub....when encoding...but he manages the first stream perfectly...no matter if i take stream 1 or two..and always failes on the second stream...again no matter which one i use...it also doesn't matter if it is pre-encoded...

however nandub seems to have a bug...since it never encodes the second stream..even if it is set to 'full processing/MP3' he only encodes the first which works...but streams the second...so for the second i have to use a pre-encoded file....maybe older version of nandub work correctly?...i use 1.0rc2...but if i stream the first mp3 track in...he has no problems...this really drives me crazy....
k-motion is offline   Reply With Quote
Old 8th January 2002, 17:47   #9  |  Link
k-motion
Registered User
 
Join Date: Jan 2002
Posts: 6

sorry...i mean i also use Windows Media Player..

as i said this drives me crazy
k-motion is offline   Reply With Quote
Old 8th January 2002, 22:39   #10  |  Link
chi
Registered User
 
Join Date: Oct 2001
Posts: 87

i never experienced any problems like the oney descibed by you... yesterday i made a nice bivx rip of fightclub, video/sound with mpeg2avi/besweet (using simple.frontend) muxing/splitting with nandub 1.0rc2...
__________________
simple.frontend
mpeg2avi gui with besweet support
http://www.world-free.com/chi
chi is offline   Reply With Quote
Old 8th January 2002, 23:08   #11  |  Link
k-motion
Registered User
 
Join Date: Jan 2002
Posts: 6

do u encode multfile movies...or single file ones...in singlefile movies one would probably not recognize this problem...but in multifile you recognize this problem at the end of every file...

which version of nandub are u using....are you compressing the second stream with nandub or before muxing?
k-motion is offline   Reply With Quote
Old 9th January 2002, 00:12   #12  |  Link
chi
Registered User
 
Join Date: Oct 2001
Posts: 87

i'm using nandub 1.0rc2 build 1852 for muxing/splitting and besweet for audio processing(encoding both streams before muxing! like i wrote above). normaly i merge all vobs from the dvd to one vob on my hd with smartripper, but i did fightclub from multiple vobs. with this movie i headed for two 700mb cds. btw. i'm doing muxing/splitting at the same time.
__________________
simple.frontend
mpeg2avi gui with besweet support
http://www.world-free.com/chi
chi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:42.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.