Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 4th November 2008, 13:00   #4621  |  Link
romanesque
Registered User
 
Join Date: Sep 2008
Posts: 21
On some mkv's at the bottom of the video the image is distorted:

http://i33.tinypic.com/2ecglg9.jpg

http://i36.tinypic.com/2diismo.jpg

I get this distorsion only when I play the video with mpchc. Is there any way to correct this?

Thank you.

Last edited by romanesque; 4th November 2008 at 13:42.
romanesque is offline  
Old 4th November 2008, 13:02   #4622  |  Link
Kado
Otaku
 
Kado's Avatar
 
Join Date: Sep 2006
Location: Portugal
Posts: 575
Quote:
Originally Posted by JohnLai View Post
O.o seem like the changelog at sourceforge mentions something about nvidia card supporting L5.1 by matmaul. Is it really work?
Although we would still be limited by the reference frames right?
__________________
In the school, the three guys met. Their relation had been changed in the season, and turned into three love stories.
Kado is offline  
Old 4th November 2008, 14:03   #4623  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,667
Quote:
Originally Posted by Kado View Post
Although we would still be limited by the reference frames right?
Yes, still 11 refs from what I can see in the code.
clsid is offline  
Old 4th November 2008, 14:27   #4624  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by mariner View Post
Any plans for interlaced VC1 DXVA support?
It's on todo list.

Quote:
Originally Posted by clsid View Post
@Casimir
There were some improvements to ffdshow recently with regard to H.264 and compatibility with various splitters. It would be worthwhile to implement those in MPCVideoDec.
I know we have a chat with Haruhiko and CinCh on this subject. My patch is not finished yet.

Quote:
Originally Posted by MatMaul View Post
there is a patch in the ffmpeg-devel ml written by haruhiko which allows libavcodec to parse SEI and retrieve interlaced and field order from SEI. the patch have been reviewed and will hit the trunk very soon.
I think it can be useful to correctly detect interlaced frame and correct field order, especially in MBAFF streams.
I have an 1080i sample rip on a french TNT-HD which is not de-interlace by mpc decoder. The reason for this is that the "field_pic_flag" is not set in the H264 bitstream. Matmaul do you think that :
- frame_mbs_only_flag can be used to detect interlaced video (1=progressive, 0=interlaced)
- what should i do when field_pic_flag is not set? Suppose it's a top field first?

Quote:
Originally Posted by QuePaso View Post
any update for G45 support? I tried the newest build but no HA yet.
Intel management didn't want to release their specifications because they fears lawsuit about content management (seen answer #15) :
http://software.intel.com/en-us/foru...gy/topic/60703
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 4th November 2008, 15:51   #4625  |  Link
MatMaul
Registered User
 
Join Date: Apr 2004
Posts: 402
Quote:
Originally Posted by Casimir666 View Post
I have an 1080i sample rip on a french TNT-HD which is not de-interlace by mpc decoder. The reason for this is that the "field_pic_flag" is not set in the H264 bitstream. Matmaul do you think that :
- frame_mbs_only_flag can be used to detect interlaced video (1=progressive, 0=interlaced)
according to specs 0 means progressive or interlaced so it is not very reliable
Quote:
Originally Posted by Casimir666 View Post
- what should i do when field_pic_flag is not set? Suppose it's a top field first?
I think most of MBAFF live streams rely on the SEI layer to signal interlaced content (I haven't check it yet) so the easiest way is I think :
- apply this patch to ffmpeg (or wait a day or two that the patch hit the trunk)
- pass SEI packets to the ffmpeg h264 decoder
- read the libavcodec flags interlaced_frame and top_field_first (and I think it should be done for all the codecs decoded by ffmpeg, not only h264)
MatMaul is offline  
Old 4th November 2008, 15:55   #4626  |  Link
Keiyakusha
契約者
 
Keiyakusha's Avatar
 
Join Date: Jun 2008
Posts: 1,567
Quote:
Originally Posted by romanesque View Post
On some mkv's at the bottom of the video the image is distorted:

http://i33.tinypic.com/2ecglg9.jpg

http://i36.tinypic.com/2diismo.jpg

I get this distorsion only when I play the video with mpchc. Is there any way to correct this?

Thank you.
I also have something like that:

Maybe its because source resolution is even non MOD8? It is 864x434
Keiyakusha is offline  
Old 4th November 2008, 16:08   #4627  |  Link
JohnLai
Registered User
 
Join Date: Mar 2008
Posts: 426
I just tested svn 857 from alexin. It appears that L5.1 is not really well decoded, green line and messy image.



8500GT driver=177.92
Latest DirectX runtime installed
Setting used to encode: cabac=0 / ref=5 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=6 / me-prepass=0 / brdo=1 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / chroma_qp_offset=0 / threads=3 / nr=0 / decimate=1 / mbaff=0 / bframes=3 / b_pyramid=1 / b_adapt=1 / b_bias=0 / direct=1 / wpredb=1 / bime=1 / keyint=250 / keyint_min=25 / scenecut=40(pre) / rc=2pass / bitrate=5000 / ratetol=2.0 / rceq='blurCplx^(1-qComp)' / qcomp=1.00 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00

Progressive
frame rate=29.970fps
1920x1080
Main@L5.1

Last edited by JohnLai; 4th November 2008 at 16:15. Reason: add some image and info
JohnLai is offline  
Old 4th November 2008, 16:23   #4628  |  Link
Keiyakusha
契約者
 
Keiyakusha's Avatar
 
Join Date: Jun 2008
Posts: 1,567
Also, player is not fit video well, when chacked "AutoZoom: Auto Fit"
UPD: only when DXVA is used.
UPD2: tested on level 3.1 stream

Last edited by Keiyakusha; 4th November 2008 at 16:32.
Keiyakusha is offline  
Old 4th November 2008, 16:23   #4629  |  Link
MatMaul
Registered User
 
Join Date: Apr 2004
Posts: 402
as I said...
Quote:
Originally Posted by MatMaul View Post
just removed the level 4.1 check for nvidia cards as they now support level 5.1 streams.
if you encounter a problem, please update your driver before report it
this is only supported since drivers 178.24

if it doesn't work with those new drivers, please report again.
MatMaul is offline  
Old 4th November 2008, 16:42   #4630  |  Link
Jeff Flowerday
Registered User
 
Join Date: Aug 2008
Location: Calgary, AB
Posts: 150
So is there any combination of external splitter and decoder that works with m2ts containers containing lpcm audio? I'm pulling my hair out here trying every combination known to man.

I don't want to install Nero showtime if I don't have to...
Jeff Flowerday is offline  
Old 4th November 2008, 16:46   #4631  |  Link
JohnLai
Registered User
 
Join Date: Mar 2008
Posts: 426
OK, after updating the driver,it's works. So, ATI card can't decode L5.1, isn't it? Man, I wish the ref frame problem is fixed by the nvidia.

Last edited by JohnLai; 4th November 2008 at 16:50.
JohnLai is offline  
Old 4th November 2008, 16:47   #4632  |  Link
ash925
 
Join Date: Sep 2007
Location: Seventh Dimension
Posts: 54
I am using MPC-HC for HW acceleration.The problem I have is that some files like GOD OF WAR 3 Teaser in 1080p run smoothly on my HD4850.But files encoded by me in megui DXVA EXTRA Quality profile run with frames dropped but when I play through graphstudio using the same MPC video decoder the files run just fine.
Any help is appreciated.
ash925 is offline  
Old 4th November 2008, 16:58   #4633  |  Link
ikarad
Registered User
 
Join Date: Apr 2008
Posts: 527
Quote:
Originally Posted by Casimir666 View Post
It's on todo list.


I know we have a chat with Haruhiko and CinCh on this subject. My patch is not finished yet.


I have an 1080i sample rip on a french TNT-HD which is not de-interlace by mpc decoder. The reason for this is that the "field_pic_flag" is not set in the H264 bitstream. Matmaul do you think that :
- frame_mbs_only_flag can be used to detect interlaced video (1=progressive, 0=interlaced)
- what should i do when field_pic_flag is not set? Suppose it's a top field first?


Intel management didn't want to release their specifications because they fears lawsuit about content management (seen answer #15) :
http://software.intel.com/en-us/foru...gy/topic/60703

Casimir one question: are you french?
ikarad is offline  
Old 4th November 2008, 17:13   #4634  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,667
Quote:
Originally Posted by MatMaul View Post
as I said...

this is only supported since drivers 178.24

if it doesn't work with those new drivers, please report again.
Just an idea...

Is it possible to determine the driver version in MPC? If so, it might be a good idea to use that info to our advantage. For example:
* Limit to level 4.1 if vendor == NVIDIA && driver_version < 178.24
* Disable DXVA if driver_version equals some_known_buggy_version

This would be particularly useful for the average user (typically non Doom9 members). Those will not update their drivers at a regular basis, or at all for that matter. MPC is the first thing they will blame if things don't work. So making it n00b-proof is alwyas useful.

Last edited by clsid; 4th November 2008 at 17:24.
clsid is offline  
Old 4th November 2008, 18:13   #4635  |  Link
rack04
Registered User
 
Join Date: Mar 2006
Posts: 1,526
Quote:
Originally Posted by Jeff Flowerday View Post
So is there any combination of external splitter and decoder that works with m2ts containers containing lpcm audio? I'm pulling my hair out here trying every combination known to man.

I don't want to install Nero showtime if I don't have to...
Does it not work with MPC-HC internal M2TS splitter?
rack04 is offline  
Old 4th November 2008, 18:54   #4636  |  Link
alexins
MPC-BE DEV
 
alexins's Avatar
 
Join Date: Mar 2008
Location: Slovenija
Posts: 584
Media Player Classic HomeCinema (x86), svn 857
Media Player Classic HomeCinema (x64), svn 857

Supported languages: CN, CZ, DE, ES, FR, HU, IT, KR, PL, RU, SK, TR, UA

Changes log

nvidia cards now support level 5.1 streams
__________________
Win10 x64, i7 7700K 5.2Ghz, ASUS MAXIMUS VIII HERO, HyperX Fury 16GB (2x8GB) 3000MHz, ASUS GTX1060-6G,TV Philips 40PFS6909/12, MED1000X3D
Media Player Classic - BE x86/x64. Team of developers.
alexins is offline  
Old 4th November 2008, 18:56   #4637  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by clsid View Post
Just an idea...

Is it possible to determine the driver version in MPC? If so, it might be a good idea to use that info to our advantage. For example:
* Limit to level 4.1 if vendor == NVIDIA && driver_version < 178.24
* Disable DXVA if driver_version equals some_known_buggy_version

This would be particularly useful for the average user (typically non Doom9 members). Those will not update their drivers at a regular basis, or at all for that matter. MPC is the first thing they will blame if things don't work. So making it n00b-proof is alwyas useful.

Yes : D3DADAPTER_IDENTIFIER9 have a DriverVersion field ;-)
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 4th November 2008, 18:57   #4638  |  Link
Jeff Flowerday
Registered User
 
Join Date: Aug 2008
Location: Calgary, AB
Posts: 150
Quote:
Originally Posted by rack04 View Post
Does it not work with MPC-HC internal M2TS splitter?
It works within MPC-HC itself. But I'm trying to get the external filters working so I can use Media Portal for me media center needs.

If I use mpegsplitter.ax externally with dtsac3source.ax or ffdshow's audio decoder I get nothing. I'm probably doing something wrong, I'm a bit of a noob at this.

Last edited by Jeff Flowerday; 4th November 2008 at 19:06.
Jeff Flowerday is offline  
Old 4th November 2008, 18:59   #4639  |  Link
MatMaul
Registered User
 
Join Date: Apr 2004
Posts: 402
Quote:
Originally Posted by Casimir666 View Post
Yes : D3DADAPTER_IDENTIFIER9 have a DriverVersion field ;-)
I need someone with a nvidia card to launch this little program before and after the driver update :
http://www.etud.insa-toulouse.fr/~mv...er_version.exe
MatMaul is offline  
Old 4th November 2008, 20:12   #4640  |  Link
rack04
Registered User
 
Join Date: Mar 2006
Posts: 1,526
Quote:
Originally Posted by MatMaul View Post
I need someone with a nvidia card to launch this little program before and after the driver update :
http://www.etud.insa-toulouse.fr/~mv...er_version.exe
Which update? 178.24 -> 180.43 or pre 178.24 -> 178.24?
rack04 is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.