Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > New and alternative video codecs

Reply
 
Thread Tools Search this Thread Display Modes
Old 29th January 2010, 20:44   #10541  |  Link
tal.aloni
Registered User
 
Join Date: Sep 2008
Posts: 496
Quote:
Originally Posted by buletti View Post
sharpening and denoising operations could probably work and would be greatly appreciated.
HeadlessCow was right on the money.
the DXVA decoded frame ends up being written to USWC memory,
which was not designed for fast reading operations.

sharpening and denoising can be made to work with the beta 2, but you'll learn that it's unstable, and the CPU usage is greater than software decoding.
tal.aloni is offline   Reply With Quote
Old 29th January 2010, 20:51   #10542  |  Link
dann23
Registered User
 
Join Date: Apr 2009
Posts: 89
do you plan to add MPEG2 to be decoded using DXVA?
dann23 is offline   Reply With Quote
Old 29th January 2010, 21:01   #10543  |  Link
tal.aloni
Registered User
 
Join Date: Sep 2008
Posts: 496
Quote:
Originally Posted by dann23 View Post
do you plan to add MPEG2 to be decoded using DXVA?
I think that albain would share my view that if casimir (MPC-HC) will implement it, we will import it as well, but I don't really think it's worth the effort. mpeg2 decoding does not require much cpu power.
tal.aloni is offline   Reply With Quote
Old 29th January 2010, 21:02   #10544  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
Yes, also MPEG2 does not consume a lot of CPU

And MPEG2HD is a dead end (HDDVD)
albain is offline   Reply With Quote
Old 29th January 2010, 21:35   #10545  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Hi.
By some reason i am not able to make DXVA + subtitles (and OSD) work.
Haali <-> FFDShow DXVA decoder Pin is connected, but no subtitles are displayed (EVR as renderer).
No problem in "normal" FFDShow.

Win7 + ATI 4770

EDIT:
Same result on XP:
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin

Last edited by hoborg; 29th January 2010 at 21:51.
hoborg is offline   Reply With Quote
Old 29th January 2010, 22:14   #10546  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by tal.aloni View Post
I think that albain would share my view that if casimir (MPC-HC) will implement it, we will import it as well, but I don't really think it's worth the effort. mpeg2 decoding does not require much cpu power.
We already added it in http://sourceforge.net/apps/trac/mpc-hc/changeset/1552
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline   Reply With Quote
Old 29th January 2010, 22:38   #10547  |  Link
dann23
Registered User
 
Join Date: Apr 2009
Posts: 89
Quote:
Originally Posted by tetsuo55 View Post
yes thank you. hope that albain will change his mind
dann23 is offline   Reply With Quote
Old 29th January 2010, 22:43   #10548  |  Link
tal.aloni
Registered User
 
Join Date: Sep 2008
Posts: 496
Quote:
Originally Posted by hoborg View Post
Hi.
By some reason i am not able to make DXVA + subtitles (and OSD) work.
have you enabled post-processing? (configuration > hardware acceleration)

Last edited by tal.aloni; 29th January 2010 at 22:53.
tal.aloni is offline   Reply With Quote
Old 29th January 2010, 23:08   #10549  |  Link
Mr VacBob
Registered User
 
Join Date: Feb 2005
Posts: 141
Quote:
Originally Posted by clsid View Post
On a related note, libavcodec and ffmpeg-mt should give better performance now compared to any 2009 build. The gain is supposed to be a few %. It would be interesting to see some benchmarks.
It should be more than 10% so far (it's not done yet). r21455 should improve high bitrates, but I didn't push it into mt yet.

There's also some MMX/SSE/2 inlined directly into the decoder now, so you'll see further improvements (~3%) if you can build with --cpu=i686 or higher.
Mr VacBob is offline   Reply With Quote
Old 29th January 2010, 23:13   #10550  |  Link
hoborg
Registered User
 
Join Date: Nov 2008
Posts: 454
Quote:
Originally Posted by tal.aloni View Post
have you enabled post-processing? (configuration > hardware acceleration)
Nope, i miss that option, thanks!
__________________
Working machine: Win10x64 + Intel Skull Canyon
My HTPC.

How to start with Bitcoin
hoborg is offline   Reply With Quote
Old 30th January 2010, 00:02   #10551  |  Link
MatLz
I often say "maybe"...
 
MatLz's Avatar
 
Join Date: Jul 2009
Location: France
Posts: 586
Hi!

I've updated to 3237 but I'm in trouble with gamma correction:

A capture speaks more than a thousand words

What's the hell?
MatLz is offline   Reply With Quote
Old 30th January 2010, 00:26   #10552  |  Link
tal.aloni
Registered User
 
Join Date: Sep 2008
Posts: 496
Quote:
Originally Posted by MatLz View Post
Hi!

I've updated to 3237 but I'm in trouble with gamma correction:
Edit:
I see it now, modifying contrast triggers it.
starts with rev. 3233

Last edited by tal.aloni; 30th January 2010 at 00:33.
tal.aloni is offline   Reply With Quote
Old 30th January 2010, 00:38   #10553  |  Link
MatLz
I often say "maybe"...
 
MatLz's Avatar
 
Join Date: Jul 2009
Location: France
Posts: 586
I'm also in trouble with sourceforge and mediafire....I can just say I think 3207 was ok.
MatLz is offline   Reply With Quote
Old 30th January 2010, 01:46   #10554  |  Link
thuan
Registered User
 
Join Date: Sep 2005
Location: Vietnam, HCM City
Posts: 262
Quote:
Originally Posted by HeadlessCow View Post
thuan: could you do me a favor and try out the beta1 or beta2 build with the full processing mode to see if it drops frames like crazy? If the Intel guy wrote his code with an Intel graphics card, maybe you'll have better performance than the rest of us did. That would at least explain why he was able to get performance that is so much better than when tal.aloni used the code in ffdshow.
I will, on Monday as the computer with G45 is my computer at work. By full processing mode you meant Surface Overlay Post Processing mode right? And what did you mean by beta2? The last ffdshow-tryouts version is beta 6. I haven't used ffdshow for far too long (been using MPC-HC internal filter).
thuan is offline   Reply With Quote
Old 30th January 2010, 04:15   #10555  |  Link
onomatopellan
Registered User
 
Join Date: Jan 2010
Posts: 47
@thuan:This is beta1 http://forum.doom9.org/showthread.ph...14#post1364814
and this is the beta 2 http://forum.doom9.org/showthread.ph...03#post1365503

Quote:
Originally Posted by albain View Post
I think this comes from the media types

I removed uncompress mediatypes but this is not a good idea because I guess that FFDShow DXVA may not be consulted for subtitles connection
I have done more tests and these are the results using ffdshow DXVA rev3237 in MPC-HC:

In my PC with Windows 7 32bits -> embedded subs of most files (sample) aren't detected. Subs are not shown

In the laptop Windows 7 64 bits -> embedded subs of most files aren't detected. Subs are not shown

In a PC with Windows Xp 32 bits -> All the embedded subs of my files are detected flawlessly. Subs are shown without problem

So maybe the problem is in the way Text input pin is connected in Windows 7? Can please somebody with Windows 7 confirm this?

Last edited by onomatopellan; 30th January 2010 at 04:46.
onomatopellan is offline   Reply With Quote
Old 30th January 2010, 04:42   #10556  |  Link
thuan
Registered User
 
Join Date: Sep 2005
Location: Vietnam, HCM City
Posts: 262
Quote:
Originally Posted by thuan View Post
Thanks to albain and tal.aloni that implemented DXVA and sub rendering with DXVA in ffdshow. I still have 2 problems with it though.

Sub bleeding and blocky


And broken image when seeking that happens sometimes


Tested at work on Intel G45, Windows Vista 64bit up to date BTW. I view my videos with Haali splitter. I also have the 9800GT with Windows 7 64bit at home and the 2nd problem happens there, too. I will check whether the first problem happens at my home computer configuration after work.

Thank you guys for the continuous development.
At home, the blocking problem when seeking is still the same. As for sub with DXVA, it simply does not work on my 9800GT . Driver is 196.21 on Windows 7 64bit.
thuan is offline   Reply With Quote
Old 30th January 2010, 09:05   #10557  |  Link
tal.aloni
Registered User
 
Join Date: Sep 2008
Posts: 496
Quote:
Originally Posted by thuan View Post
At home, the blocking problem when seeking is still the same. As for sub with DXVA, it simply does not work on my 9800GT . Driver is 196.21 on Windows 7 64bit.
what do you mean by "does not work"?
did you enable "post processing"? (see above)
tal.aloni is offline   Reply With Quote
Old 30th January 2010, 09:29   #10558  |  Link
CiNcH
Registered User
 
CiNcH's Avatar
 
Join Date: Jan 2004
Posts: 567
But this is only MPEG-2 Bitstream which only works for some nVIDIA GPU's, right? Think most GPU's still only do MPEG-2 MC and iDCT.
__________________
Bye
CiNcH is offline   Reply With Quote
Old 30th January 2010, 09:36   #10559  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
Quote:
Originally Posted by onomatopellan View Post
@thuan:This is beta1 http://forum.doom9.org/showthread.ph...14#post1364814
and this is the beta 2 http://forum.doom9.org/showthread.ph...03#post1365503



I have done more tests and these are the results using ffdshow DXVA rev3237 in MPC-HC:

In my PC with Windows 7 32bits -> embedded subs of most files (sample) aren't detected. Subs are not shown

In the laptop Windows 7 64 bits -> embedded subs of most files aren't detected. Subs are not shown

In a PC with Windows Xp 32 bits -> All the embedded subs of my files are detected flawlessly. Subs are shown without problem

So maybe the problem is in the way Text input pin is connected in Windows 7? Can please somebody with Windows 7 confirm this?
Thanks, I didn't test your sample but if you say that it works on XP this confirms my thoughts : on XP directshow consults filters for uncompressed formats, not on vista/7

Here is a test build to confirm this

Please tell me if this solves the problem

Last edited by albain; 30th January 2010 at 09:43.
albain is offline   Reply With Quote
Old 30th January 2010, 10:34   #10560  |  Link
tal.aloni
Registered User
 
Join Date: Sep 2008
Posts: 496
Quote:
Originally Posted by MatLz View Post
Hi!

I've updated to 3237 but I'm in trouble with gamma correction
should be fixed in rev. 3241
tal.aloni is offline   Reply With Quote
Reply

Tags
ffdshow, ffdshow tryouts, ffdshow-mt, ffplay, icl

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:18.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.