Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-2 Encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 30th December 2006, 05:54   #1  |  Link
rkr1958
Registered User
 
Join Date: Jan 2005
Location: Huntsville, AL
Posts: 96
Have I been encoding my DV captures using the wrong field order setting?

I have a Sony TRV-320 DV camera. I been using TMPGEnc-Plus for 4+ years now & CCE-Basic for 2+ years to encode.

Up until the last year or so I've cut out the portions of the avi video that I've wanted to encode with Virtualdub and either done a direct stream copy or frameserve to encode.

In the past year in a desire to learn AVISynth and basic to intermediate filtering techinques I've gained some understanding of details such as video frames versus fields & field order. I've also discovered that my TRV-320 DV camera records and transfers DV video interlaced with bottom field first (BFF). I've just recently discovered that the advance video settings in both CCE-basic and TMPGEnc-Plus for NTSC 4:3 default to output top field first.

Have I been encoding my DV video wrong for the past 4-years?

rkr1958 is offline   Reply With Quote
Old 30th December 2006, 10:11   #2  |  Link
Serbianboss
Registered User
 
Serbianboss's Avatar
 
Join Date: Mar 2006
Posts: 232
Its wrong.

If your source is DV avi interlaced,BFF then you should to diselect output top field first and enter 0 instead 1.

Because when is 0 it keeps the same input and output source.
Serbianboss is offline   Reply With Quote
Old 30th December 2006, 16:22   #3  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,287
Actually chances are that it's correct in CCE. IIRC the offset line set to 1 will change the field order in your case from BFF to TFF. In TMPGEnc, the field order should be bottom field first.

You can fix the incorrect field order with ReStream without re-encoding, but reauthoring is probably a must. (I don't know if there are any ways to do the same for VOBs)
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 30th December 2006, 19:01   #4  |  Link
rkr1958
Registered User
 
Join Date: Jan 2005
Location: Huntsville, AL
Posts: 96
@Boulder & Serbianboss, thanks for your replies. I did analyses of two previous DV encodes (one w/CCE-Basic & one w/TMPGenc-Plus). Based on this analyses (which is summarized below) all appears well. Also, it appears that using the defaults CCE-Basic encodes BFF interlaced to TOP field first and TMPGEnc-Plus encodes BFF interlaced to BOTTOM field first.

I took the first vob from the authoring of each encode and copy them to my harddrive. I used DGIndex to generate a d2v file for each. I then found a fast action segment in each and used the following AVISynth script is virtualdub to see which playbacks were smooth and which were jerky to confirm if the outputted field orders of each encode played correctly.

Quote:
# Import / Load needed plugins
Import(plugin_dir+"mvbob.avs")
LoadPlugin(plugin_dir+"DGDecode.dll")

# Load D2V video
MPEG2Source("video.d2v")

# Set field dominance (try both & see which one is smooth and which one is jerky)
# AssumeTFF()
# AssumeBFF()

# Seperate into "fields" using a simple bob
# Note video is treated as full-height frames at twice the original framerate
eedibob()

# Get Info (Load file in VirtualDub)
# info()
1. CCE-Basic encode.
CAP Method: VHS > DV passthrough > PC (Panasonic DV Codec)
CAP Source: AVI, 4:3 NTSC 720 x 480, interlaced with BFF
Encoded Output: MPEG-2 720x480, interlaced with TFF
TFF Default in AVS (i.e., both AssumeTFF() & AssumeBFF() commented out): smooth playback
AssumeTFF() Enabled in AVS script: smooth
AssumeBFF() Enabled in AVS script: jerky

2. TMPGEnc-Plus encode.
CAP Method: VHS > DV passthrough > PC (Panasonic DV Codec)
CAP Source: AVI, 4:3 NTSC 720 x 480, interlaced with BFF
Encoded Output: MPEG-2 720x480, interlaced with BFF
BFF Default in AVS (i.e., both AssumeTFF() & AssumeBFF() commented out): smooth playback
AssumeTFF() Enabled in AVS script: jerky
AssumeBFF() Enabled in AVS script: smooth

Does all this make sense? Am I overlooking something?

EDIT: The TMPGEnc-Plus results are incorrect. I just did a short encode of a BFF interlaced video and the playback is jerky. So, somehow when I originally encoded the video in TMPGEnc-Plus field order must have been set to BFF. I'm not sure how though.

O.K. it's time to do a more controlled analysis. I'm going to take two small avi files, one interlaced w/TFF and the other interlaced w/BFF and encode both with CCE-basic & TMPGEnc-Plus using their default advance settings and see what I get. I'll post what I find.

Last edited by rkr1958; 30th December 2006 at 19:49.
rkr1958 is offline   Reply With Quote
Old 30th December 2006, 21:30   #5  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,287
TMPGEnc tries to determine the correct field order automatically. Sometimes it gets it right, sometimes it doesn't. Looks like you were lucky
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline   Reply With Quote
Old 30th December 2006, 22:22   #6  |  Link
rkr1958
Registered User
 
Join Date: Jan 2005
Location: Huntsville, AL
Posts: 96
Quote:
Originally Posted by Boulder View Post
TMPGEnc tries to determine the correct field order automatically. Sometimes it gets it right, sometimes it doesn't. Looks like you were lucky
Yes I was ... both with CCE-Basic & TMPGEnc-Plus.

If you use the wizard in TMPGEnc-Plus to set up your encode it determines with field order to use based on your input. However, I don't recall using the wizard (maybe I did) or maybe like you said I was just lucky.

With CCE-Basic, it appears that the default advance settings are for input interlaced source w/BFF and encodes to TFF. I found out that with the default advance settings if the input source is interlaced w/TFF that the encode is incorrectly set to TFF. There's no way, which I see, that CCE-Basic tries to determine the correct field order. Maybe I'm missing something here ... but it looks to me that CCE-basic requires a much more knowledge user than does TMPGEnc-Plus w/wizard mode.
rkr1958 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 18:47.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.