Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 24th November 2006, 19:33   #281  |  Link
gonwk
Registered User
 
Join Date: Aug 2006
Posts: 164
Hi Weaver,

from the 5 programs that you mentioned which AVI file looked the BEST picture wise?

Thanks,
G!
gonwk is offline  
Old 24th November 2006, 21:01   #282  |  Link
weaver4
Registered User
 
Join Date: Jun 2005
Posts: 925
I put the avi.net, autogk and automkv outputs on a DVD. Then I put it on my HD TV.

To me it appears that the automkv is not as good quality as the other two.

The image sizes are the same, but the resizers and filters are different. The Matrix is not the same, but I do think that the avi.net uses the same Sharktooth matrix as I was using in automkv.

I am not sure, but I don't think any of these other programs use xvid_encraw.
weaver4 is offline  
Old 24th November 2006, 21:05   #283  |  Link
gonwk
Registered User
 
Join Date: Aug 2006
Posts: 164
Thanks Weaver!
G!
gonwk is offline  
Old 24th November 2006, 22:39   #284  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
Quote:
The image sizes are the same, but the resizers and filters are different. The Matrix is not the same, but I do think that the avi.net uses the same Sharktooth matrix as I was using in automkv.
autogk is probably using the LanczosResize, on of most sharpen.

Anyway i had very little control over cq encoding. i can suggest in "defense" of automkv to try with
1) lanczos resize
2) at cq 3 the "Sharktooth's EQM v3ULR.cqm" isn't well suited, better a non "ultra low rate"...
3) use a 2 pass profile

thanks for your test... i am very glad to improve the quality of encoding

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline  
Old 25th November 2006, 15:25   #285  |  Link
fogbav
Registered User
 
Join Date: Feb 2002
Posts: 87
Hi buzzqw ... i tested some random TV-Rips ... and about 50 % are converted superb ... but the other ones will not encode ...

I have uploaded a TS sample (8 MB with mkv.ini file)

http://www.file-upload.net/download_...g7l8h.rar.html


Maybe you can analyse ... i think the avs thing is not working correctly ...

Batch-job from my scripts :

automkv.exe automkv.ini %1 0 0 0 0 start kill

ts file is splitted with projectx into m2v and sound files .... so i parse the m2v (only video) to automkv ...

an other bug with this ts in GUI mode with automkv ... delaycut is not working correctly ... filling up my complete hard disk with the mpa file ... but i think you will see ...

Maybe one time i can do an batch : automkv.exe convertallaudiotracks start kill ....8)

thanx

FoGBaV

Last edited by fogbav; 25th November 2006 at 15:40.
fogbav is offline  
Old 25th November 2006, 15:46   #286  |  Link
SeeMoreDigital
Life looks better in HD
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 11,209
Quote:
Originally Posted by fogbav View Post
Maybe you can analyse ... i think the avs thing is not working correctly ...
I've just tried feeding your source "directly" into DGIndex 1.4.8 and it would seem it's unable to "automatically" detect any of the streams within your .TS source.

It's probably best to contact Neuron2 (Donald Graft) direct about this source


EDIT: Even HDTVtoMPEG2 and MPEG2 Repair have problems locating the elementary streams within your .TS source


Cheers
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |

Last edited by SeeMoreDigital; 25th November 2006 at 17:57.
SeeMoreDigital is offline  
Old 25th November 2006, 16:02   #287  |  Link
fogbav
Registered User
 
Join Date: Feb 2002
Posts: 87
@SeeMoreDigital : Thanks for analysing ...

hmm ... taking the ts file through projectx is taking me to a playable m2v file without errors ... hmm ...

TS is from a dbox2 ...

OK ... this is the resulting ProjectX File ...

http://www.file-upload.net/download_...diab9.rar.html

Last edited by fogbav; 25th November 2006 at 16:20.
fogbav is offline  
Old 25th November 2006, 16:18   #288  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
if delaycut is unable to fix and go crazy filling disk that would mean demuxing was wrong.
Better remuxing m2v and mpa an then go with dgindex
This isn't a true problem of automkv , just of delaycut and your source files

Quote:
maybe one time i can do an batch : automkv.exe convertallaudiotracks start kill ....8)
this is already possible. just use "All audio tracks", BUT remember that dgindex is unable to demux more than 1 audio tracks at time from ts files.

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline  
Old 25th November 2006, 16:22   #289  |  Link
fogbav
Registered User
 
Join Date: Feb 2002
Posts: 87
Please retry with file uploaded file above ... (ProjectX has no prblems with the TS stream) ...

and ... i never sayed that it is a direct automkv problem - never thought of this ... never ...8) ... really ...8)

Last edited by fogbav; 25th November 2006 at 16:26.
fogbav is offline  
Old 25th November 2006, 16:28   #290  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
i have an idea... i will try to work this weekend...

should i drop dgindex usage TS files and use instead projectx ?

ALL please post your ideas

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline  
Old 25th November 2006, 16:37   #291  |  Link
weaver4
Registered User
 
Join Date: Jun 2005
Posts: 925
buzzqw or sharktooth: What filter do you recommend for XviD cq 3?

I will retest it again.
weaver4 is offline  
Old 25th November 2006, 16:43   #292  |  Link
fogbav
Registered User
 
Join Date: Feb 2002
Posts: 87
Would be great .... never had problems with ProjectX in the past ... also ProjectX is fixing errors in TS ...

Also ... cutting in TS with ProjectX is very easy ....

But i think my problem is not dgindex (log shows correct frames and With/size etc.) ... think the problem is the avs file ...

Future wishes :
The only thing i want is take a ts (or MPG) file from my Dbox2 Record and convert ALL audio Tracks with org. Settings (Stereo/AC3-> AAC) to a XVID/H264 file ... with reduction of XX% (that is the job my script is doing - modifying your automkv.ini- dest size setting) ... and if possible ... watch a "record-Folder" for new files.

I'm recording some TV-Series and some other things and ts files are very big (you know about that ..8) )... so i only want to convert everything to format XXX - playable at my Xbox (so Xvid is perfect )

Computers here are running 24/7 so waching an TS-Incoming folder is a great deal ... and 2 or more computers are computing XX TS files at the same time ...tagging a converting file so the other computer is not working on the same file (but i don't know if this wishes is a target for your great application).

Last edited by fogbav; 25th November 2006 at 16:52.
fogbav is offline  
Old 25th November 2006, 17:04   #293  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
Quote:
buzzqw or sharktooth: What filter do you recommend for XviD cq 3?
simply change resizer to Lanczos, in cq30.xml change <BQuantOffset>100<BQuantOffset> to <BQuantOffset>0<BQuantOffset> and for matrix use Sharktooth's EQM v3LR.cqm

no filter adjustmen is needed

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline  
Old 25th November 2006, 18:39   #294  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
@fogbav

check your pm

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline  
Old 26th November 2006, 00:04   #295  |  Link
weaver4
Registered User
 
Join Date: Jun 2005
Posts: 925
Quote:
Originally Posted by buzzqw View Post
simply change resizer to Lanczos, in cq30.xml change <BQuantOffset>100<BQuantOffset> to <BQuantOffset>0<BQuantOffset> and for matrix use Sharktooth's EQM v3LR.cqm

no filter adjustmen is needed

BHH
OK, I did that, much better results.

I think you should change the default profile to the above. It does not make sense to have Sharktooth's EQM v3ULR.cqm when you have the quantizer set to 3.
weaver4 is offline  
Old 26th November 2006, 10:27   #296  |  Link
fogbav
Registered User
 
Join Date: Feb 2002
Posts: 87
One little bug : Selecting Filers : None with TS file above is not working - stalling at enconding ...

With same preferences and file selecting any Filter is working ...

(Think that is the error i mentionend above)

and ... if it is ok .. i would wish one last parameter for batch encoding :

Size = 10
Slice = 1

until now i have to fix automkv.ini manually befor encoding to select final size of the encode.
(witch doesn't really matter - but would be nicer to set it with cli parameters)

Edit : Audio "All Tracks" - already implemented ... stupid FoGBaV ... 8) 3 0 0 0 in CLI does the trick perfectly ... thanks !


Greets

FoGBaV -P.S. : Buzzqw 4 president ...8)

Last edited by fogbav; 26th November 2006 at 11:30.
fogbav is offline  
Old 26th November 2006, 11:02   #297  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
got the error too... BUT with X264.exe i got NO error...
i think something is wrong with xvid_encraw...

i will search on xvid forum

thanks for testing !

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline  
Old 26th November 2006, 18:43   #298  |  Link
travisbell
Registered User
 
Join Date: Feb 2005
Location: Calgary, Canada
Posts: 139
Quote:
Originally Posted by buzzqw View Post
i have an idea... i will try to work this weekend...

should i drop dgindex usage TS files and use instead projectx ?

ALL please post your ideas

BHH
I don't think you should. I have been using AutoGK for 2 years (it uses DGIndex) and now your app with DGIndex with HD .ts files and never once ran into a problem.

If you did change it, it would be nice to have the option to choose which to use, because I myself have always like DGIndex.

Thanks!
__________________
--
Travis Bell
Consumeroo!
travisbell is offline  
Old 26th November 2006, 20:31   #299  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
projectx is only used for demuxing pourpose (from ts to m2v+ac3/mpa...)

Dgindex is then call to parse the m2v and do all the fine job

Using projectx my ts demuxing (before done by dgindex) is more robust: Delaycut no more hang, is possible to extract more then 1 only audio, ts streams corrupted got fixed...

I had already implemented projectx and if you want test please PM

About using choice of use dgindex or projectx i will see what possible.

BHH

P.S: even if projectx is used... is used only for .TS files... i can just rename your TS file to .VOB and then dgindex is used... and is fully fuctional as always !
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8

Last edited by buzzqw; 26th November 2006 at 20:35.
buzzqw is offline  
Old 26th November 2006, 20:34   #300  |  Link
SeeMoreDigital
Life looks better in HD
 
SeeMoreDigital's Avatar
 
Join Date: Jun 2003
Location: Notts, UK
Posts: 11,209
All clever stuff indeed Buzz
__________________
| I've been testing hardware media playback devices and software A/V encoders and decoders since 2001 | My Network Layout & A/V Gear |
SeeMoreDigital is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:18.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.