Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 6th December 2005, 11:52   #1  |  Link
ariga
Learning...
 
ariga's Avatar
 
Join Date: Nov 2005
Location: 12.97°N, 77.56°E
Posts: 135
Fix colour streaks

It looks like an interlaced frame, but it is not. Only some parts have red colour sticking out as sharp lines.

Performing a deinterlace doesn't help. Is there any filter to fix it ?

The avi clip is here
ariga is offline   Reply With Quote
Old 6th December 2005, 12:26   #2  |  Link
Chainmax
Huh?
 
Chainmax's Avatar
 
Join Date: Sep 2003
Location: Uruguay
Posts: 3,103
Looks like a color sampling issue, try using ConvertToYV12() or ConvertToYV12(interlaced=true) at the beginning of your script.
__________________
Read Decomb's readmes and tutorials, the IVTC tutorial and the capture guide in order to learn about combing and how to deal with it.
Chainmax is offline   Reply With Quote
Old 6th December 2005, 12:29   #3  |  Link
Didée
Registered User
 
Join Date: Apr 2002
Location: Germany
Posts: 5,394
"MergeChroma( blur(0,1) )" will help for sure ...
__________________
- We´re at the beginning of the end of mankind´s childhood -

My little flickr gallery. (Yes indeed, I do have hobbies other than digital video!)
Didée is offline   Reply With Quote
Old 6th December 2005, 12:36   #4  |  Link
Chainmax
Huh?
 
Chainmax's Avatar
 
Join Date: Sep 2003
Location: Uruguay
Posts: 3,103
What is it with you second guessing my latest posts?
__________________
Read Decomb's readmes and tutorials, the IVTC tutorial and the capture guide in order to learn about combing and how to deal with it.
Chainmax is offline   Reply With Quote
Old 6th December 2005, 13:16   #5  |  Link
ariga
Learning...
 
ariga's Avatar
 
Join Date: Nov 2005
Location: 12.97°N, 77.56°E
Posts: 135
Quote:
Originally Posted by Chainmax
Looks like a color sampling issue, try using ConvertToYV12() or ConvertToYV12(interlaced=true) at the beginning of your script.
It's DV decoded as YV12 already. Captured via analog input of camcorder.
Will try MergeChroma.
ariga is offline   Reply With Quote
Old 6th December 2005, 13:57   #6  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,335
Before you do that. I don't know how you created the screenshot (and which codec you used for decoding), but try to open it with Cedocida DV Codec first (as YV12),
Code:
AviSource(...)
ConvertToRGB32(interlaced=true) # or false if it is progressive
and post some screenshots.

I will look at the avi when i'm home.
Wilbert is offline   Reply With Quote
Old 6th December 2005, 15:40   #7  |  Link
ariga
Learning...
 
ariga's Avatar
 
Join Date: Nov 2005
Location: 12.97°N, 77.56°E
Posts: 135
Quote:
Originally Posted by Wilbert
Before you do that. I don't know how you created the screenshot (and which codec you used for decoding)
The frame was decoded using Cedocida in Vdub. Still frame copied to clipboard, pasted into The Gimp, added yellow border, cropped, saved as png.

But it looks the same with Avisynth serving YV12 to Vdub. I was applying some filters to clean up the source and thought the colour streaks were because of some filter wrongly applied. Then I opened the avi in Vdub directly and took a screenshot. Will try with the ConvertToRGB and post another screenshot if it looks any different.
ariga is offline   Reply With Quote
Old 6th December 2005, 16:15   #8  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,335
Quote:
But it looks the same with Avisynth serving YV12 to Vdub.
This the problem. VDub upsamples progressively when displaying, so it's only a display problem (your source is interlaced, you can check this in AviSynth using AviSource(...).SeparateFields). Use ConvertToRGB32(interlaced=true) for proper display, or just encode straight away. It will not be visible in your encoding.
Wilbert is offline   Reply With Quote
Old 7th December 2005, 07:24   #9  |  Link
ariga
Learning...
 
ariga's Avatar
 
Join Date: Nov 2005
Location: 12.97°N, 77.56°E
Posts: 135
@Wilbert: ConvertToRGB32(interlaced=true) did make it a little better but didn't fix it (don't have a screenshot). But i'm not convinced about the source being interlaced. If the source is processed with TDeint(), the preview in Vdub shows the streaks as broken dashes. I have another partial capture of the same broadcast from a different channel which is interlaced for sure - almost every scene has combing.

But take a look at these. Frame 38 of the clip with different sampling options in Cedocida.

Vdub direct


Frameserved/AviSource (YV12, sampling=DV)


Frameserved/AviSource (YV12, sampling=MPEG2 non-int)


Frameserved/AviSource (YV12, sampling=MPEG2 int)


Framedserved/DirectShowSource (YUY2)



Changing the sampling option didn't effect the preview in Vdub when opened directly, but it did effect when frameserving via Avisynth !! Info() says it's YV12 all the time.

Sampling option set to MPEG non-interlaced shows the "correct" preview. Does this imply the source is non-interlaced ? Or does Cedocida modify the chroma info in the YV12, so that when Vdub upsamples progressively the preview is correct ?

BTW, the effect is amplified if using video overlay in Vdub. Instead of colour streaks, the entire frame appears blocky. (Unfortunately I cannot take a screenshot of it). With MPEG2 non-interlaced sampling the playback is correct.
ariga is offline   Reply With Quote
Old 7th December 2005, 23:14   #10  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,335
Ok, i looked at it. In my opinion the source is progressive (as you suggest). It seems to me this is also encoded as progressive, but i don't understand how this would be possible. What dv codec did you use for this?

Indeed setting Cedocida to MPEG-2 non-interlaced for decoding gives "correct" output. Thus, the artefacts you saw is the cause of a progressive source being decoded as interlaced.
Wilbert is offline   Reply With Quote
Old 8th December 2005, 05:15   #11  |  Link
scharfis_brain
brainless
 
scharfis_brain's Avatar
 
Join Date: Mar 2003
Location: Germany
Posts: 3,607
Quote:
Originally Posted by Wilbert
Thus, the artefacts you saw is the cause of a progressive source being decoded as interlaced.
These artefakts will also show up, if an interlaced source is sampled up interlaced.

to avoid that, use my motion adaptiv chroma upsampling routines with Tdeint.
http://forum.doom9.org/showthread.ph...squeeze+detail

DV also supports Progressive encoding.
I've seen interlaced cameras, that encode low and nomotion blocks progressive, wjich obviously destroys the chroma for that block, but effectively reduces ringing in allover the image.
__________________
Don't forget the 'c'!

Don't PM me for technical support, please.
scharfis_brain is offline   Reply With Quote
Old 9th December 2005, 09:56   #12  |  Link
ariga
Learning...
 
ariga's Avatar
 
Join Date: Nov 2005
Location: 12.97°N, 77.56°E
Posts: 135
Quote:
Originally Posted by Wilbert
What dv codec did you use for this?
A/V out (TV) => A/V in TRV-355E camcorder => DV out.
Quote:
Originally Posted by scharfis_brain
These artefakts will also show up, if an interlaced source is sampled up interlaced.
Thanks, I'll remember that !
yv12toyuy2_laced (Is this similar to autoyuy2 ?) followed by a TDeint() didn't fix it. Besides, I do not need an upsampling since I'm encodig to DivX.
Quote:
Originally Posted by Wilbert
... or just encode straight away. It will not be visible in your encoding.
Forgot to mention earlier. AviSource() with Cedocida -> Vdub and encoded to DivX with these settings.
(a) YV12 sampling=DV / DivX interlace=Progressive Source
(b) YV12 sampling=MPEG2 non int / DivX interlace=Progressive Source
(c) YV12 sampling=DV / DivX interlace=Preserve interlace
(d) YV12 sampling=MPEG2 non int / DivX interlace=Preserve interlace
When played in PowerDVD with deinterlacing turned off, (a) was messed up whereas (b), (c) and (d) played back fine.
Playback in Vdub however still showed slightly jagged edges in some places.

MPEG2 non-interlaced sampling fixes the problem. Finally the author clears it up !

Last edited by ariga; 9th December 2005 at 14:11.
ariga is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 14:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.