Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Newbies

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th November 2005, 12:30   #1  |  Link
TheTrooper
Registered User
 
Join Date: Dec 2004
Posts: 5
Uninstalled Haali Media Splitter,now I can't view avi's

Hi, I hope this is in the correct forum
I installed Haali Media Splitter,my computer slowed down when opening avi's for editing, so I uninstalled it and now I can't view any avi's.

I have searched the forum and tried everything I could find useful;
I tried "Start>Run> regsvr32 quartz.dll" but that didn't work.
I installed Directx Media 6 which someone said worked for them, that didn't work either.
I put new versions of quartz.dll and avisplitter.ax in my system folder and system32 folder, I'm not really sure what I doing here
Tried changing merits with Radlight filter manager and re-registering quartz, but again I'm not really sure what I'm doing.
Tried installing the latest version of ffdshow but still no luck in getting avi's to work.
Gspot reports;
Code:
Failed to create the source filter for the input file F.AddsourceFilter() failed. Error 0x80040241: The source filter for the file could not be loaded.
Is there a foolproof way of getting the default quartz avi splitter to work again without a reformat, any help will be greatly appreciated.
Thanks in advance
TheTrooper is offline   Reply With Quote
Old 17th November 2005, 17:07   #2  |  Link
ammck55
Moderator
 
Join Date: Oct 2002
Location: U.S. of A.
Posts: 1,307
Welcome to the Forum:

When you installed Haali's splitter, did you check "enable avi support" in the setup?

This may not be what you're looking for, but this thread has some tips on the installation of Haali's Media Splitter; both manual installation, and use of the installer.

ammck55
ammck55 is offline   Reply With Quote
Old 20th November 2005, 05:44   #3  |  Link
sapient
Unbeliever
 
Join Date: Sep 2002
Location: Greece
Posts: 111
I have the exact same problem.
I will try to explain it better, hoping someone will provide a solution.
I installed HaaliMediaSplitter and checked avi suppurt during installation.
So all avi files used HaaliMediaSplitter to play.
When I unistalled the filter, I couldn't play avi files any more.
The question is, how can we re-register the default avi splitter, so we can view avi files again, withOUT re-installing the haali splitter.

edit:After a LOT of searching around in the registry I discovered several things about the HaaliMediaSplitter:
During installation it moves the .avi media type to a new category ( in the rgisty's mediatype section) that uses itself as the source filter.
After uninstallation this category is not removed nor is .avi returned to its default group. So even though quartz.dll is registered as a file source filter, avi is no longer set to open with it. So re-registering quatz.dll does not help.
Additionally, Haalisplitter never actually unregisters itself.
All in all the unistallation routine is extremely inadequate.
In order to restore my system I had to import the mediatype section of the registry from another computer.

Last edited by sapient; 20th November 2005 at 07:34.
sapient is offline   Reply With Quote
Old 20th November 2005, 09:11   #4  |  Link
Koti
Always trying
 
Koti's Avatar
 
Join Date: Jan 2005
Location: The O.C. ;)
Posts: 221
ezier way to fix this - reinstall haalis splitter , same version, manually unregister (regsvr /u ) all the files it installs and then uninstall . Seems thier is a bug in the unregistering upon uninstall

then quartz dll will split avi
Koti is offline   Reply With Quote
Old 20th November 2005, 09:17   #5  |  Link
sapient
Unbeliever
 
Join Date: Sep 2002
Location: Greece
Posts: 111
Will not work
The prob is not only that it does not unregister, but that it makes quartz to no longer handle avis. Even if I unregister everything and re-register the system filters it still will not wotk because the avi mediatype remain in the new group that uses haali as source instead of quartz.
sapient is offline   Reply With Quote
Old 20th November 2005, 13:40   #6  |  Link
TheTrooper
Registered User
 
Join Date: Dec 2004
Posts: 5
Yeah, sorry my first post wasn't very clear.
I don't want Haali Media Splitter installed anymore, but I'm stuck with it for now.
I'm not very good with things like editing the registry so it looks like I might have to re-install my OS, unless someone has an idiots guide for restoring the registry settings
TheTrooper is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:39.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.