Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 28th October 2005, 03:24   #1  |  Link
IanB
Avisynth Developer
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 3,168
AviSynth 2.5.6 [temporarily withdrawn] - Re-released as 2.5.6a

Dear all,

The AviSynth 2.5.6 release has a corruption at the end of the IScriptEnvironment vtable and has been temporarily withdrawn from distribution.

Any pluggin compiled with avisynth.h from version 2.5.5 and prior (i.e just about all of them) using the following calls (fortunatly almost none) may have unpredictable results :-

IScriptEnvironment::SubFrame()
IScriptEnvironment::SetMemoryMax()
IScriptEnvironment::SetWorkingDir()


User not using any pluggins effected by these calls need take no further action.


Any new pluggins using the following calls in avisynth.h from version 2.5.6

IScriptEnvironment::SubFrame()
IScriptEnvironment::SetMemoryMax()
IScriptEnvironment::SetWorkingDir()
IScriptEnvironment::ManageCache()
IScriptEnvironment::PlanarChromaAlignment()


Will need to be recompiled with the avisynth.h in the replacement version 2.5.6 available shortly.

Sorry for any inconvienience.
IanB

Last edited by IanB; 29th October 2005 at 06:42.
IanB is offline   Reply With Quote
Old 28th October 2005, 06:35   #2  |  Link
JuanC
Registered User
 
Join Date: May 2002
Posts: 220
Ian: is it safe to use 2.5.6 RC2 ?
JuanC is offline   Reply With Quote
Old 28th October 2005, 07:27   #3  |  Link
IanB
Avisynth Developer
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 3,168
@JuanC

2.5.6 RC2 is identical to the withdrawn version. A replacement installable package should be up in a few hours. If you really, really must download an installable version before the replacement is available then yes RC2 is a suitable source.

If you already have 2.5.6 installed, there should be no problem continuing to use it, only a very small set of pluggins are effected by the problem.

IanB
IanB is offline   Reply With Quote
Old 28th October 2005, 07:56   #4  |  Link
JuanC
Registered User
 
Join Date: May 2002
Posts: 220
OK, No problem at all. Thanks a lot for your hard work
JuanC is offline   Reply With Quote
Old 28th October 2005, 07:58   #5  |  Link
Mug Funky
interlace this!
 
Mug Funky's Avatar
 
Join Date: Jun 2003
Location: i'm in ur transfers, addin noise
Posts: 4,547
this is why i like opensource... you're actually telling us there's a bug and doing something about it. payware will keep the same fatal crash bugs for up to 5 releases into the future (each one you have to pay through the nose for).

thanks for the heads-up. will re-download as soon as the fix is upped
__________________
sucking the life out of your videos since 2004
Mug Funky is offline   Reply With Quote
Old 28th October 2005, 10:48   #6  |  Link
stickboy
AviSynth Enthusiast
 
Join Date: Jul 2002
Location: California, U.S.
Posts: 1,268
Quote:
Originally Posted by IanB
Will need to be recompiled with the avisynth.h in the replacement version 2.5.6 available shortly.
You're not going to re-release it as 2.5.6 are you (versus 2.5.6a, 2.5.6.1, 2.5.7, whatever)?
stickboy is offline   Reply With Quote
Old 28th October 2005, 12:11   #7  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,301
I also thought about this. People shouldn't be able to download and use 2.5.6. Perhaps the best way to ensure that is to remove 2.5.6 from the servers, release a 2.5.7 and make a proper announcement on sourceforge?
Wilbert is offline   Reply With Quote
Old 28th October 2005, 13:03   #8  |  Link
Prodater64
Registered User
 
Join Date: Mar 2004
Posts: 266
Quote:
Originally Posted by IanB
If you already have 2.5.6 installed, there should be no problem continuing to use it, only a very small set of pluggins are effected by the problem.

IanB
It would be nice a list of the "very small set of plugins". If it is very small it can't be hard to list they, isn't it?
__________________
Prodater64
Prodater64 is offline   Reply With Quote
Old 28th October 2005, 15:13   #9  |  Link
IanB
Avisynth Developer
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 3,168
@stickboy,
> You're not going to re-release it as 2.5.6 are you (versus 2.5.6a,
> 2.5.6.1, 2.5.7, whatever)?

Normally I wouldn't but the main file to pull was avisynth.h in the source .zip, I have already done this, repaired it and replaced it. The reason to replace the installable version is just to say that this is the executable that goes with this source. To identify it, it will have a different build date and time. Not an ideal situation, but better than sitting on the problem and letting it fester.


@Wilbert,
> I also thought about this. People shouldn't be able to download and
> use 2.5.6. Perhaps the best way to ensure that is to remove 2.5.6
> from the servers, release a 2.5.7 and make a proper announcement
> on sourceforge?

The main aim is to have the installable match the source. I don't expect there to be any manifest difference between the versions and I don't want to preempt 2.5.7 as is already underway, it currently has 3 minor bug fixes and we are looking for the cause of 3 more. I don't plan any enhancements (all in 2.6). We can put out a 2.5.7alpha when the 3 current outstanding bugs are found and fixed.


@Prodater64,
> It would be nice a list of the "very small set of plugins". If it
> is very small it can't be hard to list they, isn't it?

So far the set is 1 pluggin (the one I wrote to prove the problem), however I am sure Murphy has at least one more hiding out there in the wings, if found the answer will be "fixed in 2.5.7"
IanB is offline   Reply With Quote
Old 28th October 2005, 16:43   #10  |  Link
Fizick
AviSynth plugger
 
Fizick's Avatar
 
Join Date: Nov 2003
Location: Russia
Posts: 2,183
IanB,
IMHO, your bugfixed version must NOT be called 2.5.6 an sourceforge,
it must be called 2.5.6a or "2.5.6bugfixed", to prevent mess.
But internally it may be called 2.5.6 (as DLL version, etc, or Version() return).

BTW, there were many bugs in versions 2.5.3, 2.5.4, etc (and in its avisynth.h too), but they are still in sourceforge
Fizick is offline   Reply With Quote
Old 28th October 2005, 17:03   #11  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,301
@Fizick,
You misunderstand. The problem doesn't affect the dll itself (so for the user there isn't any difference between the old and the new one), but it affects avisynth.h (and thus certain plugins compiled with the old avisynth.h).
Wilbert is offline   Reply With Quote
Old 28th October 2005, 17:42   #12  |  Link
Fizick
AviSynth plugger
 
Fizick's Avatar
 
Join Date: Nov 2003
Location: Russia
Posts: 2,183
Thanks.
I understand it.
There was some errors in old (2.5.3 ?) avisynth.h (pixel type in place of image type for example) . And it influence all complied plugins.
But it is not important now.

I repeat, that the name similar to "2.5.6bugfixed" is better than simply new "2.5.6". (IMHO).
Fizick is offline   Reply With Quote
Old 28th October 2005, 18:45   #13  |  Link
acrespo
Brazilian Anime Ripper
 
Join Date: Nov 2001
Location: Brazil
Posts: 237
IanB:
If some plugins will not function with the new version, I think the best is increase the version number to 2.5.7, and the version you work actually rename to 2.5.8 when release. It's more easy to understand and make plugin documentation too.

"This plugin is compatible up to v2.5.6"
__________________
Capture cards:
Compro VideoMate Gold+ (Philips SAA7134 based) (not active)
Hauppauge PVR 150MCE (not active)
ATI TV Wonder Elite (active)

Last edited by acrespo; 28th October 2005 at 18:50.
acrespo is offline   Reply With Quote
Old 28th October 2005, 19:18   #14  |  Link
stickboy
AviSynth Enthusiast
 
Join Date: Jul 2002
Location: California, U.S.
Posts: 1,268
Quote:
Originally Posted by IanB
Normally I wouldn't but the main file to pull was avisynth.h in the source .zip, I have already done this, repaired it and replaced it. The reason to replace the installable version is just to say that this is the executable that goes with this source. To identify it, it will have a different build date and time. Not an ideal situation, but better than sitting on the problem and letting it fester.
Well are you at least going to add a specific version number to avisynth.h, then?

I still think you should adjust the version number, even if the binary hasn't really changed. I don't understand why not to do it. Is changing it to 2.5.6.1 so much trouble?
stickboy is offline   Reply With Quote
Old 28th October 2005, 20:19   #15  |  Link
Fizick
AviSynth plugger
 
Fizick's Avatar
 
Join Date: Nov 2003
Location: Russia
Posts: 2,183
IanB, Wilbert,
Thanks for your works,

I see new 2.5.6 at sourceforge.
You do not hear us,
O.K., but please give last comment:
I now see at sourceforge :
1) source avisynth_256_src.zip dated 2005-10-15, which had (has ?) bad avisynth.h,
2) new binary avisynth_256.exe dated 2005-10-28, which had avisynth.dll, quite good in previous 2.5.6.
Fizick is offline   Reply With Quote
Old 28th October 2005, 21:03   #16  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,301
Quote:
I now see at sourceforge :
1) source avisynth_256_src.zip dated 2005-10-15, which had (has ?) bad avisynth.h,
Crappy CVS. Fixed that. (I don't know why is has the old date stamped on it. But it contained the correct avisynth.h.)
Wilbert is offline   Reply With Quote
Old 28th October 2005, 22:12   #17  |  Link
Elic
Registered User
 
Elic's Avatar
 
Join Date: Apr 2005
Location: Ukraine, Vinnitsa
Posts: 110
IanB, Wilbert,
I have (and lots of people in Ukraine and Russia too) a relately expensive and pretty slow internet connection; so can you please make available just patches for Avisynth 2.5.6 bugfix together with whole bugfixed Avisynth?
Thanks in advance.
__________________
-= Elicit Gingers =-
Elic is offline   Reply With Quote
Old 28th October 2005, 22:44   #18  |  Link
Fizick
AviSynth plugger
 
Fizick's Avatar
 
Join Date: Nov 2003
Location: Russia
Posts: 2,183
Dear Elic,
If you translate some plugin doc to Russian (or Ukrainian ),
I will upload such patches or send it directly to your.
__________________
My Avisynth plugins are now at http://avisynth.org.ru and mirror at http://avisynth.nl/users/fizick
I usually do not provide a technical support in private messages.
Fizick is offline   Reply With Quote
Old 28th October 2005, 22:46   #19  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,301
Check your pm for the patches!
Wilbert is offline   Reply With Quote
Old 29th October 2005, 06:33   #20  |  Link
IanB
Avisynth Developer
 
Join Date: Jan 2003
Location: Melbourne, Australia
Posts: 3,168
Uncle! I have renamed the release to Avisynth 2.5.6a the files are still the same.
IanB is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 21:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.