Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 14th September 2009, 04:35   #1  |  Link
MOverride
The Hamster
 
MOverride's Avatar
 
Join Date: Feb 2006
Posts: 20
Which AAC encoders support simultaneous encoding?

I've just moved up from a P4 HT to a brand spanking-new Core i7. I'm quite impressed with how much faster it is with encoding, especially when I'm running on three cores at once.

However, while x264 will happily encode on three cores at once, NeroAacEnc won't--the resulting AAC files are trash, either no audio or static.

Is this a problem with how MeGUI invokes NeroAacEnc, or with the latter's own behavior? Is there a multiple-invocation-safe AAC encoder supported by MeGUI?

Thanks for any information you can provide!

MeGUI: 0.3.1.1051
NeroAacEnc: 1.3.3.0
__________________
"Niceness is the greatest human flaw, except for all the others."
--Brendan Moody
MOverride is offline   Reply With Quote
Old 14th September 2009, 12:22   #2  |  Link
RunningSkittle
Skittle
 
RunningSkittle's Avatar
 
Join Date: Mar 2008
Posts: 539
use search!
foobar2000
or http://forum.doom9.org/showthread.ph...811#post920811
etc
RunningSkittle is offline   Reply With Quote
Old 15th September 2009, 00:58   #3  |  Link
MOverride
The Hamster
 
MOverride's Avatar
 
Join Date: Feb 2006
Posts: 20
Quote:
Originally Posted by RunningSkittle View Post
use search!
I tried and didn't come up with any useful results.

Quote:
Originally Posted by RunningSkittle View Post
Huh. So it probably is MeGUI's fault, if LameXP supports NeroAacEnc properly. Unfortunate.

Thanks for the information.
__________________
"Niceness is the greatest human flaw, except for all the others."
--Brendan Moody
MOverride is offline   Reply With Quote
Old 15th September 2009, 23:43   #4  |  Link
Doom9
clueless n00b
 
Join Date: Oct 2001
Location: somewhere over the rainbow
Posts: 10,570
the way I read that linked thread is that it's a frontend that allows for parallel encoding of separate files - the same can be achieved using worker threads in megui.

and the output has probably something to do with filters.. it's one of the most common problems with megui (not that it's megui's fault though.. )
__________________
For the web's most comprehensive collection of DVD backup guides go to www.doom9.org
Doom9 is offline   Reply With Quote
Old 15th September 2009, 23:55   #5  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 12,826
Quote:
Originally Posted by Doom9 View Post
the way I read that linked thread is that it's a frontend that allows for parallel encoding of separate files
Exactly
__________________
There was of course no way of knowing whether you were being watched at any given moment.
How often, or on what system, the Thought Police plugged in on any individual wire was guesswork.


LoRd_MuldeR is offline   Reply With Quote
Old 16th September 2009, 12:48   #6  |  Link
RunningSkittle
Skittle
 
RunningSkittle's Avatar
 
Join Date: Mar 2008
Posts: 539
yes, trying to encode multiple audio sources just errors out in megui. it only does this with nicaudiosource. if you force decoding with directshow it works again
RunningSkittle is offline   Reply With Quote
Old 17th September 2009, 23:34   #7  |  Link
MOverride
The Hamster
 
MOverride's Avatar
 
Join Date: Feb 2006
Posts: 20
Quote:
Originally Posted by Doom9 View Post
and the output has probably something to do with filters.. it's one of the most common problems with megui (not that it's megui's fault though.. )
It's possible, though given that this happens to me on a fresh Windows install with no DirectShow filters installed beyond whatever AviSynth, MeGUI, and VLC bring along for the ride (no codec packs or anything like that installed), there's very little chance to avoid filter issues if that's the problem.

Maybe something in the AviSynth script that MeGUI assembles isn't threadsafe... That would suck.
__________________
"Niceness is the greatest human flaw, except for all the others."
--Brendan Moody
MOverride is offline   Reply With Quote
Old 18th September 2009, 00:01   #8  |  Link
MOverride
The Hamster
 
MOverride's Avatar
 
Join Date: Feb 2006
Posts: 20
Quote:
Originally Posted by MOverride View Post
Maybe something in the AviSynth script that MeGUI assembles isn't threadsafe... That would suck.
And it seems to be the downsampling to stereo, since when I turn that off it works fine. Hmm. Well, thanks for sending me down the path of thinking to try turning off the filtering options, doom9, even if I don't have a fix in hand.

(No, DirectShowSource isn't one for me, since that... well, it either takes forever or it just locks up at "Preprocessing" with no useful log entries to debug. Hard to tell.)
__________________
"Niceness is the greatest human flaw, except for all the others."
--Brendan Moody
MOverride is offline   Reply With Quote
Old 21st September 2009, 05:54   #9  |  Link
click2
aka mappy
 
click2's Avatar
 
Join Date: Mar 2007
Posts: 63
Megui's preprocessing takes a while (with no progress bar), but it gets there in the end. Are you sure it's locking up?
__________________
<Dark_Shikari> its linux, I don't really care :: <pengvado> #x264 is not for dancing.
click2 is offline   Reply With Quote
Old 21st September 2009, 23:10   #10  |  Link
MOverride
The Hamster
 
MOverride's Avatar
 
Join Date: Feb 2006
Posts: 20
Quote:
Originally Posted by click2 View Post
Megui's preprocessing takes a while (with no progress bar), but it gets there in the end. Are you sure it's locking up?
I let it preprocess for a half-hour, which is about five times as long as it takes to do a complete file (preprocess and process) without "Force DirectShow" checked. That sure looks like a hangup to me...
__________________
"Niceness is the greatest human flaw, except for all the others."
--Brendan Moody
MOverride is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.