Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 21st May 2016, 16:31   #1  |  Link
reko
Registered User
 
Join Date: Apr 2013
Posts: 4
play mp3 using ffdshow audio decoder with mpc-hc ?

Hi,

I'm frustated here.
This is my story :
2 days ago, I downloaded MPC-HC.1.7.10.x86.
In my computer was already installed ffdshow rev 3984 (32 bit).

I add ffdshow audio decoder in MPC-HC external filter. Tick the "prefer" radio button.

I unchecked all type in the [SourceFilter] of MPC-HC internal filter.

Either mp3 file or AAC file, when I open with MPC-HC - it "calls" the ffdshow audio decoder - as the blue ffdshow icon appear in the system tray on the right bottom of my monitor.

I'm happy because I can use the equalizer in ffdshow audio decoder to adjust the sound. I never install any new software to my computer since that.

But today, suddenly when I open mp3 file or video file with AAC audio, it doesn't "call" the ffdshow audio decoder. When I play the mp3 file, this what I get from the Filter of MPC-HC :
Filters currently loaded:
- Default DirectSound Device
- MP3 Decoder DMO
- MPEG-I Stream Splitter
- File Source (Async.)

So I search from the internet about this problem, and I downloaded Win7DSFilter Tweaker. In this app of the [Preffered decoder] section, I mark the radio button for mp3 to ffdswhow (before the radio button is microsoft) and disable the MP3 Decoder DMO in the [MS Codec Tweak] of this app.

Still, when I play the mp3 from MPC-HC, it doesn't call ffdshow audio decoder. MPC-HC Filter now showed :
Filters currently loaded:
- Default DirectSound Device
- ACM Wrapper (0x0055)
- MPEG-I Stream Splitter
- File Source (Async.)

When I play a video file with DTS/AC3 audio, it calls the ffdshow audio (and also ffdshow video). When I play .DAT (vcd) file, it calls the ffdshow video, but not the ffdshow audio.

I wonder why without I do anything, suddenly playing mp3 file (from MPC-HC) doesn't call the ffdshow audio decoder ?

I've tried by deleting the whole folder of MPC-HC. Restart the computer. Extract the MPC-HC zip file. Play the mp3, still no joy.

Just now I noticed,
A. when my video file with AAC file format profile (from the media-info) is [HE-AAC / LC] - [Codec ID : 40] it doesn't call ffdshow audio.

B. But if my video file with AAC file format profile [High@L4.1] - [Codec ID : avc1] it calls ffdshow audio.

But before, whatever format profile of the AAC, playing either the A video or the B video above, both is calling ffdshow audio.

Anykind of help/respond would be greatly appreciated.
Thank you in advanced.
(I'm sorry for my broken English).

regards.
reko is offline   Reply With Quote
Old 21st May 2016, 16:56   #2  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,838
Start by installing a newer version of ffdshow. Your version is three years older than the latest one (r4533).
clsid is offline   Reply With Quote
Old 22nd May 2016, 09:39   #3  |  Link
reko
Registered User
 
Join Date: Apr 2013
Posts: 4
Quote:
Originally Posted by clsid View Post
Start by installing a newer version of ffdshow. Your version is three years older than the latest one (r4533).
Thank you for your respond clsid.

I've downloaded the r4533.
Uninstall the old version, restart the computer then install the r4533. (I didn't do anything during installation process, leaving all the option as it is, click ok... ok... ok until the installation finish).

Play the mp3 file and video with AAC audio, and it works ! Ffdshow audio blue icon showed in the system tray bottom right of my monitor. But different problems appear... :

1. While a movie with two subtitle files (.srt) played in MPC-HC, when I right click the MPC-HC --> Filters --> the ffdshow video decoder doesn't have small triangle anymore where I can choose which subtitle file I want to display.

In the old version, it has the small triangle - from there I can choose which .srt file I want to display.

In the r4533, I need to click the red icon in the system tray, then manually choose the subtitle file I want to display in the Subtitle Filter of the ffdshow.

I've tried here and there hoping the triangle showed, but in vain.

2. While playing a 3D SBS video file, there are 3 column of the subtitle displayed on the video if I "tick" the stereoscopic placement as seen in the photo below

If I "untick" the sterescopic, only the middle subtitle displayed. But this title is unwatchable once I put the 3D setting on my 3D-TV.

In the old version, the subtitle displayed correctly which is on the left and right only, no middle sub displayed.

I've tried here and there trying to get rid off the middle sub, but in vain.

3. Playing mpeg2 and mp4 video file, the color tone is distorted... "splotchy". This is the same thing happen if I use WMP-11, as seen in the picture below :


With the ffdshow old version and MPC-HC, the video is displayed oke, no "splotchy" color.

I've tried here and there trying to get the correct color, such as changing each DirectShow options (EVR, VMR7, VMR9, Default, etc) in the Playback Output of MPC-HC, but in vain.

Sadly, I uninstall the r4533. Restart the computer. Install back the old version r3984. And then... "boom", playing the mp3 file and other video files with AAC audio is calling the ffdshow audio again . And of course, with r3984 I don't have the 3 problems I mentioned above, although with r3984 - playing mp4 file above 10 Mbps and playing MTS (approx 28 Mbps) file from my camcorder is laggy.... and it seems the video play a little bit slow, causing unsync between audio and video. When the audio is not heard anymore, the video still runs. But I can live with that . Funny thing is that the same video files play smooth (no lag - no unsync) with MPC-HC and ffdshow when I was still in XP with lower spec of CPU, GPU and Memory.

Anyway I want to say thank you very much for your respond/help/suggestion, clsid. And from your name, it seems you are the programmer of ffdshow ? If yes, wow... I'm flattered and I want to say thank you once again for your ffdshow. The name of the installer file I use is [ffdshow_rev3984_20110922_clsid.exe]





regards.
reko is offline   Reply With Quote
Old 22nd May 2016, 15:11   #4  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,838
I was mostly just one of the project admins. Development of ffdshow has stopped long ago.

You can fix the subtitle positioning for stereoscopic subtitles by adjusting the "Parallax" slider.

Since you only need the ffdshow processing functionality:
1) Re-enable all internal filters in MPC-HC. This should give correct and smooth playback.
2) Go into the settings of ffdshow video decoder and audio decoder. On the "Codecs" pages, disable everything. This will stop ffdshow from being used as a decoder (in other apps).
3) In MPC-HC external filters add "ffdshow raw video filter" and "ffdshow audio processor" and set them as preferred.

In new version you can select subtitle through: right-click on the tray icon > subtitle streams
For embedded subs, there is an option "always connect subtitle pin".
clsid is offline   Reply With Quote
Old 22nd May 2016, 15:39   #5  |  Link
reko
Registered User
 
Join Date: Apr 2013
Posts: 4
Quote:
Originally Posted by clsid View Post
I was mostly just one of the project admins. Development of ffdshow has stopped long ago.
Still thanks to you who still takes care over the ffdshow user .

Quote:
You can fix the subtitle positioning for stereoscopic subtitles by adjusting the "Parallax" slider.
It's not about the parallax actually, but there are 3 placement of the subtitle, left - middle - right. Which actually it must be only on the left and right when the stereoscopic option is ticked.

Quote:
Since you only need the ffdshow processing functionality:
1) Re-enable all internal filters in MPC-HC. This should give correct and smooth playback.

2) Go into the settings of ffdshow video decoder and audio decoder. On the "Codecs" pages, disable everything. This will stop ffdshow from being used as a decoder (in other apps).
3) In MPC-HC external filters add "ffdshow raw video filter" and "ffdshow audio processor" and set them as preferred.
Thank you for your recommendation. I will try that steps.

Quote:
In new version you can select subtitle through: right-click on the tray icon > subtitle streams
For embedded subs, there is an option "always connect subtitle pin"
bold, to be honest I didn't try that. Anyway, for the time being I will still use the old version

Thank you once again.
Really appreciate your time and help here.

regards.
reko is offline   Reply With Quote
Reply

Tags
ffdshow audio, mp3, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.