Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > New and alternative a/v containers

Reply
 
Thread Tools Search this Thread Display Modes
Old 4th January 2019, 18:29   #23241  |  Link
amichaelt
Registered User
 
Join Date: Apr 2018
Posts: 62
Quote:
Originally Posted by Megalith View Post
Why does LAV Audio output in 32-bit float for 24-bit TrueHD and DTS-HD MA tracks? Doesn't that mean the track is no longer bit-perfect?
No, single-precious float can represent all possible 24-bit integers.

https://en.wikipedia.org/wiki/Single...g-point_format

Quote:
Originally Posted by Megalith View Post
EDIT: Okay, apparently it does on a technical level, but some DACs seem to sound different when the bit-depth is upconverted...
There's no "upconverting" unless you think that 24 and 24.0 are different numbers.
__________________
My project BDSup2Sub++: https://github.com/amichaeltm/BDSup2SubPlusPlus
amichaelt is offline   Reply With Quote
Old 4th January 2019, 23:42   #23242  |  Link
nautilus7
Registered User
 
nautilus7's Avatar
 
Join Date: Jan 2006
Location: Athens, Greece
Posts: 1,514
Quote:
Originally Posted by el Filou View Post
Sorry for the off-topic, but TS Doctor says the audio stream is (partly) encrypted and that's why it won't decode:
Hi, yes you are correct. I was able to solve the problem by fixing a descrambling bug in the software. Audio plays ok now. Thanks.
nautilus7 is offline   Reply With Quote
Old 6th January 2019, 08:48   #23243  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,060
LAV Video decoder has problems after rewinding in software mode and DXVA2 on these files.
https://yadi.sk/i/jteUfal9hY7QR
https://yadi.sk/i/JZeFZiDFfXlmRg
The problem is in ffmpeg. There is a solution.
https://trac.ffmpeg.org/ticket/3705#comment:10

PS: Files on which artifacts appeared when using option "-flags2 +showall".
https://cloud.mail.ru/public/9krZ/vP4undPnV

Last edited by v0lt; 6th January 2019 at 08:50.
v0lt is offline   Reply With Quote
Old 12th January 2019, 12:10   #23244  |  Link
foxyshadis
ангел смерти
 
foxyshadis's Avatar
 
Join Date: Nov 2004
Location: Lost
Posts: 9,392
Quote:
Originally Posted by lvqcl View Post
No, they don't.
I honestly wouldn't be surprised. I've seen a lot of terrible implementations in my day, and int vs float sounds like just the thing to trigger them.
__________________
There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order. ~ Ed Howdershelt
foxyshadis is offline   Reply With Quote
Old 12th January 2019, 12:20   #23245  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 9,534
Quote:
Originally Posted by foxyshadis View Post
I honestly wouldn't be surprised. I've seen a lot of terrible implementations in my day, and int vs float sounds like just the thing to trigger them.
The float audio is never going to leave your PC though. It'll always be converted back to typically 16 or 24-bit int (at most 32-bit, typically for ASIO).
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 14th January 2019, 17:55   #23246  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,865
It has been 4 months since last FFmpeg update. Time for another update?
clsid is offline   Reply With Quote
Old 15th January 2019, 09:05   #23247  |  Link
OvejaNegra
ekTOMBE STUDIOS
 
OvejaNegra's Avatar
 
Join Date: Dec 2005
Location: Cuba
Posts: 253
Hi: PLayback of full chroma seems to be broken (High 4:4:4), is affecting the mpch 1.8.4 and the lavfilter pack, confirmed using graphstudio next, output looks garbage.

Switching off color formats or, multithreading does not helps, can anybody confirm this?
Thanks
__________________
So, it works or not???
OvejaNegra is offline   Reply With Quote
Old 15th January 2019, 10:10   #23248  |  Link
sneaker_ger
Registered User
 
Join Date: Dec 2002
Posts: 5,207
Is it an old x264 encode? There are bugs in old x264 4:4:4 encoding mode. Upload sample.
sneaker_ger is offline   Reply With Quote
Old 15th January 2019, 13:37   #23249  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 9,534
This is most likely the case. Old x264 produced out-of-spec files, which was since fixed, and the decoders updated to handle proper in-spec files.
The decoder can still handle old files, but only if the files properly identify as such - ie. the x264 SEI is still present that identifies the version of the encoder. If this SEI is missing, either deliberately removed, or lost due to a cut, then the file is quite simply broken now.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 27th January 2019, 06:27   #23250  |  Link
darkrenata
Registered User
 
Join Date: Oct 2017
Posts: 5
I was getting dropouts on an Atmos track watching Incredibles 2 4k Bluray (also Incredibles 1 as well) with LAV filters version .72 as well as latest.
My receiver is an Anthem MRX-1120.

I downgraded to .71 LAV filters and the issue seemed to go away.
darkrenata is offline   Reply With Quote
Old 30th January 2019, 12:58   #23251  |  Link
max79
Registered User
 
Join Date: Mar 2017
Posts: 52
Support request - #33

@Nevcairiel
Please have a look at the issue that i describe here(FFMPEG site moderator didn't give me a details):
https://trac.ffmpeg.org/ticket/7707

I never came across with a similar form of answers to common simple questions. I didn't like it.

Any feedback would be appreciated.
max79 is offline   Reply With Quote
Old 1st February 2019, 21:48   #23252  |  Link
AsadAlrafidain
Registered User
 
Join Date: Jan 2019
Posts: 2
I was wondering....when using advanced mode for subtitles in splitter settings, the rules seem to work only for embedded subtitles and ignore external subtitles.....is it just on my part or is the splitter intended to work this way ?

I was using this rule:

jap:eng|!f jap:jap|!f eng:ara eng:eng|!f


However when using this on a video with English audio, embedded English subtitles and external Arabic subtitles, lav splitter choose embedded English subtitles even though i preferred Arabic subtitles before English subtitles in the above rule....so what's the deal ?
AsadAlrafidain is offline   Reply With Quote
Old 1st February 2019, 21:49   #23253  |  Link
nevcairiel
Registered Developer
 
Join Date: Mar 2010
Location: Hamburg/Germany
Posts: 9,534
The splitter is not involved with external subtitles. Thats solely a feature of your player.
__________________
LAV Filters - open source ffmpeg based media splitter and decoders
nevcairiel is offline   Reply With Quote
Old 1st February 2019, 21:59   #23254  |  Link
AsadAlrafidain
Registered User
 
Join Date: Jan 2019
Posts: 2
@nevcairiel

well, that's a shame....the problem is that my player (Potplayer) doesn't recognize forced subtitles the same way Lav splitter does....

any intentions to include external subtitles in the future ?...oh and BTW I'm grateful for your wonderful software.
AsadAlrafidain is offline   Reply With Quote
Old 3rd February 2019, 15:57   #23255  |  Link
mzso
Registered User
 
Join Date: Oct 2009
Posts: 807
Is it normal for yadif to look like this?
https://drive.google.com/open?id=1JN...24vAtMbfazOjWe

The fizzyness does not happen with the HW deinterlacer of LAV or madVR. But it also looks similar with Weston three field.
mzso is offline   Reply With Quote
Old 3rd February 2019, 23:12   #23256  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 5,253
sample?

as it is not frame adaptive yes i can see this as a default artefacts.
huhn is offline   Reply With Quote
Old 4th February 2019, 21:16   #23257  |  Link
mzso
Registered User
 
Join Date: Oct 2009
Posts: 807
Quote:
Originally Posted by huhn View Post
sample?

as it is not frame adaptive yes i can see this as a default artefacts.
Here's one: https://drive.google.com/open?id=12w...A38RrBBdziCda8 (note: Looks like google deinterlaces it without this artifact)

Last edited by mzso; 4th February 2019 at 21:21.
mzso is offline   Reply With Quote
Old 4th February 2019, 23:19   #23258  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 5,253
i'm pretty sure your browser is using hardware deinterlancing.

looks like a limitation yadif.
huhn is offline   Reply With Quote
Old 5th February 2019, 14:59   #23259  |  Link
juffi
Registered User
 
Join Date: Jul 2007
Posts: 9
This may be wrong place for this question, but anyway.

I cannot get HW acceleration with LAV Filters 0.73.1-1 using msdk mvc decoder. My poor mini PC does not manage SW decoding properly, otherwise everything is fine. I try to play 3D blu ray ripped to mkv with MakeMKV. Original disk plays fine with PowerDVD 18 with HW accelaration.

Last edited by juffi; 5th February 2019 at 15:06.
juffi is offline   Reply With Quote
Old 5th February 2019, 15:30   #23260  |  Link
huhn
Registered User
 
Join Date: Oct 2012
Posts: 5,253
3D hardware decoding isn't supported in lavfilter only software.
huhn is offline   Reply With Quote
Reply

Tags
decoders, directshow, filters, splitter

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 18:12.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.