Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 12th March 2007, 22:03   #161  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by Hans Ohlo View Post
could you fill us in if you do this yourself or someone other is doing it (and mybe a eta ?
I will attempt it myself. No ETA. It works in the JVT decoder, so there is an extant example of how to do it.
Guest is offline  
Old 12th March 2007, 22:23   #162  |  Link
bond
Registered User
 
Join Date: Nov 2001
Posts: 9,779
Quote:
Originally Posted by neuron2 View Post
Please point me to the spec and section number that describes this index. Thank you.
http://standards.iso.org/ittf/Public...12_2005(E).zip

basically chapter 8.15, stts and ctts atoms
__________________
Between the weak and the strong one it is the freedom which oppresses and the law that liberates (Jean Jacques Rousseau)
I know, that I know nothing (Socrates)

MPEG-4 ASP FAQ | AVC/H.264 FAQ | AAC FAQ | MP4 FAQ | MP4Menu stores DVD Menus in MP4 (guide)
Ogg Theora | Ogg Vorbis
use WM9 today and get Micro$oft controlling the A/V market tomorrow for free
bond is offline  
Old 12th March 2007, 23:37   #163  |  Link
ilhyfe
Registered User
 
Join Date: Sep 2005
Posts: 50
Hi,

I just tested this software, but it doesn't work with the streams I use. I record from satelite with DVBVier PRO in .ts and .mpg format, but it seemd DGAIndex doesn't like the streams I record. Does anyone have an idea what I can do to solve it?

BTW: The most common errors are:
1. "Found NALU type 0, len xxx undefined, ignore NALI, moving on"
2. "Found NALU w/ forbidden_bit set, bit error? Let's try..."
3. "Garbage at start of bitstream... skipping it"

Last edited by ilhyfe; 12th March 2007 at 23:41.
ilhyfe is offline  
Old 12th March 2007, 23:41   #164  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by ilhyfe View Post
I just tested this software, but it doesn't work with the streams I use. I record from satelite with DVBVier PRO in .ts and .mpg format, but it seemd DGAIndex doesn't like the streams I record. Does anyone have an idea what I can do to solve it?
Yes. As clearly stated several times in this thread (in bold!), if you want support make an elementary stream available for testing. You see, my magic wand is broken, so I have to do it the old-fashioned way.

You didn't try to open the TS or MPG file, did you? I haven't added container support yet, again, as clearly stated several times.

Last edited by Guest; 12th March 2007 at 23:45.
Guest is offline  
Old 13th March 2007, 00:00   #165  |  Link
ilhyfe
Registered User
 
Join Date: Sep 2005
Posts: 50
Quote:
Originally Posted by neuron2 View Post
You didn't try to open the TS or MPG file, did you? I haven't added container support yet, again, as clearly stated several times.
Hehe, I did. I demuxed the movie now with elecard xmuxer and DGAIndex works. Bit while opening the .avs script I get this error:

AVCSource: Could not open one of the input files (test.avs, line 2).
ilhyfe is offline  
Old 13th March 2007, 01:27   #166  |  Link
HookedOnTV
Registered User
 
Join Date: Apr 2005
Posts: 122
PM'd you links to another file that doesn't seem compatable. This one is from another channel and it is 720p. Basically the same behavior except that ffdshow will play it fine. File indexes fine but no decoding.
HookedOnTV is offline  
Old 13th March 2007, 02:45   #167  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by ilhyfe View Post
AVCSource: Could not open one of the input files (test.avs, line 2).
Please provide the stream if you want support. Thank you.

Last edited by Guest; 13th March 2007 at 02:48.
Guest is offline  
Old 13th March 2007, 02:48   #168  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by HookedOnTV View Post
PM'd you links to another file that doesn't seem compatable. This one is from another channel and it is 720p. Basically the same behavior except that ffdshow will play it fine. File indexes fine but no decoding.
Your first one was PAFF so forget it. This second one appears to have no IDRs or recovery points, which confuses the heck out DGAVCDecode. I'm investigating further because libavcodec does spit out a good first frame, so DGAVCDecode ought to be able to as well.

EDIT: The second one does have recovery points. Should be decodable...stand by.

Last edited by Guest; 13th March 2007 at 03:34.
Guest is offline  
Old 13th March 2007, 18:03   #169  |  Link
ilhyfe
Registered User
 
Join Date: Sep 2005
Posts: 50
Quote:
Originally Posted by neuron2 View Post
Please provide the stream if you want support. Thank you.
Hi,

I recorded a new stream (10 MB) for you, but now I get "Field pictures not supported". Since I don't know how to cut my old streams (a ~6GB), I can't send you a sample yet.
ilhyfe is offline  
Old 15th March 2007, 10:42   #170  |  Link
thany
Registered User
 
Join Date: Mar 2006
Posts: 4
I can't get it to work

DGAVCIndex works just fine, as it generates a dga file. Then I create an avisynth script like this:
Code:
loadplugin("DGAVCDecode.dll")
AVCSource("tloeg.dga")
But when I open it in Vdub, it says
Code:
Avisynth open failure
AVCSource: Could not open one of the input files.
F:\Download\tloeg.avs
The first chunk of the dga file looks like so:
Code:
DGAVCIndexFile2

F:\Download\tloeg.avc

SPS 6 
PPS 96 
IDR 157 
FRM 7 0
PPS 1488 
FRM 5 3
PPS 1662 
FRM 6 1
PPS 2144 
FRM 6 2
PPS 2629 
FRM 5 6
PPS 2806 
FRM 6 4
PPS 3291 
FRM 6 5
PPS 3772 
FRM 5 9
PPS 3946 
FRM 6 7
PPS 4427 
FRM 6 8
PPS 4911 
FRM 5 12
PPS 5088 
FRM 6 10
PPS 5572 
FRM 6 11
PPS 6053 
FRM 5 15
PPS 6227 
FRM 6 13
PPS 6708 
FRM 6 14
PPS 7192 
FRM 5 18
PPS 7369 
FRM 6 16
PPS 7851 
FRM 6 17
PPS 8330 
FRM 5 21
PPS 8504 
FRM 6 19
PPS 8983 
FRM 6 20
SPS 9465 
PPS 9555 
FRM 7 24
PPS 10942 
FRM 6 22
PPS 11424 
FRM 6 23
PPS 11903 
FRM 5 27
PPS 12077 
FRM 6 25
PPS 12559 
FRM 6 26
PPS 13044 
FRM 5 30
PPS 13221 
FRM 6 28
PPS 13706 
FRM 6 29
PPS 14188 
FRM 5 1
PPS 14362 
FRM 6 31
PPS 14843 
FRM 6 0
PPS 15327 
FRM 5 4
PPS 15504 
FRM 6 2
PPS 15988 
FRM 6 3
SPS 16469 
PPS 16559 
FRM 7 7
PPS 17945 
FRM 6 5
PPS 18426 
FRM 6 6
PPS 18910 
FRM 5 10
PPS 19087 
FRM 6 8
PPS 19572 
FRM 6 9
PPS 20054 
FRM 5 13
PPS 20228 
FRM 6 11
PPS 20710 
FRM 6 12
PPS 21195 
FRM 5 16
PPS 22219 
FRM 6 14
PPS 22704 
FRM 6 15
PPS 23189 
FRM 5 19
PPS 102847 
FRM 6 17
PPS 111355 
FRM 6 18
SPS 141724 
PPS 141814 
IDR 141874 
FRM 7 0
PPS 286164 
FRM 5 3
PPS 381650 
FRM 6 1
PPS 436848 
FRM 6 2
PPS 488249 
FRM 5 6
PPS 584625 
FRM 6 4
PPS 632564 
FRM 6 5
PPS 684384 
FRM 5 9
PPS 796977 
FRM 6 7
PPS 857664 
FRM 6 8
PPS 904314 
FRM 5 12
PPS 983756 
FRM 6 10
PPS 1026181 
FRM 6 11
PPS 1064744 
FRM 5 15
PPS 1139978 
FRM 6 13
PPS 1181892 
FRM 6 14
PPS 1221000 
FRM 5 18
PPS 1296883 
FRM 6 16
PPS 1339205 
FRM 6 17
PPS 1383369 
FRM 5 21
PPS 1481305 
FRM 6 19
PPS 1534642 
FRM 6 20
SPS 1587835 
PPS 1587925 
FRM 7 24
PPS 1771298 
FRM 6 22
PPS 1830881 
FRM 6 23
PPS 1903379 
FRM 5 27
PPS 2046878 
FRM 6 25
PPS 2122813 
FRM 6 26
PPS 2183204 
FRM 5 30
PPS 2294158 
FRM 6 28
PPS 2366403 
FRM 6 29
PPS 2427841 
FRM 5 1
PPS 2514537 
FRM 6 31
PPS 2564817 
FRM 6 0
PPS 2614611 
FRM 5 4
PPS 2680869 
FRM 6 2
PPS 2723513 
FRM 6 3
PPS 2761543 
FRM 5 7
PPS 2824438 
FRM 6 5
PPS 2864656
And it keeps going like that. Did something go wrong?
thany is offline  
Old 15th March 2007, 11:12   #171  |  Link
ilhyfe
Registered User
 
Join Date: Sep 2005
Posts: 50
Quote:
Originally Posted by thany View Post
I can't get it to work

DGAVCIndex works just fine, as it generates a dga file. Then I create an avisynth script like this:
Code:
loadplugin("DGAVCDecode.dll")
AVCSource("tloeg.dga")
But when I open it in Vdub, it says
Code:
Avisynth open failure
AVCSource: Could not open one of the input files.
F:\Download\tloeg.avs
The first chunk of the dga file looks like so:
And it keeps going like that. Did something go wrong?
Some problem here...
ilhyfe is offline  
Old 15th March 2007, 13:51   #172  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
I need a stream to help you. I am getting tired of saying it.

Last edited by Guest; 15th March 2007 at 14:00.
Guest is offline  
Old 15th March 2007, 14:36   #173  |  Link
thany
Registered User
 
Join Date: Mar 2006
Posts: 4
Alright alright, here you go.

Unfortunately, the whole stream is a little too much (like, 13GB), so I'm only publishing the first 1MB. Hope that's enough.
thany is offline  
Old 15th March 2007, 16:38   #174  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Rename it to "tloeg.264"

I'll fix that in the next release.
Guest is offline  
Old 15th March 2007, 20:28   #175  |  Link
thany
Registered User
 
Join Date: Mar 2006
Posts: 4
Works like a charm, thanks
thany is offline  
Old 16th March 2007, 16:42   #176  |  Link
Eastermeyer
Happy Easter!
 
Eastermeyer's Avatar
 
Join Date: Aug 2005
Posts: 73
Just tried to use DGAVCIndex. But the Indexing-Tool isn't doing anything , even after an hour.

I am using WinXPH SP2 and a raw h264-File created with Haali Splitter / Dump Filter (Graphedit).

Here is a 15MB Sample cutted with a binary splitter from the beginning auf the h264-file :

http://files.to/get/395915/41023/cut.h264
__________________
Sorry for my terrible English!
I am from Germany.
Eastermeyer is offline  
Old 16th March 2007, 17:52   #177  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
Quote:
Originally Posted by Eastermeyer View Post
Just tried to use DGAVCIndex. But the Indexing-Tool isn't doing anything , even after an hour.

I am using WinXPH SP2 and a raw h264-File created with Haali Splitter / Dump Filter (Graphedit).

Here is a 15MB Sample cutted with a binary splitter from the beginning auf the h264-file :

http://files.to/get/395915/41023/cut.h264
It doesn't look like an ES and VLC crashes when trying to play it. Also, Elecard XMuxer doesn't like it. So it's not a valid ES.

What is the original container format?
Guest is offline  
Old 16th March 2007, 18:07   #178  |  Link
Eastermeyer
Happy Easter!
 
Eastermeyer's Avatar
 
Join Date: Aug 2005
Posts: 73
TransportStream.

Oh I am very sorry , it seems to be Haali Splitter's fault. It seems to work with a File demuxxed by Intervideo Filter. But it's PAFF , so unsupported.
__________________
Sorry for my terrible English!
I am from Germany.

Last edited by Eastermeyer; 16th March 2007 at 18:26.
Eastermeyer is offline  
Old 16th March 2007, 18:52   #179  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,922
I'm beginning to get disillusioned with libavcodec. I keep running into crashes and obscure bugs. I am unable to debug/trace the code due to the inability to build it in my windows development environment. And of course the lack of PAFF is very irritating. So I am considering starting again with the JM reference software, which I can actually build and debug in my environment. It should be possible to optimize it to an acceptable level (borrowing from libavcodec source for key things like transforms, etc.). Then we would have proper open source for a full featured decoder that is usable in standard windows development environments, as opposed to kludgy pseudo-unix environments.

Any thoughts?
Guest is offline  
Old 16th March 2007, 18:58   #180  |  Link
Adub
Fighting spam with a fish
 
Adub's Avatar
 
Join Date: Sep 2005
Posts: 2,687
I have to admit, that is a good idea. But you have to consider, would it be easier to start from scratch, or to just go through the old code of libavcodec and make bug fixes and so on. Personally I don't know enough code to make a judgement on this, but if you feel up to it neuron2, more power to you.

In short, I vote for the whole overall and start from scratch idea.
__________________
FAQs:Bond's AVC/H.264 FAQ
Site:Adubvideo
Adub is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.