Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th June 2009, 13:01   #8981  |  Link
odin24
Registered User
 
odin24's Avatar
 
Join Date: Mar 2008
Location: The Great North (the better half of North America)
Posts: 301
Quote:
Originally Posted by setarip_old View Post
There are two observable differences:

1) A total 13 second time difference

2) Different sequence of the audio tracks

What is the title of your BluRay disc?
The time difference is playlist 1 has "Columbia Pictures" intro, and 2) has "Sony Pictures Classics".

Also, one other thing I didn't notice last night in tsMuxeR... 00011.m2ts has a slightly different order to the tracks as the rest of the m2ts files in 1). Same goes for 2).

The movie in question is CJ7... I just wasn't sure I was allowed to post titles.

Quote:
Originally Posted by mrr19121970
@odin24

why have you blanked out your name in 3 out of 4 C:\Users\XXXXX> ?

and yes, I saw it yesterday. With the 'March of the Pengiuns' German version, Kinowelt have added a 13 second trailer to the start of the film. There were 3 playlists all with 00026.mts (from memory). The chapter points are different.

1) 1:22:26 mins long one with the trailer.
2) can't remember
3) 1:22:15 mins long - was clearly the original film without the trailer

However on demuxing either 1) or 3) I always got the longest version.

I can update the post later with the logs.
LOL... i posted my initial concern just before bed, I was pretty tired... now that you all know my true identity... I must kill you!!!... Just kidding.

I'm pretty sure I know why, the first m2ts in each playlist is different from the rest of the m2ts' in rest of the movie. I'm pretty sure manually demuxing the rest, excluding the first m2ts will work... I just haven't tried yet.

Quote:
Originally Posted by BZeeme
I get the same results as you using eac3to on CJ7. I'm trying to back it up using BD Rebuilder (movie only). The movie only result would play with PowerDvD but not my Sony standalone (audio, subtitles, but no video).
I am working with CJ7 too. I think the only way to get this going properly is to manually demux, excluding the first m2ts file. Then remux with tsMuxeR, then feed that structure into BD-rebuilder.

Thanks for the responses people.
odin24 is offline   Reply With Quote
Old 16th June 2009, 23:27   #8982  |  Link
rapscallion
NY Frame of Mind
 
rapscallion's Avatar
 
Join Date: Dec 2005
Location: L.I.,NY
Posts: 586
DTS Encoding

I've searched through this thread and found conflicting opinions re Surcode as a DTS Encoder.
For example, the 2 below....

One poster states :
Quote:
"Also I wouldnt use Surcodode DTS Encoder. Its a low quality and outdated encoder. And you cant encode dts es 6.1 with Surcode"
While another states :
Quote:
A dts file created from surcode will most definitely sound better than a core ac3 file if the source is the same. Such as a lossless audio track, like true hd. Remember, there is no magic way the studios have to encode an ac3 file. The same could be said of dts. Surcode outputs the same dts file as a studio would(if not very, very, close)
Which of these opinions have most of you found to be the most accurate ?

My goal is to convert/recode a 1536 dts file to a 768 bitrate. I've been using eacto_more gui , Sonic to decode and Surcode to encode, so am curious if this is the best way or is their another simpler one I should be using ? Thanks

Last edited by rapscallion; 16th June 2009 at 23:35.
rapscallion is offline   Reply With Quote
Old 17th June 2009, 00:49   #8983  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,615
Quote:
Originally Posted by rapscallion View Post
My goal is to convert/recode a 1536 dts file to a 768 bitrate.
For what?
http://www.ebu.ch/CMSimages/en/tec_d...tcm6-53801.pdf
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Old 17th June 2009, 05:42   #8984  |  Link
73ChargerFan
Registered User
 
73ChargerFan's Avatar
 
Join Date: Dec 2006
Posts: 517
Quote:
Originally Posted by rapscallion View Post
My goal is to convert/recode a 1536 dts file to a 768 bitrate.
I'd listen to a 640 AC3 soundtrack, and compare it to a 768dts. I'd think they'd be about the same, and the 640 would probably be better (done by the dvd mixing company).
73ChargerFan is offline   Reply With Quote
Old 17th June 2009, 06:36   #8985  |  Link
qyot27
...?
 
qyot27's Avatar
 
Join Date: Nov 2005
Location: Florida
Posts: 1,062
I was looking to decode the MP3 Surround files from the diatonis web site (http://www.diatonis.com/downloads.html), but I don't know if the process I'm using is correct concerning the channel ordering.

Only the Fraunhofer decoder package can decode MP3 Surround files to actual 5.1-channel PCM Waves, but while the output files have WAVE_FORMAT_EXTENSIBLE headers, the channels aren't defined. Running these Waves through eac3to produces files with the channels defined, but I have no idea if the Fraunhofer decoder reorders the channels or not (I would assume it does, though, if that's needed; however, I'd rather ask and be certain than just assume things).
qyot27 is offline   Reply With Quote
Old 17th June 2009, 09:26   #8986  |  Link
Kuningas
Registered User
 
Join Date: Nov 2004
Location: Russia
Posts: 11
OS - Windows 7.
eac3to doesn't see Nero Audio Decoder (Nero 6 or older). But I have Nero 7.11.10.0 and the Blu-ray/HD-DVD plug-in registered.
It works fine on Vista.

Is there any decision for Windows 7?
__________________
In vino veritas
Kuningas is offline   Reply With Quote
Old 17th June 2009, 14:05   #8987  |  Link
darthcloud
Registered User
 
Join Date: Jun 2007
Posts: 5
Quote:
Originally Posted by Kuningas View Post
OS - Windows 7.
eac3to doesn't see Nero Audio Decoder (Nero 6 or older). But I have Nero 7.11.10.0 and the Blu-ray/HD-DVD plug-in registered.
It works fine on Vista.

Is there any decision for Windows 7?
I'm running Windows 7 x64 RC1 and everything work fine, nero BD/HDDVD plugin, arcsoft, nero aac, surcode...
darthcloud is offline   Reply With Quote
Old 17th June 2009, 15:01   #8988  |  Link
Kuningas
Registered User
 
Join Date: Nov 2004
Location: Russia
Posts: 11
darthcloud

I'm running Windows 7 x64 RC1 and everything work fine, nero BD/HDDVD plugin, arcsoft, nero aac, surcode...

What's you version of Nero?
__________________
In vino veritas
Kuningas is offline   Reply With Quote
Old 17th June 2009, 19:04   #8989  |  Link
ggking7
Registered User
 
Join Date: Sep 2006
Posts: 249
Sure was cool when the latest version of eac3to worked via wine.
ggking7 is offline   Reply With Quote
Old 17th June 2009, 22:57   #8990  |  Link
10L23r
Registered User
 
Join Date: Apr 2009
Posts: 122
what's the equivalent of besweet's pregain in eac3to? i couldn't find such an option...
10L23r is offline   Reply With Quote
Old 18th June 2009, 00:44   #8991  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,615
You can use:
-normalize
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Old 18th June 2009, 01:37   #8992  |  Link
Steel
Registered User
 
Steel's Avatar
 
Join Date: Mar 2003
Posts: 127
Are there any known problems when demuxing a 7.1 source track such as a DTS-MA 7.1 into wav files with EAC3TO?
Steel is offline   Reply With Quote
Old 18th June 2009, 01:52   #8993  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,615
Quote:
Originally Posted by qyot27 View Post
I was looking to decode the MP3 Surround files from the diatonis web site (http://www.diatonis.com/downloads.html), but I don't know if the process I'm using is correct concerning the channel ordering.

Only the Fraunhofer decoder package can decode MP3 Surround files to actual 5.1-channel PCM Waves, but while the output files have WAVE_FORMAT_EXTENSIBLE headers, the channels aren't defined. Running these Waves through eac3to produces files with the channels defined, but I have no idea if the Fraunhofer decoder reorders the channels or not (I would assume it does, though, if that's needed; however, I'd rather ask and be certain than just assume things).
The wav output from the command line mp3sDecoder.exe have the WAVE_FORMAT_EXTENSIBLE header, but the MaskChannel field have a value of '0' and can be rejected by some audio soft.

I make a test with mp3sEncoder -> mp3sDecoder and the channel order is correct then you can use eac3to to obtain a wav with a correct MaskChannel value:
MaskChannels : 1551 (FL FR FC LF SL SR)

Other correct value for MaskChannel is:
MaskChannels : 63 (FL FR FC LF BL BR)
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Old 18th June 2009, 02:10   #8994  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,615
Quote:
Originally Posted by Steel View Post
Are there any known problems when demuxing a 7.1 source track such as a DTS-MA 7.1 into wav files with EAC3TO?
You need use ArcSoft decoder.

This:
"Using eac3to with ArcSoft decoder there are a problem, the Side and Back channels are interchanged"

Was solved with a more recent version of dtsdecoderdll.dll
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Old 18th June 2009, 07:36   #8995  |  Link
qyot27
...?
 
qyot27's Avatar
 
Join Date: Nov 2005
Location: Florida
Posts: 1,062
Quote:
Originally Posted by tebasuna51 View Post
The wav output from the command line mp3sDecoder.exe have the WAVE_FORMAT_EXTENSIBLE header, but the MaskChannel field have a value of '0' and can be rejected by some audio soft.

I make a test with mp3sEncoder -> mp3sDecoder and the channel order is correct then you can use eac3to to obtain a wav with a correct MaskChannel value:
MaskChannels : 1551 (FL FR FC LF SL SR)

Other correct value for MaskChannel is:
MaskChannels : 63 (FL FR FC LF BL BR)
Thanks. So the difference between the two is basically the difference between Dolby 5.1 and DTS 5.1 configurations?
qyot27 is offline   Reply With Quote
Old 18th June 2009, 09:05   #8996  |  Link
xkodi
Registered User
 
Join Date: Aug 2002
Posts: 221
Quote:
Originally Posted by tebasuna51 View Post
You need use ArcSoft decoder.

This:
"Using eac3to with ArcSoft decoder there are a problem, the Side and Back channels are interchanged"

Was solved with a more recent version of dtsdecoderdll.dll
TMT 3 has version 1.1.0.1 of "dtsdecoderdll.dll"
TMT 3.5 has version 1.1.0.10 of "dtsdecoderdll.dll"

have you tried this new versions?

the latest 1.1.0.10 doesn't work with eac3to though. anyway, it's interesting if they fixed the problem with DTS-HD MA tracks reported by eac3to as "7.1 (strange setup)". as you know such tracks are not bit-perfect decoded by old 1.1.0.0 versions of "dtsdecoderdll.dll"
xkodi is offline   Reply With Quote
Old 18th June 2009, 10:38   #8997  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,615
Quote:
Originally Posted by qyot27 View Post
Thanks. So the difference between the two is basically the difference between Dolby 5.1 and DTS 5.1 configurations?
What?
Don't exist difference between Dolby 5.1 and DTS 5.1 or any 5.1 config, is always 3 front channels, 2 surround channels and LFE.
The Surround channels must be at +-120 from Central channel (more or less)

With 7.1 config the order in wav files is: FL FR FC LF BL BR SL SR
and mean:
BL BR = Back Channels at 150 (more or less)
SL SR = Side Channels at 90 (more or less)

Like you can see don't exist (in wav specs) a exact correspondence with Surround channels in 5.1 (120)
Before XP SP2 the FL FR FC LF BL BR maskchannels was used for 5.1, after the FL FR FC LF SL SR was recommended but the previous one is also accepted.
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Old 18th June 2009, 11:02   #8998  |  Link
tebasuna51
Moderator
 
tebasuna51's Avatar
 
Join Date: Feb 2005
Location: Spain
Posts: 5,615
Quote:
Originally Posted by xkodi View Post
TMT 3 has version 1.1.0.1 of "dtsdecoderdll.dll"
TMT 3.5 has version 1.1.0.10 of "dtsdecoderdll.dll"

have you tried this new versions?
Nope, I'm not very interested in 7.1 DTS-MA, I only have 5.1 systems and the 'core' DTS (or AC3) is enough for my old ears.

Sorry.
__________________
BeHappy, AviSynth audio transcoder, in Doom9 forums. NicAudio, BassAudio, audio decoders.
tebasuna51 is offline   Reply With Quote
Old 18th June 2009, 12:24   #8999  |  Link
rickardk
Registered User
 
Join Date: Jul 2007
Posts: 259
Quote:
Originally Posted by xkodi View Post
TMT 3 has version 1.1.0.1 of "dtsdecoderdll.dll"
TMT 3.5 has version 1.1.0.10 of "dtsdecoderdll.dll"

have you tried this new versions?

the latest 1.1.0.10 doesn't work with eac3to though. anyway, it's interesting if they fixed the problem with DTS-HD MA tracks reported by eac3to as "7.1 (strange setup)". as you know such tracks are not bit-perfect decoded by old 1.1.0.0 versions of "dtsdecoderdll.dll"
Maybe the new version can decode titles like Black Hawk Down DTS-HD MA 7.1 without the static noise that is introduced when decoded now.
rickardk is offline   Reply With Quote
Old 18th June 2009, 12:27   #9000  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,171
for me the 5.1 LPCM track of the US disc sounds better anyway, maybe its just a crappy made 7.1 track
Thunderbolt8 is offline   Reply With Quote
Reply

Tags
eac3to

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:59.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.