Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 10th August 2010, 03:18   #41  |  Link
roozhou
Registered User
 
Join Date: Apr 2008
Posts: 1,181
New build 24750 available.
1) Fixed a bug in bitstream parser. Now streams with seq_scaling_matrix are supported.
2) Added new option to h264_changesps: remove aud
roozhou is offline   Reply With Quote
Old 10th August 2010, 13:57   #42  |  Link
0028606
Registered User
 
Join Date: Jan 2009
Posts: 28
I have been trying to compile this on Mac OS X 10.6 for the last coulpe of hours but it keeps give errors. If someone could please explain the process as I'm at a loss I would be very grateful
__________________
Check Out All My Tutorials
Code:
http://instantitunes.wordpress.com/
0028606 is offline   Reply With Quote
Old 10th August 2010, 14:11   #43  |  Link
roozhou
Registered User
 
Join Date: Apr 2008
Posts: 1,181
What error did you get?
Plz apply my latest patch before you start.
roozhou is offline   Reply With Quote
Old 10th August 2010, 14:19   #44  |  Link
0028606
Registered User
 
Join Date: Jan 2009
Posts: 28
Yes I have applied patch with -
Cd ffmpeg
Patch p1 < ffmpeg_svn_r24573.patch

is this the correct way to do it?

When apply the patch I get FAIL for imx_dump_header_bsf.c
Code:
ffmpeg john$ patch -p1 < ffmpeg_svn_r24573.patch
missing header for unified diff at line 5 of patch
(Stripping trailing CRs from patch.)
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: ffmpeg.c
|===================================================================
|--- ffmpeg.c	(revision 24573)
|+++ ffmpeg.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/ffmpeg.c 
patching file /Developer/ffmpeg/ffmpeg.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 155
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/aac_adtstoasc_bsf.c
|===================================================================
|--- libavcodec/aac_adtstoasc_bsf.c	(revision 24573)
|+++ libavcodec/aac_adtstoasc_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/aac_adtstoasc_bsf.c 
patching file /Developer/ffmpeg/libavcodec/aac_adtstoasc_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 177
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/allcodecs.c
|===================================================================
|--- libavcodec/allcodecs.c	(revision 24573)
|+++ libavcodec/allcodecs.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/allcodecs.c 
patching file /Developer/ffmpeg/libavcodec/allcodecs.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 206
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/avcodec.h
|===================================================================
|--- libavcodec/avcodec.h	(revision 24573)
|+++ libavcodec/avcodec.h	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/avcodec.h 
patching file /Developer/ffmpeg/libavcodec/avcodec.h
Hunk #8 succeeded at 3903 (offset -1 lines).
(Stripping trailing CRs from patch.)
can't find file to patch at input line 285
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/bitstream_filter.c
|===================================================================
|--- libavcodec/bitstream_filter.c	(revision 24573)
|+++ libavcodec/bitstream_filter.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/bitstream_filter.c 
patching file /Developer/ffmpeg/libavcodec/bitstream_filter.c
(Stripping trailing CRs from patch.)
patching file h264_changesps_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 890
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/h264_mp4toannexb_bsf.c
|===================================================================
|--- libavcodec/h264_mp4toannexb_bsf.c	(revision 24573)
|+++ libavcodec/h264_mp4toannexb_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/h264_mp4toannexb_bsf.c 
patching file /Developer/ffmpeg/libavcodec/h264_mp4toannexb_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 986
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/h264_ps.c
|===================================================================
|--- libavcodec/h264_ps.c	(revision 24573)
|+++ libavcodec/h264_ps.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/h264_ps.c 
patching file /Developer/ffmpeg/libavcodec/h264_ps.c
Hunk #1 succeeded at 37 (offset 1 line).
(Stripping trailing CRs from patch.)
can't find file to patch at input line 999
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/imx_dump_header_bsf.c
|===================================================================
|--- libavcodec/imx_dump_header_bsf.c	(revision 24573)
|+++ libavcodec/imx_dump_header_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/imx_dump_header_bsf.c 
patching file /Developer/ffmpeg/libavcodec/imx_dump_header_bsf.c
(Stripping trailing CRs from patch.)
patching file Makefile
Hunk #1 FAILED at 285.
Hunk #2 FAILED at 595.
2 out of 2 hunks FAILED -- saving rejects to file Makefile.rej
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1032
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/mjpega_dump_header_bsf.c
|===================================================================
|--- libavcodec/mjpega_dump_header_bsf.c	(revision 24573)
|+++ libavcodec/mjpega_dump_header_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/mjpega_dump_header_bsf.c 
patching file /Developer/ffmpeg/libavcodec/mjpega_dump_header_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1045
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/mp3_header_compress_bsf.c
|===================================================================
|--- libavcodec/mp3_header_compress_bsf.c	(revision 24573)
|+++ libavcodec/mp3_header_compress_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/mp3_header_compress_bsf.c 
patching file /Developer/ffmpeg/libavcodec/mp3_header_compress_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1058
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/mp3_header_decompress_bsf.c
|===================================================================
|--- libavcodec/mp3_header_decompress_bsf.c	(revision 24573)
|+++ libavcodec/mp3_header_decompress_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/mp3_header_decompress_bsf.c 
patching file /Developer/ffmpeg/libavcodec/mp3_header_decompress_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1071
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/noise_bsf.c
|===================================================================
|--- libavcodec/noise_bsf.c	(revision 24573)
|+++ libavcodec/noise_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/noise_bsf.c 
patching file /Developer/ffmpeg/libavcodec/noise_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1084
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/options.c
|===================================================================
|--- libavcodec/options.c	(revision 24573)
|+++ libavcodec/options.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/options.c 
patching file /Developer/ffmpeg/libavcodec/options.c
(Stripping trailing CRs from patch.)
patching file r10kdec.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1254
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/r210dec.c
|===================================================================
|--- libavcodec/r210dec.c	(revision 24573)
|+++ libavcodec/r210dec.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/r210dec.c 
patching file /Developer/ffmpeg/libavcodec/r210dec.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1298
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavcodec/remove_extradata_bsf.c
|===================================================================
|--- libavcodec/remove_extradata_bsf.c	(revision 24573)
|+++ libavcodec/remove_extradata_bsf.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavcodec/remove_extradata_bsf.c 
patching file /Developer/ffmpeg/libavcodec/remove_extradata_bsf.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1314
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/assenc.c
|===================================================================
|--- libavformat/assenc.c	(revision 24573)
|+++ libavformat/assenc.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/assenc.c 
patching file /Developer/ffmpeg/libavformat/assenc.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1330
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/avienc.c
|===================================================================
|--- libavformat/avienc.c	(revision 24573)
|+++ libavformat/avienc.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/avienc.c 
patching file /Developer/ffmpeg/libavformat/avienc.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1534
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/flvenc.c
|===================================================================
|--- libavformat/flvenc.c	(revision 24573)
|+++ libavformat/flvenc.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/flvenc.c 
patching file /Developer/ffmpeg/libavformat/flvenc.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1577
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/isom.c
|===================================================================
|--- libavformat/isom.c	(revision 24573)
|+++ libavformat/isom.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/isom.c 
patching file /Developer/ffmpeg/libavformat/isom.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1589
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/matroskadec.c
|===================================================================
|--- libavformat/matroskadec.c	(revision 24573)
|+++ libavformat/matroskadec.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/matroskadec.c 
patching file /Developer/ffmpeg/libavformat/matroskadec.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1666
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/matroskaenc.c
|===================================================================
|--- libavformat/matroskaenc.c	(revision 24573)
|+++ libavformat/matroskaenc.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/matroskaenc.c 
patching file /Developer/ffmpeg/libavformat/matroskaenc.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1715
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/mov.c
|===================================================================
|--- libavformat/mov.c	(revision 24573)
|+++ libavformat/mov.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/mov.c 
patching file /Developer/ffmpeg/libavformat/mov.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1736
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/movenc.c
|===================================================================
|--- libavformat/movenc.c	(revision 24573)
|+++ libavformat/movenc.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/movenc.c 
patching file /Developer/ffmpeg/libavformat/movenc.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1782
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/raw.c
|===================================================================
|--- libavformat/raw.c	(revision 24573)
|+++ libavformat/raw.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/raw.c 
patching file /Developer/ffmpeg/libavformat/raw.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1849
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/riff.c
|===================================================================
|--- libavformat/riff.c	(revision 24573)
|+++ libavformat/riff.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/riff.c 
patching file /Developer/ffmpeg/libavformat/riff.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1894
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/rmdec.c
|===================================================================
|--- libavformat/rmdec.c	(revision 24573)
|+++ libavformat/rmdec.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/rmdec.c 
patching file /Developer/ffmpeg/libavformat/rmdec.c
(Stripping trailing CRs from patch.)
can't find file to patch at input line 1906
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: libavformat/utils.c
|===================================================================
|--- libavformat/utils.c	(revision 24573)
|+++ libavformat/utils.c	(working copy)
--------------------------
File to patch: /Developer/ffmpeg/libavformat/utils.c 
patching file /Developer/ffmpeg/libavformat/utils.c

This is the Error I can't get past
Code:
CC	libavcore/utils.o
LD	libavcore/libavcore.0.dylib
ld: warning: -read_only_relocs cannot be used with x86_64
LD	libavcodec/libavcodec.52.dylib
ld: warning: -read_only_relocs cannot be used with x86_64
Undefined symbols:
  "_r10k_decoder", referenced from:
      _avcodec_register_all in allcodecs.o
  "_h264_changesps_bsf", referenced from:
      _avcodec_register_all in allcodecs.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [libavcodec/libavcodec.52.dylib] Error 1
__________________
Check Out All My Tutorials
Code:
http://instantitunes.wordpress.com/

Last edited by 0028606; 10th August 2010 at 14:32.
0028606 is offline   Reply With Quote
Old 10th August 2010, 14:36   #45  |  Link
J_Darnley
Registered User
 
J_Darnley's Avatar
 
Join Date: May 2006
Posts: 959
Quote:
Originally Posted by 0028606 View Post
Yes I have applied patch with -
Cd ffmpeg
Patch p1 < ffmpeg_svn_r24573.patch

is this the correct way to do it?
No, you don't need to strip any levels from the paths (-p0)
__________________
x264 log explained || x264 deblocking how-to
preset -> tune -> user set options -> fast first pass -> profile -> level
Doom10 - Of course it's better, it's one more.
J_Darnley is offline   Reply With Quote
Old 10th August 2010, 14:37   #46  |  Link
roozhou
Registered User
 
Join Date: Apr 2008
Posts: 1,181
I have uploaded the new patch (ffmpeg_svn_r24750.patch). Update to svn 24750 and apply the patch.

P.S. why did you use "p1"?
roozhou is offline   Reply With Quote
Old 10th August 2010, 14:46   #47  |  Link
0028606
Registered User
 
Join Date: Jan 2009
Posts: 28
Quote:
Originally Posted by roozhou View Post
I have uploaded the new patch (ffmpeg_svn_r24750.patch). Update to svn 24750 and apply the patch.
I do not see 24750 on the svn linked

Quote:
P.S. why did you use "p1"?
The answer to that one is short,

No idea why....



EDIT.....

I see it on the SVN now thank you
__________________
Check Out All My Tutorials
Code:
http://instantitunes.wordpress.com/

Last edited by 0028606; 10th August 2010 at 14:58.
0028606 is offline   Reply With Quote
Old 10th August 2010, 19:24   #48  |  Link
b66pak
Registered User
 
b66pak's Avatar
 
Join Date: Aug 2008
Location: The Land Of Dracula (Romania - EU)
Posts: 934
@roozhou thanks a lot...
_
__________________
if you ask a question and somebody give you the correct answer don't forget to leave a "thank you" note...
Visit The Land Of Dracula (Romania - EU)!
b66pak is offline   Reply With Quote
Old 15th August 2010, 23:03   #49  |  Link
J_Darnley
Registered User
 
J_Darnley's Avatar
 
Join Date: May 2006
Posts: 959
Hey all, I wanted to use this tool today so I decided to build it. It wouldn't apply on top of my other patches, and it wouldn't build on a clean source. So I decided to cut out the functional bits. You can get them here: http://users.telenet.be/darnley/ffmpeg/

These are from git format-patch and the ones from this thread start at 3. Not all the code is there yet
__________________
x264 log explained || x264 deblocking how-to
preset -> tune -> user set options -> fast first pass -> profile -> level
Doom10 - Of course it's better, it's one more.

Last edited by J_Darnley; 16th August 2010 at 00:07.
J_Darnley is offline   Reply With Quote
Old 16th August 2010, 08:07   #50  |  Link
roozhou
Registered User
 
Join Date: Apr 2008
Posts: 1,181
@J_Darnley
The first version of ffmpeg_svn_r24750.patch contains debug code in h264_changesps_bsf.c. It will dump extra data to files before and after modification. Please check out the latest version from svn or just remove two fopen-fwrite-fclose sections in h264_changesps_filter function.
roozhou is offline   Reply With Quote
Old 14th September 2010, 18:25   #51  |  Link
iwod
Registered User
 
Join Date: Apr 2002
Posts: 753
I just refer to my post here http://forum.doom9.org/showthread.ph...94#post1442894

I know it may not be your tools problem. ( More likely itunes problem ), but any guess as to why only one of the file could be transferred to iPhone while others can not.

It is very frustrating.

P.S - You ffmpeg build is simply AWESOME!!!
iwod is offline   Reply With Quote
Old 14th September 2010, 18:56   #52  |  Link
b66pak
Registered User
 
b66pak's Avatar
 
Join Date: Aug 2008
Location: The Land Of Dracula (Romania - EU)
Posts: 934
run this line on the source file that after conversion don't work on iPhone:

Code:
ffmpeg -i my_file.mkv
and post the output log here...
_
__________________
if you ask a question and somebody give you the correct answer don't forget to leave a "thank you" note...
Visit The Land Of Dracula (Romania - EU)!
b66pak is offline   Reply With Quote
Old 14th September 2010, 19:35   #53  |  Link
iwod
Registered User
 
Join Date: Apr 2002
Posts: 753
Well i manage to use MKVmerge to extract the Raw Stream and Audio, and then use MP4box to mux it back.

And it works perfectly fine using this method, with all my files.

So here is the log

Quote:
FFmpeg version SVN-r24750, Copyright (c) 2000-2010 the FFmpeg developers
built on Aug 10 2010 00:58:46 with gcc 4.4.4
configuration:
libavutil 50.23. 0 / 50.23. 0
libavcore 0. 3. 0 / 0. 3. 0
libavcodec 52.84. 3 / 52.84. 3
libavformat 52.78. 1 / 52.78. 1
libavdevice 52. 2. 1 / 52. 2. 1
libswscale 0.11. 0 / 0.11. 0
[matroska,webm @ 00c69c30] max_analyze_duration reached
[matroska,webm @ 00c69c30] Estimating duration from bitrate, this may be inaccur
ate

Seems stream 0 codec frame rate differs from container frame rate: 49.98 (269908
51/540000) -> 500.00 (500/1)
Input #0, matroska,webm, from 'Ch33.mkv':
Duration: 00:49:59.17, start: 0.000000, bitrate: N/A
Stream #0.0(eng): Video: h264, yuv420p, 848x480, PAR 213:212 DAR 71:40, 24.9
9 fps, 500 tbr, 1k tbn, 49.98 tbc
Stream #0.1: Audio: aac, 48000 Hz, stereo, s16
Stream #0.2(chi): Subtitle: [0][0][0][0] / 0x0000
Metadata:
title : Traditional Chinese
At least one output file must be specified
iwod is offline   Reply With Quote
Old 14th September 2010, 20:05   #54  |  Link
b66pak
Registered User
 
b66pak's Avatar
 
Join Date: Aug 2008
Location: The Land Of Dracula (Romania - EU)
Posts: 934
this will do the job:

Code:
ffmpeg -y -i Ch33.mkv -vbsf h264_changesps=fps=25000:1000 -vcodec copy -acodec copy -sn Ch33.mp4
_
__________________
if you ask a question and somebody give you the correct answer don't forget to leave a "thank you" note...
Visit The Land Of Dracula (Romania - EU)!
b66pak is offline   Reply With Quote
Old 8th October 2010, 19:28   #55  |  Link
kla960
Registered User
 
Join Date: Sep 2010
Posts: 1
I have h.264 videos with mp3 audio as vfr in an avi container. But I need it as h.264 video with ac3 audio as cfr in a mkv or ts container.

Is it possible to add the ac3 codec to the patched ffmpeg version???
kla960 is offline   Reply With Quote
Old 8th October 2010, 21:13   #56  |  Link
J_Darnley
Registered User
 
J_Darnley's Avatar
 
Join Date: May 2006
Posts: 959
Yes, if you apply the patches (my patches at least) then compile as normal you can use any features of ffmpeg that would normally be present.
__________________
x264 log explained || x264 deblocking how-to
preset -> tune -> user set options -> fast first pass -> profile -> level
Doom10 - Of course it's better, it's one more.
J_Darnley is offline   Reply With Quote
Old 19th December 2010, 13:06   #57  |  Link
0028606
Registered User
 
Join Date: Jan 2009
Posts: 28
can some please provide some advice i'm trying to build this on mac os x 10.6 with ffmpeg 0.6 source

I applied j_darnley patch

I keep getting this error -
Code:
CC	libavcodec/h261.o
CC	libavcodec/h261_parser.o
CC	libavcodec/h261dec.o
CC	libavcodec/h261enc.o
CC	libavcodec/h263.o
CC	libavcodec/h263_parser.o
CC	libavcodec/h263dec.o
CC	libavcodec/h264.o
libavcodec/h264.c: In function ‘fill_filter_caches’:
libavcodec/h264.c:2309: warning: initialization from incompatible pointer type
libavcodec/h264.c:2386: warning: initialization from incompatible pointer type
libavcodec/h264.c:2401: warning: initialization from incompatible pointer type
libavcodec/h264.c: At top level:
libavcodec/h264.h:1256: warning: ‘decode_mb_skip’ defined but not used
CC	libavcodec/h264_cabac.o
CC	libavcodec/h264_cavlc.o
libavcodec/h264_cavlc.c: In function ‘decode_residual’:
libavcodec/h264_cavlc.c:411: warning: suggest parentheses around comparison in operand of &
make: *** No rule to make target `libavcodec/h264_changesps_bsf.o', needed by `libavcodec/libavcodec.a'.  Stop.
does anyone know where I'm going wrong
__________________
Check Out All My Tutorials
Code:
http://instantitunes.wordpress.com/
0028606 is offline   Reply With Quote
Old 20th December 2010, 15:31   #58  |  Link
roozhou
Registered User
 
Join Date: Apr 2008
Posts: 1,181
New build 25887 is available.
roozhou is offline   Reply With Quote
Old 23rd December 2010, 21:35   #59  |  Link
MGSteve
Registered User
 
Join Date: Jul 2005
Posts: 26
Quote:
Originally Posted by roozhou View Post
New build 25887 is available.
Suppose a Win32 binary is out of the question? I don't compile stuff on my PC
MGSteve is offline   Reply With Quote
Old 24th December 2010, 01:32   #60  |  Link
7ekno
Registered User
 
Join Date: Jul 2007
Posts: 389
Quote:
Originally Posted by MGSteve View Post
I don't compile stuff on my PC
Nor follow links too well ... first post, the red writing under the SVN version is a direct link to the Win32 binary from SourgeForge

Tek
7ekno is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 07:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.