Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 1st November 2009, 13:37   #10301  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by ikarad View Post
could you explain how I post bug on the tracker because I don't understand how to do? it's very difficult
Go to this page: http://sourceforge.net/apps/trac/mpc-hc/newticket

Fill in the fields as best as you can.


make sure you used the troubleshooting guidelines before posting
: http://sourceforge.net/apps/trac/mpc...ing_guidelines
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 1st November 2009, 14:10   #10302  |  Link
Polcius
Registered User
 
Join Date: Aug 2009
Posts: 102
Has anyone found a way to: Cyberlink MPEG-2 decoder when DXVA is enabled + Subtitles?

I'm really interested in that combination. Any fix/alternative to use DXVA+Subs wil help.
Polcius is offline  
Old 1st November 2009, 15:03   #10303  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by Polcius View Post
Has anyone found a way to: Cyberlink MPEG-2 decoder when DXVA is enabled + Subtitles?

I'm really interested in that combination. Any fix/alternative to use DXVA+Subs wil help.
simply enabling the built in subtitle renderer will solve your problem afaik
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 1st November 2009, 17:24   #10304  |  Link
JaDz
Registered User
 
Join Date: Jul 2009
Posts: 1
Quote:
Originally Posted by Snowknight26 View Post
MPC-HC now tries to play all H.264 content with DXVA regardless of resolution/refs and causes noticable corruption in the video and occasionally on the desktop.
Same here. Windows 7, ATI 4850.
JaDz is offline  
Old 1st November 2009, 19:41   #10305  |  Link
Polcius
Registered User
 
Join Date: Aug 2009
Posts: 102
Quote:
Originally Posted by tetsuo55 View Post
simply enabling the built in subtitle renderer will solve your problem afaik
No, it doesn't work.
Polcius is offline  
Old 1st November 2009, 20:02   #10306  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,769
You need to disable DXVA in the Cyberlink decoder or use the internal MPEG-2 decoder.
clsid is offline  
Old 1st November 2009, 20:57   #10307  |  Link
gngn
the hedgehog
 
gngn's Avatar
 
Join Date: Apr 2008
Posts: 163
Quote:
Originally Posted by Polcius View Post
No, it doesn't work.


works fine here. the usual settings for DXVA on XP: VMR9renderless as output renderer, the internal subtitles renderer on.
__________________
Athlonx2@2,9Ghz,2G DDRAM2@800Mhz,WinXPSP3 x86,GF8600GTS-256M,Nvidiadrivers 295.73
latest MPC-HC (MVS2010 SP1, GCC 4.7.1)
VMR9renderless+VMR9MixerMode+YUVMixing,VSync+AccurateVSync,all GPUflushes on

Last edited by gngn; 2nd November 2009 at 00:06.
gngn is offline  
Old 1st November 2009, 23:06   #10308  |  Link
Polcius
Registered User
 
Join Date: Aug 2009
Posts: 102
Quote:
Originally Posted by clsid View Post
You need to disable DXVA in the Cyberlink decoder or use the internal MPEG-2 decoder.

Yes but if I do that I can't use DXVA in the internal MPEG2 decoder.

gngn, I don't fully understand this graph XD
Polcius is offline  
Old 2nd November 2009, 00:07   #10309  |  Link
gngn
the hedgehog
 
gngn's Avatar
 
Join Date: Apr 2008
Posts: 163
Quote:
Originally Posted by Polcius View Post
gngn, I don't fully understand this graph XD
admittedly, "that" graph was pretty much pointless
i put up a new screenshot to show that DVD-subs + DXVA (in my case mpeg2-IDCT) works on XP. dunno about win7 thou
__________________
Athlonx2@2,9Ghz,2G DDRAM2@800Mhz,WinXPSP3 x86,GF8600GTS-256M,Nvidiadrivers 295.73
latest MPC-HC (MVS2010 SP1, GCC 4.7.1)
VMR9renderless+VMR9MixerMode+YUVMixing,VSync+AccurateVSync,all GPUflushes on
gngn is offline  
Old 2nd November 2009, 01:15   #10310  |  Link
Polcius
Registered User
 
Join Date: Aug 2009
Posts: 102
Quote:
Originally Posted by gngn View Post
admittedly, "that" graph was pretty much pointless
i put up a new screenshot to show that DVD-subs + DXVA (in my case mpeg2-IDCT) works on XP. dunno about win7 thou
But do you use any special settings in MPC-HC? (I mean, "not default")
Polcius is offline  
Old 2nd November 2009, 05:49   #10311  |  Link
GrofLuigi
Member of a Library
 
Join Date: Oct 2002
Posts: 463
What is SPCDisableAnim=1 in ini file?

GL
GrofLuigi is offline  
Old 2nd November 2009, 05:50   #10312  |  Link
namaiki
Registered User
 
Join Date: Sep 2009
Location: Sydney, Australia
Posts: 1,073
In options -> subtitles -> disable animation (is ticked).

If auto-load subtitles is checked in playback, the internal subtitle renderer is enabled and then soft subtitle animation like karaoke will stay still on the screen.
namaiki is offline  
Old 2nd November 2009, 06:30   #10313  |  Link
boyumeow
Registered User
 
boyumeow's Avatar
 
Join Date: Aug 2007
Posts: 143
MPC-HC 1326

Изменения/Changes:

* CHANGED: Allow screensaver to activate when audio only (sleep is still stopped).;


Hi, I need someone to confirm that the above status not only allow screensaver to activate when audio only but happens when video too. Thanks.
boyumeow is offline  
Old 2nd November 2009, 07:34   #10314  |  Link
Tenki
Registered User
 
Join Date: Oct 2009
Posts: 14
Two problems in this version right now.

Two problems in this version (1326) right now.

1.If I use DXVA, VobSub won't run, so I can't see any subtitles.
(this problem is since 130x, the previous version are ok.)

DXVA off:
http://img97.imageshack.us/img97/4628/nodxva.jpg
DXVA on:
http://img3.imageshack.us/img3/2817/dxva.jpg
You can see The DirectVobSub are disappear when DXVA run.


2. If I use MPC-HC to play DVD, MPC-HC can't change other subtitles when playing.
(this problem is since 130x, the previous version are ok.)

Last edited by Tenki; 2nd November 2009 at 10:29.
Tenki is offline  
Old 2nd November 2009, 07:42   #10315  |  Link
namaiki
Registered User
 
Join Date: Sep 2009
Location: Sydney, Australia
Posts: 1,073
Tenki, you need to enable 'auto-load subtitles' and use the internal subtitle renderer if you want to use DXVA.

In MPC-HC, View -> Options -> Playback -> and make sure there is a tick next to 'auto-load subtitles'.
namaiki is offline  
Old 2nd November 2009, 07:42   #10316  |  Link
73ChargerFan
Registered User
 
73ChargerFan's Avatar
 
Join Date: Dec 2006
Posts: 511
I'd like copies of older mpc-hc releases, svn 1180 through 1235 or so.
If anyone has one or more, please pm me. Thanks.
73ChargerFan is offline  
Old 2nd November 2009, 08:43   #10317  |  Link
Snowknight26
Registered User
 
Join Date: Aug 2007
Posts: 1,390
When no DX9 compatible device (no video card) is installed in a machine running MPC-HC, several errors are throw:

EVR: CreateDevice failed, DX9AllocatorPresenter failed, D3DERR_NOTAVAILABLE
VMR9: CreateDevice failed, D3DERR_NOTAVAILABLE
VMR7: No video
Overlay: No video
Old renderer: Crash <-- shouldn't happen
System default (Video Renderer): No video

Should at least get video as it works fine in graphedit using Video Renderer.
Snowknight26 is offline  
Old 2nd November 2009, 09:08   #10318  |  Link
namaiki
Registered User
 
Join Date: Sep 2009
Location: Sydney, Australia
Posts: 1,073
Quote:
Originally Posted by Snowknight26 View Post
When no DX9 compatible device (no video card) is installed in a machine running MPC-HC, several errors are throw:

EVR: CreateDevice failed, DX9AllocatorPresenter failed, D3DERR_NOTAVAILABLE
VMR9: CreateDevice failed, D3DERR_NOTAVAILABLE
VMR7: No video
Overlay: No video
Old renderer: Crash <-- shouldn't happen
System default (Video Renderer): No video

Should at least get video as it works fine in graphedit using Video Renderer.
Just curious, but what video card and OS?
namaiki is offline  
Old 2nd November 2009, 10:25   #10319  |  Link
Tenki
Registered User
 
Join Date: Oct 2009
Posts: 14
namaiki, thank you.
But it only solve the first problem.

If I use MPC-HC to play DVD (file-> open disk), MPC-HC still can't change other subtitles when playing.
Tenki is offline  
Old 2nd November 2009, 10:39   #10320  |  Link
namaiki
Registered User
 
Join Date: Sep 2009
Location: Sydney, Australia
Posts: 1,073
Tenki, in 'Navigate -> Subtitle Language', what options do you see there when playing that DVD?
namaiki is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.