Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Subtitles

Reply
 
Thread Tools Search this Thread Display Modes
Old 8th July 2006, 18:05   #441  |  Link
steelman
Registered User
 
Join Date: Dec 2002
Location: Slovakia
Posts: 23
Quote:
Originally Posted by ai4spam
Does it always happen, or does it go away after you restart?
If it happens always, send me (fine my mail in the manual) the char matrix file you're using.

It happens all the time and it will not go away after restart. Maybe I'm blind but i haven't seen you mail in guide on zuggy web. I'm attaching it here. Oh and I'm trying to delete character with index 00036

EDIT:
btw aren't you plannig remove HI optional option for post OCR correction. Something like building another character matrix with this textes (e.g. [MAN]
Attached Files
File Type: zip univerzal.zip (2.5 KB, 234 views)

Last edited by steelman; 8th July 2006 at 18:07.
steelman is offline   Reply With Quote
Old 9th July 2006, 07:52   #442  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
I said the manual, as in the file Credits.txt .
Hearing Impaired removal should not be that difficult, especially with the code in place to do whole words formatting (same principle). I'll think about it.
ai4spam is offline   Reply With Quote
Old 12th July 2006, 19:03   #443  |  Link
steelman
Registered User
 
Join Date: Dec 2002
Location: Slovakia
Posts: 23
Have you checked it?
steelman is offline   Reply With Quote
Old 13th July 2006, 03:56   #444  |  Link
Teebeeke
Registered User
 
Join Date: Jun 2005
Posts: 36
I tried that hardcoded thing, yesterday, but after 5 hours i still hadnt reached 50 %. I have a hard time getting the right colors for the program to reckognize the subs. I converted a tape to avi, which makes it hard i guess.
Teebeeke is offline   Reply With Quote
Old 14th July 2006, 00:55   #445  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
@steelman: I can't, the attachments has not been approved yet. Mail it to me (see Credits.txt for the address).
@Teebeeke: It takes a while, what can I say. Try lowering the OCR sensitivity.
ai4spam is offline   Reply With Quote
Old 20th July 2006, 08:26   #446  |  Link
SvenBent
Registered User
 
Join Date: Nov 2003
Posts: 29
Sorry i didnt read thorug 22 page of post.
just spank me for being a bad boy :-)

anyway the "format whoel words" cotains some bugs

E.G

Original: Dennis<i>...</i>
"fixed": <i> Dennis... </i>
Correct would be : Dennis ...

personaly i disable the function (but it wouldnt save it :-( ) and modify the punct.dic


ooh and also a suggestions
you should be able to selecte multiple languages from a list. The list should be a long list with checkboxes and a selection for "correction by langaug" for the post ocr correction.
And then it would go throug alle the files and saving it by the original language name.

That would save the user some time.
maybe even run each languange in its own threads. Rhat way the whole project would not stop for just one letter being uknown, and the speed would scale on a SMP system.
__________________
Sven Bent - Denmark

Last edited by SvenBent; 20th July 2006 at 08:39.
SvenBent is offline   Reply With Quote
Old 20th July 2006, 08:38   #447  |  Link
ukendt
Moderator
 
Join Date: Oct 2001
Location: Denmark
Posts: 538
Quote:
@steelman: I can't, the attachments has not been approved yet. Mail it to me (see Credits.txt for the address).
They were approved short after your comment
Quote:
Sorry i didnt read thorug 22 page of post.
just spank me for being a bad boy :-)
Spank beat hit ...

(furthemore in danish...)
Sl, fl, rive ....God varm sommer Sven Bent
ukendt is offline   Reply With Quote
Old 21st July 2006, 01:23   #448  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
Hmm, does it happen when the word is the first in the sentence, or anywhere?
The principle is: it looks for how many characters are italicized and how many are not, and depending on which number is greater, it formats the whole word or not.
ai4spam is offline   Reply With Quote
Old 26th July 2006, 21:33   #449  |  Link
SvenBent
Registered User
 
Join Date: Nov 2003
Posts: 29
Quote:
Originally Posted by ai4spam
Hmm, does it happen when the word is the first in the sentence, or anywhere?
The principle is: it looks for how many characters are italicized and how many are not, and depending on which number is greater, it formats the whole word or not.
I have sofar only found the errors when thers is only one word and then the triple dot

maybe jut make on corret one letter in a word. (or ...)

also i can oresse that this may also make more mistakes ten it fixed
E.G
the original lin :either/or
detectes as: either<i>i</i>or
fixed as: Eitherior

actually i would preffer te non fixes version is its graphically better reprenst what should be there

this is just my 2 cent.

thusfar i have fixed most errors without a wrong fixation by using these lines in the punc.dic

<i></i>

</i><i>

<i>/</i>
/
</i>/<i>
/
<i>...</i>
...
</i>...<i>
...

Works wonders
__________________
Sven Bent - Denmark
SvenBent is offline   Reply With Quote
Old 27th July 2006, 01:33   #450  |  Link
iElectric
Registered User
 
Join Date: May 2006
Posts: 23
Someone i know gets this error at start:
"Bad Packet Header at LBA 2. Do you want to continue?"
Then LBA just grows up: 2,3,4..
iElectric is offline   Reply With Quote
Old 28th July 2006, 04:15   #451  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
@SvenBent: Working on fixing it, but my motherboard died . Also, the correction is applied AFTER the punctuation correction, so feel free to use the dictionary to work wonders .
@iElectric: That's usually a bad/non-standard .sub file. Try a different source. Other than that, I don't know, Zuggy handles the .vob/.sub parsing stuff.
ai4spam is offline   Reply With Quote
Old 28th July 2006, 22:35   #452  |  Link
SvenBent
Registered User
 
Join Date: Nov 2003
Posts: 29
another "bug" (actualyl a limitation i think)

Error
Not enough memory to add this character to the Matrix!
Size of the Matrix in Bytes: 6326094

would you consider increaseing te maximum size for the matrix file ?
__________________
Sven Bent - Denmark
SvenBent is offline   Reply With Quote
Old 29th July 2006, 03:35   #453  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
It's not memory that's the problem, it's the fragmentation. Now SubRip allocates each character on demand, when it should in fact allocate chunks of 10 or even 100, and fill them afterwards. Too many allocation requests eventually lead to the failures that you get.
So... as soon as my new motherboard gets in, I'll work on this as well.
ai4spam is offline   Reply With Quote
Old 6th August 2006, 19:37   #454  |  Link
colonel32
Registered User
 
Join Date: Oct 2004
Posts: 5
Hi, I'd like to report a bug. If you view/edit a character matrix which contains unicode characters (Korean), and try to "Delete This Character (Del)", SubRip 150b3 crashes with an "Access Violation at address 004C7AF8 in module 'SubRip.exe'. Read of address 00000000."

It seems to be reproduceable after a restart and a reboot. You can see yourself by editing the attached character matrix and trying to delete index 00094.

Hope this helps!

This is an excellent program, thanks so much
Attached Files
File Type: zip korean.zip (4.1 KB, 185 views)

Last edited by colonel32; 6th August 2006 at 19:52.
colonel32 is offline   Reply With Quote
Old 8th August 2006, 05:21   #455  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
I'm working on a new version, which should take care of all these issues. I'll try your example when I'm done. Thanks for reporting.

PS: I'll repeat an earlier request: anyone wants to volunteer to design a new face for the SubRip page, once we move to SourceForge?
ai4spam is offline   Reply With Quote
Old 8th August 2006, 12:30   #456  |  Link
iElectric
Registered User
 
Join Date: May 2006
Posts: 23
I would gladly help, but only thing i am good at is Flash.
iElectric is offline   Reply With Quote
Old 9th August 2006, 00:16   #457  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
Well, a nice Flash intro wouldn't hurt either. No need for fancy menus or anything, just an intro would be cool.
ai4spam is offline   Reply With Quote
Old 10th August 2006, 22:30   #458  |  Link
masken
uhm... ?
 
Join Date: Oct 2001
Location: Gothenburg, Sweden
Posts: 281
just like to say thanks for your continued efforts with this excellent and essential application ai4spam. Keep up the good work
masken is offline   Reply With Quote
Old 13th August 2006, 02:32   #459  |  Link
iElectric
Registered User
 
Join Date: May 2006
Posts: 23
ai4spam, you have msn or something? Tell me more details about intro, i would like to help at making new home for subrip
iElectric is offline   Reply With Quote
Old 13th August 2006, 04:48   #460  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
Thanks for the offer. I have gMail (use the same id as here @ gmail). I don't log in often, but you can leave me messages that way. Just add my id to your contacts.
ai4spam is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.