Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 29th December 2015, 05:40   #1  |  Link
creedo
Registered User
 
Join Date: Dec 2007
Posts: 41
Latest MPC-HC, some 720p videos stutter despite good GPU and CPU

Sorry if this isn't the right place to ask. I've been googling for a while and just can't find a solution that works for me.

MPC-HC is playing my 1080p videos flawlessly, yet I have a handful of 720p MKVs that are very choppy. They appear to be H.264 video, AAC audio. Actually just the video is choppy, audio is fine.

These same MKV's play back fine in VLC, so I'm sure this is just a setting thing. The hardware is a Core i5-4460 and an R9 300 video card. Running win7 pro 64.

I'm wondering if it has something to do with the program failing to take advantage of my GPU?
Here are the fixes I've tried so far.

Uninstalled all codec packs, ffdshow, etc. I actually just reformatted so I've only installed MPC-HC, VLC, and the latest video card driver.

Options -> playback -> output -> tried Enhanced Video Renderer (custom presenter) and also System Default.

Options -> internal filters -> video decoder -> hardware decoder -> tried DXVA2 (native), NVIDIA CUVID, and none.

No custom shaders have been added or enabled.

Any ideas? Again VLC plays these files fine, but I would like to just use mpc-hc for everything.

Here's the codec info if it helps:

Code:
Video
ID                             : 1
Format                         : AVC
Format/Info                    : Advanced Video Codec
Codec ID                       : V_MPEG4/ISO/AVC
Duration                       : 47mn 35s
Bit rate                       : 2 084 Kbps
Width                          : 1 280 pixels
Height                         : 720 pixels
Display aspect ratio           : 16:9
Frame rate mode                : Constant
Frame rate                     : 23.976 fps
Bits/(Pixel*Frame)             : 0.094
Stream size                    : 709 MiB (83%)
Default                        : Yes
Forced                         : No

Audio
ID                             : 2
Format                         : AC-3
Format/Info                    : Audio Coding 3
Mode extension                 : CM (complete main)
Format settings, Endianness    : Big
Codec ID                       : A_AC3
Duration                       : 47mn 35s
Bit rate mode                  : Constant
Bit rate                       : 384 Kbps
Channel(s)                     : 6 channels
Channel positions              : Front: L C R, Side: L R, LFE
Sampling rate                  : 48.0 KHz
Compression mode               : Lossy
Stream size                    : 131 MiB (15%)
Default                        : Yes
Forced                         : No
creedo is offline   Reply With Quote
Old 29th December 2015, 22:03   #2  |  Link
Nullack
Registered User
 
Join Date: May 2015
Posts: 188
Its low framerate low bitrate AVC/H.264 stuff, at low HD resolution it shouldnt be a problem at all. Post a sample please.

I personally use the nightly x64 LAV filters - they are very stable and robust. I disable all internal filters and just run the three LAV externally being splitter/audio/video as the only filters with priority merit order.
Nullack is offline   Reply With Quote
Old 30th December 2015, 01:27   #3  |  Link
creedo
Registered User
 
Join Date: Dec 2007
Posts: 41
ack

Well I got all excited because I thought I solved it... AMD Catalyst control center, which is the settings screen for my video card driver, had a bunch of video options enabled like denoise, deblock, etc... a half dozen filters or something. I tried disabling them and the video seemed to play smooth. I reopened it and it was right back to being jerky again. And the options are still disabled when I return to the settings.

So anyway, before that, I tried your suggestion but I must be doing something wrong. Here's what I did.

1. Downloaded LAV nightly build installer at https://files.1f0.de/lavf/nightly/ , installed it, went to settings page for splitter / audio / video, changed no settings except to enable DXVA2 (native).

2. Went to media player classic HC, options, internal filters, unchecked everything in both columns.

3. Went to external filters, added LAV spitter, LAV audio, LAV video decoder (in that order) then chose "prefer" for the merit setting on each of these.

Apply, then OK, closed the program, reopened it, reopened one of the problem MKVs.... still stuttering.

I'm not sure if I can upload a sample for you, because I don't have tools to make a short clip and also I don't want any copyright issues.

Would the info on this screen hold any clues? http://i.imgur.com/XhaF7in.jpg
creedo is offline   Reply With Quote
Old 30th December 2015, 02:03   #4  |  Link
Asmodian
Registered User
 
Join Date: Feb 2002
Location: San Jose, California
Posts: 2,865
1) DXVA2 Copyback is recommended but that probably not the issue here.

Your screen shot has a max 71.5 ms paint time, that is too high but I don't have any advice on fixing it.
__________________
madVR options explained
Asmodian is online now   Reply With Quote
Old 30th December 2015, 02:08   #5  |  Link
Nullack
Registered User
 
Join Date: May 2015
Posts: 188
Just use ffmpeg to easily cut a video, google is your friend. Nighlyt ffmpeg builds:

http://ffmpeg.zeranoe.com/builds/

I cant comment on copyright in your country but in mine, a small sample that is non significant to the piece for personal study or research is entirely legal
Nullack is offline   Reply With Quote
Old 30th December 2015, 03:22   #6  |  Link
creedo
Registered User
 
Join Date: Dec 2007
Posts: 41
Solved it, but not sure why this fixes it.

So first I thought "screw lav, let's try ffdshow, always worked before." But playback was still choppy.

Then I remembered "oh yeah I should uncheck all those internal filters to force it to use ffdshow video decoder."

Out of laziness I didn't uncheck every format, just Matroska from the left column, and H.264 from the right.

Nice, smooth playback.

Then on a hunch, I rechecked MKV, removed the ffdshow external filter entirely.

Still nice, smooth playback.

So the culprit is the internal H264/AVC transform filter. Which strikes me as weird... H.264 is the most popular thing on earth. If they get just ONE thing right, just one thing that works correctly right out of the box, it should be H.264.

Here's the setting I mean if it's unclear:
https://i.imgur.com/PtPGegy.jpg

creedo is offline   Reply With Quote
Old 30th December 2015, 04:16   #7  |  Link
Nullack
Registered User
 
Join Date: May 2015
Posts: 188
Mate ffdshow is deprecated. LAV Filters is the current directshow decoder for AVC/H.264. Its based off ffmpeg. ffmpegs and in turn LAV filters hevc decoder is amongst the very best available. Maybe its something unique about the encoding stream of your particular file. Thats why I suggested posting a sample of it.
Nullack is offline   Reply With Quote
Old 30th December 2015, 04:47   #8  |  Link
creedo
Registered User
 
Join Date: Dec 2007
Posts: 41
Quote:
Originally Posted by Nullack View Post
Mate ffdshow is deprecated. LAV Filters is the current directshow decoder for AVC/H.264. Its based off ffmpeg. ffmpegs and in turn LAV filters hevc decoder is amongst the very best available. Maybe its something unique about the encoding stream of your particular file. Thats why I suggested posting a sample of it.
I remember that ffdshow stopped being supported, and someone came up with ffdshow-tryouts... basically picking up where they left off... is tryouts also obsolete? Pretty much everyone is using LAV now?

I don't think lav is at fault exactly.

If I disable support for H.264 in the setting I circled... I'm basically instructing MPCHC not to use its internal LAV decoder, right? So if you disable that, what does the program use to decode video? Something built into windows 7?
creedo is offline   Reply With Quote
Old 30th December 2015, 05:23   #9  |  Link
Nullack
Registered User
 
Join Date: May 2015
Posts: 188
Yes, LAV Filters is the premier directshow implementation of ffmpeg. The developer Hendrik has done a masterful job and its more robust than what ffdshow and the tryouts ever was. Its really stable even the nightly builds I have had very little defects with it. Like his VP9 DXVA2 implementation, that was recently supported by nvidia in new drivers and there was not a single defect I could see with gpu accelerated vp9 playback right off the bat. I dont wax lyrical lightly - its very unusual and I deeply suspect he has some sort of secret advanced AI system running on his personal supercomputer that does all his unit tests for him

As to what will happen if you disable the internal MPC-HC filter, yes your saying dont use it. What is used happens on two levels. First, if you tell MPC-HC under external filters to do some custom setups within the HPC_ME config, MPC-HC will use whatever merit order for defined external filters you enter into MPC-HC. On a second level where there is no applicable external filters applied in custom user entries within the MPC-HC config, the OS filters will be used using the OS's filter merit order if it can.....Then if its totally stuck MPC-HC will use one of its internal ones overriding the user choice and in the EVR-CP in that final outcome youll see it noted MPC Video Decoder (low merit) indicating its totally out of merits and is improvising internally.

Unless Im testing I always run MPC-BE x64 nightly, with external nightly x64 LAV Filters. Usually with madVR and AnydvdHD. That said, the various current MPC projects synch pretty regularly with LAV Filters. LAV Filters in turn synchs pretty regularly with ffmpeg.

PS: When I said "ffmpegs and in turn LAV filters hevc decoder" I meant ...AVC decoder.

Last edited by Nullack; 30th December 2015 at 05:28.
Nullack is offline   Reply With Quote
Old 30th December 2015, 14:08   #10  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,720
Disable hardware acceleration and also disable NV12 in LAV Video. Maybe that helps to bypass the driver processing.

Development of ffdshow(-tryouts) was stopped a few years ago.
clsid is offline   Reply With Quote
Old 30th December 2015, 15:08   #11  |  Link
filler56789
SuperVirus
 
filler56789's Avatar
 
Join Date: Jun 2012
Location: Antarctic Japan
Posts: 795
OFF-TOPIC

Quote:
Originally Posted by Nullack View Post
google is your friend.
Please stop spreading outdated information.

http://forum.videohelp.com/threads/3...earch-response

/OFF-TOPIC
filler56789 is offline   Reply With Quote
Old 30th December 2015, 20:32   #12  |  Link
vivan
/人 ◕ ‿‿ ◕ 人\
 
Join Date: May 2011
Location: Russia
Posts: 649
Quote:
Originally Posted by creedo View Post
If I disable support for H.264 in the setting I circled... I'm basically instructing MPCHC not to use its internal LAV decoder, right? So if you disable that, what does the program use to decode video? Something built into windows 7?
It will use H.264 decoder with highest priority (merit) that your system can has. AFAIK W7 comes with some kind of H.264 decoder so it might use it.
When playing H.264 video right click inside mpc-hc window and select Filters. It will show list of filters used, one of them will be video decoder.
vivan is offline   Reply With Quote
Old 31st December 2015, 00:25   #13  |  Link
Nullack
Registered User
 
Join Date: May 2015
Posts: 188
Quote:
Originally Posted by filler56789 View Post
OFF-TOPIC



Please stop spreading outdated information.

http://forum.videohelp.com/threads/3...earch-response

/OFF-TOPIC
Pull your head in pal....All he needed to do is google something like "ffmpeg cut sample" and there is a bazillion instructions on how to do that.
Nullack is offline   Reply With Quote
Reply

Tags
720p, choppy, dxva, h.264, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:55.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.