Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 8th May 2010, 00:59   #141  |  Link
J_Darnley
Registered User
 
J_Darnley's Avatar
 
Join Date: May 2006
Posts: 959
It does print the percent done, at least for wav input.
__________________
x264 log explained || x264 deblocking how-to
preset -> tune -> user set options -> fast first pass -> profile -> level
Doom10 - Of course it's better, it's one more.
J_Darnley is offline   Reply With Quote
Old 8th May 2010, 01:03   #142  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
yeah, but since 5.1 wav are kind of huge (temporary files) and it accepts input via a pipe I would prefer to use it via pipe. (decode with ffmpeg/mencoder -> filter with sox -> encode with oggenc/neroaacenc)
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 8th May 2010, 01:45   #143  |  Link
J_Darnley
Registered User
 
J_Darnley's Avatar
 
Join Date: May 2006
Posts: 959
It does read wav from a pipe. (I didn't say a file). I did a simple test: cat temp.wav | oggenc2 - -o temp.ogg -q4
__________________
x264 log explained || x264 deblocking how-to
preset -> tune -> user set options -> fast first pass -> profile -> level
Doom10 - Of course it's better, it's one more.
J_Darnley is offline   Reply With Quote
Old 8th May 2010, 08:39   #144  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
Code:
ffmpeg -threads 4 -v -10 -y -i "test_en_aid_128__09_37_15_718_01.ac3" -f sox - | sox -p -t wav - remix -m 1v0.2646,3v0.1870,4v0.1870,5v0.2291,6v0.1323 2v0.2646,3v0.1870,4v0.1870,5v-0.1323,6v-0.2291 norm | oggenc -r -b 196 -C 6 -R 48000 --ignorelength --utf8 -o "test_en_aid_128__09_37_15_718_02.ogg" -
and
Code:
ffmpeg -v -10 -threads 4 -i "test_en_aid_128__09_38_42_868_01.ac3" -acodec pcm_s16le -ac 6 -ar 48000 -f wav - | oggenc -r -b 128 -C 6 -R 48000 --ignorelength --utf8 -o "test_en_aid_128__09_38_42_868_02.ogg" -
both don't show any progress besides time-elapsed here,...
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 8th May 2010, 10:04   #145  |  Link
J_Darnley
Registered User
 
J_Darnley's Avatar
 
Join Date: May 2006
Posts: 959
Well that's just wrong. You told oggenc to use raw input when it is wav so of course there is no progress. Are you really using oggenc version 1? You should be using oggenc2. You could also just use sox to encode.
__________________
x264 log explained || x264 deblocking how-to
preset -> tune -> user set options -> fast first pass -> profile -> level
Doom10 - Of course it's better, it's one more.
J_Darnley is offline   Reply With Quote
Old 8th May 2010, 10:08   #146  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
I tested with:
a. oggenc that comes with vorbis-tools on current Ubuntu systems
b. oggenc2 provides by rarewares

Since I never used oggenc before, since I normally don't use ogg: if you know a way to tweak the command calls please speak up since 'Well that's just wrong.' doesn't really help.
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 8th May 2010, 11:54   #147  |  Link
J_Darnley
Registered User
 
J_Darnley's Avatar
 
Join Date: May 2006
Posts: 959
I must apologise. It seems that oggenc doesn't like the ffmpeg|sox|oggenc2 combination. It spits out errors and doesn't encode anything. So yes, if you are going to use oggenc then it looks like it will have to be raw input.
__________________
x264 log explained || x264 deblocking how-to
preset -> tune -> user set options -> fast first pass -> profile -> level
Doom10 - Of course it's better, it's one more.
J_Darnley is offline   Reply With Quote
Old 8th May 2010, 12:13   #148  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
So no ogg support until I find a way to get some progress indication with oggenc or another way to create ogg vorbis content.
(made a feature request over at xiph)

Cu Selur
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 11th May 2010, 18:03   #149  |  Link
Riki
Registered User
 
Join Date: Dec 2007
Posts: 152
Hi Selur. May I ask what to adjust in hybrid to get the most lossess conversion (and easiest to edit with a video editing program)? I did set CQ to Lossless but Im not sure if the colors were preserved and other stuff. Are there other settings I can adjust, or is there a profile I can look at?

The goal is lossless quality, yet fast playback/editing.
Riki is offline   Reply With Quote
Old 11th May 2010, 18:07   #150  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
colors are always be yv12 (4:2:0), so if you input rgb you will lose some.
lossless + http://forum.doom9.org/showthread.php?p=1396455 is probably a good start
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 11th May 2010, 18:54   #151  |  Link
Riki
Registered User
 
Join Date: Dec 2007
Posts: 152
thanks, although on the hybrid encoding tests the quality did not look so good on certain frames (with thin colored lines, etc). I was hoping there were other setting involved, but I guess CRF is probably the best option for now.
Riki is offline   Reply With Quote
Old 11th May 2010, 18:58   #152  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
could be a TV/PC scale or a Rec.601, Rec.709 problem but I don't know of any way to control these through ffmpeg/mencoder (or another tool besides avisynth) so I couldn't add options to modify these. (Googled a lot but didn't find anything about it on the net regarding mencoder/ffmpeg. )

Cu Selur
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 13th May 2010, 15:28   #153  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
Would anyone prefer aften for ac3 encoding over ffmpeg?
I'm thinking about adding support for an addition option to select aften as encoder, but I'm not sure if it would be useful to have some of aftens options, besides bitrate and quality available through the gui?

Cu Selur
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 13th May 2010, 15:47   #154  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
aften!

and bitrate/channels as option is enough, aften has excellent default

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 13th May 2010, 22:02   #155  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
Hybrid ver.100513

*added*
- aften and oggenc support (reading progress from ffmpeg)

*changed*
- framecounter became a separate application (see first post for Download)

*fixed*
- raw avc frame counter
- mplayer not called with absolute path when doing dvd analysis
- "should be there" checks
- audio language passthrough on audio stream passthrough
- bug when raw audio passthrough and passthrough audio language were enabled

*cosmetics*
- show avc/vc1 frame counter progress in title bar

*updated*
- windows 32bit package (added oggenc, aften and framecounter)

(you need to enable Misc in the Main-Tab to enable the Misc-Tab)
Reset Defaults in Misc-Tab on first start

-> updated links in 1st post
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 15th May 2010, 18:12   #156  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
Hybrid ver.100515

*fixed*
- padding with ffmpeg (making sure that one multiple of 2 are padded)
sidenode: current ffmpeg build cause problems when using crop&pad together

*changed*
- using 'aften -v 2' output for progress indication instead of ffmpegs output during ac3 encoding with aften
- don't add -ss when autorcop raw video input- show number of scanned frames during autocrop

*cosmetics*
- hiding other audio options when 'ogg' is selected
- show number of scanned frames during autocrop

*updated*
- windows 32bit package (larger than before since mplayer, ffmpeg and mencoder use TLS Callbacks and I don't know a binary packer that can handle these)

(you need to enable Misc in the Main-Tab to enable the Misc-Tab)
Reset Defaults in Misc-Tab on first start

-> updated links in 1st post
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 16th May 2010, 18:40   #157  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
I'm getting "Crop Crashed" using auto crop + Mplayer or ffmpeg for cropping.

Using the latest hybrid package on win7 32bit

Code:
Video changed to:
Format: AVC
Bit rate: 192
Frame rate: 23.976
Resolution: 1280x720
Interlacing: progressive
Aspect ratio: 1
Frame count: 1010

2010.05.16 - 13:38:00_100515 - selectVideoStream: 0
2010.05.16 - 13:38:00_100515 - setCurrentVideoInput: 0
2010.05.16 - 13:38:00_100515 - Crop crashed
CpT is offline   Reply With Quote
Old 16th May 2010, 18:50   #158  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
Okay, I can reproduce this. Will send you a fixed version once I find the problem. (normal crop seems to work)
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Old 16th May 2010, 18:51   #159  |  Link
CpT
Registered User
 
Join Date: Aug 2009
Posts: 135
kk thanks, no hurries - its the weekend
CpT is offline   Reply With Quote
Old 16th May 2010, 21:16   #160  |  Link
Selur
Registered User
 
Selur's Avatar
 
Join Date: Oct 2001
Location: Germany
Posts: 6,117
Think I found the problem,..
__________________
Hybrid here in the forum, homepage
Notice: Since email notifications do not work here any more, it might take me quite some time to notice a reply to a thread,..
Selur is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:48.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.