Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 12th June 2018, 22:39   #201  |  Link
Alex-Kid
Antronio's DV ambassador
 
Alex-Kid's Avatar
 
Join Date: Mar 2006
Location: Santiago, Chile
Posts: 113
Thanks StainlessS, I knew I forgot something: Avisynth v2.60 ST 32-bit.

I'm going to post that AvsMeter output later, when I get home.

----------EDIT----------

Avsmeter output is too big for the forum, I uploaded to pastebin.

Last edited by Alex-Kid; 13th June 2018 at 06:34.
Alex-Kid is offline   Reply With Quote
Old 16th June 2018, 21:45   #202  |  Link
Wilbert
Moderator
 
Join Date: Nov 2001
Location: Netherlands
Posts: 6,335
I don't know what the problem is. But you have tons of files in your plugin folder and most of them are not even AviSynth plugins.

You might start by leaving only immaavs.dll in your plugin folder. Did you also copy the imagemagick dll's and xml's in your system folder (SysWOW64)?
Wilbert is offline   Reply With Quote
Old 16th June 2018, 22:24   #203  |  Link
Groucho2004
Cantankerous Fossil
 
Groucho2004's Avatar
 
Join Date: Mar 2006
Location: A wretched hive of scum and villainy
Posts: 4,470
700+ files in your plugin directory - I was about to start pointing out the files that really don't belong there, duplicates, etc. but this is just silly. As Wilbert suggested, remove everything from the directory (make a backup if you wish) and add plugins as needed.
__________________
Groucho's Avisynth Stuff
Groucho2004 is offline   Reply With Quote
Old 8th May 2019, 17:15   #204  |  Link
ingoldie
Registered User
 
Join Date: Sep 2014
Posts: 126
When I try to open lena_std.tif with ImmaRead("C:\lena_std.tif")

I get the following error message

"ImmaRead:you haven't set the MAGICK_HOME variable and you didn't provide it as argument!"

How can I solve this problem?


For the original as a TIFF image:http://www.lenna.org/
ingoldie is offline   Reply With Quote
Old 8th May 2019, 17:32   #205  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,263
First page of thread
Quote:
You need the ImageMagick dll's in order to be able to use this plugin. They should be copied to some folder (any folder will do). You need to set the MAGICK_HOME variable to the location of ImageMagick dll's (under Settings -> System -> Advanced -> Environment Variables -> Add MAGICK_HOME as a user variable), or you need to provide it using the magick_home argument. Thus for example, magick_home = "C:\\WINNT\\system32".
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???
StainlessS is offline   Reply With Quote
Old 8th May 2019, 17:49   #206  |  Link
ingoldie
Registered User
 
Join Date: Sep 2014
Posts: 126
Like this?

ImmaRead("C:\lena_std.tif", magick_home="C:\Windows\SysWOW64")
ingoldie is offline   Reply With Quote
Old 8th May 2019, 18:07   #207  |  Link
ingoldie
Registered User
 
Join Date: Sep 2014
Posts: 126
If yes, now I'm getting

"ImmaRead:couldn't open picture file:severity=1ef, reason=RegistryKeyLookupFailed 'CoderModulesPath' @error/module.c/GetMagickModulePath/670, description=(null)" error message
ingoldie is offline   Reply With Quote
Old 8th May 2019, 19:20   #208  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,263
Like this I think (untested)

EDIT: Oops sorry, posted image is wrong, should be in USER VARIABLES(top one) not System variables(bottom one).

Quote:
Thus for example, magick_home = "C:\\WINNT\\system32".
NOTE, Wilbert used double backSlash, if dont work with single, then try double backslash.
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 10th May 2019 at 15:20.
StainlessS is offline   Reply With Quote
Old 10th May 2019, 14:01   #209  |  Link
ingoldie
Registered User
 
Join Date: Sep 2014
Posts: 126
It's not working.I'm still getting the same

"ImmaRead:couldn't open picture file:severity=1ef, reason=RegistryKeyLookupFailed 'CoderModulesPath' @error/module.c/GetMagickModulePath/670, description=(null)" error message
ingoldie is offline   Reply With Quote
Old 10th May 2019, 15:19   #210  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,263
Oops sorry,posted image is wrong, should be in USER VARIABLES(top one) not System variables(bottom one).
(but I think should have worked ok after a reboot when in system variables - did you reboot ?)
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 10th May 2019 at 15:22.
StainlessS is offline   Reply With Quote
Old 10th May 2019, 17:19   #211  |  Link
StainlessS
HeartlessS Usurer
 
StainlessS's Avatar
 
Join Date: Dec 2009
Location: Over the rainbow
Posts: 7,263
I'm getting exact same error as Ingoldie.

Search for "CoderModulesPath" gives this solution,
https://www.imagemagick.org/discours...ic.php?t=26856

Looks like you need to have imagemagick installed else dll's dont work (solution in above link).

Also, what you supposed to do with CORE_RL_magick_.dll, I dont see it mentioned, but it is clearly needed.
__________________
I sometimes post sober.
StainlessS@MediaFire ::: AND/OR ::: StainlessS@SendSpace

"Some infinities are bigger than other infinities", but how many of them are infinitely bigger ???

Last edited by StainlessS; 11th May 2019 at 17:00.
StainlessS is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.