Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.


Go Back   Doom9's Forum > Hardware & Software > Software players

Thread Tools Search this Thread Display Modes
Old 24th May 2020, 18:55   #1  |  Link
Registered User
Join Date: Apr 2019
Posts: 51
MadVr stutter workaround

Thought I would post here to help anyone seeking out an answer. Stutter occurs when using some Nvidia cards, mostly Rtx2000 series although I have seen some other complaints from other series owners, and the problem is mostly with 24fps content 60, 30, and even 50 doesnt seem to be so bad (I have a 60hz 4k panel). I discovered a workaround last year and these workarounds seem to have been confirmed by some other members within the madvr or mpc threads. So I thought I'd make a dedicated thread where we can confirm and share things we have experienced.

1.In madvr control panel set frames presented in advance to 1.
2.Or you can also try setting low latency mode to On in nvidia cp.
3. Or set windows power options setting to power saver.

They are ranked in most reliable starting with the first option. None are perfect or guaranteed to work as a fix for the future and may stop working as a fix. Some content may even become out of sync with the audio.

My experience with this issue has been quite weird. For a few months I was having no issues with stutter without having to use a workaround, madvr was functioning normally, then one day it was stuttering again, so now I am using the first workaround. I do not watch too many movies mostly game so I cannot say if it was a driver update or mpc or lav filter update which broke it. I had this issue on my Intel build and now on my AMD build with the only component in common is the rtx2070, I have tried 3 different cards and they all stutter. Sometimes even just a simple boot up will fix it for awhile. I have also noticed setting power option in nvidia cp to high performance for MPC makes it worse so keep it on adaptive or even optimal, note that it doesn't seem to matter when used in combination with the frames in advance to 1 workaround.

Anyhow, you can also search my profile for posts related to this topic if you feel it may help you.

So until we get a fix from the dev which looks like it is not going to happen please post your experiences with the stutter problem here.
3700X - RTX2070 - 970EVO - EVGA Supernova 750W Gold - Sony KD55X720E

Last edited by hotripper; Yesterday at 20:29.
hotripper is offline   Reply With Quote
Old 24th May 2020, 21:01   #2  |  Link
Registered User
Join Date: Feb 2002
Location: San Jose, California
Posts: 3,865
Setting frames presented in advance to 3 or below has worked well for me. That and keeping GPU power management mode on adaptive.
madVR options explained
Asmodian is offline   Reply With Quote
Old 25th May 2020, 04:51   #3  |  Link
Registered User
Join Date: Apr 2019
Posts: 51
Cool. I will try to set it to 3. Since I sometimes do notice audio out of sync when at 1.
3700X - RTX2070 - 970EVO - EVGA Supernova 750W Gold - Sony KD55X720E
hotripper is offline   Reply With Quote
Old Yesterday, 11:55   #4  |  Link
Registered User
Join Date: Apr 2007
Posts: 66
that's brilliant! I had been looking for a solution for this and this thread just magically appeared

for what its worth, I have the stutter problem on 50/60fps content on a laptop with Intel HD Graphics GPU. Setting frames in advance to 3 did the trick!

Last edited by Lebowsky; Yesterday at 14:32.
Lebowsky is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +1. The time now is 18:41.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.