Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 9th April 2009, 18:20   #61  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,171
yes, but only with autoloading. but then you cant choose between differents subs, for example different ones inside one mkv file or between an internal or an external file.
Thunderbolt8 is offline   Reply With Quote
Old 9th April 2009, 18:23   #62  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 5,010
Then you are doing something wrong! DirectVobSub (aka VSFilter) supports subtitle switching and works for both embedded and external subs.
clsid is offline   Reply With Quote
Old 9th April 2009, 19:23   #63  |  Link
Rectal Prolapse
Registered User
 
Join Date: Mar 2005
Posts: 433
Quote:
both, haali and madvr look quite similar to each other, apart from that one can see that haali outputs a bit too much red.
I believe this is because haali has the incorrect colorspace conversion for 709. AFAIK, Haali Renderer has always had the wrong colors, which is why I don't use it (I have calibrated displays and I can see the problems hehe).
Rectal Prolapse is offline   Reply With Quote
Old 9th April 2009, 19:37   #64  |  Link
leeperry
Kid for Today
 
Join Date: Aug 2004
Posts: 3,463
Quote:
Originally Posted by Rectal Prolapse View Post
haali has the incorrect colorspace conversion for 709.
it's also wrong for 601....HR in YUY2 is a no no

Last edited by leeperry; 9th April 2009 at 19:43.
leeperry is offline   Reply With Quote
Old 9th April 2009, 20:09   #65  |  Link
Rectal Prolapse
Registered User
 
Join Date: Mar 2005
Posts: 433
heh, I didn't know that leeperry!

Anyhow - kudos to madshi for this cool renderer.
Rectal Prolapse is offline   Reply With Quote
Old 9th April 2009, 20:14   #66  |  Link
leeperry
Kid for Today
 
Join Date: Aug 2004
Posts: 3,463
Quote:
Originally Posted by Rectal Prolapse View Post
heh, I didn't know that leeperry!
well, there's some new comers that didn't follow all the previous episodes
leeperry is offline   Reply With Quote
Old 9th April 2009, 20:43   #67  |  Link
Dark Shikari
x264 developer
 
Dark Shikari's Avatar
 
Join Date: Sep 2005
Posts: 8,689
Quote:
Originally Posted by honai View Post
@Dark

this is not about dithering to RGB16, but dithering from YV12 (i.e. floating point)
YV!2 isn't floating-point.
Quote:
Originally Posted by honai View Post
to RGB24/32. What you observed is something totally different, namely GDI dithering from RGB24 to RGB16.
But then why does it still dither even when I use FFDshow for the conversion?
Dark Shikari is offline   Reply With Quote
Old 9th April 2009, 20:46   #68  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Quote:
Originally Posted by Thunderbolt8 View Post
yes, but only with autoloading. but then you cant choose between differents subs, for example different ones inside one mkv file or between an internal or an external file.
Quote:
Originally Posted by clsid View Post
Then you are doing something wrong! DirectVobSub (aka VSFilter) supports subtitle switching and works for both embedded and external subs.
Subtitle switching is working fine over here as well using VSFilter and Haali Media Splitter on MKVs with multiple subtitles. Switching between internal and external subs also is working fine. I think clsid is right, you must be doing something wrong.

Last edited by cyberbeing; 9th April 2009 at 20:49.
cyberbeing is offline   Reply With Quote
Old 9th April 2009, 21:12   #69  |  Link
TripleH
Registered User
 
Join Date: Jun 2006
Posts: 26
My findings (all tests was made with remuxed BDs):

Configuration:

Intel Core 2 Quad Q9400
2GB DDR2 800Mhz CL4
Radeon HD 4670 512MB GDDR3

Windows Vista Ultimate SP1 32bit
ATi Catalyst 9.2

FFDShow video decoder, MPC-HC and Reclock latest version

1080p@23.976hz to Optoma HD81 projector


Result:
The video is suffering from massive tearing, and Reclock Vsync correction doesn't seem to work on it (the Vsync cross is always stays at the same area, even if I move the Vsync target position).

Moreover, I've tried setting Reclock hardware access method to both automatic (then it choose DirectDraw) and Direct3D, and the result is the same.



I think it'll be one hell of a renderer when it stables.
TripleH is offline   Reply With Quote
Old 9th April 2009, 22:24   #70  |  Link
cyberbeing
Broadband Junkie
 
Join Date: Oct 2005
Posts: 1,859
Configuration:

AMD X2 4800+ @ 2.64Ghz
2GB DDR400 @ 440Mhz 2-3-3-6-1T
NVIDIA 7800GTX 512MB

Windows XP SP3 x86
NVIDIA Forceware 182.50

Tested Resolutions:
1920x1080@120Hz, 1280x720@144Hz, 1600x1200@96Hz
on Sony GDM-F520

Software:
CoreAVC(software only)/FFDshow, MPC-HC, Reclock 1.8.4.2

I'm seeing no tearing with or without Reclock. It's not as smooth as Haali Renderer, but since you haven't done any work on smoothness yet, that is to be expected. It is very watchable with the current smoothness, but I will welcome any improvements you are able to make in that area.

Other then the simple changes in my previous post, and the ability to switch between two different LUTs automatically depending on the video resolution, I have no other wishlist features in mind.

BUG:
madVR freezes (locks up) when I check both use 10bit luma & chroma buffer during playback and hit apply. It recovers when I uncheck the options and click apply.

madVR freezes (locks up) when I check use 10bit luma buffer and click apply. It recovers when I uncheck the options and click apply.

madVR crashes the player silently when I check use 10bit chroma buffer and click apply.

Last edited by cyberbeing; 11th April 2009 at 22:32.
cyberbeing is offline   Reply With Quote
Old 9th April 2009, 23:05   #71  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,171
Quote:
Originally Posted by clsid View Post
Then you are doing something wrong! DirectVobSub (aka VSFilter) supports subtitle switching and works for both embedded and external subs.
hm seems like it. on another system that button is not greyed out, although I did exactly the same on I did on my PC. strange :S
Thunderbolt8 is offline   Reply With Quote
Old 9th April 2009, 23:48   #72  |  Link
Mark_A_W
3 eyed CRT supporter
 
Join Date: Jan 2008
Location: Or-strayl-ya
Posts: 563
Quote:
Originally Posted by Mark_A_W View Post
My setup:

Q6600
HD2600XT
Vista32
CRT monitor/projector running 1920x1080 interlaced at 95.904hz exactly.
CoreAVC for AVC
FFdshow using WMV9 decoder for VC-1
(Therefore no DXVA...ever!!)
Ffdshow doing RGB HQ for Haali Renderer
Reclock
Madflac for Flac (of course )

With MadVR I get slight stutters and tearing. The tearing is odd, there are about 5 little tears, rather than the more normal big single tear towards the top of the screen (I get that with EVR back on XP).
More info:

I'm watching 1080p BD/HD-DVD transferred to MKV.

And the levels were fine. They were unmolested, with black at 16 and white at 235....just the way they should be

When I play a file with a freshly opened ZP, all is well. But if I try to play another file, or replay the original, ZP just disappears.

I haven't played with the scaling options...because I don''t scale anything (HD on HD baby!).

Thanks Madshi

Mark
Mark_A_W is offline   Reply With Quote
Old 10th April 2009, 00:03   #73  |  Link
vucloutr
Registered User
 
vucloutr's Avatar
 
Join Date: Nov 2008
Posts: 64
Quote:
Originally Posted by cyberbeing View Post
..
NVIDIA 7800GTX 512MB
..
BUG:
madVR freezes (locks up) when I check both use 10bit luma & chroma buffer during playback and hit apply. It recovers when I uncheck the options and click apply.

madVR freezes (locks up) when I check use 10bit luma buffer and click apply. It recovers when I uncheck the options and click apply.

madVR crashes the player silently when I check use 10bit chroma buffer and click apply.
I encoutered the same problem with GeForce 7 Series onboard graphics.

silent crash on 10bit luma and/or chroma when hitting apply.

btw: great work madshi !
first eac3to and now this gem. thanks ! ^.^

Last edited by vucloutr; 10th April 2009 at 00:05.
vucloutr is offline   Reply With Quote
Old 10th April 2009, 02:09   #74  |  Link
Rectal Prolapse
Registered User
 
Join Date: Mar 2005
Posts: 433
Hmmm. If I use Haali Media Splitter + Autoloading VSFilter, the madVR renderer is never loaded. Only the regular Video Renderer is loaded, and the subtitle rendering is awful. If I disable VSFilter.dll, madVR loads fine again. What am I missing?

(I am using an older Haali Media Splitter, from June 2007, the last known Haali splitter that doesn't blow out my speakers when playing LPCM in .m2ts files).
Rectal Prolapse is offline   Reply With Quote
Old 10th April 2009, 02:21   #75  |  Link
TinTime
Registered User
 
Join Date: Jan 2009
Location: UK
Posts: 403
Is VSFilter passing out YV12? If not then madVR won't connect.
TinTime is offline   Reply With Quote
Old 10th April 2009, 02:21   #76  |  Link
Rectal Prolapse
Registered User
 
Join Date: Mar 2005
Posts: 433
Hmm didn't work with latest Haali splitter either.
Rectal Prolapse is offline   Reply With Quote
Old 10th April 2009, 11:04   #77  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 9,137
Quote:
Originally Posted by Hypernova View Post
Second, the output color is certainly different from EVR CP and everything else. I think madVR is wrong though
You were right after all. There is a bug in madVR's color handling. This will be fixed in the next build.

Quote:
Originally Posted by Hypernova View Post
I think the scaling method crash may have something to do with something else entirely and not relate to the scaling itself. The thing is, I can't change the scaling method by go to MPC-HC options->external filter. When I change it there and play a file, it go back to default. When I right click while playing and change it by go to filter->madVR then close the file and reopen it, MPC-HC crash as soon as (I guess) the 96mb is filled and it try to display the video.
Strange. You don't need to close the file and reopen, though. Changing scaling settings by right clicking during playing should show immediate effect.

Quote:
Originally Posted by wozio View Post
If you want any hardware acceleration working best on ATI you must use NV12, be it hardware decoding, deinterlacing, post processing or color conversion.
Well, I've retested and I get ugly chroma upsampling with ATI when using NV12, too. However, Beliyaal has sent me a screenshot of his ATI card which looks a lot nicer. We're not sure yet why he gets different results than I do. Might be due to different OS, driver version or graphics card...

Quote:
Originally Posted by zn View Post
Will this work on popular integrated video card Intel GMA X3100/X3000?
Technically it should work. But I rather guess that the Intel GMA shaders and memory access speed will not be fast enough for fluid playback. But you can give it a try...

Quote:
Originally Posted by noee View Post
With default upscaling, I get substantial tearing at 24Hz. Switching to 3tap Lanzcos or Spline helps. Haven't tried any other settings. When I switch to 60Hz, the tearing goes away.
Quote:
Originally Posted by TripleH View Post
The video is suffering from massive tearing
Not sure why you guys get tearing. I've not seen any tearing on my setup. But I'll investigate. I plan to implement a fullscreen mode, which should get rid of any tearing, if all else fails...

Quote:
Originally Posted by Thunderbolt8 View Post
edit: another little things, step forward (right arrow button) in mpc also doenst work yet
I know, but I don't know why it doesn't work right now. Will have to see...

Quote:
Originally Posted by tetsuo55 View Post
Would it be possible to get DXVA working with madVR?
Nope, sorry.

Quote:
Originally Posted by haruhiko_yamagata View Post
Great work, specially the dithering is impressive. ffdshow's output is inferior just because it does not have dithering. I'm sure ffdshow converters calculate in 10bit and round to 8bit.

With "Allow output format change during playback" checked and "Connect to compatible filters only" unchecked,
I found two issues,
  • I cannot toggle resize during playback.
  • I cannot play DVD at all (DVD: Macrovision Fail) whichever the decoder is.
Reconnecting filters is the most difficult and important step in DirectShow.
Each video renderer has its own API to reconnect, and most open source DirectShow filters have workaround for each video renderer. This is a big mess. I don't want to add new workaround in ffdshow.
Please simulate one video renderer's behavior so that we don't have to code too much.
Also please document how to reconnect with your video renderer.
You may want to check out our svn and read Tffdecoder.cpp TffdshowDecVideo::reconnectOutput (which is a mess) or DScaler5's DSVideoOutPin.cpp.
Thanks for the feedback! I'll see what I can do about the reconnect problems. Can you give me a hint what I need to do to make this macrovision error go away? I've no clue right now...

Quote:
Originally Posted by TinTime View Post
My first impressions...
Thanks!

Quote:
Originally Posted by TinTime View Post
And so to the inevitable feature request... In the future you mentioned adding support for user switching between 3D LUTs. I have absolutely no idea whether this is possible or not, but what would seem to be ideal for playback purposes would be to flag mkv files somehow to indicate to madVR which 3D LUT to use when playing it back. Perhaps the appropriate LUT could be attached to the mkv and madVR would load it from there? That's for further down the line anyway.
I'm not sure how I will handle that. Theoretically the video bitstream contains information about which color transformation has to be used, but sometimes this information is not available.

Quote:
Originally Posted by cyberbeing View Post
Could you make a small change so the properties settings are retained?
That's on my to do list, of course.

Quote:
Originally Posted by cyberbeing View Post
BUG:
madVR freezes (locks up) when I check both use 10bit luma & chroma buffer during playback and hit apply. It recovers when I uncheck the options and click apply.

madVR freezes (locks up) when I check use 10bit luma buffer and click apply. It recovers when I uncheck the options and click apply.

madVR crashes the player silently when I check use 10bit chroma buffer and click apply.
Quote:
Originally Posted by vucloutr View Post
I encoutered the same problem with GeForce 7 Series onboard graphics.

silent crash on 10bit luma and/or chroma when hitting apply.
It seems that either your graphics card hardware or the driver you're using doesn't support 10bit temp buffers. I'll need to handle that situation gracefully, of course, but I'll probably not be able to make 10bit work for you.

Quote:
Originally Posted by Mark_A_W View Post
When I play a file with a freshly opened ZP, all is well. But if I try to play another file, or replay the original, ZP just disappears.
Strange. Doesn't happen with MPC HC, it seems. Will have to check that...
madshi is offline   Reply With Quote
Old 10th April 2009, 11:05   #78  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 9,137
madVR 0.2 released

http://madshi.net/madVideoRenderer.rar

Code:
* fixed: colors were not fully correct
* improved install/uninstall
madshi is offline   Reply With Quote
Old 10th April 2009, 11:37   #79  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,171
thanks!
Thunderbolt8 is offline   Reply With Quote
Old 10th April 2009, 11:52   #80  |  Link
haruhiko_yamagata
Registered User
 
Join Date: Feb 2006
Location: Japan
Posts: 1,560
Quote:
Originally Posted by madshi View Post
Thanks for the feedback! I'll see what I can do about the reconnect problems. Can you give me a hint what I need to do to make this macrovision error go away? I've no clue right now...
Well, just random guesses...
For DVD playback, renderers have to implement subpicture input pin. ffdshow does alpha blending in itself, this shouldn't be necessary (only if you use ffdshow) though.
Renderers have to support switches between 16:9 and 4:3 during playback. Even if it is the first picture, it's technically during playback.
You could ask Casimir for support.
__________________
[ Download ffdshow | Wiki ]
haruhiko_yamagata is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 08:41.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.