Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > New and alternative video codecs

Reply
 
Thread Tools Search this Thread Display Modes
Old 24th December 2011, 14:26   #14461  |  Link
pandy
Registered User
 
Join Date: Mar 2006
Posts: 1,038
Hi Guys, quick question - ICL12 build is patched against bad dispatcher for AMD CPU's or not? (or should i use MSVC2010 version for AMD CPU's?).

btw

Is there any chance to restore MPEG encoder - 10 bit precision for DCT, interlace support, I frame - MJPEG is fine however there is lack for such small things (i believe that there is no standardization how to implement such features in MJPEG and MPEG-2 syntax seems to be tempting)

Last edited by pandy; 24th December 2011 at 14:45.
pandy is offline   Reply With Quote
Old 24th December 2011, 16:19   #14462  |  Link
Dstruct
Registered User
 
Join Date: Jan 2011
Posts: 102
Quote:
Originally Posted by pandy View Post
Hi Guys, quick question - ICL12 build is patched against bad dispatcher for AMD CPU's or not? (or should i use MSVC2010 version for AMD CPU's?).
I don't know what a bad dispatcher is. But here I need to use MSVC builds on my AMD CPU (no SSE2). ICL12 builds (xvidvideo.ru) don't let me open the config windows.


Also the "IntelQuickSyncDecoder.dll" is shown as "not found" in "Version details" with AMD CPU here (although the DLL is there)!

Last edited by Dstruct; 24th December 2011 at 16:31.
Dstruct is offline   Reply With Quote
Old 24th December 2011, 16:28   #14463  |  Link
gendouhydeist
Registered User
 
Join Date: Aug 2007
Posts: 16
Quote:
Originally Posted by haruhiko_yamagata View Post
Thank you for finding the bug. Fixed at rev 4200.
This also fix the crash that I'm encountering on Y416 output thanks!!
gendouhydeist is offline   Reply With Quote
Old 24th December 2011, 23:56   #14464  |  Link
haruhiko_yamagata
Registered User
 
Join Date: Feb 2006
Location: Japan
Posts: 1,560
Quote:
Originally Posted by gendouhydeist View Post
This also fix the crash that I'm encountering on Y416 output thanks!!
Yes, it was fixed. Thanks for letting me know.
__________________
[ Download ffdshow | Wiki ]
haruhiko_yamagata is offline   Reply With Quote
Old 25th December 2011, 02:38   #14465  |  Link
pandy
Registered User
 
Join Date: Mar 2006
Posts: 1,038
Quote:
Originally Posted by Dstruct View Post
I don't know what a bad dispatcher is.
http://www.agner.org/optimize/blog/read.php?i=49#49
pandy is offline   Reply With Quote
Old 25th December 2011, 14:23   #14466  |  Link
egur
QuickSync Decoder author
 
Join Date: Apr 2011
Location: Atlit, Israel
Posts: 916
Quote:
Originally Posted by Dstruct View Post
...

Also the "IntelQuickSyncDecoder.dll" is shown as "not found" in "Version details" with AMD CPU here (although the DLL is there)!
It's not a bug it's a feature. It will only work on Intel CPUs + GPU.
__________________
Eric Gur,
Processor Application Engineer for Overclocking and CPU technologies
Intel QuickSync Decoder author
Intel Corp.
egur is offline   Reply With Quote
Old 25th December 2011, 14:43   #14467  |  Link
haruhiko_yamagata
Registered User
 
Join Date: Feb 2006
Location: Japan
Posts: 1,560
Quote:
Originally Posted by ryrynz View Post
Haruhiko, build 4142 and above cause a green line to appear on the right side of the screen when playing back a DVD with the MS DTV-DVD decoder and passing through ffdshow RAW.
I can reproduce this. I have fixed the problem in my working copy. I'll commit it to the SVN in a few days.
__________________
[ Download ffdshow | Wiki ]
haruhiko_yamagata is offline   Reply With Quote
Old 26th December 2011, 03:50   #14468  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 2,815
Great work, thank you Haruhiko.
ryrynz is offline   Reply With Quote
Old 27th December 2011, 15:35   #14469  |  Link
djchristian
Registered User
 
Join Date: Dec 2008
Posts: 7
Why aren't there a installguide for ffshow and media player classic HC???
djchristian is offline   Reply With Quote
Old 27th December 2011, 19:33   #14470  |  Link
pulbitz
Registered User
 
Join Date: Sep 2011
Posts: 22
I'm sorry. I don't speak English very well.

ffdshow video decoder configuration | Output | Stream settings
Check "Set interlaced flag in output media type"

- libavcodec
perfect smooth playback of 1080i content. (double framerate)

- Intel QuickSync
motion is steppier. (poor)

Is this a bug? Or QuickSync decoder limitation?

Last edited by pulbitz; 27th December 2011 at 19:54.
pulbitz is offline   Reply With Quote
Old 27th December 2011, 19:41   #14471  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,769
@Haruhiko
There is a bug in ffdshow that causes a freeze with Haali video renderer.
4174 = ok
4183 = broken
clsid is offline   Reply With Quote
Old 27th December 2011, 22:47   #14472  |  Link
egur
QuickSync Decoder author
 
Join Date: Apr 2011
Location: Atlit, Israel
Posts: 916
Quote:
Originally Posted by pulbitz View Post
I'm sorry. I don't speak English very well.

ffdshow video decoder configuration | Output | Stream settings
Check "Set interlaced flag in output media type"

- libavcodec
perfect smooth playback of 1080i content. (double framerate)

- Intel QuickSync
motion is steppier. (poor)

Is this a bug? Or QuickSync decoder limitation?
You need a SandyBridge (or newer) to enjoy the HW acceleration used in the QuickSync decoder.
Please specify which renderer was use as well other setup (driver version, OS version, 32/64 bit, player, display is connected to iGPU or dGPU, etc). If you can post a part of the clip (10-20 seconds) that would help development.
This thread is very busy so please report issues at the QuickSync decoder thread:
http://forum.doom9.org/showthread.php?t=162442
__________________
Eric Gur,
Processor Application Engineer for Overclocking and CPU technologies
Intel QuickSync Decoder author
Intel Corp.

Last edited by egur; 28th December 2011 at 22:29.
egur is offline   Reply With Quote
Old 28th December 2011, 05:17   #14473  |  Link
Midzuki
Unavailable
 
Midzuki's Avatar
 
Join Date: Mar 2009
Location: offline
Posts: 1,465
r4206: raw video filter FAILS again

the annoying vertical green bar has disappeared, BUT the aspect ratio gets screwed -.-

Going back to r4052.

Last edited by Midzuki; 28th December 2011 at 05:19.
Midzuki is offline   Reply With Quote
Old 28th December 2011, 10:17   #14474  |  Link
haruhiko_yamagata
Registered User
 
Join Date: Feb 2006
Location: Japan
Posts: 1,560
Quote:
Originally Posted by clsid View Post
@Haruhiko
There is a bug in ffdshow that causes a freeze with Haali video renderer.
4174 = ok
4183 = broken
I have fixed at rev 4207. Please confirm.
__________________
[ Download ffdshow | Wiki ]
haruhiko_yamagata is offline   Reply With Quote
Old 28th December 2011, 11:23   #14475  |  Link
haruhiko_yamagata
Registered User
 
Join Date: Feb 2006
Location: Japan
Posts: 1,560
Quote:
Originally Posted by Midzuki View Post
the annoying vertical green bar has disappeared, BUT the aspect ratio gets screwed -.-
It works for me. How can I reproduce?
__________________
[ Download ffdshow | Wiki ]
haruhiko_yamagata is offline   Reply With Quote
Old 28th December 2011, 12:15   #14476  |  Link
ryrynz
Registered User
 
ryrynz's Avatar
 
Join Date: Mar 2009
Posts: 2,815
4206 is working fine for me, cheers.
ryrynz is offline   Reply With Quote
Old 28th December 2011, 12:19   #14477  |  Link
Midzuki
Unavailable
 
Midzuki's Avatar
 
Join Date: Mar 2009
Location: offline
Posts: 1,465
Quote:
Originally Posted by haruhiko_yamagata View Post
It works for me. How can I reproduce?
Try using a *real* MPEG-2 decoder (Mainconcept, Cyberlink, ArcSoft).

Last edited by Midzuki; 28th December 2011 at 12:22.
Midzuki is offline   Reply With Quote
Old 28th December 2011, 14:02   #14478  |  Link
clsid
Registered User
 
Join Date: Feb 2005
Posts: 4,769
Quote:
Originally Posted by haruhiko_yamagata View Post
I have fixed at rev 4207. Please confirm.
Fix confirmed. Thanks.
clsid is offline   Reply With Quote
Old 28th December 2011, 15:18   #14479  |  Link
haruhiko_yamagata
Registered User
 
Join Date: Feb 2006
Location: Japan
Posts: 1,560
Quote:
Originally Posted by Midzuki View Post
Try using a *real* MPEG-2 decoder (Mainconcept, Cyberlink, ArcSoft).
Mainconcept decoder crashes in MPC-HC, whatever the file is. I don't know what is real. ffdshow is not related.
It works in graphstudio and ffdshow raw filter is OK with it.
Cyberlink decoder (PDVD8 or 11) and ffdshow raw works fine.
I don't have ArcSoft.
__________________
[ Download ffdshow | Wiki ]
haruhiko_yamagata is offline   Reply With Quote
Old 28th December 2011, 15:44   #14480  |  Link
Midzuki
Unavailable
 
Midzuki's Avatar
 
Join Date: Mar 2009
Location: offline
Posts: 1,465
Quote:
Originally Posted by haruhiko_yamagata View Post
Mainconcept decoder crashes in MPC-HC, whatever the file is. I don't know what is real. ffdshow is not related.
It works in graphstudio and ffdshow raw filter is OK with it.
Cyberlink decoder (PDVD8 or 11) and ffdshow raw works fine.
I don't have ArcSoft.
Thanks for checking. I will try to find the actual source of the problem.

[ E D I T ]

ffdshow's MPEG decoder was not affected by the new raw video filter.
ArcSoft is not affected neither.
Downgraded from PDVD9 to PDVD7, the problem remains
Moving house to r4127.

Last edited by Midzuki; 28th December 2011 at 17:39.
Midzuki is offline   Reply With Quote
Reply

Tags
ffdshow, ffdshow tryouts, ffdshow-mt, ffplay, icl

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.