Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 6th January 2011, 05:33   #1  |  Link
GG-Xtreme
Registered User
 
Join Date: Dec 2010
Posts: 45
[SOLVED] Seeking Problem in H.264 MP4's Encoded with MeGUI/AviSynth

It seems I can finally post

Anyway, I got a new Android phone, but due to lack of good .ass softsubs support, I decided to convert my softsubbed videos to hardsubs. The videos involved were .mkv with AVC/H.264 video (all at 23.976fps), various audio codecs and ASS softsubs.

I used MKVextractGUI to obtain the raw .h264 video streams, the subtitle files and the audio. I converted all of the audio to 48KHz 256Kb/s vbr AAC and put the video streams into MP4 containers using MP4Box with the '-fps 23.976' parameter.

Then I loaded up MeGUI and created a new script, specifying the subtitle files, a simple resize, and some good quality settings. The resulting MP4 files played fine and had no seek problems in VLC...but in MPC, playing the files just gave me a green screen (the original MKV's played fine). I ignored this and used MP4Box to remux the audio and hardsubbed videos and loaded them onto my phone.

They play fine, only I can't seek past around 14 minutes in any of the re-encoded videos (the exact time seems arbitrary). Seeking past that area of the timeline in any Android video player causes the player to freeze/crash. Seeking before that time, or letting the video play through is just fine.

I'm a bit of a newbie with this stuff, so I'm hoping someone can point me in the right direction about what's going wrong here.

Edit: BTW, I'm running Windows 7 Ultimate 64-bit. I'm using 64-bit ffdshow and AviSynth (as well as MPC).

Edit: Solved!
Following nm's advice, I used FFmpegSource instead of DirectShowSource, and all my playback/seeking issues were solved.

Last edited by GG-Xtreme; 10th January 2011 at 10:00. Reason: problem solved =)
GG-Xtreme is offline   Reply With Quote
 

Tags
hardsub, megui, mkv, mp4, seeking problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.