Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 ASP

Reply
 
Thread Tools Search this Thread Display Modes
Old 1st December 2009, 20:58   #1  |  Link
Guilllo
Registered User
 
Join Date: Jan 2006
Location: Correze, France
Posts: 53
Video not transcodable using Mencoder

Hi all!

I have a very annoying problem because I can't really see why it does NOT work as it should.

I have a video which comes from Adobe Premiere Pro (edited from a JVC hd camera). It has been exported in Microsoft DV at 29.97 fps, interlaced.

I am trying to transcode it with mencoder but the output has a "hanging problem". Let me explain :

There is a fading in of a text, than a fading out. everything is smooth in the source file. But when I encode it in xvid or x264 or mpeg4 with libavcodec, the fade-out hangs for 1 second. An exception though : the first pass of x264 shows smooth playback but the second one has the same problem as xvid.

Moreover the next scene shows smoke. Even at 2500kbps with xvid the video out is highly blocky. I am sure what I am saying is not clear at all so :

here are my commands :

Code:
mencoder Séquence\ 02.avi -ovc x264 -x264encopts pass=2:bitrate=1500:turbo=1:bframes=3:b_adapt:cabac:weight_b:partitions=all:8x8dct:me=umh:subq=9:chroma_me:trellis=1 -oac mp3lame -lameopts cbr:br=128  -o test.avi
for x264 and :

Code:
mencoder Séquence\ 02.avi  -ovc xvid -xvidencopts pass=1:bitrate=1500:me_quality=6:qpel:gmc:trellis:chroma_me:chroma_opt:hq_ac:vhq=4 -oac mp3lame -lameopts cbr:br=128 -o test.avi
for xvid.

I don't know what's not goàd in my parameters or in the source video but it works great with both x264 and xvid are smooth after encoding with avidemux2.

I would like to get a deinterlaced file with good quality at ~1500kbps

And as an example is better than words, please try these samples files :

source file

xvid encoded

Note : - mencoder warns me about a lot of duplicate frames where it hangs in playback.
- I have tried with -vf kerndeint to deinterlace but output is not smooth neither

Last edited by Guilllo; 1st December 2009 at 21:11.
Guilllo is offline   Reply With Quote
Old 2nd December 2009, 00:22   #2  |  Link
MatLz
I often say "maybe"...
 
MatLz's Avatar
 
Join Date: Jul 2009
Location: France
Posts: 589
Hi Guillo, I don't know mencoder. But if it can help you, it seems your source is a true 29.97fps so for deinterlace it, I think a simple selecteven(bob()) (if you can use Avisynth with mencoder?)
For the quality, if you experience block artifacts even with X264, that mean your source is difficult to compress, so if you want keep your 1500kbps, reduce the resolution. Or simply raise the bitrate.

(OOT: I can also see a lot of orthographic mistakes...)
MatLz is offline   Reply With Quote
Old 2nd December 2009, 04:57   #3  |  Link
henryho_hk
Registered User
 
Join Date: Mar 2004
Posts: 889
Why is there only the 2nd pass commandline for x264 and the 1st pass one for xvid?

To vastly improve the compressibility of your HD DV clip, you can add "-vf pp=ha:c/va:c/dr/fd" which means deblocking+deringing+deinterlacing(simple). Also, since homemade DV footages are usually rather unstable and noisy, try omitting "qpel" and "gmc" for xvid. But then, if your footage is really 1280x720@29.97fps, 1500kbps is never sufficient.

For x264 encoding, you'd better use x264.exe.
henryho_hk is offline   Reply With Quote
Old 2nd December 2009, 09:38   #4  |  Link
Guilllo
Registered User
 
Join Date: Jan 2006
Location: Correze, France
Posts: 53
Code:
Why is there only the 2nd pass commandline for x264 and the 1st pass one for xvid?
I only pasted the firts one I found in my bash history that's all.

My video has been resized at 720*480 so bitrate should be enough. Ans quality is not a problem with x264, only with xvid so I will try your settings.

Is 29.29 fps a problem or can i let it as is ?
I will also try your vf -pp..... I used kerndeint to deinterlace because I didn't know which one to used. Which one is the better ?

Thanks

PS : I am aware about the mistakes but I am not the one who made the video, I am just trying to encode it for him and it is not definitive.
Guilllo is offline   Reply With Quote
Old 4th December 2009, 15:48   #5  |  Link
Guilllo
Registered User
 
Join Date: Jan 2006
Location: Correze, France
Posts: 53
I have tried your settings but it is still has not smooth playback.
Guilllo is offline   Reply With Quote
Old 5th December 2009, 22:41   #6  |  Link
Guilllo
Registered User
 
Join Date: Jan 2006
Location: Correze, France
Posts: 53
I have nearly solved the problem with the help of mencoder mailing lists. With -mc 0 - noskip I have no more hangs on the ouptut. But doing so, mencoder cuts the 2 first seconds of the file which were black frames. Doing so it gives me a A/V desync.


Any idea ?
Guilllo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 16:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.