Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 20th March 2011, 08:52   #481  |  Link
Taurus
Registered User
 
Taurus's Avatar
 
Join Date: Mar 2002
Location: Krautland
Posts: 783
Quote:
Taurus: Thanks for trying that out. What MeGUI version do you have?
Latest MeGui dev version. You can change to the update server within MeGui/Options.
Well, I wonder how -Vit- managed to crash MeGui.
I could scroll in the timeline, expand the preview window, stop, reload the video to my heart out.
No crashes.
But if it' fixed, it's fixed.

@mr.duck.
Quote:
But installed a recent build of ffdshow and I couldn't believe how good yadif was
So what are you waiting/looking for?
If it fullfills your needs, use it.
If you want to see some real magic, try QTGMC or it's mother/father TGMC.
I never was satisfied with deinterlacers until I found Didée's and -Vit-'s scripts.
Thank you to both of you.
Taurus is offline  
Old 20th March 2011, 10:25   #482  |  Link
nhope
partially-informed layman
 
Join Date: Jan 2002
Location: Bangkok, Thailand
Posts: 308
Quote:
Originally Posted by -Vit- View Post
nhope. Your perseverance has paid off. I reproduced your problem in the MeGUI preview and fixed the cause, there's a new version v3.31 in the OP. There's no need to update documentation or spreadsheets, it's only this bug-fix.
Thanks very much for a such a fast fix. I see it was just one value in the new ChromaMotion code. I updated the version numbers on the 3 spreadsheets anyway to 3.31.

Quote:
Originally Posted by Taurus View Post
Latest MeGui dev version. You can change to the update server within MeGui/Options.
At the moment the development server isn't offering me anything that the stable one isn't, since there was a big update a few days ago. As so many variables are involved here, I think I prefer to stay with the stable update server. I'm really trying to put a "stake in the ground" regarding version numbers of programs and filters that, in most cases, work according to my guide. Once I've done that and spread the word a bit, that page is going to get a lot of traffic. Apologies in advance to -Vit- for all the people that are likely to come here saying "This isn't working on my 64-bit PC. I'm using Debugmode Frameserver blah blah...".

Quote:
Well, I wonder how -Vit- managed to crash MeGui.
Maybe he dug out his old Commodore Amiga.
nhope is offline  
Old 20th March 2011, 10:45   #483  |  Link
Taurus
Registered User
 
Taurus's Avatar
 
Join Date: Mar 2002
Location: Krautland
Posts: 783
@nhope
Great that it works now.
Nice guide you wrote!
Taurus is offline  
Old 20th March 2011, 10:50   #484  |  Link
Delerue
Registered User
 
Join Date: Jun 2005
Posts: 365
I posted this on x64 Avisynth thread, but maybe it's better here:

I've tried to run QTGMC with all 64-bit dependencies, but no success. It crashes instantly with MPC-HC x64 1.5.2.2972 + FFDShow x64 3760. I tried with avisynth tab inside FFDShow (checking 'Add ffdshow video source') using only this line of code:

Code:
QTGMC( Preset="Medium" )
Here's the list of the dependencies I have:

nnedi3_64.dll (0.9.2.0)
mt_masktools-25-x64.dll (2.0.48.0)
mvtools2.dll (last 'official' version of Joshua Duncan from the first page of this very thread)
avisynth.dll (same as above)
Repair.dll and Removegrain.dll (from here: http://code.google.com/p/avisynth64/wiki/PluginLinks)

Any idea?

Also, no success on running multi-thread with x86 version (although single-thread works flawlessly); instantly crash when using 'distributor()'. Without it I have no crash, but there's no multi-thread either. BTW, I'm using 'setMTMode(2,12)' because I have an i7 860. The problem doesn't seem to be related to MT version of 'avisynth.dll', as I can run MVTools2 with multi-thread.

Thanks

Last edited by Delerue; 20th March 2011 at 10:58.
Delerue is offline  
Old 20th March 2011, 11:25   #485  |  Link
jpsdr
Registered User
 
Join Date: Oct 2002
Location: France
Posts: 1,459
Quote:
Originally Posted by SubJunk View Post
Is that version of 2.6 multithreaded?
No, it's standard 2.6 and MT 2.5.8.

Quote:
Originally Posted by SubJunk View Post
Have you tried them?
Actualy, all my work are not MT script with x64 bit version.
If i'm not using MT in my script it's because all the slowestfilter/things i'm using are already multi-threaded themselve, and i'm not using QTGMC for now.

I was just asking out of curiosity, because i've noticed that he was doing updates of 2.6 and 2.5.8MT build regularly. So, i assumed (but maybe wrong), that maybe in these build there was regularly update/bug fixes, things you don't find in others MT avisynth versions, because these others builds begin to be "a little old", and don't seem to be updated, contrary to xkomisar's builds.
jpsdr is offline  
Old 20th March 2011, 11:42   #486  |  Link
Didée
Registered User
 
Join Date: Apr 2002
Location: Germany
Posts: 5,390
Quote:
Originally Posted by mr.duck View Post
... couldn't believe how good yadif was. I could not tell it apart from hardware vector adaptive deinterlacing!
It seems that Yadif indeed is similar to HW deinterlacing. Or vice versa.

You might want to have a look at this little comparison.

Beware - this is the RED pill to take.
__________________
- We´re at the beginning of the end of mankind´s childhood -

My little flickr gallery. (Yes indeed, I do have hobbies other than digital video!)
Didée is offline  
Old 20th March 2011, 11:48   #487  |  Link
nhope
partially-informed layman
 
Join Date: Jan 2002
Location: Bangkok, Thailand
Posts: 308
I nailed my problem with YUY2. I was using mt_masktools-26.dll instead of mt_masktools-25.dll. Presumably the version I was using was intended for AviSynth 2.6.

-Vit-, I think it would be a good idea in the documentation to specifically state exactly which files are required from the "Requirements". This will help not-so-avisynth-savvy users and keep problems like mine off your plate. i.e.:

RemoveGrainSSE2.dll
RepairSSE2.dll
RSharpenSSE2.dll
mt_masktools-25.dll (for 32-bit use in AviSynth 2.5)
SSE3Tools.dll (for YUY2)

Now YUY2 is working, I'll do a few speed trials and check out the colours/levels.
nhope is offline  
Old 20th March 2011, 11:49   #488  |  Link
Boulder
Pig on the wing
 
Boulder's Avatar
 
Join Date: Mar 2002
Location: Hollola, Finland
Posts: 4,324
-Vit-,

do you use some other program than Notepad to save your script? It seems that in the latest versions (at least v3.30 and v3.31), opening in Notepad shows a bit messy script. It looks to me that the script has been saved in Unix format instead of DOS.
__________________
And if the band you're in starts playing different tunes
I'll see you on the dark side of the Moon...
Boulder is offline  
Old 20th March 2011, 12:07   #489  |  Link
nhope
partially-informed layman
 
Join Date: Jan 2002
Location: Bangkok, Thailand
Posts: 308
Quote:
Originally Posted by Delerue View Post
Also, no success on running multi-thread with x86 version (although single-thread works flawlessly); instantly crash when using 'distributor()'. Without it I have no crash, but there's no multi-thread either. BTW, I'm using 'setMTMode(2,12)' because I have an i7 860. The problem doesn't seem to be related to MT version of 'avisynth.dll', as I can run MVTools2 with multi-thread.
I haven't tested this personally but some are getting more success with SEt's version of AviSynth 2.6. If you use that you might want to use mt_masktools-26.dll, not mt_masktools-25.dll.
nhope is offline  
Old 20th March 2011, 15:06   #490  |  Link
-Vit-
Registered User
 
Join Date: Jul 2010
Posts: 448
Boulder: Somehow the line breaks were converted to UNIX-style recently. I've updated the OP to use Windows style line breaks again so it should be more readable now (no version number change). I use Notepad++, Visual Studio or AvsPmod to edit, but those editors will accept any line break style so I didn't notice the problem.

Delerue: You cannot always run 1 thread per core because you might run out of memory. On 32-bit avisynth you have 2Gb memory regardless of your machine. Multi-threaded complex HD scripts need more memory (which is why we need 64-bit Avisynth). Cut down the number of threads. Also always try different versions of MT avisynth. Just because MVTools works for you multi-threaded, doesn't mean that you are using the most stable MT version for your machine.

nhope: I'm going to add plugin packages for 2.5x, 2.6x and x64-2.5x to the OP to ease the plugin confusion. I'm not in my lair at the moment so I can't test anything properly - it will have to wait.

Last edited by -Vit-; 20th March 2011 at 15:37.
-Vit- is offline  
Old 20th March 2011, 16:10   #491  |  Link
Delerue
Registered User
 
Join Date: Jun 2005
Posts: 365
Quote:
Originally Posted by nhope View Post
I haven't tested this personally but some are getting more success with SEt's version of AviSynth 2.6. If you use that you might want to use mt_masktools-26.dll, not mt_masktools-25.dll.
Thanks, but it didn't work either. Only single-thread.

Quote:
Originally Posted by -Vit- View Post
Delerue: You cannot always run 1 thread per core because you might run out of memory.
I've managed to get x64 version to work using another version of Avisynth. But no success with multi-thread, again. I'm aware of the problem regarded to huge memory usage when working with lot of threads, but I believe that the problem here has nothing to do with memory as it doesn't matter how many threads I set, it always crash instantly as soon as I put 'distributor()' line. I even tried something like this with no success:

Code:
setMTMode(2,3)
QTGMC( Preset="Fast", EdiThreads=3 )
SelectEven()
distributor()
Delerue is offline  
Old 20th March 2011, 17:06   #492  |  Link
Didée
Registered User
 
Join Date: Apr 2002
Location: Germany
Posts: 5,390
For the love of Manitu, make your first x64 tests with a VfW application like VirtualDub. Avery offers an x64 version "VeeDub".

If it works there (and there are good chances it will, I can personally confirm "success" with it) ... then it's time to go asking why it doesn't work in other scenarios.

After all, Avisynth support in ffdshow is somewhat fishy. Even in 32bit country. It works, but several things don't react like expected. And I suspect in 64bit country it's rather worse than better, if anything.
__________________
- We´re at the beginning of the end of mankind´s childhood -

My little flickr gallery. (Yes indeed, I do have hobbies other than digital video!)
Didée is offline  
Old 20th March 2011, 18:01   #493  |  Link
Delerue
Registered User
 
Join Date: Jun 2005
Posts: 365
Thanks, Didée. I managed to make it work with x64 AND MT using this:

Code:
setMTMode(2,4)
ffdshow_source()
QTGMC( Preset="Medium", EdiThreads=4 )
SelectEven()
distributor()
Apparently, unchecking 'Add ffdshow video source' and using 'ffdshow_source()' line fixed the crash.

Unfortunately, without 'SelectEven()' the motion is choppy/weird to the point that sometimes frame 2, for example, can be motion positioned before frame 1, and frame 3 is after frame 1; a completely mess. I tested with 640x480@30 FPS video.
Delerue is offline  
Old 20th March 2011, 18:19   #494  |  Link
mr.duck
quack quack
 
Join Date: Apr 2009
Posts: 259
Quote:
Originally Posted by Didée View Post
You might want to have a look at this little comparison.

Beware - this is the RED pill to take.
hmmmmmm... I may be back after upgrading to a 8 core CPU. It will be a while
__________________
Media Player Classic Home Cinema Icon Library: NORMAL VERSION / GLOWING VERSION
mr.duck is offline  
Old 20th March 2011, 20:41   #495  |  Link
nhope
partially-informed layman
 
Join Date: Jan 2002
Location: Bangkok, Thailand
Posts: 308
Quote:
Originally Posted by -Vit- View Post
I'm going to add plugin packages for 2.5x, 2.6x and x64-2.5x to the OP to ease the plugin confusion.
That sounds like an excellent idea, especially as one or two of the required filters' servers seem to have off days.

YUY2 support seems to be fine. It's the same speed as YV12 and the result is identical on the scopes.

Also I'm seeing a 5-8% speed increase in 3.31 over 3.25 using "faster" preset (single-threaded), and negligible difference in the result.
nhope is offline  
Old 20th March 2011, 20:53   #496  |  Link
-Vit-
Registered User
 
Join Date: Jul 2010
Posts: 448
Quote:
Originally Posted by Delerue View Post
Unfortunately, without 'SelectEven()' the motion is choppy/weird
Add "ComplementParity()" after your source line?
-Vit- is offline  
Old 20th March 2011, 22:29   #497  |  Link
SubJunk
Registered User
 
Join Date: Jun 2010
Posts: 441
Quote:
Originally Posted by jpsdr View Post
No, it's standard 2.6 and MT 2.5.8.



Actualy, all my work are not MT script with x64 bit version.
If i'm not using MT in my script it's because all the slowestfilter/things i'm using are already multi-threaded themselve, and i'm not using QTGMC for now.

I was just asking out of curiosity, because i've noticed that he was doing updates of 2.6 and 2.5.8MT build regularly. So, i assumed (but maybe wrong), that maybe in these build there was regularly update/bug fixes, things you don't find in others MT avisynth versions, because these others builds begin to be "a little old", and don't seem to be updated, contrary to xkomisar's builds.
Ah I see. Well regardless of bugfixes I need MT. I have a quad core CPU so to only use one core would be to severely limit the speed
SubJunk is offline  
Old 21st March 2011, 04:29   #498  |  Link
Delerue
Registered User
 
Join Date: Jun 2005
Posts: 365
Quote:
Originally Posted by -Vit- View Post
Add "ComplementParity()" after your source line?
Perfect! Now I really can see the quality of this deinterlacer. Thanks a lot.
Delerue is offline  
Old 21st March 2011, 09:27   #499  |  Link
jpsdr
Registered User
 
Join Date: Oct 2002
Location: France
Posts: 1,459
Quote:
Originally Posted by SubJunk View Post
Ah I see. Well regardless of bugfixes I need MT. I have a quad core CPU so to only use one core would be to severely limit the speed
As i said, the 2.5.8 is MT, and regularly updated. These are the facts. After, i don't realy know what there is in the update. I simply assumed it's bugfixes. So, between an old 2.6MT and a regularly updated 2.5.8MT, i've choosen the regularly updated. Now, is my choice correct ? I don't know. This is why i've asked if you have tested this version.
jpsdr is offline  
Old 21st March 2011, 11:11   #500  |  Link
SubJunk
Registered User
 
Join Date: Jun 2010
Posts: 441
No, I haven't tried it. I will
SubJunk is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 09:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.