Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Reply
 
Thread Tools Search this Thread Display Modes
Old 31st July 2018, 02:33   #1  |  Link
Cyber Akuma
Registered User
 
Cyber Akuma's Avatar
 
Join Date: May 2002
Posts: 147
Mp4Box is failing to merge files with one I encoded

My camera is hard-coded to split files at the 4GB mark even if the filesystem on the SDcard I am using can handle files over 4GB.

Ok, fair enough, it's a few seconds of extra work but I can always use MP4BOX to just merge them. And normally this would work, but during one of my recordings I have a 10 second gap near the end. It looks horrible to just merge them like that with the cut, and re-encoding an hour long video just to add a quick transition in the last minute would normally not be worth it, but I lucked out in that it had just started a new file past the previous 4GB mark when the cut happened, so I just have to add a transition between a 15 second and 1 minute file.

I wrote a simple AviSynth script to add a transition and then tried to use MP4BOX to merge them, but now it's not working. MP4BOX does not seem to like the clip I encoded as it's finding something (I honestly have no idea what) incompatible with it, and fails to properly merge the video. It tosses the warning "No suitable destination track found - creating new one (type vide)" and spits out a file that will not play. This only occurs when I attempt to add the encoded file in the mix, it has no issues merging all the original untouched files.

I am not sure what kind of information I am even supposed to provide to try to help with this.

Here is my AviSynth script:
Code:
Mov1=FFmpegSource2("video1.mp4", atrack=-1)
Mov2=FFmpegSource2("video2.mp4", atrack=-1)

Eff1=TransRipple(Mov1,Mov2,24,20,8)

FullMov = Eff1

ConvertToYV12(FullMov)

And what data MPC-HC reports for one of the original files:
https://pastebin.com/KMwqpxFv


As well as what I encoded:
https://pastebin.com/ZpvZ3pSL


I honestly do not see any difference, so I have no idea what MP4BOX is complaining about.

Does anyone have any suggestions what I can look into that could be causing this issue with MP4BOX failing to merge the files?
__________________
"A train station is where a train stops. A bus station is where a bus stops. On my desk I have a workstation..." - ComradOtter
Cyber Akuma is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.