Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th December 2012, 22:45   #41  |  Link
jkauff
Registered User
 
Join Date: Oct 2012
Location: Doylestown, PA in the U.S.A.
Posts: 349
Quote:
Originally Posted by soneca View Post
I can not convert any wav file to other formats, and the log is not clear on this issue.
When the TAC does not finish the task, the log is not saved in text format.
Copied and sent to you.
I can reproduce this on both 24 bit and 16 bit WAV files. Odd considering that TAC correctly converted my 24 96 FLAC to WAV and then to 24 48 FLAC according to the log. For my WAV test I converted from FLAC to WAV using dbPoweramp, in case that has a bearing on the problem.

Last edited by jkauff; 15th December 2012 at 22:48.
jkauff is offline   Reply With Quote
Old 16th December 2012, 03:43   #42  |  Link
jkauff
Registered User
 
Join Date: Oct 2012
Location: Doylestown, PA in the U.S.A.
Posts: 349
Quote:
Originally Posted by jkauff View Post
I can reproduce this on both 24 bit and 16 bit WAV files. Odd considering that TAC correctly converted my 24 96 FLAC to WAV and then to 24 48 FLAC according to the log. For my WAV test I converted from FLAC to WAV using dbPoweramp, in case that has a bearing on the problem.
Update: I tried the same test decoding with foobar2000, with the same result.
jkauff is offline   Reply With Quote
Old 16th December 2012, 14:21   #43  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Log is saved as log.txt in application folder after TAC is closed and overwritten all the time.

When you select that wav file in the list, what do you see in "Audio Track" list over file list? Is first number -1?
ozok is offline   Reply With Quote
Old 16th December 2012, 14:36   #44  |  Link
soneca
Registered User
 
Join Date: Feb 2008
Location: Brazil
Posts: 744
Quote:
Originally Posted by ozok View Post
Log is saved as log.txt in application folder after TAC is closed and overwritten all the time.

When you select that wav file in the list, what do you see in "Audio Track" list over file list? Is first number -1?
That's right,

-1, PCM, 1411.2 Kbps, 2 channels, 44.1Khz, unknown
soneca is offline   Reply With Quote
Old 16th December 2012, 14:40   #45  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Same here too. Looks like there is a problem with stream indexes.
ozok is offline   Reply With Quote
Old 16th December 2012, 15:02   #46  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Please try that exe.
ozok is offline   Reply With Quote
Old 16th December 2012, 15:26   #47  |  Link
soneca
Registered User
 
Join Date: Feb 2008
Location: Brazil
Posts: 744
Yes, apparently is working properly.

Ozok,
I think those bars indicating the use of memory and cpu could have a name in front of each, so that the indication it easier to visualize. It's just an opinion.
soneca is offline   Reply With Quote
Old 16th December 2012, 16:25   #48  |  Link
jkauff
Registered User
 
Join Date: Oct 2012
Location: Doylestown, PA in the U.S.A.
Posts: 349
Both 16 bit and 24 bit WAVs convert perfectly with the new .exe,
with one slight exception--setting bit depth to "Original" does not work on the 24 bit, it converts it to 16 bit. Setting bit depth explicitly to 24 bit works fine.
jkauff is offline   Reply With Quote
Old 16th December 2012, 18:43   #49  |  Link
soneca
Registered User
 
Join Date: Feb 2008
Location: Brazil
Posts: 744
Confirmed.
To keep the bit depth in the wav files you must specify.
The same happens with flac files. In auto mode the bit depth is changed to 16 bits.
soneca is offline   Reply With Quote
Old 17th December 2012, 15:51   #50  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Ok, I will look into that problem.
ozok is offline   Reply With Quote
Old 18th December 2012, 05:58   #51  |  Link
bilditup1
Registered User
 
bilditup1's Avatar
 
Join Date: Feb 2004
Location: NYC
Posts: 121
Quits with a meaningless log when I try to feed an 8ch, 24-bit wav (decoded from 6.1 DTSHD with Arcsoft/eac3to) for use with qaac. Use of the same file with qaac directly is just fine.

Last edited by bilditup1; 18th December 2012 at 06:21.
bilditup1 is online now   Reply With Quote
Old 18th December 2012, 13:24   #52  |  Link
jkauff
Registered User
 
Join Date: Oct 2012
Location: Doylestown, PA in the U.S.A.
Posts: 349
Quote:
Originally Posted by bilditup1 View Post
Quits with a meaningless log when I try to feed an 8ch, 24-bit wav (decoded from 6.1 DTSHD with Arcsoft/eac3to) for use with qaac. Use of the same file with qaac directly is just fine.
Did you specify 24 bit on the UI? We've already established that the "Same as source" setting doesn't work properly.
jkauff is offline   Reply With Quote
Old 18th December 2012, 16:18   #53  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Update:
Quote:
--0.6
-Added: Files without an audio stream will not be added to list
-Added: Summary will be added to log
-Removed: "Custom Options" tab
-Removed: enc_fhgaac.dll, libmp4v2.dll and nsutil.dll (Please see \Tools\fhgaacenc\Readme.txt)
-Fixed: Selecting "Bit Depth" as "Original" did not have any effect
-Fixed: If encoding stopped and re-started progress window shows wrong info
-Fixed: Some audio only files could not be encoded (thx to jkauff and soneca)
-Fixed: If output folder does not exist, it will be created (thx to Meeko)
-Fixed: Some VOB files caused "x not integer" error (thx to Rollin)
-Updated: QAAC to 2.09
-Updated: OpusEnc to build using libopus 1.0.2
ozok is offline   Reply With Quote
Old 19th December 2012, 04:44   #54  |  Link
bilditup1
Registered User
 
bilditup1's Avatar
 
Join Date: Feb 2004
Location: NYC
Posts: 121
Quote:
Originally Posted by jkauff View Post
Did you specify 24 bit on the UI? We've already established that the "Same as source" setting doesn't work properly.
No, I specifically changed that setting to 16-bit. No joy.
bilditup1 is online now   Reply With Quote
Old 19th December 2012, 09:51   #55  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Quote:
Originally Posted by bilditup1 View Post
Quits with a meaningless log when I try to feed an 8ch, 24-bit wav (decoded from 6.1 DTSHD with Arcsoft/eac3to) for use with qaac. Use of the same file with qaac directly is just fine.
What settings are you using? Can you send log.txt?
ozok is offline   Reply With Quote
Old 21st December 2012, 01:11   #56  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Update:
Quote:
--0.6.1
-Added: Support for 3gp files (thx to Rollin)
-Fixed: "m4a" will be used instead of "aac" when extracting streams (thx to Rollin)
-Fixed: Copied streams will be extracted to their own folders
-Fixed: Created temp. wav files will be always little-endian (thx to Rollin)
ozok is offline   Reply With Quote
Old 23rd December 2012, 19:17   #57  |  Link
bilditup1
Registered User
 
bilditup1's Avatar
 
Join Date: Feb 2004
Location: NYC
Posts: 121
Quote:
Originally Posted by ozok View Post
What settings are you using? Can you send log.txt?
LOL, works now on version 0.6.1. I didn't try it on 0.6 but I'm assuming the changes were made for that. This'll be much more convenient than piping from eac3to to qaac, though I suppose I'll have to keep doing that until your program can decode TrueHD and DTS-MA.
I love the polish of this program though. Nice updating, pretty straightfwd UI...good stuff man.
bilditup1 is online now   Reply With Quote
Old 26th December 2012, 14:41   #58  |  Link
ozok
TEncoder, TX264, TAC
 
ozok's Avatar
 
Join Date: Jun 2011
Location: Turkey
Posts: 540
Update:
Quote:
--0.6.2
-Added: Support for Monkey's Audio and TTA codecs
-Added: Support for 3ga files (thx to botface)
-Added: More tag fields for Opus
-Added: Option to reset number of process to ideal value
-Fixed: Wma and 3gp files could not be drag&dropped
-Fixed: Problems while extracting FLAC and AMR streams from videos (thx to Rollin)
-Fixed: MPC quality value was not saved
-Fixed: "Year" tag converted to "Date" for FLAC files
-Fixed: Wrong "Year" tag was passed to Lame.exe
-Updated: AlphaControls to 8.13
-Updated: QAAC to 2.10
ozok is offline   Reply With Quote
Old 26th December 2012, 22:12   #59  |  Link
soneca
Registered User
 
Join Date: Feb 2008
Location: Brazil
Posts: 744
New version, cool!
soneca is offline   Reply With Quote
Old 27th December 2012, 23:38   #60  |  Link
soneca
Registered User
 
Join Date: Feb 2008
Location: Brazil
Posts: 744
Some problems with the percentage bar(converting large files) and distortion gui after conversion finished.
I'll do some more tests, no time.
soneca is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:37.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.