Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th May 2009, 22:40   #1081  |  Link
Egh
Registered User
 
Join Date: Jun 2005
Posts: 630
Quote:
Originally Posted by KoD View Post
Actually, the subtitles being placed only on top of the image is how things are supposed to be. That's how subtitles are designed to work in the first place by the one creating them. If you ever get to watch subtitles which are placed over specific elements in an image, you'll notice they're no longer where they should be if you force positioning overriding.
I thought you can override placement on per style basis Or maybe vsfilter is not that advanced then.

Quote:
All of this is because vsfilter (the external version) is the renderer that defines the standards for advanced subtitle formats like ssa and ass, and every subtitle file that is being created is being created to work the way vsfilter works.
Not exactly as there are some differences between MPCHC and vsfilter renderers, apparently.
In MPCHC you can, for instance, select the texture resolution to render subs on.
Egh is offline   Reply With Quote
Old 17th May 2009, 23:12   #1082  |  Link
kostik
Registered User
 
Join Date: Jul 2007
Posts: 130
Something interesting i've found out. When you turn VSYNC and Triple Buffer on (in 3D settings,in catalyst), you get much smoother playback . On my pioneer tv it even seems like 100Hz . I chose in all the options ,lancroz 8.
kostik is offline   Reply With Quote
Old 18th May 2009, 00:06   #1083  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,171
a question on those lanczos filters, is it the higher the better (just with more GPU power needed)? if yes then why was lanczos4 chosen instead of lanczos8 for luma downscaling, shouldnt lanczos8 be better then?
Thunderbolt8 is offline   Reply With Quote
Old 18th May 2009, 00:16   #1084  |  Link
honai
Guest
 
Posts: n/a
You shouldn't ask "which one is better" questions. Also, the differences between Lanczos 4/8 tap and the other algorithms have been discussed long ago.
  Reply With Quote
Old 18th May 2009, 00:20   #1085  |  Link
Thunderbolt8
Registered User
 
Join Date: Sep 2006
Posts: 2,171
better in terms of PQ quality
Thunderbolt8 is offline   Reply With Quote
Old 18th May 2009, 00:38   #1086  |  Link
STaRGaZeR
4:2:0 hater
 
Join Date: Apr 2008
Posts: 1,307
Have you guys tried the new dithering option in ffdshow? Madshi's test patterns look very very close to madVR. I see no real world difference.
__________________
Specs, GTX970 - PLS 1440p@96Hz
Quote:
Originally Posted by Manao View Post
That way, you have xxxx[p|i]yyy, where xxxx is the vertical resolution, yyy is the temporal resolution, and 'i' says the image has been irremediably destroyed.
STaRGaZeR is offline   Reply With Quote
Old 18th May 2009, 00:40   #1087  |  Link
honai
Guest
 
Posts: n/a
Quote:
Originally Posted by Thunderbolt8 View Post
better in terms of PQ quality
Rephrasing makes no difference. People have different tastes, so for some people Lanczos-ringing will look better than to others.
  Reply With Quote
Old 18th May 2009, 00:42   #1088  |  Link
honai
Guest
 
Posts: n/a
Quote:
Originally Posted by STaRGaZeR View Post
Have you guys tried the new dithering option in ffdshow? Madshi's test patterns look very very close to madVR. I see no real world difference.
Where would that be, which revision? I haven't seen any announcements. Who implemented it?
  Reply With Quote
Old 18th May 2009, 01:02   #1089  |  Link
Mark_A_W
3 eyed CRT supporter
 
Join Date: Jan 2008
Location: Or-strayl-ya
Posts: 563
Quote:
Originally Posted by Blight View Post
v0.10 Bug Report using Zoom Player:

1. When pausing the video, the image is not updated (pause the video then drag the window off-screen and the window will be wiped black).
2. Switching the playback window between monitors doesn't update the OSD data (which may indicate that it's not being updated with the new monitor data).
3. Initial video load drops a lot of frames (even with tear-fix disabled), about 9-15 dropped.
4. Pressing Stop and then seeking, doesn't update the image (and pressing Stop doesn't show the first video frame either).
5. Pressing Pause doesn't pause the image instantly, at least 3-4 more frames are displayed.
6. I still get the occasional full on freeze (no image, GUI stops responding).
7. It takes 2-3 seconds longer than other renderers for the first video frame to show.

WinVista 32bit, NV 7600GT


I kinda think the pause thing is cool - it's like it rolls to a stop


Blight, while you are here...how about rudimentary Bluray navigation in ZP please? Open-> Drive and it plays the main title. (HD-DVD too!) No menu or anything difficult - just read the playlist and play the longest/main title.

With MadVR and basic navigation, ZP will leap frog over MPC-HC.

Because, at the moment, MPC-HC has implemented Bluray navigation and smooth playback with EVR custom....you are getting left behind

MadVR fixes the smooth playback...so now we need the navigation.

Thank you

Mark (ZP user since...oooo...V2 or 3...I forget, but I think I bought the Cineplayer decoders for DVD about then, as they were red hot at the time).

Sorry for the OT guys.
Mark_A_W is offline   Reply With Quote
Old 18th May 2009, 01:03   #1090  |  Link
STaRGaZeR
4:2:0 hater
 
Join Date: Apr 2008
Posts: 1,307
Quote:
Originally Posted by honai View Post
Where would that be, which revision? I haven't seen any announcements. Who implemented it?
See the changelog, rev2947 and up. AFAIK there are no builds up there, I'm using my own. madVR is sighly better, but I can see absolutely no real world differences and it has the advantage of being renderer agnostic. You can use it where you want as long as the renderer accepts RGB32.
__________________
Specs, GTX970 - PLS 1440p@96Hz
Quote:
Originally Posted by Manao View Post
That way, you have xxxx[p|i]yyy, where xxxx is the vertical resolution, yyy is the temporal resolution, and 'i' says the image has been irremediably destroyed.

Last edited by STaRGaZeR; 18th May 2009 at 01:06.
STaRGaZeR is offline   Reply With Quote
Old 18th May 2009, 01:09   #1091  |  Link
LoRd_MuldeR
Software Developer
 
LoRd_MuldeR's Avatar
 
Join Date: Jun 2005
Location: Last House on Slunk Street
Posts: 13,048
Quote:
Originally Posted by STaRGaZeR View Post
See the changelog, rev2947 and up. AFAIK there are no builds up there, I'm using my own.
For recent ffdshow builds check:
http://www.xvidvideo.ru/content/category/1/4/5/
__________________
There was of course no way of knowing whether you were being watched at any given moment.
How often, or on what system, the Thought Police plugged in on any individual wire was guesswork.


LoRd_MuldeR is offline   Reply With Quote
Old 18th May 2009, 01:12   #1092  |  Link
Mark_A_W
3 eyed CRT supporter
 
Join Date: Jan 2008
Location: Or-strayl-ya
Posts: 563
Quote:
Originally Posted by KoD View Post
I'm sorry to inform you, but the external vsfilter is more advanced in the features it supports than the internal MPC one. As for Haali's renderer, subtitle rendering happens with MPC by using vsfilter callbacks, so Haali's renderer doesn't magically use any other subtitling code, it's still vsfilter that does the job.

Similar advice to Mark_A_W, who also somehow believes Haali's renderer has a subtitler incorporated. Just use the vsfilter.dll I've linked to in a previous post, and be done with it. No more "madVR doesn't support subtitles" nonsense, please. This is the fourth time I write about this, but some people seem to have selective blindness.
Ok, it took me ages to get subtitles to work for 1080p MKV files, using DirectVobSub and Ffdshow.

When I try to play a file using MadVR it fails, with Haali it works.

Can you please start a thread on how to download/install/configure VSfilter? I can't even find a version newer than 2005...
Mark_A_W is offline   Reply With Quote
Old 18th May 2009, 04:01   #1093  |  Link
Hypernova
Registered User
 
Join Date: Feb 2006
Posts: 293
I tried reduce the number of process that's running, doesn't seem to help. I'll hope that fullscreen exclusive mode give me a better result.

About ffdshow dithering, I just try that and it doesn't seem to give me any better result on the color band that I posted before, so I'm still keep my eyes closed on madVR
__________________
Spec: Intel Core i5-3570K, 8g ram, Intel HD4000, Samsung U28D590 4k monitor+1080p Projector, Windows 10.
Hypernova is offline   Reply With Quote
Old 18th May 2009, 06:41   #1094  |  Link
jmonier
Registered User
 
Join Date: Oct 2008
Posts: 183
Quote:
Originally Posted by Mark_A_W View Post
I can't even find a version newer than 2005...
Here's the latest (2.39 - 11/2008):

http://sourceforge.net/project/showf...ease_id=541232
jmonier is offline   Reply With Quote
Old 18th May 2009, 08:05   #1095  |  Link
nlnl
Registered User
 
Join Date: Aug 2008
Posts: 176
MadVR 0.10 report
Nvidia 9400 IGP, Intel 8300/2.83Gh, Vista 32, 185.85 video driver, MPC-HC
display refresh rate 23.976
AERO ON

playing 1080p@23 NO RESIZING

display 23.976 correct and stable, time keeps growing (I have issues with 0.9 +185.85)
movie fps 23.976fps (says source filter)
decoder queue 16/16
upload queue 4-5/8
render queue 7-8/8
movie res 1920,1080
target rectangle 0,0,1920,1080

dropped frames stable
delayed frames stable

Playback is very smooth and colours are vivid!

Remark:
1) After seeking 'upload queue', 'render queue' show something strange like 8/8, 8/8
2) Issue with VC-1 WMV DMO decoder: 'delayed frames' and 'dropped frames' are progressing. And using MPC-HC internal VC-1 decoder everything is OK.
3) Tearing when Aero OFF.

Thank you madshi!

Last edited by nlnl; 18th May 2009 at 08:20.
nlnl is offline   Reply With Quote
Old 18th May 2009, 09:55   #1096  |  Link
yesgrey
Registered User
 
Join Date: Sep 2004
Posts: 1,295
Quote:
Originally Posted by Hypernova View Post
I tried reduce the number of process that's running, doesn't seem to help. I'll hope that fullscreen exclusive mode give me a better result.
With your graphics card, I think that even the fullscreen mode will not help you. Remember that madVR is shader based, and the old cards are not powerful enough in that area...
yesgrey is offline   Reply With Quote
Old 18th May 2009, 10:04   #1097  |  Link
Mark_A_W
3 eyed CRT supporter
 
Join Date: Jan 2008
Location: Or-strayl-ya
Posts: 563
Quote:
Originally Posted by yesgrey3 View Post
With your graphics card, I think that even the fullscreen mode will not help you. Remember that madVR is shader based, and the old cards are not powerful enough in that area...

Which is interesting, as according to the sig, Hypernova has a HD2600 Pro 512mb.

I have a HD2600XT 256mb, which is a tiny bit faster, and I have no problems at all. (But I am watching 1920x1080 material at 1920x1080, so only Chroma scaling).
Mark_A_W is offline   Reply With Quote
Old 18th May 2009, 10:26   #1098  |  Link
Mark_A_W
3 eyed CRT supporter
 
Join Date: Jan 2008
Location: Or-strayl-ya
Posts: 563
Quote:
Originally Posted by jmonier View Post
Here's the latest (2.39 - 11/2008):

http://sourceforge.net/project/showf...ease_id=541232

Thanks

But I'm already running it, it seems. DirectVobSub and VSfilter are the same thing.

It's not working for me, so there must be a configuration setting I'm missing - I'll play around.
Mark_A_W is offline   Reply With Quote
Old 18th May 2009, 10:29   #1099  |  Link
allak
Registered User
 
Join Date: Feb 2009
Posts: 47
Quote:
Originally Posted by cyberbeing View Post
You would have to ask in the MPC-HC thread for someone to fix that. I just checked and MPC Video decoder does seem to always output YUY2 when connecting to VSFilter. This is something outside of madshi's control.
Thanks for the confirmation. I am aware that this is something that madshi can't fix.

I will probably wait for madVR to support subs. I don't think it would be useful to add a workaround in MPC-HC for something that is going to be added to madVR anyway.
allak is offline   Reply With Quote
Old 18th May 2009, 11:02   #1100  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Okay i tested 0.10 on my system (4770 on w7 x64 RC1)

Here are the stats:

Display 60.000XXHz (YY) (XX this changes every few seconds, YY keeps gettting higher and higher)
Movie (accurately shows the correct value for each sample i tested)
Decoder queue 16 / 16
upload queue 4-5 / 8 (very rarely it will show 6 / 8)
render queue 8 / 8

Frames drop or delay only on startup and seek

Whats wierd though is that nothing will change these numbers, it doesnt matter if i use nearest neighbour or lancsoz 8

It also does not matter if i do or don't scale (up or down) the input resolution doesn't matter either

EDIT:

Wow wierdness, actually nearest neighbour shows 4/8 and lancsoz8 shows 5/8

EDIT2:

Could someone write a small tutorial on how to get subtitles working?

Last edited by tetsuo55; 18th May 2009 at 11:07.
tetsuo55 is offline   Reply With Quote
Reply

Tags
direct compute, dithering, error diffusion, madvr, ngu, nnedi3, quality, renderer, scaling, uhd upscaling, upsampling

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 04:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.