Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 24th December 2012, 09:16   #2881  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,399
You are using an AVI input container. MeGUI currently cannot extract the audio track from that container and therefore it must be converted.
Workaround: Convert your file in a MKV with mkvmerge (MeGUI\tools\mkvmerge\mmg.exe - just drag & drop your file into it and hit "start muxing")
Use this file as input in OneClick.
Zathor is offline  
Old 24th December 2012, 13:05   #2882  |  Link
Slasher
Registered User
 
Join Date: Oct 2011
Posts: 14
Um, how can I use the latest megui without needing to install that portable avs? I have avs 2.6 MT installed for using multithreaded qtgmc.
Slasher is offline  
Old 24th December 2012, 13:16   #2883  |  Link
Slasher
Registered User
 
Join Date: Oct 2011
Posts: 14
Quote:
Originally Posted by LigH View Post
They are not at all "associated with" MeGUI. MeGUI is only a user interface. Only controls to build an AviSynth script, a window to display a preview, and a job control to execute the command line encoders converting the script output. MeGUI itself does not need any DirectShow filters. The decoders used in the script may. That depends on the content of your script, the filetype of the original media being loaded... You wrote the script manually, so you are responsible for its dependencies. Not MeGUI.
"associated with" = "megui has open handles on those files", just to clear up the confusion

When I encode DVDs, avs contains (most used settings scenario):

SetMemoryMax(1024)
SetMTMode(5, 4)
LoadPlugin("path\dgmpgdec158\DGDecode.dll")
MPEG2Source(***)
SetMTMode(2)
QTGMC(settings)
SelectEven()
Crop()

When I encode H.264, avs contains (most used settings scenario):

LoadPlugin("path\ffms2.dll")
FFVideoSource(***)
Crop()
spline36resize()

Now I fail to see how the above avs scenarios could create dependencies with ac3filter, office groove, canon decoder and other seemingly random stuff.
Slasher is offline  
Old 24th December 2012, 13:29   #2884  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,399
Quote:
Originally Posted by Slasher View Post
Um, how can I use the latest megui without needing to install that portable avs? I have avs 2.6 MT installed for using multithreaded qtgmc.
The portable avs will only be "installed" (= copied in the MeGUI root directory) when needed, but it must be downloaded.
Zathor is offline  
Old 24th December 2012, 13:58   #2885  |  Link
Slasher
Registered User
 
Join Date: Oct 2011
Posts: 14
OK thank you.
Slasher is offline  
Old 24th December 2012, 19:50   #2886  |  Link
djmasturbeat
Registered User
 
Join Date: Oct 2008
Posts: 89
issues updating core (update bug?)

I am having an infinite loop of update notices for the core. Everything else updated correctly, but MeGUI keeps asking me to update core from 2153 to 2237, which I do, then it tells me MeGUI needs to restart. I say OK, but then it never starts up again, even if I wait an hour, lol. I finally manually restart and get same message.
I tried force reinstall as a context menu choice in the Update Window, but that didn't do anything differently.

If I can get you more info to help fix this bug, please let me know. I just don't know what you may need.
djmasturbeat is offline  
Old 24th December 2012, 20:36   #2887  |  Link
pureocean
Registered User
 
Join Date: Apr 2011
Posts: 13
@Zathor: Thank you for the information and MMG tip. I hope that the next releases will have more improvements.
Espically, Direct Stream Copy+Audio Copy parts easily that would be great.
pureocean is offline  
Old 25th December 2012, 01:17   #2888  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,399
Quote:
Originally Posted by djmasturbeat View Post
I am having an infinite loop of update notices for the core.
Sorry, no clue. In general it is working. Maybe some kind of AntiVirus tool is causing problems.
As a workaround you can use the 2237 file from the sourceforge page and copy it over your installation.
Zathor is offline  
Old 26th December 2012, 01:39   #2889  |  Link
unknownsoldierX
Registered User
 
Join Date: Jun 2005
Posts: 236
Had the same problem as djmasturbeat. Downloaded a fresh copy from sourceforge. When I run it, it automatically starts downloading updates for all components. The local date for every file is listed as 1/1/0001.

edit: Went back to an old version and disabled updates.

Last edited by unknownsoldierX; 26th December 2012 at 01:46.
unknownsoldierX is offline  
Old 26th December 2012, 05:22   #2890  |  Link
djmasturbeat
Registered User
 
Join Date: Oct 2008
Posts: 89
I disabled all AV/spyware and issue persisted, so that was not the issue that I can perceive.
There was some errors about the file downloading, but unable to download, and then errors aboutbeing unable to unpack the zip then unable to delete the zip. I looked and the zip was in the cache, too.
I watched it alternately at times use the main or backup server for update, both failed on core install.

edit, here is one of the logs
Code:
-[Information] [12/25/2012 5:13:44 PM] Updating core. File 1/3.
--[Information] [12/25/2012 5:13:44 PM] Could not unzip C:\MeGUI\update_cache\megui-core_2237.zip. Deleting file.
--[Error] [12/25/2012 5:13:44 PM] Could not delete file C:\MeGUI\update_cache\megui-core_2237.zip
--[Error] [12/25/2012 5:13:44 PM] Failed to download file core with error: CouldNotDownloadFile.
I tried removing the core from update_cache and then running it, but no dice.


I finally deleted my MeGUI directory other than my profiles and jobs and logs, and just unpacked the newest build.

For the record:
pretty fresh install of Windows7x64, with barely anything installed yet, not even ffdshow/haali or LAVF, etc. Mostly just DVD Decrypter, a stand alone stable MPC-HC and some browsers and AV/spyware, and the stuff for Mobo (mostly drivers).


I won't know if the bug persists till a new core is released for stable servers.

I suppose this should have gone here top start with, since I am using a vanilla MeGUI now, and this seems like a bug for MeGUI
http://forum.doom9.org/showthread.php?t=151159
apologies for misplaced post, but since I started it here, thought I would follow up here.

Last edited by djmasturbeat; 26th December 2012 at 05:53.
djmasturbeat is offline  
Old 26th December 2012, 11:46   #2891  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,399
Please upload the full log. I just tested also both update servers and was successfull.
Zathor is offline  
Old 26th December 2012, 13:03   #2892  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,756
Quote:
Originally Posted by FHeLLx View Post
Script Error: Invalid Arguments To Function "LanczosResize"
Knowing your script content would be useful to understand the reason for this issue. At least of the script line which contains this filter. But probably better the whole script, as it may depend on surrounding context.
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline  
Old 29th December 2012, 21:38   #2893  |  Link
djmasturbeat
Registered User
 
Join Date: Oct 2008
Posts: 89
Quote:
Originally Posted by Zathor View Post
Please upload the full log. I just tested also both update servers and was successfull.
full log (1 of many that are exactly the same):
Code:
[Error] Log
-[Information] Versions
--[Information] [12/24/2012 10:20:50 AM] MeGUI: 2153 (svn)
--[Information] [12/24/2012 10:20:50 AM] Operating System: Windows 7 Ultimate Edition x64 SP1 (6.1.65536.7601)
--[Information] [12/24/2012 10:20:50 AM] .Net Framework: 4.0 (4.0.0.0)
--[Information] [12/24/2012 10:20:50 AM] AviSynth: 2.5.8.5 (12/21/2008 9:46:54 PM)
--[Information] [12/24/2012 10:20:50 AM] AvisynthWrapper: 1/2/2009 8:34:04 PM
--[Information] [12/24/2012 10:20:50 AM] ICSharpCode.SharpZipLib: 0.85.5.452 (8/8/2008 2:31:12 AM)
--[Information] [12/24/2012 10:20:50 AM] LinqBridge: 1.0.0.0 (5/28/2009 7:24:34 AM)
--[Information] [12/24/2012 10:20:50 AM] MediaInfo: 0.7.61.0 (10/21/2012 4:29:05 PM)
--[Information] [12/24/2012 10:20:50 AM] MediaInfoWrapper: 0.7.53.0 (8/23/2012 2:33:43 PM)
--[Information] [12/24/2012 10:20:50 AM] MessageBoxExLib: 1.0.2218.28317 (12/20/2008 2:53:04 AM)
--[Information] [12/24/2012 10:20:50 AM] SevenZipSharp: 0.64.3890.29348 (1/2/2011 4:59:32 PM)
--[Information] [12/24/2012 10:20:50 AM] 7z: 9.20 (11/18/2010 10:27:34 PM)
-[Error] Update detection
--[Information] [12/24/2012 10:20:51 AM] Connecting to server: http://megui.org/auto/stable/
--[Information] [12/24/2012 10:20:52 AM] There is 1 file which can be updated.
--[Information] [12/24/2012 10:24:05 AM] Updating core. File 1/1.
--[Information] [12/24/2012 10:24:05 AM] Could not unzip C:\MeGUI\update_cache\megui-core_2237.zip. Deleting file.
--[Error] [12/24/2012 10:24:05 AM] Could not delete file C:\MeGUI\update_cache\megui-core_2237.zip
--[Error] [12/24/2012 10:24:05 AM] Failed to download file core with error: CouldNotDownloadFile.
--[Information] [12/24/2012 10:24:05 AM] Update completed
--[Error] [12/24/2012 10:24:05 AM] Files which have been not sucessfully updated: 1

Last edited by djmasturbeat; 29th December 2012 at 21:40.
djmasturbeat is offline  
Old 30th December 2012, 10:40   #2894  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,399
Do you still have the problem? I have fixed it several days ago.
Zathor is offline  
Old 3rd January 2013, 13:25   #2895  |  Link
Slasher
Registered User
 
Join Date: Oct 2011
Posts: 14
Quote:
Originally Posted by Zathor View Post
The portable avs will only be "installed" (= copied in the MeGUI root directory) when needed, but it must be downloaded.
When using MT functions in the script megui says there's no such thing. I had to copy avisynth.dll (Set's 2.6 MT) into the avs directory of megui.

Means that even though I had avs installed and configured, megui still used its version.
Slasher is offline  
Old 3rd January 2013, 15:05   #2896  |  Link
Zathor
Registered User
 
Join Date: Nov 2009
Posts: 2,399
Please post your log (the version part)
Zathor is offline  
Old 7th January 2013, 20:32   #2897  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 5,756
There is now a quite big leap in the version number of MP4Box used by MeGUI (from 0.4.6-DEV-rev2735 to 0.5.1-DEV-rev4234:4272M).

Was it just time to do something, or are there specific new features MeGUI will take care of now?
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline  
Old 8th January 2013, 10:12   #2898  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
better apple devices support...

The last MP4Box version adds eac3 files support + mvc/svc + few others things (not supported into megui though).

Last edited by Kurtnoise; 8th January 2013 at 10:20.
Kurtnoise is offline  
Old 8th January 2013, 12:56   #2899  |  Link
dj-big
Registered User
 
Join Date: Oct 2012
Posts: 25
hei i start encoding 4 mkv videos 2 of them have very similar size but the others have 150mb difrence i use oneclick encode and the settings are all the same the source is same for all and the size of source are similar why i have this problem last befor . why some files are much bigger than others? how can i fix this i want all have similar size i dont care about 10 mb but 100or150 is to high i user 2passencode with bitrate mode and i dont want to user filesize limit each time i want to encode is there any solution in settings to encode all files in similar size ?

Last edited by dj-big; 8th January 2013 at 13:00.
dj-big is offline  
Old 8th January 2013, 14:09   #2900  |  Link
Kurtnoise
Swallowed in the Sea
 
Kurtnoise's Avatar
 
Join Date: Oct 2002
Location: Aix-en-Provence, France
Posts: 5,183
Kurtnoise is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:33.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.