Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Subtitles

Reply
 
Thread Tools Search this Thread Display Modes
Old 11th October 2008, 03:32   #581  |  Link
Gokumon
Guest
 
Posts: n/a
I don't know if anyone will be interested but I am rewriting and refactoring SubRip into C# with an end goal of having it be able to run on Mono. I'll hopefully have something up and running in a few weeks but I can't make any guarantees as, like ai4spam has said previously, the current code base for SubRip is a big mess.
  Reply With Quote
Old 18th October 2008, 11:25   #582  |  Link
avivahl
Registered User
 
Join Date: Dec 2007
Posts: 215
Quote:
Originally Posted by Gokumon View Post
I don't know if anyone will be interested but I am rewriting and refactoring SubRip into C# with an end goal of having it be able to run on Mono. I'll hopefully have something up and running in a few weeks but I can't make any guarantees as, like ai4spam has said previously, the current code base for SubRip is a big mess.
A C# rewriting would be an amazing project.
avivahl is offline   Reply With Quote
Old 19th October 2008, 01:27   #583  |  Link
Gokumon
Guest
 
Posts: n/a
Quote:
Originally Posted by avivahl View Post
A C# rewriting would be an amazing project.
Yeah, I hope to end up with something rather nice and easy to work with. It's just been so far a slow and tedious process getting stuff translated over.
  Reply With Quote
Old 20th October 2008, 13:01   #584  |  Link
kabster
Registered User
 
kabster's Avatar
 
Join Date: Jun 2007
Posts: 80
Quote:
Originally Posted by picrade View Post
Well, all I can say is that I have used SubRip at least 100 times and never had any synch problem.
I use Maestro as authoring tool and extract bitmaps directly from DVD (.son format). I rarely use .srt or the OCR.
Thats very VerRY hard to believe, not to say complete nonesens!

Quote:
Originally Posted by picrade View Post
Not seeing exactly what you are doing it is difficult to say what the problem is.
Wot iam doing is probebly just the same as you woud do to get the subs!! Meaning , either using OCR (save to text) or Demux (save as bmp/sup) !! NOt many options left are there !!
I read emm strait from my hard drive (video_ts) folder !!

Quote:
Originally Posted by picrade View Post
Is that delay of 700ms the same in every DVD you reauthor?
Are they PAL or NTSC format? (Mine is NTSC)
Not always that amount of time no... And it happends BOTH whit PAL and NTSC sources!!!
Its realy strange how i most of the time A+L+W+A+Y+S need to RE-Synch them after ripped the original subs to keep them playing in synch whit the movie through MPC6. And when i need and convert them to .stl format ( meastro) ill need to synchronize them again by adding delay's through time correction !!!!!!!?

Quote:
Originally Posted by picrade View Post
Give the title of a few movies you have this trouble with.
Post the timings of the first and last subtitles from the .son file when you extract directly from the DVD.
Open the DVD in DVDSubEdit, full domain, and post the timings of the first and last subs from the same stream as in the .son file.
I dont have a direct stream, as its uselless to import them in meastro because of the synch problem you know!! But i can give you an comparison of .srt ripped subs yes..

And SubEdit somehow suffers the same fate !! I need submagic to re-synch them almost everytime!!


For wot its worth ill give you an fresh ripped english stream from the movie " Journey to the center of the earth 2008". This stream needed to be synchronized aswell by removing ALMOST A WHOLE MINUTE


This is orginal ripped untouched sub (not playing in synch)

Code:
Start time:

00:01:58,383 --> 00:02:00,551
Trevor!

End time:
01:26:49,216 --> 01:26:50,817
Come on.
And now the timings from an perfectly good re-synched subtitle:

Code:
Start time:
00:01:08,983 --> 00:01:11,151
Trevor.

End Time:
01:25:59,816 --> 01:26:01,816
Come on.

Now, iam not sure wots going on here !! But DVdSubedit shows the first line (star time) of the ripped sub in question at 00:01:07 !!!

But once i save it to a file and re-open the sub instead of 1:07 minute it shows 1:58 minutes !!!!?

So, theres something realy WEIRD going on there !!!

Still not fixed whit the latest release of subedit 1.5 !!


rgds,

kabster,
kabster is offline   Reply With Quote
Old 1st November 2008, 05:19   #585  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
Quote:
Originally Posted by Gokumon View Post
I don't know if anyone will be interested but I am rewriting and refactoring SubRip into C# with an end goal of having it be able to run on Mono. I'll hopefully have something up and running in a few weeks but I can't make any guarantees as, like ai4spam has said previously, the current code base for SubRip is a big mess.
That's a bit of an understatement . Good luck re-coding. I suggest you start by using some C source from guliverkli: http://sourceforge.net/projects/guliverkli/. That will give you C code that reads and writes .idx/.sub files properly (VSRip http://sourceforge.net/project/showf...ckage_id=84442), and even does OCR (SubResync). Obviously a lot of things will still be missing, but it's a start.

To everyone else: sorry for the lack of updates, I have too much going on in my life right now and no time to deal with this mess. I have a more advanced beta version that I use, with character matrix synthesis and rudimentary/incomplete support for external OCR engines, but it's too buggy to release and I haven't touched the code in months. If anyone wants to try their luck at it, email me.
ai4spam is offline   Reply With Quote
Old 1st November 2008, 16:32   #586  |  Link
vartaxe
Registered User
 
Join Date: Dec 2007
Posts: 6
release those buggy builds mate
vartaxe is offline   Reply With Quote
Old 2nd November 2008, 06:08   #587  |  Link
JoeBG
stupid
 
JoeBG's Avatar
 
Join Date: Sep 2004
Location: Cologne
Posts: 638
Quote:
Originally Posted by Gokumon View Post
I don't know if anyone will be interested but I am rewriting and refactoring SubRip into C# with an end goal of having it be able to run on Mono.
This would be really great. Many people are waiting for it.
__________________
cu

Joe
------------------------
freedom is just another word for nothing left to loose
JoeBG is offline   Reply With Quote
Old 8th November 2008, 18:51   #588  |  Link
Gokumon
Guest
 
Posts: n/a
Quote:
Originally Posted by ai4spam View Post
That's a bit of an understatement . Good luck re-coding.
Thanks, it's definitely been far harder than I thought just to do the initial translating of the code to C#.

Quote:
Originally Posted by ai4spam View Post
I suggest you start by using some C source from guliverkli: http://sourceforge.net/projects/guliverkli/. That will give you C code that reads and writes .idx/.sub files properly (VSRip http://sourceforge.net/project/showf...ckage_id=84442), and even does OCR (SubResync). Obviously a lot of things will still be missing, but it's a start.
Where are the actually source files for VSRip? All that it has on the site is the compiled dll.

Quote:
Originally Posted by ai4spam View Post
To everyone else: sorry for the lack of updates, I have too much going on in my life right now and no time to deal with this mess. I have a more advanced beta version that I use, with character matrix synthesis and rudimentary/incomplete support for external OCR engines, but it's too buggy to release and I haven't touched the code in months. If anyone wants to try their luck at it, email me.
I would definitely be interested in the source.

ETA: Oops, I found the source. I forgot about having to click the more tab in SourceForge for it to bring up the code tab.

Last edited by Gokumon; 8th November 2008 at 19:02.
  Reply With Quote
Old 8th November 2008, 19:01   #589  |  Link
Gokumon
Guest
 
Posts: n/a
Quote:
Originally Posted by JoeBG View Post
This would be really great. Many people are waiting for it.
Hehe well if the current pace of work continues it may either be close to the end of the year or early next year before I get a working test build done. Not only is the source difficult at times to work but it's been something of a big learning curve in figuring out what exactly is happening, as I've never done any work with subtitles before, to make sure that none of the functionality gets broken as I translate it over. This is making my progress a bit slower than I expected, but as soon as I have something ready that people can use I will post it. I will try to keep people informed on my progress as it goes along.

Last edited by Gokumon; 8th November 2008 at 19:06.
  Reply With Quote
Old 14th December 2008, 22:31   #590  |  Link
odyssey
Registered User
 
Join Date: Dec 2003
Posts: 155
I've ripped idx/sub files from mplayer and they work perfectly when I mux them and playback, but they appear corrupt when I open them in SubRip. Some lines appear with interlacing-like artefacts and other lines are completely unreadable and with wrong colors etc.

Why is this? Can I fix it somehow?
odyssey is offline   Reply With Quote
Old 15th December 2008, 14:42   #591  |  Link
muci
Registered User
 
Join Date: Mar 2006
Posts: 6
Hy! Can someone tell me what should I do when I get letters like these?


I'm using 1.40, tried with 1.50 and it's the same.
muci is offline   Reply With Quote
Old 15th December 2008, 22:33   #592  |  Link
odyssey
Registered User
 
Join Date: Dec 2003
Posts: 155
Quote:
Originally Posted by muci View Post
Hy! Can someone tell me what should I do when I get letters like these?
They look pretty much the same as the one I'm referring to in my last post.
odyssey is offline   Reply With Quote
Old 16th December 2008, 10:03   #593  |  Link
muci
Registered User
 
Join Date: Mar 2006
Posts: 6
Did you find a solution?
muci is offline   Reply With Quote
Old 16th December 2008, 16:22   #594  |  Link
odyssey
Registered User
 
Join Date: Dec 2003
Posts: 155
No, as you can see noone has replied...

How did you get these subs?
odyssey is offline   Reply With Quote
Old 16th December 2008, 17:42   #595  |  Link
muci
Registered User
 
Join Date: Mar 2006
Posts: 6
They're on DVD (vob, ifo files). Strange, I never had a problem with Subrip before.
muci is offline   Reply With Quote
Old 30th December 2008, 20:06   #596  |  Link
ai4spam
Programmer
 
ai4spam's Avatar
 
Join Date: Sep 2003
Posts: 378
Well, the general recommendation is to try "Change text color" and select ONLY the text, without outlines.
In your situation, it may be the case that the text color just happens to LOOK the same as the background, but recognition works anyway.
ai4spam is offline   Reply With Quote
Old 25th January 2009, 13:40   #597  |  Link
LeXXuz
16 years and counting...
 
LeXXuz's Avatar
 
Join Date: Oct 2002
Location: Germany
Posts: 231
Quote:
Originally Posted by odyssey View Post
I've ripped idx/sub files from mplayer and they work perfectly when I mux them and playback, but they appear corrupt when I open them in SubRip. Some lines appear with interlacing-like artefacts and other lines are completely unreadable and with wrong colors etc.

Why is this? Can I fix it somehow?
I have exactly the same problem with almost all vobsub files. I have to convert all my encodes with vobsub files to srt, because WD TV Player does not accept picture based subtitle files.

The subs look like in this screenshot:


When I play these subs on my Tvix Box or with mpc+vsfilter they look just fine.

Any ideas?
LeXXuz is offline   Reply With Quote
Old 25th January 2009, 14:23   #598  |  Link
manusse
SubtitleCreator's Co-Dev
 
manusse's Avatar
 
Join Date: Oct 2005
Location: France
Posts: 579
Hi,

Could you please post the problematic sub/idx file.
(post a link to rapidshare or similar)

Thanks
Manusse
manusse is offline   Reply With Quote
Old 25th January 2009, 14:43   #599  |  Link
LeXXuz
16 years and counting...
 
LeXXuz's Avatar
 
Join Date: Oct 2002
Location: Germany
Posts: 231
Quote:
Originally Posted by manusse View Post
Hi,

Could you please post the problematic sub/idx file.
(post a link to rapidshare or similar)

Thanks
Manusse
No problem. Here you go:
http://rapidshare.com/files/189209258/subs.rar

I put 5 different subfiles into that archive. They all look more or less distorted in SubRip.
LeXXuz is offline   Reply With Quote
Old 25th January 2009, 17:20   #600  |  Link
manusse
SubtitleCreator's Co-Dev
 
manusse's Avatar
 
Join Date: Oct 2005
Location: France
Posts: 579
@LeXXuz and muci

Try this: http://forum.doom9.org/showthread.ph...09#post1178709

Cheers
Manusse
manusse is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 05:32.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.