Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 28th June 2009, 10:15   #8481  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Yeah Real-Life(TM) has cought up with everyone (madshi is missing too)

Realistically i would say all volunteer open source programs like this one will see slow developement over the summer (due to vacations and extra work at the office due to others taking vacations)

I'm on vacation right now actually!


Quote:
Originally Posted by bur View Post
I still have this bug with VMR9 freezing after hibernate or fullscreen applications and did file it at sourceforge a couple of weeks ago. Any idea if this will be fixed any time soon?

Are there others with that problem as well, or is it just me?

I don't want to annoy the devs, it's just that I'd like to know if I can expect this to be fixed in the next month or rather this year? So I don't check sourceforge every few days...
don't expect this to be fixed any time soon, the bug is elusive, as far as the dev's can see we follow the windows hibernation guidelines to the letter.
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC

Last edited by tetsuo55; 28th June 2009 at 10:17.
tetsuo55 is offline  
Old 28th June 2009, 20:34   #8482  |  Link
ADude
Registered User
 
Join Date: Nov 2007
Posts: 340
Quote:
Originally Posted by tetsuo55 View Post
Yeah Real-Life(TM) has cought up with everyone (madshi is missing too)

Realistically i would say all volunteer open source programs like this one will see slow developement over the summer (due to vacations and extra work at the office due to others taking vacations)

I'm on vacation right now actually!
All that is just fine.

My only concern was when I heard some desire to rush out a new "stable" release that has not been adequately tested.

I'm in no rush, fall would be fine...
__________________
s/w: Vista Home Basic 32bit (no Aero), MPC-HC, EVR Custom Presenter, CoreAVC Pro, ffdshow, SPDIFer
h/w: Antec 2480 case, Gigabyte GA-MA69GM-S2H, 4200+, 2.5gb+512mb, ATI x1250 IGP, MS MCE remote
ADude is offline  
Old 29th June 2009, 14:03   #8483  |  Link
Mixer73
Registered User
 
Join Date: Nov 2007
Posts: 239
Quote:
Originally Posted by tetsuo55 View Post
don't expect this to be fixed any time soon, the bug is elusive, as far as the dev's can see we follow the windows hibernation guidelines to the letter.
I'd wager this is a driver problem relating to hibernation rather than MPC bug.
Mixer73 is offline  
Old 29th June 2009, 16:27   #8484  |  Link
DrNein
Registered User
 
Join Date: Sep 2002
Posts: 145
Quote:
Originally Posted by mark0077 View Post
hmm oddly no.... might have to try vista.
Indeed, with XP, "VMR9 renderless" and "EVR Custom Pres." cause awful tearing and pixelization.

So, simply use "VMR7 windowed" ("System Default" should also result in same). It has the best quality and features with the only exception being losing DXVA when subtitles are present. In that case, a seperate configuration using "VMR9 renderless" can be used with a shortcut on the Send To menu.
DrNein is offline  
Old 29th June 2009, 19:32   #8485  |  Link
ADude
Registered User
 
Join Date: Nov 2007
Posts: 340
Quote:
Originally Posted by Sharc View Post
UAC disabled:
When trying to playback a DVD rip from HD, MPC produces the error: DVD Incompatible Disc and Decoder Regions.

UAC enabled:
Playback with MPC works as expected

Is there no other solution than always enabling UAC just for playback a DVD with MPC (or WMP) from HD?
No one ever answered this, perhaps clsid has some insight ?

I just encountered the same thing, using a rip from a DVD that I own:

- MPC plays the DVD fine.
- MPC has the above error when asked to play the rip.
- VLC will play the rip fine.
__________________
s/w: Vista Home Basic 32bit (no Aero), MPC-HC, EVR Custom Presenter, CoreAVC Pro, ffdshow, SPDIFer
h/w: Antec 2480 case, Gigabyte GA-MA69GM-S2H, 4200+, 2.5gb+512mb, ATI x1250 IGP, MS MCE remote
ADude is offline  
Old 29th June 2009, 21:17   #8486  |  Link
mark0077
Registered User
 
Join Date: Apr 2008
Posts: 1,055
Quote:
Originally Posted by ADude View Post
No one ever answered this, perhaps clsid has some insight ?

I just encountered the same thing, using a rip from a DVD that I own:

- MPC plays the DVD fine.
- MPC has the above error when asked to play the rip.
- VLC will play the rip fine.
Are you trying to play the disk from an external drive. Vista has some strange bug that playing dvd rips that are residing on external drives won't work properly in some players.
mark0077 is offline  
Old 29th June 2009, 21:41   #8487  |  Link
starla_
Registered User
 
Join Date: May 2009
Posts: 11
Quote:
Originally Posted by mark0077 View Post
Are you trying to play the disk from an external drive. Vista has some strange bug that playing dvd rips that are residing on external drives won't work properly in some players.
In Vista MS DVD Navigator doesn't allow playing DVDs from external hard disk. So it is intended behavior and players that are failing are most likely using MS DVD Navigator as source fitler.
starla_ is offline  
Old 29th June 2009, 22:09   #8488  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by starla_ View Post
In Vista MS DVD Navigator doesn't allow playing DVDs from external hard disk. So it is intended behavior and players that are failing are most likely using MS DVD Navigator as source fitler.
unfortunately that is the only navigator that will work with mpc
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 30th June 2009, 05:15   #8489  |  Link
ADude
Registered User
 
Join Date: Nov 2007
Posts: 340
Yes, external drive, thanks for the replies !

Copying to internal drive is a simple workaround.
__________________
s/w: Vista Home Basic 32bit (no Aero), MPC-HC, EVR Custom Presenter, CoreAVC Pro, ffdshow, SPDIFer
h/w: Antec 2480 case, Gigabyte GA-MA69GM-S2H, 4200+, 2.5gb+512mb, ATI x1250 IGP, MS MCE remote
ADude is offline  
Old 30th June 2009, 05:49   #8490  |  Link
kumi
Straight to video
 
kumi's Avatar
 
Join Date: Jun 2005
Posts: 637
Quote:
Originally Posted by starla_ View Post
In Vista MS DVD Navigator doesn't allow playing DVDs from external hard disk.
That is ridiculous. Is it the same in Windows 7 RC1?
__________________
.
kumi is offline  
Old 30th June 2009, 18:42   #8491  |  Link
starla_
Registered User
 
Join Date: May 2009
Posts: 11
Quote:
Originally Posted by kumi View Post
That is ridiculous. Is it the same in Windows 7 RC1?
Wouldn't be suprised if Hollywood was behind such request. After all, no original DVD is delivered as a folder on a hard disk :P
starla_ is offline  
Old 30th June 2009, 18:46   #8492  |  Link
starla_
Registered User
 
Join Date: May 2009
Posts: 11
Quote:
Originally Posted by tetsuo55 View Post
unfortunately that is the only navigator that will work with mpc
Maybe it's time to fix MPC-HC ? What kind of issues MPC-HC has with other DVD navigators?

If it is only menu issues then the sollution is following: DVD navigator should be always used with corresponding MPEG2 decoder (Cyberlink's DVD Navigator with Cyberlink's MPEG2 codec, Vista MS DVD Navigator with Vista's MPEG2 decoder etc.). This is how it works perfectly in MediaPortal. Mixing the decoder and navigator filters causes just lot of non-working DVD manus.
starla_ is offline  
Old 30th June 2009, 19:56   #8493  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Can anyone check that with MPC?

"matching decoder and navigator"
__________________
MPC-HC, an open source project everyone can improve. Want to help? Test Nightly Builds, submit patches or bugs and chat on IRC
tetsuo55 is offline  
Old 30th June 2009, 20:48   #8494  |  Link
Inspector.Gadget
Registered User
 
Join Date: May 2008
Posts: 1,618
Setting the Cyberlink navigator and decoder to preferred here and block the Microsoft ones allows the use of the decoder but still appears to use the MS navigator.
Inspector.Gadget is offline  
Old 1st July 2009, 17:13   #8495  |  Link
v0lt
Registered User
 
Join Date: Dec 2008
Posts: 1,080
А fix for On top->While Playing mode, when the user stops the play by space botton:
Code:
void CMainFrame::OnPlayPauseI()
{
	if(m_iMediaLoadState == MLS_LOADED)
	{
		//I cut this line:
		//SetAlwaysOnTop(AfxGetAppSettings().iOnTop);

		if(m_iPlaybackMode == PM_FILE)
		{
			pMC->Pause();
		}
		else if(m_iPlaybackMode == PM_DVD)
		{
			pMC->Pause();
		}
		else if(m_iPlaybackMode == PM_CAPTURE)
		{
			pMC->Pause();
		} 

		SetTimer(TIMER_STREAMPOSPOLLER, 40, NULL);
		SetTimer(TIMER_STREAMPOSPOLLER2, 500, NULL);
		SetTimer(TIMER_STATS, 1000, NULL);

		//and paste where
		SetAlwaysOnTop(AfxGetAppSettings().iOnTop);
	}

	MoveVideoWindow();
	m_Lcd.SetStatusMessage(ResStr(IDS_CONTROLS_PAUSED), 3000);
	SetPlayState (PS_PAUSE);
}
it's work. look please.

Last edited by v0lt; 1st July 2009 at 17:57. Reason: fix post
v0lt is offline  
Old 1st July 2009, 19:17   #8496  |  Link
Duker
Registered User
 
Join Date: Jun 2009
Posts: 2
Hi,

MPC can play Canon 5D Mark II Movies (H264 MOV), but without audio.

here is a sample:
http://rapidshare.com/files/250770170/MVI_0823.MOV.html

I get this error:


MVI_0823.MOV::Output 2

Media Type 0:
--------------------------
Audio: 0x0000 44100Hz stereo

AM_MEDIA_TYPE:
majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
subtype: Unknown GUID Name {74776F73-0000-0010-8000-00AA00389B71}
formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
bFixedSizeSamples: 1
bTemporalCompression: 0
lSampleSize: 1
cbFormat: 94

WAVEFORMATEX:
wFormatTag: 0x0000
nChannels: 2
nSamplesPerSec: 44100
nAvgBytesPerSec: 0
nBlockAlign: 4
wBitsPerSample: 16
cbSize: 76 (extra bytes)

pbFormat:
0000: 00 00 02 00 44 ac 00 00 00 00 00 00 04 00 10 00 ....DŽ..........
0010: 4c 00|00 00 00 4c 73 6f 77 74 00 00 00 00 00 00 L....Lsowt......
0020: 00 01 00 01 00 00 00 00 00 00 00 02 00 10 00 00 ................
0030: 00 00 ac 44 00 00 00 00 00 01 00 00 00 02 00 00 ..ŽD............
0040: 00 04 00 00 00 02 00 00 00 18 63 68 61 6e 00 00 ..........chan..
0050: 00 00 00 65 00 02 00 00 00 00 00 00 00 00 ...e..........
Duker is offline  
Old 1st July 2009, 20:05   #8497  |  Link
her34
Registered User
 
Join Date: Dec 2008
Posts: 28
ogg videos don't play in mpc

sample:
http://www.mozilla.com/en-US/firefox...refox-3.5.html
her34 is offline  
Old 1st July 2009, 20:15   #8498  |  Link
Leak
ffdshow/AviSynth wrangler
 
Leak's Avatar
 
Join Date: Feb 2003
Location: Austria
Posts: 2,441
Quote:
Originally Posted by her34 View Post
ogg videos don't play in mpc

sample:
http://www.mozilla.com/en-US/firefox...refox-3.5.html
I've downloaded the OGV file that's linked to on that page, and it plays just fine with MPC-HC's built-in Theora and Vorbis decoders...

np: Sascha Funke - Double-Checked (Mango)
__________________
now playing: [artist] - [track] ([album])
Leak is offline  
Old 1st July 2009, 20:23   #8499  |  Link
Keiyakusha
契約者
 
Keiyakusha's Avatar
 
Join Date: Jun 2008
Posts: 1,571
Same here. Works fine.
Keiyakusha is offline  
Old 1st July 2009, 20:33   #8500  |  Link
_xxl
ffdshow user
 
_xxl's Avatar
 
Join Date: Oct 2005
Location: Romania
Posts: 818
Quote:
Setting the Cyberlink navigator and decoder to preferred here and block the Microsoft ones allows the use of the decoder but still appears to use the MS navigator.
If I remember correctly MS DVD navigator is hard coded to be used in mpc. I have tested some time ago and found that Nero and Cyberlink Navigator can be used in MPC.
_xxl is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.