Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 11th September 2009, 08:00   #2001  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
@Sharc

thanks, i'll try to debug the called fuctions

@Chengbin

it can copy audio from avi if allowd muxing in mkv, BUT not in multiqueue.

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 11th September 2009, 12:14   #2002  |  Link
Chengbin
Registered User
 
Join Date: Oct 2007
Posts: 1,059
Before you can copy audio from AVI without muxing to MKV. I tried the "painful" way of building the queue.
Chengbin is offline   Reply With Quote
Old 11th September 2009, 20:25   #2003  |  Link
paolo1983
Registered User
 
Join Date: Oct 2008
Posts: 46
Hi, I just do another test, without specifying 1100MB, leaving your default 700MB and I must say it looks very good...
I think I will left your default setting :-)

1)
when I asked about automkv, you said that adding removegrain gives better results...
Should I just enable it in advanced options ?

2)
Manual says in AVI container you can mux only SRT (textual) subtitles.
Subtitles from DVDs are graphical? There is a simple way to make xvid with subtitles not encrusted, starting from dvd?

3)
xvid_encraw.exe process on my PC don't saturate the CPU...
It stays about 70% ...
I have an athlon64x2 4200+ , it's not a monster, but I'd like to use ALL its power :-)

4)
eac3to says in its output log:
[a05] The Nero decoder doesn't seem to work, will use libav instead.

5)
I cannot find a way, eg. a checkbox, to save a logfile of the whole encoding.
paolo1983 is offline   Reply With Quote
Old 11th September 2009, 21:57   #2004  |  Link
Jaspa
Registered User
 
Join Date: Mar 2002
Location: Austria
Posts: 40
Have problems now with the correct display ar or movie ar when analyzing dvd sources.

example lotr pal dvd i am getting somthing like this

Input File: d:\fulldisc\lotr_two_towers_see_d1\video_ts\vts_01_1.vob ( D:\FullDisc\LOTR_TWO_TOWERS_SEE_D1\VIDEO_TS\VTS_01_0.IFO )
PGC : PGC 1. Length: 1:42:11:06 / chained=1
Codec Video: mpeg
Width / Heigh : 720 / 576
Framerate / Framecount: 25.000 / 153275
Duration(hh:mm:ss): 1:42:12
Aspect Ratio: 1.3334
Resized resolution: 716 / 384
Crop Values : 2:80:2:80

dont know whats the problem, i worked in the past perfect!
Ascept Ratio should be 2.35:1


All ripped with DVdfab in Full disc mode
Jaspa is offline   Reply With Quote
Old 11th September 2009, 22:07   #2005  |  Link
whipdancer
Registered User
 
Join Date: Jul 2009
Posts: 104
1 success, 1 failure

@buzzqw

I will be trying out the fix you put in back here (Here's the post

I created the chapter file myself, and then ran the last line in the bat file and the result looks very good. I'll update later tonight if the fix works as well.
whipdancer is offline   Reply With Quote
Old 12th September 2009, 09:51   #2006  |  Link
Sharc
Registered User
 
Join Date: May 2006
Posts: 3,239
@buzzqw
There seems to be a bug with the -par for the XviD encoder when I want to resize a video with the original -par of 1:1 to an DVD compliant anamorphic shape.
For example, when I crop and resize a .m2ts with an original --sar of 1:1 and tick Anamorphic Shape, the -par for the XviD command line appears as -par 0:0, and XviD_encraw crashes.
(When doing similar with an original anamorphic video, the -par is recalculated correctly).

Secondly, I have to use AVIMux-GUI v1.17.7, because v1.17.8 which comes with HDC crashes when called from HDC. I am on Vista, and it is known from the AVIMux documentation that v1.17.8 must be run in XP compatibility mode. I enabled XP compatibility mode and can start AVIMux_GUI manually, however it always crashes when HDC wants to start it. Don't know if you can do much about it. Anyway, I can live with the former version 1.17.7 as I don't think that the update to 1.17.8 is critical.

Last edited by Sharc; 13th September 2009 at 12:13.
Sharc is offline   Reply With Quote
Old 14th September 2009, 07:39   #2007  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
Quote:
Originally Posted by paolo1983 View Post
1)
when I asked about automkv, you said that adding removegrain gives better results...
Should I just enable it in advanced options ?
HDC will default use HQDN3D.. so.. use removegrain if needed

Quote:
Manual says in AVI container you can mux only SRT (textual) subtitles.
Subtitles from DVDs are graphical? There is a simple way to make xvid with subtitles not encrusted, starting from dvd?
must use mkv container (xvid+avi+graphical subs)

Quote:
3)xvid_encraw.exe process on my PC don't saturate the CPU...
It stays about 70% ...
I have an athlon64x2 4200+ , it's not a monster, but I'd like to use ALL its power :-)
much depends on filters and source.. sorry pal i cannot make it faster

Quote:
eac3to says in its output log:
[a05] The Nero decoder doesn't seem to work, will use libav instead.
don't worry libav is good on decoding

Quote:
I cannot find a way, eg. a checkbox, to save a logfile of the whole encoding.
[/quote]
you are right. isn't possible to save log (and will not be possible)

Quote:
Originally Posted by Jaspa View Post
Have problems now with the correct display ar or movie ar when analyzing dvd sources.

Input File: d:\fulldisc\lotr_two_towers_see_d1\video_ts\vts_01_1.vob ( D:\FullDisc\LOTR_TWO_TOWERS_SEE_D1\VIDEO_TS\VTS_01_0.IFO )
PGC : PGC 1. Length: 1:42:11:06 / chained=1
Codec Video: mpeg
Width / Heigh : 720 / 576
Framerate / Framecount: 25.000 / 153275
Duration(hh:mm:ss): 1:42:12
Aspect Ratio: 1.3334
Resized resolution: 716 / 384
Crop Values : 2:80:2:80

dont know whats the problem, i worked in the past perfect!
Ascept Ratio should be 2.35:1


All ripped with DVdfab in Full disc mode
ar is computed from crop values, try to crop less (or more)

Quote:
Originally Posted by Sharc View Post
@buzzqw
There seems to be a bug with the -par for the XviD encoder when I want to resize a video with the original -par of 1:1 to an DVD compliant anamorphic shape.
please redownload sharc-beta

Quote:
Secondly, I have to use AVIMux-GUI v1.17.7, because v1.17.8 which comes with HDC crashes when called from HDC. I am on Vista, and it is known from the AVIMux documentation that v1.17.8 must be run in XP compatibility mode.
thanks, good to know

about your queue bug: are you using drag&drop ???

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 14th September 2009, 17:59   #2008  |  Link
Sharc
Registered User
 
Join Date: May 2006
Posts: 3,239
Quote:
Originally Posted by buzzqw View Post

please redownload sharc-beta
The NVTools deinterlacing is working now

There is however still an issue with the -par for XviD.
When I resize the original .m2ts to say 720 x 576 by manually overtyping the Height and ticking Anamorphic Shape, the par which is conveyed to the encoder is still 1:1, i.e. it is not recalculated according to my cropping and resizing.
(It should be calculated the same way as the --sar for x264).
Sharc is offline   Reply With Quote
Old 15th September 2009, 06:56   #2009  |  Link
DMagic1
Registered User
 
DMagic1's Avatar
 
Join Date: Dec 2002
Posts: 504
I've been going thru the topic with very little luck. I'm trying to convert mkv to wmv and it never encodes. It seems to stop after the audio part. I've seen a few others have similar problems but I never saw a solution posted. Even with the link to the other topic there wasnt a solution just people started to ask the person why he is using wmv.

Am I missing something with the wmv conversions? The avs files play fine and converting to mp4 worked ok too.

Any help would be great. I've converted in the past with WMNicEnc with good success. I'm running a Vista maching with all tools installed. I have checked my settings in ffdshow too.
DMagic1 is offline   Reply With Quote
Old 15th September 2009, 07:33   #2010  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
@Sharc

i don't think i fully understud.. the code is the same for both encoding.. could you redownload the sharc beta ?
i added a quick wannabe fix

@DMagic1
could you post the make report ?
also, opent the avs script with virtualdub , got errors ?
try with 2 channels, and without normalize

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 15th September 2009, 14:32   #2011  |  Link
Mrsash
Registered User
 
Join Date: Jan 2002
Posts: 210
Buzz regarding my bluray encoding problem. The moment I unticked multi thread it started working. Anyway I had posted this problem in x264 thread for which one of them advised instaed of this in the script

SetMemoryMax(512)
SetMTMode(2,0)

#Source File
AVCSource("F:\HDConvertToX\temp\job0\movie.dga")


#Applying Resizing
GaussResize(1920,1072,0,4,-0,-4,p=75)

#Insert Filters As Requested

hqdn3d(1)




You only need to "disable" the multithreaded opening of the source material ... so your AVS script (taken from the one in the logfile) should read:

SetMemoryMax(512)
SetMTMode(2,0)

SetMTMode(5,0)
AVCSource("F:\HDConvertToX\analysis\movie.dga")
SetMTMode(2,0)

GaussResize(1920,1072,0,4,-0,-4,p=75)
hqdn3d(1)


Well this script was made by HDC(not sure) so is this correct?


http://forum.doom9.org/showthread.ph...49#post1325649
Mrsash is offline   Reply With Quote
Old 15th September 2009, 14:47   #2012  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
interesting, thanks for this finding..

but i have a doubt.. why only you got this problem ?

i too should got this error...

i have i suggestion: check your RAM usage. i think your avaiable ram is very low, if not negative while encoding

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 15th September 2009, 18:43   #2013  |  Link
Sharc
Registered User
 
Join Date: May 2006
Posts: 3,239
Quote:
Originally Posted by buzzqw View Post
@Sharc

i don't think i fully understud.. the code is the same for both encoding.. could you redownload the sharc beta ?
i added a quick wannabe fix
Now it is perfect! Thanks!
Sharc is offline   Reply With Quote
Old 15th September 2009, 20:52   #2014  |  Link
andraves
Registered User
 
Join Date: Jun 2008
Posts: 3
Wrong language flag for my subtitles

After encoding a BluRay movie to x264/.mkv the language flag/titles is always set to Germen.

I have only selected one subtitles every time and that has been Norwegian. After muxing I've got the correct subtitles, but with wrong subtitles flag/title.

Is this a bug or am I doing somthing wrong?

best regards
Andraves
andraves is offline   Reply With Quote
Old 15th September 2009, 21:26   #2015  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
please andraves, post the Make Report

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 16th September 2009, 07:01   #2016  |  Link
Frozen-Figo
Registered User
 
Join Date: May 2007
Posts: 54
Hi,

I have ts file with two audio channels. I want to encode it with HDC, but when I analyze it just appear audio channel that I was select it during recording.

I tried to save file with MPEG-VCR ( Womble ) then encode it, in this case HDC detect other channel, but after encoding process the second audio channel is not work good ( slow & strange sound).

Code:
eac3to v3.16
command line: "C:\Documents and Settings\Frozen\Desktop\HDConvertToX_2.1.458.3528\applications\eac3to.exe" "c:\documents and settings\frozen\desktop\2.ts" 1:"C:\Documents and Settings\Frozen\Desktop\HDConvertToX_2.1.458.3528\job0\hdconverttox.m2v"
------------------------------------------------------------------------------
TS, 1 video track, 2 audio tracks, 0:00:11, 50i
1: MPEG2, 576i50 (4:3)
2: MP2, 2.0 channels, 256kbps, 48khz, 40ms
3: MP2, 2.0 channels, 256kbps, 48khz, 40ms
[v01] Extracting video track number 1...
[v01] Creating file "C:\Documents and Settings\Frozen\Desktop\HDConvertToX_2.1.458.3528\job0\hdconverttox.m2v"...
Video track 1 contains 278 frames.
eac3to processing took 1 second.
Done.
Thanks

Last edited by Frozen-Figo; 16th September 2009 at 07:08.
Frozen-Figo is offline   Reply With Quote
Old 16th September 2009, 07:16   #2017  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
@Frozen-Frigo

please post the Make report
you can also try to use NicAudio/SoundOut as Audio decoding

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8
buzzqw is offline   Reply With Quote
Old 16th September 2009, 07:18   #2018  |  Link
andraves
Registered User
 
Join Date: Jun 2008
Posts: 3
Quote:
Originally Posted by buzzqw View Post
please andraves, post the Make Report

BHH
Here is the Make Report:
Code:
HDConvertToX v.2.1.471.3569 "Isotta" report

Input File: h:\bdmv\stream\00002.m2ts ( H:\BDMV\STREAM\00002.m2ts )
Codec Video: avc
Width / Heigh : 1920 / 1080
Framerate / Framecount: 23.976 / 148136
Duration(hh:mm:ss): 1:42:59
Aspect Ratio: 1.7778
Resized resolution: 1920 / 800
Crop Values : 0:140:0:140

Start Video Configuration ->
Encoding Settings: X264 Slow ; Bitrate= 10000
Encoding Preset: 7
Final Size: 700
Priority: idle
Denoise Level: Super Light
Set Manual Bitrate: 10000
Video Handling: Force DirectShowSource2 (Haali)
-> End Video Configuration

Start Audio Configuration ->
Audio Codec: Copy Audio
Audio Bitrate/Quality: 128
Audio Channels: 2
MP3 Mode: abr
Normalize: On
Audio handling: Use Eac3to as demuxer
Keep only core: On
-> End Audio Configuration

Full Audio List-> (*** mean selected)
NONE
*** 4: dts master audio, english, 5.1 channels, 24 bits, 48khz
5: ac3, english, 5.1 channels, 384kbps, 48khz, dialnorm: -27db
6: ac3, english, 2.0 channels, 224kbps, 48khz, dialnorm: -27db
7: dts express, english, 2.0 channels, 24 bits, 96kbps, 48khz

-> End Full Audio List

Full Subtitle List-> (*** mean selected)
NONE
8: subtitle (pgs), english
9: subtitle (pgs), danish
10: subtitle (pgs), dutch
11: subtitle (pgs), finnish
*** 12: subtitle (pgs), norwegian
13: subtitle (pgs), swedish
14: subtitle (pgs), english
15: subtitle (pgs), danish
16: subtitle (pgs), dutch
17: subtitle (pgs), finnish
*** 18: subtitle (pgs), norwegian
19: subtitle (pgs), swedish
20: subtitle (pgs), dutch
21: subtitle (pgs), english
22: subtitle (pgs), danish
23: subtitle (pgs), finnish
*** 24: subtitle (pgs), norwegian
25: subtitle (pgs), swedish

-> End Full Subtitle List

Mux Subtitle in MP4/MKV file: On

Start Advanced AviSynth ->
ColorMatrix: On
-> End Advanced AviSynth

Start Queue ->
prompt $d $t $_$P$G

"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\eac3to.exe" "h:\bdmv\stream\00002.m2ts" 12:"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_12.sup" 18:"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_18.sup" 24:"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_24.sup"
"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\eac3to.exe" "h:\bdmv\stream\00002.m2ts" 4: "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox-pid4.dts" -core
java -jar "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\BDSup2Sub.jar" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_12.sup" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_12.idx" /res:1080p
java -jar "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\BDSup2Sub.jar" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_18.sup" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_18.idx" /res:1080p
java -jar "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\BDSup2Sub.jar" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_24.sup" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_24.idx" /res:1080p
"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\x264.exe" --pass 1 --bitrate 10000  --preset slow  --tune film  --sar 1:1  --output "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdconverttox_00002.h264" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdconverttox_00002.avs"
"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\x264.exe" --pass 2 --bitrate 10000  --preset slow  --tune film  --sar 1:1  --output "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdconverttox_00002.h264" "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdconverttox_00002.avs"
"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\eac3to.exe" "h:\bdmv\stream\00002.m2ts" 1:"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\chapters.txt"
"C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\applications\mkvmerge.exe" -o "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\hdconverttox_full_00002.mkv" --default-duration 0:23.976fps  "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdconverttox_00002.h264"   --language -1:eng "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox-pid4.dts" --default-track -1:no  "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_12.idx"  "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_18.idx"  "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdencodertox__subs_24.idx"  --chapters "C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\chapters.txt"  --title "Done with HDConvertToX v.2.1.471.3569 _Isotta_" 
-> End Queue

AviSynth Script ->
Working with files: C:\Users\HTPC\Desktop\HDConvertToX_2.1.458.3528\job1\hdconverttox_00002.avs
DSS2("h:\bdmv\stream\00002.m2ts",fps=23.976)
last = isRGB(last) ? ConvertToYV12(last) : last
last = isYUY2(last) ? ConvertToYV12(last) : last
LanczosResize(1920,800,0,140,-0,-140)
hqdn3d(1)
-> End AviSynth Script
Andraves
andraves is offline   Reply With Quote
Old 16th September 2009, 07:37   #2019  |  Link
buzzqw
HDConvertToX author
 
Join Date: Nov 2003
Location: Cesena,Italy
Posts: 6,552
Hi Andraves

ths .idx files contains the language tag, and this tag is taken from mkvmerge while muxing

i can guess that when BDSup2Sub convert your BD SUP to DVD SUB it set language to german...
i will check on BDSup2Sub thread http://forum.doom9.org/showthread.php?t=145277

EDIT -> look here http://forum.doom9.org/showthread.ph...61#post1300861

EDIT2: maybe i added a workaround please try this build: http://www.64k.it/andres/data/hdconv...beta-sharc.exe
it should detect Norwegian language

BHH
__________________
HDConvertToX: your tool for BD backup
MultiX264: The quick gui for x264
AutoMen: The Mencoder GUI
AutoWebM: supporting WebM/VP8

Last edited by buzzqw; 16th September 2009 at 07:50.
buzzqw is offline   Reply With Quote
Old 16th September 2009, 09:14   #2020  |  Link
paolo1983
Registered User
 
Join Date: Oct 2008
Posts: 46
I had encoded a movie where the "intro screen" was of a different aspect ratio than the rest of the movie..
So I have black bars in all the movie except the intro.

I think it would be better to remove them.
Trying with visual crop I find that I need to crop 70 up and 70 down to remove bars, can this be ok? Usually I never find HDC cropping so much...

Thank you
paolo1983 is offline   Reply With Quote
Reply

Tags
bluray, hdc, hdconverttox, m2ts, network media tank, playstation, x264 gui

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 00:12.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.